COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 04-24-2020, 02:42 PM   #1
tomphoolery
Human being with feelings
 
Join Date: Apr 2020
Location: Philadelphia
Posts: 5
Default ninjamcast won't connect with password

There seems to be an issue with the way `ninjamcast` parses configuration files. The username, in particular, gets a `^M` appended no matter what I do. This is OK for an anonymous stream, but it doesn't work when you try to authenticate to a real NINJAM user. I'm running the server and `ninjamcast` on Ubuntu 19.10. Is there any recourse or am I just making this an anonymous user?
tomphoolery is offline   Reply With Quote
Old 04-24-2020, 03:21 PM   #2
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 4,153
Default

Quote:
Originally Posted by tomphoolery View Post
There seems to be an issue with the way `ninjamcast` parses configuration files. The username, in particular, gets a `^M` appended no matter what I do. This is OK for an anonymous stream, but it doesn't work when you try to authenticate to a real NINJAM user. I'm running the server and `ninjamcast` on Ubuntu 19.10. Is there any recourse or am I just making this an anonymous user?
Use another text editor to create the configuration file, it seems to be problem with the way how CR/LF are added.

I have the same ^M added at the end of each line in config file for ninjam server when prior edited that file in Windows. When edited in Linux, everything was OK then, no ^M added.
akademie is offline   Reply With Quote
Old 04-25-2020, 11:50 PM   #3
tomphoolery
Human being with feelings
 
Join Date: Apr 2020
Location: Philadelphia
Posts: 5
Default

for some reason I had the CRLF setting in Vim all messed up on the server, so that's been fixed. thanks!

Last edited by tomphoolery; 04-26-2020 at 12:03 AM.
tomphoolery is offline   Reply With Quote
Old 04-26-2020, 03:31 AM   #4
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 4,153
Default

Quote:
Originally Posted by tomphoolery View Post
for some reason I had the CRLF setting in Vim all messed up on the server, so that's been fixed. thanks!
Great, tomphoolery
You're welcome.
akademie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:55 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.