Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Video Editing/Mangling

Reply
 
Thread Tools Display Modes
Old 05-13-2020, 12:41 PM   #1
gvdv
Human being with feelings
 
Join Date: Jun 2011
Posts: 342
Default HELP, Please - Video Not Displaying Properly in Reaper?

REAPER NOT DISPLAYING VIDEO PROPERLY?

Hi,
I have just started to try to work with video in Reaper, and I am having a problem.

I have taken in as much of the excellent Reaper User Guide as I can, so I may be misunderstanding things somewhat, so please work with me!

PROBLEM
The video window in Reaper is displaying my video in a different, distorted aspect ratio to the way it correctly looks in VLC.

It could be that Reaper is displaying the video correctly (although it is visibly far too squashed horizontally and far too tall vertically), and VLC compensates for this to make it look correct.

Section 20.7 ‘Reaper Video Settings and Preferences’, of the Reaper User Guide says “video playback will now be handled by VLC rather than Direct Show”, after downloading and installing the VLC .exe file, but VLC does not open for me.

Perhaps I am supposed to ‘manually’ put the .exe file into a directory, in addition to downloading and running VLC, so perhaps this is part of my problem.

I have listed below the choices and changes I have made in the ‘Project Settings’, and ‘Render’ menus in order for you to see if I am doing something wrong.

After I drag and drop the video into Reaper, I do the following:


SELECTIONS I MAKE IN THE PROJECT SETTINGS MENU
1. I go PROJECT SETTINGS and ensure that I have entered the appropriate frame rate and other information

2. In terms of the options for resizing the video, and maintaining the aspect ratio, I have gone through all the permutations of these settings, but I am still having the problem I describe above

SELECTIONS I MAKE IN THE FILE-RENDER MENU
1. I go to FILE – RENDER – FORMAT, and I replace WAV with VIDEO (FFMPEG/LIBAV ENCODER).

NOTE – even though I have VLC, I think that there should be a choice for VLC here in this Format list, but there is not. Perhaps I am misunderstanding this, and there should be no VLC choice here, because having VLC elsewhere my computer is enough for Reaper to find the appropriate file and use it.

2. I then change the second FORMAT box, which is underneath the FORMAT drop-down mentioned above, to QT/MOV/MP4
3. I then go to the right of FPS and click on the arrow, and from the bottom of that drop-down menu I choose GET WIDTH/HEIGHT/FRAME RATE FROM CURRENT VIDEO ITEM
4. When I am back in the previous window, I choose SAVE CHANGES AND CLOSE

I always check to make sure that number 4., described above, chooses the correct information each time I do this, so I do not think this is a problem.

Am I making the right selection/choices when I do the things I describe above?

Should I be doing anything else, or instead of the selections I describe above?

Should I be putting the VLC .exe file itself into a directory somewhere Reaper in order to get Reaper to shell out to VLC in order to display the video?

Many thanks for any help anybody can provide.
__________________
"If The Beatles or the 60's had a message, it was 'Learn to swim'. And once you've
learned - swim!"
John Lennon
gvdv is offline   Reply With Quote
Old 05-13-2020, 01:04 PM   #2
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 7,481
Default

No there should not be a VLC entry in the drop down list, so that part is fine.

However, do you have VLC in the same bit-type (32 or 64) as Reaper? If you have the 64-bit Reaper, I think that you need the 64-bit VLC, and last time I checked the default download of VLC was the 32-bit. You have to click the arrow next to "Download VLC" to choose the 64-bit version.

Next, if you go to Reaper's Preferences > Video/Import/Misc (quickest is to open Preferences, type "video" in the search bar, and hit "Find" twice). There you have the video settings, click "Show available decoder information" to the upper right there, and check that it says VLC there. If not, then Reaper does not see VLC on your computer.

I run a portable install of Reaper and have the portable version of VLC in <Reapers resource path>\VLC, and that works fine. You could try that. You can have both a portable and non-portable installs of Reaper on teh same computer, that's not a problem.

Also, there may be some useful info here https://forum.cockos.com/showthread.php?t=82459
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is offline   Reply With Quote
Old 05-13-2020, 01:20 PM   #3
gvdv
Human being with feelings
 
Join Date: Jun 2011
Posts: 342
Default

Quote:
Originally Posted by Fabian View Post
No there should not be a VLC entry in the drop down list, so that part is fine.

However, do you have VLC in the same bit-type (32 or 64) as Reaper? If you have the 64-bit Reaper, I think that you need the 64-bit VLC, and last time I checked the default download of VLC was the 32-bit. You have to click the arrow next to "Download VLC" to choose the 64-bit version.

Next, if you go to Reaper's Preferences > Video/Import/Misc (quickest is to open Preferences, type "video" in the search bar, and hit "Find" twice). There you have the video settings, click "Show available decoder information" to the upper right there, and check that it says VLC there. If not, then Reaper does not see VLC on your computer.

I run a portable install of Reaper and have the portable version of VLC in <Reapers resource path>\VLC, and that works fine. You could try that. You can have both a portable and non-portable installs of Reaper on teh same computer, that's not a problem.

Also, there may be some useful info here https://forum.cockos.com/showthread.php?t=82459
Hi Fabian.

Many thanks for your swift, and very helpful reply to my message.

Yes, I deliberately downloaded the 64bit version of Reaper (my computer is 64bit), but DirectShow EVR is listed in the 'Video/Import/Misc' area you pointed to; it is listed in the 'Output' box, and VLC is not listed there.

However, in the box to the right of the 'Output' box, 'Show Available Decoder Information', VLC IS listed, along with ffmpeg.

Weird.

Thank you, for the link you posted - I had read most of that thread before I looked in the User Guide, but there were things I did not take in or understand, so I will go through it again.

Thanks again, and please feel free to share any other suggestions you may have.
__________________
"If The Beatles or the 60's had a message, it was 'Learn to swim'. And once you've
learned - swim!"
John Lennon
gvdv is offline   Reply With Quote
Old 05-13-2020, 01:45 PM   #4
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 11,087
Default

In project settings, have you checked "preserve aspect ratio when resizing"? Or do you have "Always resize video sources to preferred size" checked?
Judders is offline   Reply With Quote
Old 05-13-2020, 01:51 PM   #5
gvdv
Human being with feelings
 
Join Date: Jun 2011
Posts: 342
Default

Quote:
Originally Posted by Judders View Post
In project settings, have you checked "preserve aspect ratio when resizing"? Or do you have "Always resize video sources to preferred size" checked?
Hi Judders,
Thanks for the reply.

I have tried both of those options, and tried all the permutations of all of the options in that part of the 'Project Settings' window.

But nothing has made any difference.
__________________
"If The Beatles or the 60's had a message, it was 'Learn to swim'. And once you've
learned - swim!"
John Lennon
gvdv is offline   Reply With Quote
Old 05-13-2020, 02:01 PM   #6
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 11,087
Default

I've only just started using video in REAPER myself, but it looks like you are choosing all the right options.

Hopefully someone more knowledgeable can help!
Judders is offline   Reply With Quote
Old 05-13-2020, 02:20 PM   #7
gvdv
Human being with feelings
 
Join Date: Jun 2011
Posts: 342
Default

Quote:
Originally Posted by Judders View Post
I've only just started using video in REAPER myself, but it looks like you are choosing all the right options.

Hopefully someone more knowledgeable can help!
Thanks, Judders.

I hope that your video experience in Reaper goes smoothly.
__________________
"If The Beatles or the 60's had a message, it was 'Learn to swim'. And once you've
learned - swim!"
John Lennon
gvdv is offline   Reply With Quote
Old 05-26-2020, 08:02 AM   #8
monocent
Human being with feelings
 
Join Date: Nov 2019
Posts: 4
Default

I've run into this problem with DVD rips I've made myself. It has something to do with the pixel aspect ratio of the file and the way DVD stores anamorphic widescreen, at least in my case. I'm not a video expert at all so i might be using the incorrect terms here.

If you load the file in question into Handbrake, it reports the proper display size on the summary tab, but will usually subtract the automatically detected cropped pixels you can adjust on the dimensions tab. Nevertheless, the reported display setting dimensions will usually get you in the ballpark.

I've been using Mediainfo or ffWorks to get a peek at the pixel aspect ratio of the file and performing the simple math myself instead of using handbrake.

For example, Reaper reports resolution as 720x480 and displays image incorrectly

Mediainfo reports pixel aspect ratio of 0.889

so, 720*0.889=640.08

In Reaper, set the Project Settings to 640x480, only high quality filtering and preserve aspect ratio when resizing checked.

On the video track place a video processer with the Resize track/item to project dimensions preset. set the video processer with preserve aspect off or 0.

this setup has so far always solved my aspect ratio display issues in Reaper. Like I said, I'm not a video expert so hopefully I used the correct terminology. Any correction or clarification would be much appreciated.

720x480, displayed incorrectly https://imgur.com/zo7cKyX
640x480, correct https://imgur.com/hMJ4NKG

Reaper video window on top, VLC on bottom in both screen shots
monocent is offline   Reply With Quote
Old 05-27-2020, 08:34 AM   #9
gvdv
Human being with feelings
 
Join Date: Jun 2011
Posts: 342
Default

Quote:
Originally Posted by monocent View Post
I've run into this problem with DVD rips I've made myself. It has something to do with the pixel aspect ratio of the file and the way DVD stores anamorphic widescreen, at least in my case. I'm not a video expert at all so i might be using the incorrect terms here.

If you load the file in question into Handbrake, it reports the proper display size on the summary tab, but will usually subtract the automatically detected cropped pixels you can adjust on the dimensions tab. Nevertheless, the reported display setting dimensions will usually get you in the ballpark.

I've been using Mediainfo or ffWorks to get a peek at the pixel aspect ratio of the file and performing the simple math myself instead of using handbrake.

For example, Reaper reports resolution as 720x480 and displays image incorrectly

Mediainfo reports pixel aspect ratio of 0.889

so, 720*0.889=640.08

In Reaper, set the Project Settings to 640x480, only high quality filtering and preserve aspect ratio when resizing checked.

On the video track place a video processer with the Resize track/item to project dimensions preset. set the video processer with preserve aspect off or 0.

this setup has so far always solved my aspect ratio display issues in Reaper. Like I said, I'm not a video expert so hopefully I used the correct terminology. Any correction or clarification would be much appreciated.

720x480, displayed incorrectly https://imgur.com/zo7cKyX
640x480, correct https://imgur.com/hMJ4NKG

Reaper video window on top, VLC on bottom in both screen shots
monocent,
Thank you very, very much for your reply, and for making it so clear, detailed, and – I hope – helpful.

I really appreciate this, and apologise for not having responded sooner.

I will try what you suggest and will get back to you here about the results.

Thanks again.
__________________
"If The Beatles or the 60's had a message, it was 'Learn to swim'. And once you've
learned - swim!"
John Lennon
gvdv is offline   Reply With Quote
Old 05-29-2020, 02:31 PM   #10
monocent
Human being with feelings
 
Join Date: Nov 2019
Posts: 4
Default

Quote:
Originally Posted by gvdv View Post
monocent,
Thank you very, very much for your reply, and for making it so clear, detailed, and – I hope – helpful.

I really appreciate this, and apologise for not having responded sooner.

I will try what you suggest and will get back to you here about the results.

Thanks again.
No worries, glad to help. Hope it works for you.
monocent is offline   Reply With Quote
Old 05-31-2020, 10:19 AM   #11
gvdv
Human being with feelings
 
Join Date: Jun 2011
Posts: 342
Default

Quote:
Originally Posted by monocent View Post
No worries, glad to help. Hope it works for you.
Thanks
__________________
"If The Beatles or the 60's had a message, it was 'Learn to swim'. And once you've
learned - swim!"
John Lennon
gvdv is offline   Reply With Quote
Old 02-26-2024, 06:10 AM   #12
Jonague
Human being with feelings
 
Join Date: May 2020
Posts: 6
Default Video Problems

Hey there!

I'm running Reaper x64, and it seems, though I have no clue why, that it no longer is reading videos. For a short time, Reaper was simply showing the files as being offline, and now, after reading forums and re-installing VLC to solve the problem, there no longer seems to be any problem regarding audio, but my screen still shows up as a black screen... This applies to multiple video formats : at least .mov and .mp4, and I've tried files from different sources. VLC is 64-bit. My decoder is prioritarily VLC. I've tried switching the output, I think it offers me only variations of DirectShow.

The problem started maybe three weeks ago. Might it have been due to a software update? Perhaps, I don't know... I'm on Windows, probably the latest.

It seems some people have been through similar problems, but I can't seem to find an efficient solution through forums thus far...

Does anyone have an idea?

Thanks a lot!
Jonah (a Reaper user)
Attached Images
File Type: jpg reaperVideoParameters.jpg (188.4 KB, 98 views)

Last edited by Jonague; 02-26-2024 at 06:12 AM. Reason: Add more info
Jonague is offline   Reply With Quote
Old 02-26-2024, 11:58 AM   #13
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 7,481
Default

Quote:
Originally Posted by Jonague View Post
Hey there!
Two things:
  1. Click the "Show available decoder information" button, and post here what it shows.
  2. Remove "vlc" from the "Video decoder priority" line, restart Reaper, and check if video works now.
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is offline   Reply With Quote
Old 02-26-2024, 03:36 PM   #14
Jonague
Human being with feelings
 
Join Date: May 2020
Posts: 6
Default

Quote:
Originally Posted by Fabian View Post
Two things:
  1. Click the "Show available decoder information" button, and post here what it shows.
  2. Remove "vlc" from the "Video decoder priority" line, restart Reaper, and check if video works now.
Hey there Fabian!

Thanks a lot for the reply. Here are screenshots of the data window. I've tried kicking "vlc" out of the encoder list, and the problem doesn't seem to be resolved : I relaunched Reaper, and it seems MP4 files are simply showing as "offline", and MOV files don't read video, only audio (as before).
Attached Images
File Type: jpg DecoderInfo1.jpg (87.4 KB, 88 views)
File Type: jpg DecoderInfo2.jpg (72.9 KB, 91 views)
File Type: jpg DecoderInfo3.jpg (82.8 KB, 89 views)
File Type: jpg DecoderInfo4.jpg (93.9 KB, 76 views)
File Type: jpg DecoderInfo5.jpg (92.9 KB, 90 views)
Jonague is offline   Reply With Quote
Old 02-27-2024, 11:45 AM   #15
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 7,481
Default

Try updating ffmpeg to v4.4 (not v5). See here https://reaper.blog/2021/12/ffmpeg-for-reaper-643/
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is offline   Reply With Quote
Old 02-28-2024, 01:51 AM   #16
Jonague
Human being with feelings
 
Join Date: May 2020
Posts: 6
Default Video Problems

Quote:
Originally Posted by Fabian View Post
Try updating ffmpeg to v4.4 (not v5). See here https://reaper.blog/2021/12/ffmpeg-for-reaper-643/
Thanks, I'm testing it right now. I saw the Jon Tidey video, and as I was following his instructions, I realized I didn't have OpenGL in the menu for "output" in the video settings. The version of reaper I'm running is version 6.10. Could OpenGL be a recent thing? Is it the successor to the DirectShow thing? I still have DirectShow, but it seems Tidey mentions it as being a protocol that isn't going to be supported anymore. Anyhow, I'm attempting to incorporate the correct version of Ffmpeg, see what happens, and if I have to (though I wish I don't), I'll update to whatever version of Reaper I need to work on video. I'll keep you posted as to how all of this is working out.

Many thanks!
Jonah.
Jonague is offline   Reply With Quote
Old 02-28-2024, 09:20 AM   #17
papagirafe
Human being with feelings
 
papagirafe's Avatar
 
Join Date: Aug 2020
Location: Brasil
Posts: 757
Default

Quote:
Originally Posted by Jonague View Post
<snip>I realized I didn't have OpenGL in the menu for "output" in the video settings. The version of reaper I'm running is version 6.10. Could OpenGL be a recent thing? <snip>
It appeard in v6.43 for windows & linux
papagirafe is offline   Reply With Quote
Old 02-28-2024, 01:23 PM   #18
Jonague
Human being with feelings
 
Join Date: May 2020
Posts: 6
Default

Quote:
Originally Posted by papagirafe View Post
It appeard in v6.43 for windows & linux
Thanks. I'll be back here if my solution doesn't work long run, but I believe somehow I managed to re-work with video formats by kicking out VLC of my decoder priority list. Hope my relief lasts! Thanks to y'all for being around!

Jonah.
Jonague is offline   Reply With Quote
Old 06-27-2024, 09:02 PM   #19
francoisphils
Human being with feelings
 
Join Date: Feb 2020
Location: Cebu Philippines
Posts: 16
Default Video not showing

It does not work since version 6.43 , i just verified it on LINUX Mint.
Works correctly on 6.42.
Other problem , reaper does not render the audio if you choose AAC or MP3

Last edited by francoisphils; 07-07-2024 at 07:30 PM.
francoisphils is offline   Reply With Quote
Old 07-07-2024, 11:22 PM   #20
francoisphils
Human being with feelings
 
Join Date: Feb 2020
Location: Cebu Philippines
Posts: 16
Default All problems solved for Video edition in Reaper 7

In the Preferences/Video ,on the top , choose OUTPUT=RGB , and the video window will display the video.Now , with Reaper 7.18 , i don't have problems of rendering AAC or MP3.
You can control the quality of the Video rendered by modifying the CRF parameter , in the Range of 0-51 , 0=Lossless , 51=awfull

Last edited by francoisphils; 07-07-2024 at 11:46 PM.
francoisphils is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:26 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.