Old 08-31-2011, 12:53 PM   #1
jnif
Human being with feelings
 
jnif's Avatar
 
Join Date: Dec 2008
Posts: 2,083
Default VSTi crackle noise when track armed

Reaper generates some crackle noise in VSTi output when the instrument track is armed. I noticed this first while testing some NI Massive sounds with MIDI keyboard. Then I recorded some MIDI chords and played the recorded item. The crackle was still there. Then I disabled the record arm from the Massive track and playback was clean, no crackles anymore.

Next I armed the track again and increased ASIO buffer size from 64 samples to 128 samples. The playback was now clean with track armed. So, it seemed that increasing ASIO buffer size helped. Then I duplicated the track 4 times. Then the playback was crackling again if all tracks were armed. Disabling record arm from all tracks made the output clean again.

While testing I noticed that record arming 4 VSTi tracks forced all CPU load to single core. When record arms were disabled the CPU load was evenly distributed to 4 cores. The total CPU load was about 20%.

Is it normal that Reaper requires larger ASIO buffer when VSTi track is armed?
Is there some settings that could improve record armed performance?

Setup:
Reaper 4.02/x64
NI Massive 1.2.1 x64, Arctic Sunset patch
RME Babyface, samplerate 44.1kHz
Intel Core i5-760
Windows 7 64bit

jnif

Last edited by jnif; 09-02-2011 at 04:29 PM. Reason: added OS to setup details
jnif is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:15 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.