Go Back   Cockos Incorporated Forums > REAPER Forums > MIDI Hardware, Control Surfaces, and OSC

Reply
 
Thread Tools Display Modes
Old 11-20-2020, 04:52 AM   #11601
WaveTrans
Human being with feelings
 
Join Date: Aug 2019
Location: Forest City
Posts: 215
Default

OK, I took the first step implementing all changes from Funkybot´s list.

Basic functions, Pan, Panwidth work fine.

Sends and FX don´t work for me.

ToggleMapFocusedFX, FocusedFXNavigator still valid ? (use crashes Reaper)
Or is it SelectedTrackNavigator only now?

ToggleMapSelectedTrackSends still working?

Tested some stuff, but nothing worked, so I guess the actions are different now.
__________________
CSI files for the Icon Nano Vers. 2.0: https://stash.reaper.fm/v/38686/CSI_IconNano_2_0.zip
CSI FX.zones for the Icon Nano: https://stash.reaper.fm/v/38685/CSI_FX_zones.zip
WaveTrans is offline   Reply With Quote
Old 11-20-2020, 05:09 AM   #11602
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 487
Default

Quote:
Originally Posted by WaveTrans View Post
OK, I took the first step implementing all changes from Funkybot´s list.

Basic functions, Pan, Panwidth work fine.

Sends and FX don´t work for me.

ToggleMapFocusedFX, FocusedFXNavigator still valid ? (use crashes Reaper)
Or is it SelectedTrackNavigator only now?

ToggleMapSelectedTrackSends still working?

Tested some stuff, but nothing worked, so I guess the actions are different now.
I don't want to mis-speak but here's what I recall.

Togglemapfocusedfx I do believe was taken out.

FocusedFXNavigator works though. Focusedfxnavigator goes in your fx zones and your main zone should have this line

OnFXFocus mapfocusedfxtowidgets

I can't speak to the sends. I was having trouble with them last night as well (not because they don't work, they do. It's just, up until now I've ignored any and everything to do with sends.)
cjewellstudios is online now   Reply With Quote
Old 11-20-2020, 06:36 AM   #11603
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 545
Default

Quote:
Originally Posted by WaveTrans View Post
OK, I took the first step implementing all changes from Funkybot´s list.

Basic functions, Pan, Panwidth work fine.

Sends and FX don´t work for me.

ToggleMapFocusedFX, FocusedFXNavigator still valid ? (use crashes Reaper)
Or is it SelectedTrackNavigator only now?

ToggleMapSelectedTrackSends still working?

Tested some stuff, but nothing worked, so I guess the actions are different now.
The ToggleMapSelected sends and fx actions are gone. I believe the wiki is up to date on the available actions for v 1.0
Cragster is offline   Reply With Quote
Old 11-20-2020, 07:07 AM   #11604
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 487
Default

Quote:
Originally Posted by cjewellstudios View Post

RotaryC| TrackOutputMeterMaxPeakLR

Check it out!

https://drive.google.com/file/d/1ASz...ew?usp=sharing

Twister Led rings as meters
Still geeked about this

But the meters are showing level even when they are silent. As in, I solo'd the drums and the bass and guitar tracks still show level. Is that the intention or is that a bug?
cjewellstudios is online now   Reply With Quote
Old 11-20-2020, 07:39 AM   #11605
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,783
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

CSI v1_0.zip

Oops, sorry guys, I broke Stepped params for OSC when I was muckin' about with Hold.

Should be fixed now
Working now! Many thanks
MixMonkey is offline   Reply With Quote
Old 11-20-2020, 07:42 AM   #11606
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,783
Default

Quote:
Originally Posted by WaveTrans View Post
OK, I took the first step implementing all changes from Funkybot´s list.

Basic functions, Pan, Panwidth work fine.

Sends and FX don´t work for me.

ToggleMapFocusedFX, FocusedFXNavigator still valid ? (use crashes Reaper)
Or is it SelectedTrackNavigator only now?

ToggleMapSelectedTrackSends still working?

Tested some stuff, but nothing worked, so I guess the actions are different now.
Post your .zon and we'll get you up to speed Have you altered the .mst wrt Touch definitions?
MixMonkey is offline   Reply With Quote
Old 11-20-2020, 07:50 AM   #11607
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,783
Default

Quote:
Originally Posted by poetnprophet View Post
yea, it just means I have to go back through all my stuff again. If the new configurator works as well as the old one, it shouldn't take me too long relatively speaking. It'll be good to maybe rethink my setup anyway, etc....but now is not the time for all that...

always appreciate everyone's strategies and solutions here!

edit, yes the sends work perfectly, only taking up the space they need.
One other thing you could try would be to sneak the blanking in with the Sends zone. I have no idea if this will work, but it worked for me using the FXMenu zone in similar style (get rid of the GoZone statement and Blank zone you had previously) Make sure the OnTrackSelection MapSelectedTrackSendsToWidgets comes before OnTrackSelection MapSelectedTrackFXToWidgets.
Code:
Zone "Send"
        SendNavigator
        DisplayUpperB|      NoAction
        DisplayLowerB|      NoAction
        RotaryPushB|        NoAction
        RotaryB|            NoAction
            
        DisplayUpperC|      NoAction
        DisplayLowerC|      NoAction
        RotaryPushC|        NoAction
        RotaryC|            NoAction

        DisplayUpperD|      NoAction
        DisplayLowerD|      NoAction
        RotaryPushD|        NoAction
        RotaryD|            NoAction
            
        DisplayUpperA|      TrackSendNameDisplay
        DisplayLowerA|      TrackSendVolumeDisplay                                 
        RotaryA|            TrackSendVolume [ (0.001,0.02,0.04,0.06,0.1) ]
        RotaryPushA|        TrackSendMute
ZoneEnd

Last edited by MixMonkey; 11-20-2020 at 07:55 AM.
MixMonkey is offline   Reply With Quote
Old 11-20-2020, 08:30 AM   #11608
WaveTrans
Human being with feelings
 
Join Date: Aug 2019
Location: Forest City
Posts: 215
Default

Quote:
Originally Posted by MixMonkey View Post
Post your .zon and we'll get you up to speed Have you altered the .mst wrt Touch definitions?
Thanks a bundle.
No doubts, this will speed up things.

I put the toggle with the rotaries and the touch action with the faders widgets as described.

I have two surfaces, A Icon Nano Single Channel and an Icon Xplus 8 channel.

I set up CSI.ini with both surfaces, each surface has 1 respectively 8 channels/Sends/FXmenus. Ticked Pages synched and Reaper follows surfaces

Here´s bothe zones the Nano .zon and xplus.zon below.

I cleaned them up, hope I didn´t erease too much.
JogWheelRotaryC(C)W does not work as expected, only zoom does.

Code:
 

Zone "Home"
	OnTrackSelection MapSelectedTrackSendsToWidgets
	OnFXFocus MapFocusedFXToWidgets 
/
	IncludedZones
		"Buttons"
		"Channel"
		"MasterChannel"
/		"JogWheelHack"
	IncludedZonesEnd
ZoneEnd

Zone "Buttons"
	Track 		Reaper 	"40917"  		// Master MonoStereo
/	Send 		ToggleMapSelectedTrackSends
	Send 		Reaper 	"40293"  		// Send Menu
	Pan 		Reaper 	"40293"  		// Send Menu 
/	Plugin		ToggleMapFocusedFX   
	Plugin		Reaper 	"_S&M_TOGLFXCHAIN"  // Fx menu
    EQ 			Reaper 	"_S&M_TOGLFXCHAIN"  // Fx menu  
    Instrument	Reaper 	"_S&M_SELFXNEXT" // Next FX
		
	Play 		Play
	Stop 		Stop
	Record 		Record
	Rewind 		Rewind
	FastForward	FastForward
	JogWheelRotaryCW            Reaper "988" 
        JogWheelRotaryCCW           Reaper "977" 
	Zoom+Up 		Reaper "40111"
	Zoom+Down 		Reaper "40112"
	Zoom+Right 		Reaper "1012"
	Zoom+Left 		Reaper "1011"
ZoneEnd

Zone "Channel"
	TrackNavigator
	DisplayUpper| TrackPanDisplay
	DisplayLower| TrackNameDisplay 
/	TrackTouch+DisplayUpper| TrackVolumeDisplay
/	Rotary| TrackPan "0"
	Rotary| MCUTrackPan
	RotaryPush| GoZone "PanWidth|" 
	RecordArm| TrackRecordArm
	Solo| TrackSolo
	Mute| TrackMute
	Select| TrackUniqueSelect
	Fader| TrackVolume
/	FaderTouch| TrackTouch
	VUMeter| TrackOutputMeter
ZoneEnd

Zone "MasterChannel"
	MasterTrackNavigator 
	MasterFader TrackVolume
	VUMeterMaster TrackOutputMeter
ZoneEnd

Zone "Send"
    SendNavigator
    DisplayUpper|               TrackSendNameDisplay
    DisplayLower|               TrackSendVolumeDisplay
    Mute|                       TrackSendMute
    Fader|                      TrackSendVolume
ZoneEnd 

Zone "FXMenu"
    FXMenuNavigator
    DisplayUpper|               FXMenuNameDisplay
    DisplayLower|               NoAction
    Rotary|                     NoAction
    RotaryPush|                 GoFXSlot
ZoneEnd

Zone "LastTouchedParam"
/ Select Track, 
/ "Last touch" Param in FX
/ Press "LastTouchedParam" button
/ Set track to write mode
/ Press Play to ride automation - Stop when finished
/ Envelopes remain armed; disarm before riding a different FXParam
/ Hit GoZone "Home" (Blue1) to leave 
    Fader1 FocusedFXParam
/   FaderTouch1 TrackTouch
	DisplayUpper1 FocusedFXParamNameDisplay
	DisplayLower1 FocusedFXParamValueDisplay
	GlobalView Reaper "_S&M_DISARMALLENVS" 
ZoneEnd
XPlus.zone
Code:
Zone Home
   OnTrackSelection MapSelectedTrackSendsToWidgets
	OnFXFocus MapFocusedFXToWidgets
	/OnTrackSelection MapSelectedTrackFXToMenu //FX Menu
/
	IncludedZones
		"Channel"
	IncludedZonesEnd
ZoneEnd

Zone "Channel"
	TrackNavigator
	DisplayUpper|  		TrackNameDisplay
	DisplayLower|  		TrackPanDisplay
/	TrackTouch+DisplayLower| TrackVolumeDisplay
	RotaryPush| 		GoZone "PanWidth|"
/	Rotary|				TrackPan "0"
	Rotary| 			MCUTrackPan
	RecordArm|  		TrackRecordArm
	Solo|  			TrackSolo
	Mute| 			TrackMute
	Select|  		TrackUniqueSelect
	Fader|  		TrackVolume
/	TrackTouch+Fader|  	TrackVolume
/	FaderTouch|  		TrackTouch
ZoneEnd

Zone "Send"
    SendNavigator
    DisplayUpper|               TrackSendNameDisplay
    DisplayLower|               TrackSendVolumeDisplay
    Mute|                       TrackSendMute
    Fader|                      TrackSendVolume
    Rotary|			TrackSendPan
ZoneEnd 

Zone "FXMenu"
    FXMenuNavigator
    DisplayUpper|               FXMenuNameDisplay
    DisplayLower|               NoAction
    Rotary|                     NoAction
    RotaryPush|                 GoFXSlot
ZoneEnd


[/Code]
__________________
CSI files for the Icon Nano Vers. 2.0: https://stash.reaper.fm/v/38686/CSI_IconNano_2_0.zip
CSI FX.zones for the Icon Nano: https://stash.reaper.fm/v/38685/CSI_FX_zones.zip
WaveTrans is offline   Reply With Quote
Old 11-20-2020, 08:46 AM   #11609
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Have you tried this?

Code:
Zone "Buttons"
    Send                        MapSelectedTrackSendsToWidgets
    Plugin                      MapSelectedTrackFXToMenu
ZoneEnd

Zone "Send"
    SendNavigator
    DisplayUpper|               TrackSendNameDisplay
    DisplayLower|               TrackSendVolumeDisplay
    Mute|                       TrackSendMute
    Fader|                      TrackSendVolume
ZoneEnd 

Zone "FXMenu"
    FXMenuNavigator
    DisplayUpper|               FXMenuNameDisplay
    DisplayLower|               NoAction
    Rotary|                     NoAction
    RotaryPush|                 GoFXSlot
ZoneEnd
I don't have an 8-channel MCU device (well, I could use my Artist Mix that way, but stick to Eucon) but that's what I got from checking out the included mcu.zon which isn't final. Eventually we'll get more updated .zon's out there.

Last edited by Funkybot; 11-20-2020 at 08:51 AM.
Funkybot is online now   Reply With Quote
Old 11-20-2020, 08:54 AM   #11610
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,783
Default

Quote:
Originally Posted by WaveTrans View Post
Thanks a bundle.
No doubts, this will speed up things.
Are you using OnFXFocus or the FXMenu?
MixMonkey is offline   Reply With Quote
Old 11-20-2020, 09:26 AM   #11611
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 43
Default

Quote:
Originally Posted by Equitone View Post
Hi,
Are there any rules for converting older zon/mst files to the new format or has the format changed completely and I need to rebuild from scratch. I will do this if I have to, but the zon files for the XTouch work really well.
I'm still confused on this. I obeyed FB's instructions to the letter as I thought, but still no joy.
Michael, the guy who authored this file in the first place seems to have disappeared, if anyone comes up with files for the XTouch, please let us know.
Equitone is offline   Reply With Quote
Old 11-20-2020, 10:45 AM   #11612
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Quote:
Originally Posted by Equitone View Post
I'm still confused on this. I obeyed FB's instructions to the letter as I thought, but still no joy.
Michael, the guy who authored this file in the first place seems to have disappeared, if anyone comes up with files for the XTouch, please let us know.
Can you zip up or post your files? Sorry if you did that already (if so, just link to the post).
Funkybot is online now   Reply With Quote
Old 11-20-2020, 12:37 PM   #11613
StormBlåst
Human being with feelings
 
Join Date: May 2019
Posts: 15
Default

Hi guys!

I am pretty new to this CSI integration thing and I would love to get some help from you guys.

I recently got the Icon Qcon Pro X unit with extension and I am starting to work on my own Zone template. I can make basic commands to different buttons but I would like to program the Pro X display strip to show me different things

Is it possible to make it react to my actions? meaning that if I touch or move faders, it will show track volume on the lower part of the display. Or if I rotate the rotary knobs, it will show me the pan values? And if it is possible, how would I do it?


And a couple more random questions:
What exactly "ToggleMapSelectedTrackSends" means?

And could I make the rotary led lights center point in the uppermost led light?
Meaning that if I pan track example 100% right, it will only light up the right
side of the lights from the centre and not in the left side?
and vice versa

Thanks for the advance!
StormBlåst is offline   Reply With Quote
Old 11-20-2020, 01:34 PM   #11614
lexaproductions
Human being with feelings
 
Join Date: Jan 2013
Posts: 628
Default

Quote:
Originally Posted by Funkybot View Post
It's usually up to Reaper to tell CSI what to do in these instances. CSI doesn't store any parameter states. So if your Reaper Action shows an "On" or "Off" state in the Action list (like for example "Options: Toggle Metronome") then CSI will receive feedback from Reaper and turn the light on your button on or off accordingly. If your action does not report an on/off state to CSI, then CSI cannot control the button state.

Now...I've run into this too. Then it becomes decision time. You have a few options:

1. Live with the surface button being constantly on. Sometimes I'll do this.

2. Disable the light entirely (i.e. constantly off) by commenting out the feedback line in the .mst file for your surface. This is what I normally do.

3. Find a different action for that button.

Might not be the answer you wanted, but hope that helps.
Thanks a lot. It helped me indeed.
__________________
My Patreon address: Reaper4Live
lexaproductions is offline   Reply With Quote
Old 11-20-2020, 01:48 PM   #11615
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,783
Default

Quote:
Originally Posted by StormBlåst View Post

Is it possible to make it react to my actions? meaning that if I touch or move faders, it will show track volume on the lower part of the display. Or if I rotate the rotary knobs, it will show me the pan values? And if it is possible, how would I do it?
This feature is coming Currently the default is to show track name on upper and pan on lower.


Quote:
What exactly "ToggleMapSelectedTrackSends" means?
In the latest version it is deprecated and means nothing, Use:
Code:
SomeButton MapSelectedTrackSendsToWidgets
...to map the sends and
Code:
SomeButton GoZone Home
... to get back.
Quote:
And could I make the rotary led lights center point in the uppermost led light?
Meaning that if I pan track example 100% right, it will only light up the right
side of the lights from the centre and not in the left side?
and vice versa

Thanks for the advance!
Doesn't it do this already? Mine do.
MixMonkey is offline   Reply With Quote
Old 11-20-2020, 02:12 PM   #11616
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Quote:
Originally Posted by StormBlåst View Post

And could I make the rotary led lights center point in the uppermost led light?
Meaning that if I pan track example 100% right, it will only light up the right
side of the lights from the centre and not in the left side?
and vice versa

Thanks for the advance!
Which CSI pan action are you using?

MCUTrackPan is the new one and should handle this automatically.

If you're using the old "TrackPan" that action should probably be replaced with MCUTrackPan. But if you are using TrackPan for good reason, there's a "0" that you want to put after it.
Funkybot is online now   Reply With Quote
Old 11-20-2020, 02:41 PM   #11617
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 43
Default

Quote:
Originally Posted by Funkybot View Post
Can you zip up or post your files? Sorry if you did that already (if so, just link to the post).
No, I hadn't, but here's the original files. My screen reader tells me that they're attached(?)
Equitone is offline   Reply With Quote
Old 11-20-2020, 02:59 PM   #11618
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Quote:
Originally Posted by Equitone View Post
No, I hadn't, but here's the original files. My screen reader tells me that they're attached(?)
Hmm...they didn't attach. Were they from Siniarch's website?
Funkybot is online now   Reply With Quote
Old 11-20-2020, 03:13 PM   #11619
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 43
Default

No, I used the manage attachments and uploaded them from my PC.
I'll zip them and try again.
Attached Files
File Type: zip Behringer.zip (4.5 KB, 18 views)
Equitone is offline   Reply With Quote
Old 11-20-2020, 03:40 PM   #11620
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

It occurred to me just now that if you don't want Hold+SomeButton to duplicate the same action assigned to SomeButton, in the case of toggles you can just add it again.

So in theory, this...

Code:
Click 		Reaper	40364   //toggle metronome
Hold+Click	Reaper 	40363	//Show metronome settings - problem here is that if your click was on before you pressed and held you just turned it off
Should be remedied by this, because your essentially toggling it twice...

Code:
Click 		Reaper	40364   //toggle metronome
Hold+Click	Reaper 	40363	//Show metronome settings
Hold+Click     Reaper	40364   //toggle metronome the second time
Funkybot is online now   Reply With Quote
Old 11-20-2020, 03:58 PM   #11621
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Quote:
Originally Posted by Equitone View Post
No, I used the manage attachments and uploaded them from my PC.
I'll zip them and try again.
There was a lot here to update and I haven't tested it out yet but try this...

Note to all: if you have an MCU compatible device, this .mst and .zon should be a good starting point.

Please let us know how this goes.

Made some small changes: the Track button and Pan button do nothing. Send maps the sends. Plugin maps the FXMenu. EQ toggles the FX windows. Consider using Track for GoZone Home or something else.
Attached Files
File Type: zip BehringerXTouch.zip (5.1 KB, 20 views)
Funkybot is online now   Reply With Quote
Old 11-20-2020, 04:56 PM   #11622
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 43
Thumbs up

You're a star! I'll definitely be testing this tomorrow.
You're right it is a chunky file and well beyond my capability as a zon file writer.
Equitone is offline   Reply With Quote
Old 11-21-2020, 02:40 PM   #11623
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 43
Default

Despite this being a technically calamatous day, I've got around to testing.
I've not really got into sends etc, but None of the faders seem to work, and none of the channel select/mute/solo buttons seem to work. I waded through the MST file, which I must say looks much neater, but I'm guessing that the channel zone is incorrect at some point. Rather than fixing it, I'd rather you told me what to look for.
Thanks again
Equitone is offline   Reply With Quote
Old 11-21-2020, 02:42 PM   #11624
Weston Minissali
Human being with feelings
 
Join Date: Oct 2012
Posts: 33
Default Help installing CSI

Hello All,

After a back and forth with Funkybot, I was advised to send further questions to the main CSI thread. Let me know if there's a better place for this.

My system is Windows 10 and my control surface is a BCR2000.

I have downloaded a BCR file, and zon file and sysex for my bcr here:

https://siniarch.wixsite.com/csiconf...ringer-bcr2000

So far I have successfully placed the CSI folder in my reaper path and placed the reaper_csurf_integrator64.dll into my userplugins folder. When I run the action "CSI Toggle Show Input from Surfaces" a window pops up and recognizes the turning of knobs on my surface.

In prefs Control Surfaces Settings I created a surface called BCR, given it 8 channels, 8 sends and 8 fx menu. Set BCR200 for MIDI In and Out.

Under templates I selected the downloaded BCR2000.mst file but I'm confused about the *Zone Folder*.

The zone that came with the download is for FX. I'd like to start simpler and map my BCR to control volume, pan, mute play, stop etc.

Studying other .zon files, I tried making a simple file where all there was was:

Zone "Home"
UserButton1 play
ZoneEnd

I saved it as BCR.zon

When I go to Prefs > Control Surface Settings > MIDI Surface and click the Zone Folder Menu, I don't see the simple .zon file I created.

Can anyone please advise me on how to start VERY simple. Like how do I create a .Zon file that maps a single button on my BCR to trigger Play in Reaper? From there I can expand.

Thanks everyone!
-Weston

PS please let me know if you;d like to see any screenshots etc

Last edited by Weston Minissali; 11-21-2020 at 02:51 PM.
Weston Minissali is offline   Reply With Quote
Old 11-21-2020, 02:46 PM   #11625
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Quote:
Originally Posted by Equitone View Post
Despite this being a technically calamatous day, I've got around to testing.
I've not really got into sends etc, but None of the faders seem to work, and none of the channel select/mute/solo buttons seem to work. I waded through the MST file, which I must say looks much neater, but I'm guessing that the channel zone is incorrect at some point. Rather than fixing it, I'd rather you told me what to look for.
Thanks again
Hmmm....

Maybe the CSI.ini file? The format for the csi.ini file changed for 1.0 as well. If you were running a beta build, try exiting Reaper, deleting the CSI.ini file, then re-configuring your CSI setup. When you do, be sure to setup the device as 8 Channels, 8 Sends, and 8 FXMenu in the CSI device options.
Funkybot is online now   Reply With Quote
Old 11-21-2020, 03:02 PM   #11626
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Quote:
Originally Posted by Weston Minissali View Post
Can anyone please advise me on how to start VERY simple. Like how do I create a .Zon file that maps a single button on my BCR to trigger Play in Reaper? From there I can expand.

Thanks everyone!
-Weston
Let's start with the .zon first...if you put this in your BCR.zon file, does it work? Don't forget to restart CSI (go to Reaper's Preferences, Control/OSC/Web, click CSI, click Edit, then hit ok a bunch to apply so CSI will rescan your files and apply the changes).

Code:
Zone Home
	IncludedZones
		"Buttons"
	IncludedZonesEnd
ZoneEnd

Zone "Buttons"
        UpperButton1         Play
        UpperButton2         Stop
        UpperButton3         Reaper 40364           //Toggle Metronome
ZoneEnd
If not, what does the UpperButton look like in the BCR.mst? MixMonkey knows way more about CSI than I do, so I wouldn't normally dare question an .mst or .zon file he created, but it's very possible that the BCR template is very old and the button syntax changed since. Otherwise, I've never seen buttons like in that particular .mst.

So I'd then suggest opening up the .mst file and change this...
Code:
UpperButton1 PressReleaseFB 90 20 7f  90 20 00
and make it look like this...
Code:
Widget UpperButton1
	Press 90 20 7f  90 20 00
	FB_TwoState 90 20 7f  90 20 00
WidgetEnd
Then restart CSI and see if that helps. If yes, do that for the other buttons in .mst file.
Funkybot is online now   Reply With Quote
Old 11-21-2020, 03:14 PM   #11627
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Geoff, have "AnyPress" widgets been removed or are they still a thing? Going to jump in and help with documentation.
Funkybot is online now   Reply With Quote
Old 11-21-2020, 03:23 PM   #11628
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,783
Default

Quote:
Originally Posted by Funkybot View Post
.... but it's very possible that the BCR template is very old and the button syntax changed since.
It is very old and the syntax is certainly out of date.
MixMonkey is offline   Reply With Quote
Old 11-21-2020, 03:33 PM   #11629
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 545
Default

@ GEOFF

Hey Geoff, here is a zip file containing Zones and Mst's for Icon ProX, Platform M and Platform B. All are with the new syntax changes and standard mapping compatible to the Reaper overlays that come with each surface ( except Platform M, no overlay comes with that just standard named buttons). All are ready to go in the CSI 1.0 folder if you want. They should be plug n play for a new user that are new to changing zones and mst files. Good starting point with many standard reaper actions to get them going.Thanks again for evrything
Attached Files
File Type: zip FilesForCSI1.0.zip (7.2 KB, 17 views)
Cragster is offline   Reply With Quote
Old 11-21-2020, 04:47 PM   #11630
dirtrider
Human being with feelings
 
Join Date: Mar 2011
Posts: 4
Default

Hi, this might be a really dumb question but I ordered an Icon platform Nano and I'm wondering if it's possible to setup csi so that I could press a button and turn the fader into a midi cc controller to act as a mod wheel for virtual instruments?
dirtrider is offline   Reply With Quote
Old 11-21-2020, 04:54 PM   #11631
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 545
Default

Is anyone noticing some weird behavior when using FX ? ill try to explain.. i have 3 surfaces with 2 pages set up. 1 page all 3 surfaces do normal tracking then i have a page where just 1 surface handles the tracking , 1 handles sends and 1 handles FX. so in version 0.92 it works great . i switch pages and the faders drop and the displays go blank for the sends and fx surface . which is what i want. i press the MapSelected buttons on each surface for sends and fx and boom they come up and i have it so the mute buttons are all lit and the slots with fx the mute lights go out. all good.

Then on version 1.0 i switch pages and the faders stay and diplays are still showing the tracking info on the send and fx surfaces until i hit the MapSelected buttons on those surfaces.I have that tracking stuff slashed out in the zone files for that page . then i will select a track with say 3 slots with FX and if i go to a track with 2 slots of fx that 3rd slot will stay on saying NoMap and if i go to a track with no fx it will still show 3 slots with NoMap. and my mute button light out fx slot indicator thing that i want doesnt work since its thinking those NoMap slots are fx. The 0.92 version works perfectly for this . does anyone remember anything else being broke in that version ? i may switch back to that

I dont know its like things that should go away dont. on the 0.92 version all the fx works as i want it. i mean it works in 1.0 but its just weird behavior . So i was just wondering if anyone else is noticing anything weird

I hope i explained that understandably
Cragster is offline   Reply With Quote
Old 11-21-2020, 05:18 PM   #11632
Mistik
Human being with feelings
 
Join Date: Nov 2018
Posts: 8
Question

Quote:
Originally Posted by WaveTrans View Post
...
Hey all, first of all thank you for developing this amazing project. This is one of the reasons why the Reaper community is unlike any other. Great job.

After quite a few days of learning the ins and outs of CSI (from the ground up :|), I can proudly say I have the Icon Platform Nano working, flawlessly (99,9%) and have managed to set it up exactly to my liking.

The only 1 thing that isn't working for me, is the VUMeter for the master track. I've tried everything, every possible combo from all the code snippets on the forum and wiki, to no avail.

Did anyone manage to get the master meter working on any of the Icon Platform controllers? I'd be very happy if you could share your solution with me.

Maybe WaveTrans? I've notice you're using the nano controller yourself.

After I find a solution for the meter, I'll be happy to share a 100% working solution for the Icon Platform Nano for everyone to use.

Cheers

Last edited by Mistik; 11-21-2020 at 05:23 PM.
Mistik is offline   Reply With Quote
Old 11-21-2020, 05:55 PM   #11633
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,768
Default

Quote:
Originally Posted by dirtrider View Post
Hi, this might be a really dumb question but I ordered an Icon platform Nano and I'm wondering if it's possible to setup csi so that I could press a button and turn the fader into a midi cc controller to act as a mod wheel for virtual instruments?
That might depend on if those virtual instruments expose their modwheel parameter to automation. CSI needs automation parameters to connect to. So if the plugin had a virtual modwheel on the GUI and that were an automatable parameter, sure, you could assign CSI to that.
Funkybot is online now   Reply With Quote
Old 11-21-2020, 05:56 PM   #11634
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 545
Default

Quote:
Originally Posted by Mistik View Post
Hey all, first of all thank you for developing this amazing project. This is one of the reasons why the Reaper community is unlike any other. Great job.

After quite a few days of learning the ins and outs of CSI (from the ground up :|), I can proudly say I have the Icon Platform Nano working, flawlessly (99,9%) and have managed to set it up exactly to my liking.

The only 1 thing that isn't working for me, is the VUMeter for the master track. I've tried everything, every possible combo from all the code snippets on the forum and wiki, to no avail.

Did anyone manage to get the master meter working on any of the Icon Platform controllers? I'd be very happy if you could share your solution with me.

Maybe WaveTrans? I've notice you're using the nano controller yourself.

After I find a solution for the meter, I'll be happy to share a 100% working solution for the Icon Platform Nano for everyone to use.

Cheers
I have a ProX and the master meter never worked with CSI. I think that was one of the many things on Geoffs list.
Cragster is offline   Reply With Quote
Old 11-21-2020, 06:04 PM   #11635
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,590
Default

Quote:
Originally Posted by Funkybot View Post
Geoff, have "AnyPress" widgets been removed or are they still a thing? Going to jump in and help with documentation.
AnyPress is still there. I took a shot at updating the wiki and at that point I did go over the widgets list and made sure it was up to date with the code -- that doesn't mean I got it right though, there could be errors/omissions
Geoff Waddington is offline   Reply With Quote
Old 11-21-2020, 06:05 PM   #11636
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,590
Default

Quote:
Originally Posted by Cragster View Post
@ GEOFF

Hey Geoff, here is a zip file containing Zones and Mst's for Icon ProX, Platform M and Platform B. All are with the new syntax changes and standard mapping compatible to the Reaper overlays that come with each surface ( except Platform M, no overlay comes with that just standard named buttons). All are ready to go in the CSI 1.0 folder if you want. They should be plug n play for a new user that are new to changing zones and mst files. Good starting point with many standard reaper actions to get them going.Thanks again for evrything
Thanks, will include it in the build.
Geoff Waddington is offline   Reply With Quote
Old 11-21-2020, 06:08 PM   #11637
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,590
Default

Quote:
Originally Posted by Cragster View Post
Is anyone noticing some weird behavior when using FX ? ill try to explain.. i have 3 surfaces with 2 pages set up. 1 page all 3 surfaces do normal tracking then i have a page where just 1 surface handles the tracking , 1 handles sends and 1 handles FX. so in version 0.92 it works great . i switch pages and the faders drop and the displays go blank for the sends and fx surface . which is what i want. i press the MapSelected buttons on each surface for sends and fx and boom they come up and i have it so the mute buttons are all lit and the slots with fx the mute lights go out. all good.

Then on version 1.0 i switch pages and the faders stay and diplays are still showing the tracking info on the send and fx surfaces until i hit the MapSelected buttons on those surfaces.I have that tracking stuff slashed out in the zone files for that page . then i will select a track with say 3 slots with FX and if i go to a track with 2 slots of fx that 3rd slot will stay on saying NoMap and if i go to a track with no fx it will still show 3 slots with NoMap. and my mute button light out fx slot indicator thing that i want doesnt work since its thinking those NoMap slots are fx. The 0.92 version works perfectly for this . does anyone remember anything else being broke in that version ? i may switch back to that

I dont know its like things that should go away dont. on the 0.92 version all the fx works as i want it. i mean it works in 1.0 but its just weird behavior . So i was just wondering if anyone else is noticing anything weird

I hope i explained that understandably
Are you saying that things don't reset when switching pages ?
Geoff Waddington is offline   Reply With Quote
Old 11-21-2020, 06:19 PM   #11638
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,783
Default

Here's some setup files for the Mackie MCU, XT and C4. They have the V1.0 definitions.
Attached Files
File Type: zip MCU_XT_C4.zip (15.7 KB, 10 views)
MixMonkey is offline   Reply With Quote
Old 11-21-2020, 06:26 PM   #11639
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 545
Default

Quote:
Originally Posted by Geoff Waddington View Post
Are you saying that things don't reset when switching pages ?
Yes . in the 0.92 version they do. 1.0 no. when i switch pages those 2 surfaces i have just for sends and fx should go blank and faders drop .at least i think they should . they do in the 0.92 version.all the track names and stuff from the previous page hangs around until i hit mapselected buttons.and i have all that channel tracking stuff slashed out for those 2 surfaces on that page .also when switch to a track with less fx slots then the one before those slots hang around as NoMap on the display which messes up my light system. I dont know if that was intended but its not like that in that 92 build. I just like that better.
thanks for your reply Geoff. Is this a bug ?
Cragster is offline   Reply With Quote
Old 11-21-2020, 06:35 PM   #11640
Mistik
Human being with feelings
 
Join Date: Nov 2018
Posts: 8
Default

Quote:
Originally Posted by Cragster View Post
I have a ProX and the master meter never worked with CSI. I think that was one of the many things on Geoffs list.
Ah, I see. Hopefully coming in a future update then

Did you manage to get the DisplayUpper and Lower to work on the master channel? I can't seem to get it display info for the master channel either. It just says "master" on the lower display when I switch to the master track..

Cheers
Mistik is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:09 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.