Old 05-27-2018, 05:26 AM   #1
cjunekim
Human being with feelings
 
Join Date: Dec 2016
Posts: 140
Default WASAPI exclusive issue

Hello My OS is Windows 10 and I recently upgraded to 1803 April update.

In addition to that , I also upgraded the driver for my audio interface, which is Behringer UMC404HD. The upgraded version is 4.38. The USB driver is written by Thesycon.

Its ASIO driver works okay in Reaper. However, when I select WASAPI exclusive, there is a problem. The setting works without an error, but as soon as I hit the play button, the cursor is stuck and doesn't move. Recording as well.

If I change WASAPI exclusive to shared in reaper, it works okay. Or, I can disable the recording channel(giving it size 0) and it works okay in exclusive mode.

The WDM Kernel Streaming shows the same symptom as well.

Has anyone experienced similar things?

Last edited by cjunekim; 05-27-2018 at 06:10 AM.
cjunekim is offline   Reply With Quote
Old 05-27-2018, 06:01 AM   #2
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Germany
Posts: 5,216
Default

There is an (IMHO) still not decided discussion if or if not a hardware device needs to come with a dedicatedly WASAPI enabled driver to take advantage of what Win10 WASAPI offers on top of the older (e.g. Direct-X) Audio subsystem, and hence allow for ASIO-like performance/latency and merging of multiple asynchronous sound devices.

-Michael
__________________
www.boa-sorte.de
mschnell is offline   Reply With Quote
Old 05-27-2018, 06:01 AM   #3
vitalker
Human being with feelings
 
vitalker's Avatar
 
Join Date: Dec 2012
Posts: 4,005
Default

Try to use (polled) mode or just restart reaper.
__________________
Quote:
Originally Posted by Sexan View Post
Make a thread "F%#! you Reaper! I quit!" to get more views and feedback since these kind of threads get much more traction
SoundCloudFR: "Real" Non-destructive GLUEAll the REAPER names
vitalker is online now   Reply With Quote
Old 05-27-2018, 06:09 AM   #4
cjunekim
Human being with feelings
 
Join Date: Dec 2016
Posts: 140
Default

Tried it and it didn't work.

Quote:
Originally Posted by vitalker View Post
Try to use (polled) mode or just restart reaper.
cjunekim is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:36 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.