Old 06-03-2021, 08:06 AM   #281
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by mozart999uk View Post
I'm on windows 10. Yes I did install the fonts as per the instructions.

I've attached my screenshot :-)
do you use display resolution scaling in Windows settings? i ask because i see that mute/solo looks weird similar as scaled monitors

Last edited by gapalil001; 06-03-2021 at 08:13 AM.
gapalil001 is offline   Reply With Quote
Old 06-03-2021, 08:24 AM   #282
mozart999uk
Human being with feelings
 
Join Date: Nov 2010
Posts: 758
Default

Quote:
Originally Posted by gapalil001 View Post
do you use display resolution scaling in Windows settings? i ask because i see that mute/solo looks weird similar as scaled monitors
Actually ignore me. I've just looked again at the other poster's problem and mine isn't misaligned like his / hers.

Sorry. I should have looked more carefully :-(
mozart999uk is offline   Reply With Quote
Old 06-03-2021, 08:33 AM   #283
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by mozart999uk View Post
Actually ignore me. I've just looked again at the other poster's problem and mine isn't misaligned like his / hers.

Sorry. I should have looked more carefully :-(
no. all is fine. at your screenshot i see the things thats will not happens, especially undesired width label. now i notice that reaper won't hide width label text when margins move it out of coordinates with enabled UI scaling. i'll try to solve it today and update theme files
gapalil001 is offline   Reply With Quote
Old 06-03-2021, 09:12 AM   #284
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

THEME FILES UPDATED
- fixed issue with undesired width label under pan label in TCP (i hope)
- new MONO/STEREO button in master TCP/MCP
- new HiDpi volume/pan/width labels in 4k theme versions (smoothest on retina screens)
gapalil001 is offline   Reply With Quote
Old 06-03-2021, 01:34 PM   #285
gricky
Human being with feelings
 
Join Date: Mar 2021
Posts: 1
Default

this might be a dumb question, but where is the theme adjuster file? on windows all i can do is get to a "Theme Color Controls" window
gricky is offline   Reply With Quote
Old 06-04-2021, 02:35 AM   #286
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by gricky View Post
this might be a dumb question, but where is the theme adjuster file? on windows all i can do is get to a "Theme Color Controls" window
Theme adjuster is a reaper script. You can find it in reaper’s action list (“actions” tab above) full name of the script - default 6.0 theme adjuster.lua
gapalil001 is offline   Reply With Quote
Old 06-04-2021, 03:29 AM   #287
Vagelis
Human being with feelings
 
Vagelis's Avatar
 
Join Date: Oct 2017
Location: Larisa, Greece
Posts: 1,391
Default

I still have the same issue with newest version as before, so might be something in my end, i 'll send you a pm with my config
Vagelis is offline   Reply With Quote
Old 06-04-2021, 01:31 PM   #288
sguyader
Human being with feelings
 
Join Date: Dec 2020
Posts: 42
Default

Quote:
Originally Posted by gapalil001 View Post
It’s really strange behavior to me. Seems like I can’t solve this problem by myself, do you use Mac or win?
It's not a big problem.
I use a mac.
sguyader is online now   Reply With Quote
Old 06-04-2021, 01:39 PM   #289
sguyader
Human being with feelings
 
Join Date: Dec 2020
Posts: 42
Default

Quote:
Originally Posted by gricky View Post
this might be a dumb question, but where is the theme adjuster file? on windows all i can do is get to a "Theme Color Controls" window
Try this:
- switch to Default theme
- open the Theme Adjuster
- switch back to Flat Madness theme
- now you should be able to get the Flat Madness theme adjuster
sguyader is online now   Reply With Quote
Old 06-04-2021, 02:24 PM   #290
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by sguyader View Post
It's not a big problem.
I use a mac.
This bug fixed today, and files updated
gapalil001 is offline   Reply With Quote
Old 06-05-2021, 01:03 PM   #291
Phildelica
Human being with feelings
 
Join Date: Jul 2016
Posts: 2
Default Black on black waveforms?

Hi, I love this theme and want it to be my default, but I’m having a problem with the waveforms being black on a black background. I could change the track and items color, but I want to be able to open tracks in default and see the waveforms. Is there a way to change the background or waveform color as default? Thanks, it’s great apart from that!
Phildelica is offline   Reply With Quote
Old 06-06-2021, 01:44 AM   #292
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by Phildelica View Post
Hi, I love this theme and want it to be my default, but I’m having a problem with the waveforms being black on a black background. I could change the track and items color, but I want to be able to open tracks in default and see the waveforms. Is there a way to change the background or waveform color as default? Thanks, it’s great apart from that!
Thank you! In my config new tracks are painted in random colors automatically (and children tracks paints to it’s folder color) so I’ve never had this issue. I also highly recommended to try it. You can setup it in extensions-> auto color/icon/layout, create new rule - track/(any)/color(random) and if desired - track/(children)/color(parent).
But if you still like when your tracks painted black, you can tweak it via theme tweak/configuration window from action list. You gonna find two colors - media item peaks and peak edges and choose it by your personal taste. Don’t forget to save your customized theme!
gapalil001 is offline   Reply With Quote
Old 06-06-2021, 02:27 PM   #293
sguyader
Human being with feelings
 
Join Date: Dec 2020
Posts: 42
Default

Quote:
Originally Posted by gapalil001 View Post
This bug fixed today, and files updated
What did you fix? The Theme Adjuster problem?
If so, I'm afraid to say it's not fixed in V2c3, I just installed it and it's the same issue: to get the Theme Adjuster I have to switch to Default theme, otherwise all I get is the color controls window.
sguyader is online now   Reply With Quote
Old 06-07-2021, 05:56 AM   #294
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by sguyader View Post
What did you fix? The Theme Adjuster problem?
If so, I'm afraid to say it's not fixed in V2c3, I just installed it and it's the same issue: to get the Theme Adjuster I have to switch to Default theme, otherwise all I get is the color controls window.
no. i'm about pan labels. I can't force theme adjuster bug and it's works fine to me. also i can only program slders, i guess this issue must be fixed by reaper developers. i would be glad if You or somebody post this issue (with sreencast, etc.)in my thread about reaper theme dev limitations

but i also interested, what actually happens when you push these arrows?



Thank You!

Last edited by gapalil001; 06-07-2021 at 06:07 AM.
gapalil001 is offline   Reply With Quote
Old 06-07-2021, 08:03 AM   #295
Uncovered Pitch
Human being with feelings
 
Join Date: Jul 2018
Posts: 48
Default

Quote:
Originally Posted by gapalil001;2451998

but i also interested, what actually happens when you push these arrows?
[IMG
https://stash.reaper.fm/42188/theme%20adjuster.gif[/IMG]

Thank You!
The problem is that some of us don't even get to see those arrows. I've tried to explain it before that there is a difference between "Custom Colors"(=what you see) and "Color Controls"(=what we see, screenshot attached). Switching to the default theme and then back is the only workaround.
Attached Images
File Type: png ColorControls.png (19.4 KB, 17 views)
Uncovered Pitch is offline   Reply With Quote
Old 06-07-2021, 12:42 PM   #296
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by Uncovered Pitch View Post
The problem is that some of us don't even get to see those arrows. I've tried to explain it before that there is a difference between "Custom Colors"(=what you see) and "Color Controls"(=what we see, screenshot attached). Switching to the default theme and then back is the only workaround.
that's another theme adjuster. you need to run script called "default_6.0 theme adjuster.lua from action list. it's stock script from the box

Last edited by gapalil001; 06-07-2021 at 12:51 PM.
gapalil001 is offline   Reply With Quote
Old 06-07-2021, 01:45 PM   #297
Uncovered Pitch
Human being with feelings
 
Join Date: Jul 2018
Posts: 48
Default

Quote:
Originally Posted by gapalil001 View Post
that's another theme adjuster. you need to run script called "default_6.0 theme adjuster.lua from action list. it's stock script from the box
Yes now I understand—those of us who had problems were using the standard command from the Options menu. The script worked perfectly for me. Thanks!
Uncovered Pitch is offline   Reply With Quote
Old 06-07-2021, 05:09 PM   #298
sguyader
Human being with feelings
 
Join Date: Dec 2020
Posts: 42
Default

Quote:
Originally Posted by gapalil001 View Post
that's another theme adjuster. you need to run script called "default_6.0 theme adjuster.lua from action list. it's stock script from the box
Oh, ok, it wasn't clear for me, I was just trying to launch the Theme Adjuster from the Options menu.
sguyader is online now   Reply With Quote
Old 06-08-2021, 01:19 PM   #299
Phildelica
Human being with feelings
 
Join Date: Jul 2016
Posts: 2
Default Thanks

Thanks for reply, It solved the black waves on black background problem well. Great theme!
Phildelica is offline   Reply With Quote
Old 06-08-2021, 03:59 PM   #300
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by Phildelica View Post
Thanks for reply, It solved the black waves on black background problem well. Great theme!
You are welcome!
gapalil001 is offline   Reply With Quote
Old 06-09-2021, 01:00 AM   #301
mozart999uk
Human being with feelings
 
Join Date: Nov 2010
Posts: 758
Default

Quote:
Originally Posted by gapalil001 View Post
if you mean theme tweak/configuration window, yes. you can do it.

you need to unpack the theme and browse data folder from archive of the new theme to your tweaked .reapertheme file. (browse button at the bottom)

but please note, that there is a whole new soften color scheme in V2, so old tweaks mean that you will downgrade to old colors. so i would recommend to tweak important things again to keep new colors.
Sorry - can you just clarify this for me? I don't quite understand the procedure :-)
mozart999uk is offline   Reply With Quote
Old 06-09-2021, 05:46 PM   #302
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by mozart999uk View Post
Sorry - can you just clarify this for me? I don't quite understand the procedure :-)
That’s pretty easy. In theme tweak/configuration window press the “browse” button and select the latest theme file. New theme will works with your tweaked color scheme. Be sure to save the new theme file.
gapalil001 is offline   Reply With Quote
Old 06-10-2021, 01:20 AM   #303
mozart999uk
Human being with feelings
 
Join Date: Nov 2010
Posts: 758
Default

Quote:
Originally Posted by gapalil001 View Post
That’s pretty easy. In theme tweak/configuration window press the “browse” button and select the latest theme file. New theme will works with your tweaked color scheme. Be sure to save the new theme file.
Oh ok. Great! Thanks :-)
mozart999uk is offline   Reply With Quote
Old 06-10-2021, 02:03 PM   #304
timothys_monster
Human being with feelings
 
timothys_monster's Avatar
 
Join Date: Jan 2012
Location: Germany
Posts: 966
Default

I don't know if it had been addressed already but in the render dialog it's hard to see the wave form (using 1080p dark here):

timothys_monster is offline   Reply With Quote
Old Yesterday, 05:21 AM   #305
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by timothys_monster View Post
I don't know if it had been addressed already but in the render dialog it's hard to see the wave form (using 1080p dark here):

thank you! i got the same. (i mostly use bright version now) i will fix it with the new update. before it's happens you can easily fix it manually - go to theme tweak/configuration window and find colors "media item background odd tracks" and "media item background even tracks" and change it to desired. don't forget to save before exit

i apologise about that!
gapalil001 is offline   Reply With Quote
Old Yesterday, 06:12 AM   #306
mozart999uk
Human being with feelings
 
Join Date: Nov 2010
Posts: 758
Default

Quote:
Originally Posted by gapalil001 View Post
That’s pretty easy. In theme tweak/configuration window press the “browse” button and select the latest theme file. New theme will works with your tweaked color scheme. Be sure to save the new theme file.
Fraid this didn't work :-(

I loaded the latest theme file and the changes for example to the colours of the gridlines reset to default :-(
mozart999uk is offline   Reply With Quote
Old Today, 04:37 AM   #307
gapalil001
Human being with feelings
 
gapalil001's Avatar
 
Join Date: May 2016
Location: Kyiv, Ukraine
Posts: 191
Default

Quote:
Originally Posted by mozart999uk View Post
Fraid this didn't work :-(

I loaded the latest theme file and the changes for example to the colours of the gridlines reset to default :-(
you gonna browse theme archive to your theme file, and use new theme file instead of theme archive
gapalil001 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:25 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.