COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :

Go Back   Cockos Incorporated Forums > Other Software Discussion > WDL users forum

Reply
 
Thread Tools Display Modes
Old 12-10-2019, 01:16 PM   #1
kakemot
Human being with feelings
 
Join Date: Dec 2019
Posts: 3
Default Problems building VST3 with iPlug2 project

So I have the latest iPlug2 and the latest VST3 SDK.
Everything works so far, building audio unit, macOS app and what not. But not VST3.

When I build VST3 I get an error saying vstbypassprocessor.cpp is missing. To solve this I found this exact file on github by googling it. I tried placing it in the right folder. However when the file is found, it still leads to multiple errors.
"AudioBuffer is not a class, namespace or enumeration"

I'm guessing this can be solved by having the right VST3 SDK to start with (perhaps a slightly older version?) which I cannot seem to find anywhere.

Could anyone point me in the right direction?

I'm using xCode 10.1 on macOS 10.13.6 if that's any use.
kakemot is offline   Reply With Quote
Old 12-15-2019, 06:03 AM   #2
olilarkin
Human being with feelings
 
Join Date: Apr 2009
Location: UK
Posts: 1,195
Default

steinberg updated the vst3 sdk. pull the latest iplug2 master, and it should work
__________________
VirtualCZ | pMix | Endless Series | iPlug2 | Linkedin | Facebook
Available for Audio Dev tuition via Skype (IPlug/JUCE/C++)
olilarkin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:27 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.