COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 09-15-2016, 01:14 AM   #1
User958303869
Human being with feelings
 
Join Date: Sep 2016
Posts: 6
Default Getting started with wdl-ol

I'm trying to get up and running with wdl-ol.
Are there any getting started/installing tutorials that can help me get to the point where I can build the example projects?

I've been following this tutorial but am getting stuck when trying to build the example projects. http://www.martin-finke.de/blog/arti...copy_sdk_files
I've tried it in Visual Studio 2015 and Visual C++ 2010 (2010 is the one used in the tutorial). Any pointers would be greatly appreciated!

When launching in Visual C++ 2010 I get a popup:
One of more projects in the solution were not loaded correctly. Please see the Output Window for details.

..of which the output window looks like:
C:\wdl-ol\IPlugExamples\MyFirstPlugin2\IPlugEffect-app.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlugEffect-app' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\WDL\IPlug\IPlug.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlug' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\WDL\lice\lice.vcxproj : warning : Platform 'x64' referenced in the project file 'lice' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\IPlugExamples\MyFirstPlugin2\IPlugEffect-vst2.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlugEffect-vst2' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\IPlugExamples\MyFirstPlugin2\IPlugEffect-vst3.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlugEffect-vst3' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\VST3_SDK\base\win\base_vc10.vcxproj : warning : Platform 'x64' referenced in the project file 'base' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\IPlugExamples\MyFirstPlugin2\IPlugEffect-aax.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlugEffect-aax' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\AAX_SDK\Libs\AAXLibrary\WinBuild\AAXLibrary.vcx proj : error : Project "C:\wdl-ol\AAX_SDK\Libs\AAXLibrary\WinBuild\AAXLibrary.vcx proj" could not be found.

C:\wdl-ol\PT9_SDK\AlturaPorts\TDMPlugIns\PlugInLibrary\Wi nBuild\PlugInLib.vcxproj : error : Project "C:\wdl-ol\PT9_SDK\AlturaPorts\TDMPlugIns\PlugInLibrary\Wi nBuild\PlugInLib.vcxproj" could not be found.

When trying to build I get errors, a popup saying this:
Unable to start program 'C:\wdl-ol\IPlugExamples\MyFirstPlugin2\build-win\app\Win32\bin\IPlugEffect.exe'.
The system cannot find the file specified.

And the output window looks like:
1>------ Build started: Project: lice, Configuration: Debug Win32 ------
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\M icrosoft.Cpp.Win32.Targets(511,5): error MSB8008: Specified platform toolset (v140) is not installed or invalid. Please make sure that a supported PlatformToolset value is selected.
2>------ Build started: Project: IPlug, Configuration: Debug Win32 ------
2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\M icrosoft.Cpp.Win32.Targets(511,5): error MSB8008: Specified platform toolset (v140) is not installed or invalid. Please make sure that a supported PlatformToolset value is selected.
3>------ Build started: Project: IPlugEffect-app, Configuration: Debug Win32 ------
3>LIBCMTD.lib(sprintf.obj) : error LNK2005: _sprintf already defined in IPlug.lib(IPlugBase.obj)
3>LIBCMTD.lib(vsprintf.obj) : error LNK2005: __vsprintf_l already defined in IPlug.lib(IPlugBase.obj)
3>LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt
========== Build: 0 succeeded, 3 failed, 0 up-to-date, 0 skipped ==========


When trying to run in Visual Studio 2015:
Severity Code Description Project File Line Suppression State
Error LNK2019 unresolved external symbol "int __stdcall MainDlgProc(struct HWND__ *,unsigned int,unsigned int,long)" (?MainDlgProc@@YGHPAUHWND__@@IIJ@Z) referenced in function _WinMain@16 IPlugEffect-app C:\wdl-ol\IPlugExamples\MyFirstPlugin\app_main.obj 1
Severity Code Description Project File Line Suppression State
Error LNK1120 1 unresolved externals IPlugEffect-app C:\wdl-ol\IPlugExamples\MyFirstPlugin\build-win\app\Win32\bin\IPlugEffect.exe 1

And the output...
1>------ Build started: Project: IPlugEffect-app, Configuration: Debug Win32 ------
1>app_main.obj : error LNK2019: unresolved external symbol "int __stdcall MainDlgProc(struct HWND__ *,unsigned int,unsigned int,long)" (?MainDlgProc@@YGHPAUHWND__@@IIJ@Z) referenced in function _WinMain@16
1>build-win\app\Win32\bin\IPlugEffect.exe : fatal error LNK1120: 1 unresolved externals
========== Build: 0 succeeded, 1 failed, 2 up-to-date, 0 skipped ==========

Last edited by User958303869; 10-05-2016 at 02:08 AM.
User958303869 is offline   Reply With Quote
Old 09-26-2016, 08:48 AM   #2
User958303869
Human being with feelings
 
Join Date: Sep 2016
Posts: 6
Default

97 views and no replies?

Can someone please give me a hand?
User958303869 is offline   Reply With Quote
Old 09-26-2016, 09:07 AM   #3
Tired_Joe
Human being with feelings
 
Join Date: Apr 2015
Posts: 53
Default

I tested VS2015 but it didnīt work for me, because I am not a pro and I didnīt have a clou how to make it run. I switched to VS2013 and everything worked.

Itīs a good Idea to unload every plugin format you donīt use. Then make VST2 oder VST3 as your Startup Projekt. Maybe go to project settings and adjust your toolsets.

Try to run the example plugins before you start with the (very good) tutorial.

Did you install the VST SDK?
Tired_Joe is offline   Reply With Quote
Old 09-26-2016, 09:34 AM   #4
random_id
Human being with feelings
 
random_id's Avatar
 
Join Date: May 2012
Location: PA, USA
Posts: 306
Default

Quote:
Originally Posted by User958303869 View Post
When launching in Visual C++ 2010 I get a popup:
One of more projects in the solution were not loaded correctly. Please see the Output Window for details.

..of which the output window looks like:
C:\wdl-ol\IPlugExamples\MyFirstPlugin2\IPlugEffect-app.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlugEffect-app' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\WDL\IPlug\IPlug.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlug' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\WDL\lice\lice.vcxproj : warning : Platform 'x64' referenced in the project file 'lice' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\IPlugExamples\MyFirstPlugin2\IPlugEffect-vst2.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlugEffect-vst2' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\IPlugExamples\MyFirstPlugin2\IPlugEffect-vst3.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlugEffect-vst3' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\VST3_SDK\base\win\base_vc10.vcxproj : warning : Platform 'x64' referenced in the project file 'base' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.
I don't know what these errors are from. They are all related to the 64-bit builds, but I don't know. You might want to right-click on the individual projects and build them. Then you can focus on particular problems with VST or VST3, instead of building the entire solution.

Quote:
Originally Posted by User958303869 View Post
C:\wdl-ol\IPlugExamples\MyFirstPlugin2\IPlugEffect-aax.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlugEffect-aax' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

C:\wdl-ol\AAX_SDK\Libs\AAXLibrary\WinBuild\AAXLibrary.vcx proj : error : Project "C:\wdl-ol\AAX_SDK\Libs\AAXLibrary\WinBuild\AAXLibrary.vcx proj" could not be found.

C:\wdl-ol\PT9_SDK\AlturaPorts\TDMPlugIns\PlugInLibrary\Wi nBuild\PlugInLib.vcxproj : error : Project "C:\wdl-ol\PT9_SDK\AlturaPorts\TDMPlugIns\PlugInLibrary\Wi nBuild\PlugInLib.vcxproj" could not be found.
These errors are going to happen, because you don't have the RTAS or AAX SDKs. You can ignore these.

Quote:
Originally Posted by User958303869 View Post
When trying to build I get errors, a popup saying this:
Unable to start program 'C:\wdl-ol\IPlugExamples\MyFirstPlugin2\build-win\app\Win32\bin\IPlugEffect.exe'.
The system cannot find the file specified.
If you are trying to debug the App version, it apparently can't be found. I would look in that directory and see if there is any EXE file. There might be a conflict with naming. Is the plugin names "MyFirstPlugin2" like the folder name, or is it "IPlugEffect" like the EXE. You might need to edit the resource.h file and make sure the PLUG_NAME, BUNDLE_NAME, etc. are correct.

Quote:
Originally Posted by User958303869 View Post
And the output window looks like:
1>------ Build started: Project: lice, Configuration: Debug Win32 ------
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\M icrosoft.Cpp.Win32.Targets(511,5): error MSB8008: Specified platform toolset (v140) is not installed or invalid. Please make sure that a supported PlatformToolset value is selected.
2>------ Build started: Project: IPlug, Configuration: Debug Win32 ------
2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\M icrosoft.Cpp.Win32.Targets(511,5): error MSB8008: Specified platform toolset (v140) is not installed or invalid. Please make sure that a supported PlatformToolset value is selected.
3>------ Build started: Project: IPlugEffect-app, Configuration: Debug Win32 ------
3>LIBCMTD.lib(sprintf.obj) : error LNK2005: _sprintf already defined in IPlug.lib(IPlugBase.obj)
3>LIBCMTD.lib(vsprintf.obj) : error LNK2005: __vsprintf_l already defined in IPlug.lib(IPlugBase.obj)
3>LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt
========== Build: 0 succeeded, 3 failed, 0 up-to-date, 0 skipped ==========
This error looks to be a problem with trying to build in VS 2010. VS 2010 is not finding the v140 toolset (which is the default VS 2015 toolset. You might need to go into the IPlug and Lice projects and make sure the toolset is correct (right-click and select "Properties"). Also, make sure you set the correct toolset for both 32 and 64 bit versions. Then, rebuild the solutions before trying to build your plugin. However, I haven't had issues with VS 2015, and I think it might be easier to just move to 2015. Still, you will want to make sure IPlug, Lice, and any other "base" solutions are built correctly before trying to build your plugin. I am not sure if the tutorial goes into this step, but look at text files in WDL-OL regarding getting the projects built.

Quote:
Originally Posted by User958303869 View Post
When trying to run in Visual Studio 2015:
Severity Code Description Project File Line Suppression State
Error LNK2019 unresolved external symbol "int __stdcall MainDlgProc(struct HWND__ *,unsigned int,unsigned int,long)" (?MainDlgProc@@YGHPAUHWND__@@IIJ@Z) referenced in function _WinMain@16 IPlugEffect-app C:\wdl-ol\IPlugExamples\MyFirstPlugin\app_main.obj 1
Severity Code Description Project File Line Suppression State
Error LNK1120 1 unresolved externals IPlugEffect-app C:\wdl-ol\IPlugExamples\MyFirstPlugin\build-win\app\Win32\bin\IPlugEffect.exe 1

And the output...
1>------ Build started: Project: IPlugEffect-app, Configuration: Debug Win32 ------
1>app_main.obj : error LNK2019: unresolved external symbol "int __stdcall MainDlgProc(struct HWND__ *,unsigned int,unsigned int,long)" (?MainDlgProc@@YGHPAUHWND__@@IIJ@Z) referenced in function _WinMain@16
1>build-win\app\Win32\bin\IPlugEffect.exe : fatal error LNK1120: 1 unresolved externals
========== Build: 0 succeeded, 1 failed, 2 up-to-date, 0 skipped ==========
I don't know about this one either, but it might have to do with the naming issue (between MyFirstPlug2 and IPlugEffect"

I wish I could give more advice. I know when I first started out I had to scrap my initial project and redownload everything. I think you might want to consider it since there are some issues between VS 2010 and 2015, as well as some potential naming issues.
__________________
Website: LVC-Audio
random_id is online now   Reply With Quote
Old 10-05-2016, 02:06 AM   #5
User958303869
Human being with feelings
 
Join Date: Sep 2016
Posts: 6
Default

Thanks a lot for your help!

Unfortunately I'm still getting stuck with some of these errors...

Is there no getting started tutorial to guide me through the installation process up to building the example projects?
User958303869 is offline   Reply With Quote
Old 10-05-2016, 11:13 PM   #6
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: Holland
Posts: 2,808
Default

Yeah sure, there is this:

http://www.martin-finke.de/blog/tags...o_plugins.html

It is a bit outdated in that it uses older versions of VS and Xcode, but it might still be of use.
Tale is offline   Reply With Quote
Old 10-08-2016, 04:37 AM   #7
User958303869
Human being with feelings
 
Join Date: Sep 2016
Posts: 6
Default

This is the tutorial I posted in the OP. Are there any others? Seems to be a really good one but I can't use it since the project won't build (though I know it's not the tut's fault.

I think my main problem is this:
C:\wdl-ol\WDL\IPlug\IPlug.vcxproj : warning : Platform 'x64' referenced in the project file 'IPlug' cannot be found. Please make sure you have it installed under '%VCTargetsPath%\Platforms\x64'.

I get multiple instances of it as shown above.
User958303869 is offline   Reply With Quote
Old 10-08-2016, 05:58 AM   #8
random_id
Human being with feelings
 
random_id's Avatar
 
Join Date: May 2012
Location: PA, USA
Posts: 306
Default

The error looks like it is from the x64 platform not being installed/found on your computer. I don't remember, but I am not sure the x64 platform is installed with VS2010. You might need to download it separately. I think it is the Windows 7.1 SDK.

That being said, I think you should really try to use VS 2015. VS 2013 and 2015 have both 32 and 64-bit platforms installed by default. Reading the documentation for WDL-OL, it looks like you need 2013 or newer to build the projects without significant modification. I know I said this before, but I think it might be easier to start fresh and try to build with 2013 or 2015. You can build Lice and IPlug individually for 32 and 64-bit platforms and see if the error continues. If there is no error, you can then try to build the VST project.

I would also just try to build the IPlugEffect project without any modification first. Once everything works, then you can duplicate it as a new project since you know everything is working.
__________________
Website: LVC-Audio
random_id is online now   Reply With Quote
Old 08-20-2017, 05:54 PM   #9
JustAPasserby
Human being with feelings
 
Join Date: Aug 2017
Posts: 1
Default

Hi

This post is nearly a year old but I was having a nearly identical set of issues and was able to get the wdl-ol MyFirstPlugin to eventually run so I thought I'd post. Note that I'm a complete noob at this so don't mistake this for well thought out solution. I just found something that fixed my problem by reading a bunch of forums and tried a few things. I'm posting in case it give some clues about the cause of the issue in the original post that could help somebody else.

It appears that my issue stemmed from having installed VS2015, tried to build in VS2015, and then later switching to VS2010. Once I got rid of VS2015 and re-generated a fresh wdl-ol folder, a very similar set of issues to those reported in the original post were resolved.

More detail:
I started following the wdl-ol instructions linked in the original post. I opted to try VS express 2015 first to follow the tutorial. I attempted to run the MyFirstPlugin to verify setup, and tried to build the original IPlugEffect project that is used to copy MyFirstPlugin. After attempting VS2015, I switched to VS2010 (unistalled vs2015 at this point). I returned to my wdl-ol folder and tried again. I recreated MyFirstPlugin from the IPlugEffect (the one I had tried to build in VS2015). When I tried to build the MyFirstPlugin, I received a set of errors that were very similar to the original post. Especially the errors about "Platform 'x64'...cannot be found", "Specified platform toolset (v140) in not installed...". Also, importantly, when I opened the MyFirstPlugin solution in VS 2010, it complained that the project was out of date and asked me to rebuild.

Thought that maybe VS2015 had altered something about the project or that there were some left over files from VS2015 still installed so removed everything associated with the VS2015 install and rebuilt the wdl-ol folder from scratch. After that, the project ran without a hitch. Not sure whether my theory about VS2015 was correct or not, or whether I just got lucky and happened to fix the issue, but there you go. If this helps anyone solve the original issue, I'd like to hear an explanation.
JustAPasserby is offline   Reply With Quote
Old 08-22-2017, 01:12 AM   #10
earlevel
Human being with feelings
 
Join Date: Dec 2015
Posts: 236
Default

FWIW, I built my shipping product in VS2015. It took some work, picking off build errors one by one until done, and I really can't give any kind of list of the changes needed—just an assurance that it will work.
earlevel is online now   Reply With Quote
Old 08-22-2017, 04:02 AM   #11
olilarkin
Human being with feelings
 
olilarkin's Avatar
 
Join Date: Apr 2009
Location: York, UK
Posts: 978
Default

I haven't read through all of this thread, so I'm not sure this will answer your problems. But if I remember correctly the master branch of WDL-OL on github should be set up to work with vs community 2015.

if you're following martin finke's blog, please don't check out an old commit #, since that will cause you a world of pain.

I'm in the process of updating WDL-OL to work with visual studio community 2017+ and Xcode 8+, hopefully soon it will be possible just to go with those tools
__________________
VirtualCZ | pMix | Endless Series | WDL-OL | Linkedin | Patreon
Available for Audio Dev tuition via Skype (IPlug/JUCE/C++)
olilarkin is offline   Reply With Quote
Old 08-22-2017, 01:07 PM   #12
MSK
Human being with feelings
 
Join Date: Jan 2017
Posts: 36
Default

From what I can remember (it was a few months ago when I set it up) Youlean's IPlug branch works with VS 2017 with relatively no problems.
MSK is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.