Old 03-11-2014, 03:00 AM   #1
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 17,473
Default Enclosing MIDI clips lost some notes

[v4.591]

With Item Mix behaviour set to "Enclosed items replace enclosing" or "items always replace earlier items", Glueing 2 MIDI clips lost some MIDI notes.



The notes in 4-5 are in two clips, one "enclosing" the other. The notes in 6-7 are the Glued result.
Attached Images
File Type: png MIDI_glue.png (5.8 KB, 114 views)
__________________
DarkStar ... interesting, if true. Inspired by ...
DarkStar is offline   Reply With Quote
Old 03-11-2014, 03:28 AM   #2
gofer
-blänk-
 
gofer's Avatar
 
Join Date: Jun 2008
Posts: 11,050
Default

The bug happens before glueing. You'll hear that note ring through as soon as you create the "enclosed item" situation.

The note-off of a note in the longer item is ignored in the "enclosed item" situation if the note-off is within the "enclose" range - or snapped to the position where the shorter item starts.
The same happens with the other replace mix behavior, btw. They are too rigid with MIDI note-offs. Those note offs which belong to notes that already sound should probably get through.

EDIT: Although that might cause problems if the enclosed item has notes on the same pitch (but with another rhythm) which might get stopped by the note-off from the enclosing item... uggh, not a super easy fix after all...

Maybe just send the note-off where the enclosed item starts?

Last edited by gofer; 03-11-2014 at 03:37 AM.
gofer is offline   Reply With Quote
Old 03-11-2014, 03:38 AM   #3
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 17,473
Default

Thank you for the clarification (I didn't try playing it).

I'll put it in the Issue Tracker:
http://forum.cockos.com/project.php?issueid=5109
__________________
DarkStar ... interesting, if true. Inspired by ...

Last edited by DarkStar; 03-11-2014 at 05:19 AM.
DarkStar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:39 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.