Old 05-09-2019, 12:39 PM   #441
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 3,026
Default

Yep, works, not sure what went wrong. Sorry for the inconvenience!
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan Römer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is online now   Reply With Quote
Old 05-12-2019, 01:15 PM   #442
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,629
Default

@julian - just letting you know after the latest update to your scripts and API, there is no more flickering AT ALL on my computer here.


Thank you!
EvilDragon is online now   Reply With Quote
Old 05-17-2019, 01:19 PM   #443
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by reapero View Post
I guess the Arch&Tilt script on this thread does something similar but i find it very confusing to work with.
Please let me know if anything is unclear and should be explained better.

Arch/Tilt should work very straightforward, as this GIF demonstrates. Between Arch/Tilt and Stretch/Compress, you can do everything and much more than Cubase's CC Editor can:



Quote:
Originally Posted by reapero View Post
Have i missed a script that does this in a more convenient way than the VelocityTool script?
Yes - the js_Mouse editing scripts!


Quote:
Originally Posted by reapero View Post
Would there be any interest in the community to have such a script?
I would be disappointed if (m)any in the community would prefer a Cubase-clone tool. I regard Cubase's CC Editor as outdated and limited, and my scripts are intended to be more elegant and far more powerful.

AFAIK, for example, Cubase's CC Editor can only do plain linear tilts and flat compressions. SONAR's Transform Tool is more advanced, as it can can do warping, and has a nifty "soft mode" (which inspired my "Tilt to chased values" script).


Quote:
Originally Posted by reapero View Post
In case this isnt avalable yet..is this now more easily doable than a year ago?
Indeed. At long last, after lots and lots of work, with the recent versions of the ReaScriptAPI extension, a "Transform Tool" with transparent overlay and mouse control is now fully doable.

I have already written a basic Transform Tool script, but I see little value in it. There are two main objections:

* Inconsistency: REAPER is quite shortcut-oriented, and nowhere else does REAPER use Transform Tools with overlaid graphics. MIDI notes, audio stretch markers, automation lanes, etc. all require editing that is just as complex as CC editing. NOTE: When Sexan completes his fantastic new Area Selection scripts, this objection will fall away.

* The biggest problem: messy interface: I haven't yet found a satisfactory way to pack all editing functions into one UI. Note that, besides my own scripts, there are also REAPER's native functions such as "Move in one direction" and "Linear ramp". (Any suggestions would be appreciated.)

Last edited by juliansader; 05-17-2019 at 01:29 PM.
juliansader is offline   Reply With Quote
Old 05-19-2019, 08:16 AM   #444
reapero
Human being with feelings
 
Join Date: Aug 2011
Posts: 249
Default

Thanks Julian, really appreciate the detailed answer.

I guess my main problem is i come from more than a dozen years of experience using Cubase and all of my Reaper prefs and settings mimic Cubase for the most part.

I really could get by easily with the limitations on Cubase so i dont really feel the need of the cool and nifty features on your scripts. I miss however left dragging to do tilt or scale (as you do everywhere else in Reaper and any other soft) and i also miss a "one to rule them all" phylosophy instead of having different scripts to do specific stuff. Less options, more efficiency...classic thing popping up with Reaper, isnt it?

I´ll give Tilt&Arch + Stretch/ Compress another run and try to overcome my left dragging syndrome.

Sexan´s Area selection seems so close now though..that would really make it for me. Other users also mentioned about using it in the midi editor.

Thanks for all your help and contributions to the forum and community!
reapero is online now   Reply With Quote
Old 06-07-2019, 12:20 AM   #445
AugerJ
Human being with feelings
 
Join Date: Dec 2015
Posts: 403
Default

Hi, juliansader. About your MIDI Inspector.
The script says: "ME_TextColor = nil -- Color in RRGGBB format".
I didn't know what RRGGBB is, so I've searched...
Typing in values like E0E0E0 or #E0E0E0 or 0xE0E0E0 instead of nil either doesn't change the text color or brings up the error message window:
"js_MIDI Inspector.lua:165: attempt to get length of a number value"
or "malformed" something.

Could you give some examples of that line with text color other than nil?

Last edited by AugerJ; 06-07-2019 at 12:30 AM.
AugerJ is offline   Reply With Quote
Old 06-07-2019, 12:44 AM   #446
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

0xE0E0E0 is the correct format for Lua hexadecimal values.

However, in the most recent version of the script, you don't need to edit the script file to change the color of the text that is displayed in the MIDI editor -- instead, just right-click on the Inspector in the MIDI editor, and go to "Font settings" in the context menu. (The same dialog should also pop up when you first run the new version.)
juliansader is offline   Reply With Quote
Old 06-07-2019, 01:24 AM   #447
AugerJ
Human being with feelings
 
Join Date: Dec 2015
Posts: 403
Default

Quote:
Originally Posted by juliansader View Post
0xE0E0E0 is the correct format for Lua hexadecimal values.

However, in the most recent version of the script, you don't need to edit the script file to change the color of the text that is displayed in the MIDI editor -- instead, just right-click on the Inspector in the MIDI editor, and go to "Font settings" in the context menu. (The same dialog should also pop up when you first run the new version.)
Thanks.
In AARRGGBB format (on the right-click - Font settings)
I typed in 0xFFE0E0E0 for zero transparency...
0x80E0E0E0, 0xCCE0E0E0, 0x1AE0E0E0 and 0x00E0E0E0 don't seem to affect transparency though.
AugerJ is offline   Reply With Quote
Old 06-07-2019, 10:25 AM   #448
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by AugerJ View Post
Thanks.
In AARRGGBB format (on the right-click - Font settings)
I typed in 0xFFE0E0E0 for zero transparency...
0x80E0E0E0, 0xCCE0E0E0, 0x1AE0E0E0 and 0x00E0E0E0 don't seem to affect transparency though.
This is due to an idiosyncratic way that Windows' native window-rendering functions interpret alpha values (compared to Linux, Photoshop, etc): On Windows, RRGGBB values are not "alpha-multiplied" while rendering, so you have to do it yourself.

In alpha-multiplication, the R, G and B values are each multiplied with the (normalized) alpha value, so for example if you want to change the alpha of 0xFFFF0000 to 0xCC, then the RR values must also change: 0xCCCC0000.

EDIT: Uploaded new version 1.56 that does automatic alpha-premultiplication.
juliansader is offline   Reply With Quote
Old 06-16-2019, 09:33 AM   #449
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 304
Default

Hi!

Big fan of all you do for Reaper JS.

Just wanted to say that I'm having a little less-than-deal behavior with Arch and Tilt, both the mouse editing version and "events in lane" version.

I'm not sure when your most recent update to these scripts have been, but even after updating my ReaPack, I'm showing v3.23 for Arch&Tilt in lane, and v4.20 for the mouse editing version.

They are both performing similarly, kindof jumping and glitching about, sometimes its ok and other times not.

I'd be more than happy to upload a video demonstration.
Dafarkias is offline   Reply With Quote
Old 06-16-2019, 09:53 AM   #450
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by Dafarkias View Post
Both the mouse editing version and "events in lane" version.

I'm not sure when your most recent update to these scripts have been, but even after updating my ReaPack, I'm showing v3.23 for Arch&Tilt in lane, and v4.20 for the mouse editing version.
You can safely delete the old "events in lane" version.


Quote:
Originally Posted by Dafarkias View Post
They are both performing similarly, kindof jumping and glitching about, sometimes its ok and other times not.
Note that the script tries to arch the CC under the mouse (or immediately to the left of the mouse) towards the mouse position, so if the CCs themselves are jumpy (for example, a square LFO), then the arching will also be jumpy while you move the mouse smoothly left and right.


Quote:
Originally Posted by Dafarkias View Post
I'd be more than happy to upload a video demonstration.
Please do upload a video demonstration.
juliansader is offline   Reply With Quote
Old 06-17-2019, 02:24 PM   #451
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 304
Default

Quote:
Originally Posted by juliansader View Post
You can safely delete the old "events in lane" version.




Note that the script tries to arch the CC under the mouse (or immediately to the left of the mouse) towards the mouse position, so if the CCs themselves are jumpy (for example, a square LFO), then the arching will also be jumpy while you move the mouse smoothly left and right.




Please do upload a video demonstration.
Ahh.

So the reason it was jumping up and down was because I was using it on CC with a high value of contrast.

My apologies, It's an absolutely brilliant script.

I'd PM you but I can't for some reason:

Quick question about this https://forum.cockos.com/showthread.php?t=182146 script, it doesn't really work well with large amounts of CC data. What I want to do is use your "js_Insert linear or shaped ramps between selected CCs or pitches in lane under mouse.lua" script to basically virtualize half pedaling for recorded midi piano "64 Hold Pedal" data. It works great. But after that I want to run the (thousands of) CC's through a slight bit of randomization to complete the effect, but it kinda chokes and crashes most of the time.

Would you be interested, by chance, in compiling a CC randomization script using your blazing-fast chunk techniques and superior programming?

Regards,

Dafark

[ADD.] also curious if there's any variable I can alter in your "js_Insert linear or shaped ramps between selected CCs or pitches in lane under mouse.lua" that would allow for me to get even greater ramp values than those afforded by the mouse being at the very "top" or "bottom" of the lane?
Dafarkias is offline   Reply With Quote
Old 06-23-2019, 03:55 AM   #452
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by Dafarkias View Post
Quick question about this https://forum.cockos.com/showthread.php?t=182146 script, it doesn't really work well with large amounts of CC data. What I want to do is use your "js_Insert linear or shaped ramps between selected CCs or pitches in lane under mouse.lua" script to basically virtualize half pedaling for recorded midi piano "64 Hold Pedal" data. It works great. But after that I want to run the (thousands of) CC's through a slight bit of randomization to complete the effect, but it kinda chokes and crashes most of the time.

Would you be interested, by chance, in compiling a CC randomization script using your blazing-fast chunk techniques and superior programming?
I have posted an updated, faster version in the linked thread.


Quote:
Originally Posted by Dafarkias View Post
also curious if there's any variable I can alter in your "js_Insert linear or shaped ramps between selected CCs or pitches in lane under mouse.lua" that would allow for me to get even greater ramp values than those afforded by the mouse being at the very "top" or "bottom" of the lane?
I would recommend that you update all these old "lane under mouse" scripts to the new "Mouse editing" versions. In this case, "js_Mouse editing - Connect nodes", which is more versatile, and can also do steeper ramps.
juliansader is offline   Reply With Quote
Old 06-29-2019, 03:13 AM   #453
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 304
Default

Quote:
Originally Posted by juliansader View Post
I would recommend that you update all these old "lane under mouse" scripts to the new "Mouse editing" versions. In this case, "js_Mouse editing - Connect nodes", which is more versatile, and can also do steeper ramps.
Thanks for updating your cc script for me, I was about to attempt to try and do it myself, but I'm sure you saved me a lot of time, again, thank you!

After your reply to my post on this thread, I did ensure to use your newer versions of the scripts, and I definitely noticed that the ramp is able to be set steeper than the older versions. However, if there were some sort if 'simple tweak' in which the script would create even steeper ramps, I would be very happy about that.

[Retraction]
Please let me verify I am using the correct scripts (I was confident that I was), and for the meanwhile, please disregard this post. I appreciate your prompt replies and help!
Dafarkias is offline   Reply With Quote
Old 06-29-2019, 07:03 AM   #454
lowellben
Human being with feelings
 
lowellben's Avatar
 
Join Date: Aug 2010
Location: They put me in a home.
Posts: 3,186
Default

Quote:
Originally Posted by juliansader View Post
I have posted an updated, faster version in the linked thread.




I would recommend that you update all these old "lane under mouse" scripts to the new "Mouse editing" versions. In this case, "js_Mouse editing - Connect nodes", which is more versatile, and can also do steeper ramps.
FYI your script crashes my reaper. all i have to do is select two MIDI cc nodes in a lane, run your connect nodes script, and reaper crashes instantly no warnings just closes right out. Poof.

Any ideas why? I've tried changing shortcuts, doesn't matter.
Connect Nodes = instant Reaper close crash.
Right before the crash you can see the mouse icon change to an arc icon and then it just closes Reaper.
__________________
47.8% of statistics are made up.
lowellben is online now   Reply With Quote
Old 06-29-2019, 07:13 AM   #455
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by lowellben View Post
Right before the crash you can see the mouse icon change to an arc icon and then it just closes Reaper.
Which OS/REAPER/script/SWS/ReaScriptAPI versions are you using? Does it happen in all CC lanes? Do any of the other scripts crash too?
juliansader is offline   Reply With Quote
Old 06-29-2019, 07:29 AM   #456
lowellben
Human being with feelings
 
lowellben's Avatar
 
Join Date: Aug 2010
Location: They put me in a home.
Posts: 3,186
Default

Quote:
Originally Posted by juliansader View Post
Which OS/REAPER/script/SWS/ReaScriptAPI versions are you using? Does it happen in all CC lanes? Do any of the other scripts crash too?
Just updated everything via ReaPack, all your scripts current.


SWS 2.10.0 #1
ReaPack v1.2.2

Windows 10 64 Reaper 5.978

Not sure how to find ReaScriptAPI.

Testing other CC lanes now. So far, Mod wheel fails. All CC lanes fail.

FYI updating to reaper 5.979 fixes the problem.
Do you know why?
__________________
47.8% of statistics are made up.

Last edited by lowellben; 06-29-2019 at 07:52 AM.
lowellben is online now   Reply With Quote
Old 07-03-2019, 06:33 AM   #457
AugerJ
Human being with feelings
 
Join Date: Dec 2015
Posts: 403
Default

Hello, Julian. The text of js_MIDI Inspector (docked above the MIDI Editor) gets distorted when the Play cursor passes it by. As it's shown on the attached gif.
The text resets back to normal when the "page" changes or when I left-click somewhere in the Piano roll field/area (regretfully, not on the Stop command).
Closer to the end of the gif I made a few passes including "NOTES" through "Pitch" and excluding "Length" etc.
As you can see the text tends to get more distorted with every pass.
Attached Images
File Type: gif REAPER-Script-js_MIDI Inspector.lua.gif (40.8 KB, 130 views)
AugerJ is offline   Reply With Quote
Old 07-08-2019, 01:43 AM   #458
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,629
Default

Can confirm the MIDI inspector text distortion over here as well.
EvilDragon is online now   Reply With Quote
Old 07-08-2019, 10:32 AM   #459
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by AugerJ View Post
Hello, Julian. The text of js_MIDI Inspector (docked above the MIDI Editor) gets distorted when the Play cursor passes it by. As it's shown on the attached gif.
This is a side-effect of the script automatically pausing all MIDI analysis and window re-painting during playback or recording, to minimize CPU usage. (Window re-painting is usually relatively cheap to do, so perhaps I can re-activate it.)


Quote:
Originally Posted by Dafarkias View Post
After your reply to my post on this thread, I did ensure to use your newer versions of the scripts, and I definitely noticed that the ramp is able to be set steeper than the older versions.
In case anyone else is wondering about steep ramps, here is a demonstration that ramps can go as steep as possible:
juliansader is offline   Reply With Quote
Old 08-13-2019, 02:52 PM   #460
BryanChi
Human being with feelings
 
Join Date: Jan 2019
Posts: 27
Default

Thanks for this awesome script! It's been very useful!
Just wanna confirm if the "Stretch and Compress" can be used to stretch/compress a single note? I remember being able to do it, not sure if it's because the new version disabled this or if I'm doing something wrong. I'm using 4.21 which I believe is the latest?
BryanChi is offline   Reply With Quote
Old 08-13-2019, 10:47 PM   #461
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,629
Default

You don't need the script to stretch/compress a single note. You just use Alt+drag on note edge in this case, that is the default behavior in Reaper.
EvilDragon is online now   Reply With Quote
Old 08-14-2019, 02:24 PM   #462
BryanChi
Human being with feelings
 
Join Date: Jan 2019
Posts: 27
Default

Quote:
Originally Posted by EvilDragon View Post
You don't need the script to stretch/compress a single note. You just use Alt+drag on note edge in this case, that is the default behavior in Reaper.
Yes, but I'm liked using the script because it's faster, you can just marquee select the note and use the script, instead of having to aim the mouse at the note edge
BryanChi is offline   Reply With Quote
Old 08-15-2019, 04:48 AM   #463
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

I am delighted that you are using my script, and that it is even faster to use than the native version for single notes!

EDIT: v4.22 uploaded with restored ability to stretch single notes.

I will restore the ability to stretch single notes in an upcoming version. In the meantime, you can make a small edit to the script: Replace this code at line 2939:
juliansader is offline   Reply With Quote
Old 08-15-2019, 01:24 PM   #464
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 3,026
Default

Quote:
Originally Posted by BryanChi View Post
Yes, but I'm liked using the script because it's faster, you can just marquee select the note and use the script, instead of having to aim the mouse at the note edge
I agree, this really speeds up workflow. Using this for stretching CCs all the time. I wasn’t even aware, that the script works for notes as well!
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan Römer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is online now   Reply With Quote
Old 08-16-2019, 11:34 AM   #465
BryanChi
Human being with feelings
 
Join Date: Jan 2019
Posts: 27
Default

Quote:
Originally Posted by juliansader View Post
I am delighted that you are using my script, and that it is even faster to use than the native version for single notes!

EDIT: v4.22 uploaded with restored ability to stretch single notes.

I will restore the ability to stretch single notes in an upcoming version. In the meantime, you can make a small edit to the script: Replace this code at line 2939:
Thank you sooo much Julian! Is there a way I can donate you?
BryanChi is offline   Reply With Quote
Old 08-16-2019, 11:42 AM   #466
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 862
Default

Quote:
Originally Posted by BryanChi View Post
Thank you sooo much Julian! Is there a way I can donate you?
(See the first post of this thread.)
tack is online now   Reply With Quote
Old 08-26-2019, 01:38 PM   #467
BryanChi
Human being with feelings
 
Join Date: Jan 2019
Posts: 27
Default

Quote:
Originally Posted by tack View Post
(See the first post of this thread.)
Found it, Thanks! : )
BryanChi is offline   Reply With Quote
Old 11-01-2019, 01:21 PM   #468
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 3,026
Default

I think I found a bug:




The item in question in a project:

https://nextcloud.stephanroemer.net/...CAnFRfXMXyNQxS
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan Römer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...

Last edited by _Stevie_; 11-11-2019 at 02:11 PM. Reason: fixed the link
_Stevie_ is online now   Reply With Quote
Old 11-11-2019, 01:40 PM   #469
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 304
Default

Hey Julian,

Having an issue where pressing or holding the hotkey assigned to the 'connect nodes'script is not performing as it used to, on my machine.

I've got your latest v. of your extension and also your scripts as of ReaPack.

The script activates upon pressing the hotkey but immediately exists the script without allowing for adjustment.

I've tried reinstalling, as well.

Any thoughts, perhaps?

Sorry to be so much trouble to you!





BTW, this thread should be stickied...
Dafarkias is offline   Reply With Quote
Old 11-11-2019, 01:58 PM   #470
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by Dafarkias View Post
Having an issue where pressing or holding the hotkey assigned to the 'connect nodes'script is not performing as it used to, on my machine.
Are you perhaps using one of the dev versions? The Extract and Connect scripts have unfortunately not yet been updated to work with the new CC envelopes.
juliansader is offline   Reply With Quote
Old 11-11-2019, 02:00 PM   #471
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by _Stevie_ View Post
I think I found a bug:

The item in question in a project:
Could you please check the link? It seems to link to "Kontakt Library Manager v3", not a project.
juliansader is offline   Reply With Quote
Old 11-11-2019, 02:12 PM   #472
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 3,026
Default

Quote:
Originally Posted by juliansader View Post
Could you please check the link? It seems to link to "Kontakt Library Manager v3", not a project.
Sorry, I have literally no idea what happened, lol.
Link is fixed!
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan Römer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is online now   Reply With Quote
Old 11-13-2019, 09:10 AM   #473
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 304
Default

Quote:
Originally Posted by juliansader View Post
Are you perhaps using one of the dev versions? The Extract and Connect scripts have unfortunately not yet been updated to work with the new CC envelopes.
That's a negative. I'm using the latest general release, portable install. A few months ago the scripts worked (when I was last posting here about them) but I can't imagine what has changed in my installation since then.

I realize I haven't given you much troubleshooting information to work with here...

Is there anything I can provide that may help us to figure whether or not this is user error or a compatibility issue? Lice-cap, step-by-step, video, etc.?
Dafarkias is offline   Reply With Quote
Old 11-15-2019, 10:19 AM   #474
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by Dafarkias View Post
Is there anything I can provide that may help us to figure whether or not this is user error or a compatibility issue? Lice-cap, step-by-step, video, etc.?
Ideally, could you perhaps upload a minimal RPP containing only the MIDI item with the CC events already selected? A Licecap would also be a very helpful bonus.
juliansader is offline   Reply With Quote
Old 11-19-2019, 01:56 PM   #475
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 304
Default

Will do, thanks for replying! I'll try and upload tomorrow.

[edit]

Won't be able to do it today, exhausted from work.

Last edited by Dafarkias; 11-20-2019 at 12:14 PM.
Dafarkias is offline   Reply With Quote
Old 11-24-2019, 04:01 AM   #476
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 304
Default

Sorry it took so long!



In the setup you see in this GIF, I have the connect nodes script using the hotkey 'j'. Per the script instructions, I'm holding the key, but after it's first and initial press no adjustments can be made. The script used to work just as its instructions describe for me.

Not sure what changed....

Windows 10
REAPER 5.987
JS .995

I've included a cheesy little midi-loop in a .rpp where I've manually written CC 64-hold notes.
Attached Files
File Type: rpp Nodes.rpp (66.6 KB, 6 views)

Last edited by Dafarkias; 11-24-2019 at 04:54 AM.
Dafarkias is offline   Reply With Quote
Old 11-24-2019, 05:42 AM   #477
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,836
Default

Quote:
Originally Posted by Dafarkias View Post
In the setup you see in this GIF, I have the connect nodes script using the hotkey 'j'. Per the script instructions, I'm holding the key, but after it's first and initial press no adjustments can be made. The script used to work just as its instructions describe for me.
I will check the rpp as soon as I get to my DAW. In the meantime, try clicking the right mouse button to see if the script switches to "Warp" mode. (It should display a "Warp" tooltip.) I guess that the script is in "Bézier" mode, in which it tries to automatically find the smoothest curve, and which cannot be warped.
juliansader is offline   Reply With Quote
Old 11-24-2019, 05:45 AM   #478
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 304
Default

Clicking right-click while holding down my 'j' hotkey, just to clarify?

[edit]

...and now I feel like an idiot again!

Yup, that exactly did the trick! It feels even smoother than the last time I remember using this script, absolutely phenomenal job!

Last edited by Dafarkias; 11-24-2019 at 05:54 AM.
Dafarkias is offline   Reply With Quote
Old 12-01-2019, 06:28 AM   #479
Vagelis
Human being with feelings
 
Join Date: Oct 2017
Location: Larisa, Greece
Posts: 403
Default

Quick draw lfo is really amazing as all of the scripts you 've made!
I'd like to ask, would there be a possibility to have a quick draw lfo for track automation envelopes as well? It would be really helpful!
Vagelis is online now   Reply With Quote
Old 12-01-2019, 04:45 PM   #480
Newman Ray
Human being with feelings
 
Join Date: Jul 2010
Posts: 14
Default

Quote:
Originally Posted by juliansader View Post
I will check the rpp as soon as I get to my DAW. In the meantime, try clicking the right mouse button to see if the script switches to "Warp" mode. (It should display a "Warp" tooltip.) I guess that the script is in "Bézier" mode, in which it tries to automatically find the smoothest curve, and which cannot be warped.
I have setup a number of toolbar buttons in the MIDI editor for your MIDI scripts, but it's been a while since I've used them. I'm working on something now and can't get them to work. I thought I only had to right-click the toolbar button and then left-click in the CC area to begin activating them. However, the cursor is showing the "A" that it normally shows for the activation of the scripts, but left-clicking only results in drawing CC lanes. I've tried common keyboard modifiers as well (ie. Ctrl, Alt, Shift, etc.), but nothing works. I'm not sure if I'm forgetting something or if something changed with a Reapack update? Thanks for your help and your fantastic scripts!

UPDATE - Nevermind! I didn't realize it was just a left-click in the CC lane instead of left-click and drag. Thanks!

Last edited by Newman Ray; 12-01-2019 at 06:05 PM. Reason: Updated Info
Newman Ray is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:52 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.