Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Compatibility

Reply
 
Thread Tools Display Modes
Old 12-15-2015, 06:08 PM   #1
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default Updated (again) Faderport Support (Faderport XT)

A new windows only update has been uploaded by amagalma. If his update interests you, head over to his thread here . If you use OS X or just want this driver, keep reading

Latest Update February 13, 2016

Download
https://stash.reaper.fm/26189/Faderp...%20Release.zip

After working with the code for a while I've decided to release the faderport XT driver based on the work of yhertogh's and karbomusic's additions to the driver.

This is karbomusic's original thread on the topic.

Since this is based off of the code of both karbo and yhertogh, this plugin should replace theirs.

Installation for Windows & OS X

Installation is a bit different than the original, instead of replacing Reaper's built in control surface plugin, this will be installed as a UserPlugin.
  1. Locate the Reaper Resource Directory. You can find it by starting Reaper and clicking Options > Show Reaper Resource Path in explorer/finder.
  2. Copy reaper_csurf_fpxt.ini to the Resource folder.
  3. Copy the reaper_csurf_fpxt library file (dll for windows; dylib for mac) to the UserPlugins folder. If it doesn’t exist, create it.
  4. Restart Reaper.
  5. Go to Options > Preferences > Control Surfaces and select Faderport XT
  6. Choose PreSonus - Faderport for both MIDI In & Out devices.
  7. Click OK twice.
  8. Your Faderport should now be set up using the new driver.

** If you are using karbomusic's Faderport XT, you will need to replace it with reaper_csurf.dll that came with Reaper before installing this one.

New Features
  • Shift + Bank activates FX mode (FADER_CONTROLS_FX in prefs)
  • -Bank light will blink when in FX mode
  • -Select through FX with Channel Select
  • -Select through Params with scroll knob
  • Time for pan to reset touch state can be modified (PAN_TOUCH_RESET_TIME)
  • Added support for Action CommandID
  • Reload .ini file during runtime (Shift + Stop + Play; Shift does _not_ latch for this)
  • Scrolling with pan knob delays updating fader (PAN_SCROLL_FADER_TIME)
Customization

All customizations are in the INI file (reaper_csurf_fpxt.ini) here are the defaults but the entire point is that you can make them do what works best for you:

==============================================
** New options are in bold **
Code:
MCP_VIEW=1 (default=1, enabled, Autoscroll works)
SHIFT_LATCH=1 (default=1, enabled, shift latch works)
AUTO_SCROLL=1 (view will scroll if track is hidden)
SELECT_IS_TOUCHED=1 (when creating a new track, make the new track also the 'last touched track')
PAN_SCROLLS_TRACKS=1 (Use the pan knob to scroll through tracks)
FADER_CONTROLS_FX=1 (Allows you to change FX params with the fader)
PAN_TOUCH_RESET_TIME=250  (Sets how long it will take for pan to reset after being touched)
PAN_SCROLL_FADER_TIME=250 (If pan scrolls tracks is active, Sets the delay for how long the fader updates to the new track's fader location)
PAN_MIN_TURNS=1 (The number of turns to actually get one turn event)
PAN_RESOLUTION=128 (The number of turn events to pan from L to R)
SELECT_TOUCHED_PARAM=1(Clicking an FX param in fx mode assigns the fader)

ENABLE_INTRO=1 (Allows a little intro light show of a text string)
INTRO_STRING=FPXT (The text string that the faderport lights will display)

;pan actions
;0=pan, 1=scroll tracks, 2=custom actions
PAN_MODE=1  (Sets the action for turning the pan knob)
PAN_MODE_SHIFT=0 (Sets the action for turning the pan knob while shift is pressed)
ACTION_PAN_LEFT=40104 
ACTION_PAN_RIGHT=40105
ACTION_PAN_LEFT_SHIFT=41666
ACTION_PAN_RIGHT_SHIFT=41667

ACTION_PUNCH=40222 (set start point)
ACTION_PUNCH_SHIFT=40172 (Go to previous marker/project start)
ACTION_USER=40157 (insert marker at current position)
ACTION_USER_SHIFT=40173 (Go to next marker/project end) 
ACTION_LOOP=1068 (toggle repeat)
ACTION_LOOP_SHIFT=40915 (set end point)
ACTION_FOOTSWITCH=40073 (play/pause)
ACTION_FOOTSWITCH_SHIFT=1013(record)
ACTION_MIX=40078 (toggle mixer visible)
ACTION_MIX_SHIFT=41077	(toggle show all floating windows except mixer)
ACTION_PROJECT=40861 (go to next project tab - cycle)
ACTION_PROJECT_SHIFT=40295 (zoom out project)
ACTION_TRANS=40259 (toggle transport visible)
ACTION_TRANS_SHIFT=1134 (tap tempo)
==============================================

To customize just grab the action ID you need from reaper and change it in the INI file for the button you wish to customize. You can right click the Action and select "Copy selected action command ID". This will work with custom actions as well as extensions (ex. SWS)

Learn more about FX Mode
Learn more about Pan Modes

Please feel free to browse/compile the code for yourself! It can be found here:
https://github.com/TheNimaj/Faderport_XT
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.

Last edited by The_Nimaj; 01-27-2019 at 01:57 PM. Reason: Updates for 1.27.2016
The_Nimaj is offline   Reply With Quote
Old 12-15-2015, 06:13 PM   #2
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 24,765
Default

Hey man,

Nice job. Got your PM and you are correct, been busy as crap so if this also contains the windows version, run with it and I'll pull down from your repository in the near future. Thanks again for running with this, the Mac users will be extremely happy to see this. I've kept up with this since 2010 or 2011 so I don't mind a break for sure. You might throw it in the stash soon, just so it is also available in the event you and I are kidnapped by hot swiss babe insurgents or something, never to be seen again.
__________________
If it requires a null test to find it, it is by definition minuscule.
karbomusic is online now   Reply With Quote
Old 12-15-2015, 06:22 PM   #3
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default How to modify FX with Faderport

Getting to and using FX Mode

First enable/add the line FADER_CONTROLS_FX=1 to your ini file.
You don't have to restart reaper either, press SHIFT+STOP+PLAY (shift latch doesn't matter here) if it worked, the three lights will flash. (This button combination reloads the ini file, updated your button mappings)

Then, press SHIFT (and hold, if shift latch isn't enabled) + BANK. The BANK button will begin to blink and if you currently have a track selected with TrackFX, the fader should jump to the value of the first plugin's first param. If there are no FX on the track (or on the last selected track) the Bank light will blink quickly a few times before shutting off. This means that FX mode failed.

NOTE: In some rare cases, entering FX mode on a new track or one with newly added FX will fail. Simply click off of the track and selected it again. This should fix the issue.

You can use the PAN knob to select different params within the plugin and use the Channel Select to select the next or previous plugin in the chain. For now, the info tooltip in the bottom left hand corner of the REAPER window will briefly display the currently selected FX or param. The fader should also jump to the value of each selected param! This will allow you to automate FX params like the volume, but there are bound to be some bugs with this feature.

Simply Press the BANK button once more to exit FX mode.
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.

Last edited by The_Nimaj; 04-08-2016 at 05:53 AM.
The_Nimaj is offline   Reply With Quote
Old 12-15-2015, 09:18 PM   #4
tut
Human being with feelings
 
Join Date: Feb 2012
Posts: 45
Default

Thank you, thank you, thank you! My Faderport has been reborn! I have waited so long for this piece of brilliance. My Mac is listening to my Faderport, and my Faderport will not stop giving it directions. Thank you to everyone who helped make this possible. This is going to be a very late night. You need to spread the word on this, shout it from the rooftops! Just fantastic work.
tut is offline   Reply With Quote
Old 12-16-2015, 02:20 PM   #5
tut
Human being with feelings
 
Join Date: Feb 2012
Posts: 45
Default

If the Swiss babe insurgents haven't taken you away yet, I have a couple questions. I am really struggling to get the pan knob to land on specific parameters. It seems jumpy for lack of a better word. Is it possible to change the sensitivity of the rotational readings? In other words, make it so that moving to the next parameter requires a bit more turning.(Hopefully creating a larger landing spot?) If that is not possible, could I somehow switch parameter selection from the pan knob to the channel select? I realize that some FX have hundred+ parameters available, but the exactness of clicking would be faster at this point. Thanks again for your outstanding work, it just feels so nice to write automation with an actual fader. Cheers!
tut is offline   Reply With Quote
Old 12-16-2015, 08:18 PM   #6
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default

Yeah I've had that problem as well. I believe it's a problem with the firmware as this also happens in S1. I suppose I could let you change the sensitivity of the pan knob but I'd really like to allow you to click on the param you want. The issue is that the only way I've found that the API will notify me of which param was touched is if you actually change the param. I will look more into it tonight.
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.
The_Nimaj is offline   Reply With Quote
Old 12-17-2015, 03:47 PM   #7
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default

Actually, I was wrong. I seems that the event I need fires even if you don't actually change the param. So I've implemented 3 things:
Pan minimum turns - That is, it will take an arbitrary number of turns to actually get a single turn event
Adjustable pan resolution - The default is 128, which means it would take 128 turn events to get from 100% L to 100% R.
Select Touched Param - Which will do what it sounds like..the last touched param will be assigned to the fader.

The corresponding options are:
Code:
PAN_MIN_TURNS=3
PAN_RESOLUTION=128
SELECT_TOUCHED_PARAM=1
I've updated the file in the original post.
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.
The_Nimaj is offline   Reply With Quote
Old 03-17-2019, 02:25 PM   #8
Noisy Chairs
Human being with feelings
 
Join Date: May 2018
Posts: 31
Default

Quote:
Originally Posted by The_Nimaj View Post
Getting to and using FX Mode

First enable/add the line FADER_CONTROLS_FX=1 to your ini file.
You don't have to restart reaper either, press SHIFT+STOP+PLAY (shift latch doesn't matter here) if it worked, the three lights will flash. (This button combination reloads the ini file, updated your button mappings)

Then, press SHIFT (and hold, if shift latch isn't enabled) + BANK. The BANK button will begin to blink and if you currently have a track selected with TrackFX, the fader should jump to the value of the first plugin's first param.
Shucks, I just spent hella time getting the Reaper Preferences to recognize this driver. It does finally, but now I can't get this thing to go into FX Mode using this method. I checked my .ini file, and it is indeed written as described above. Nor will Shift+Stop+Play make it blink. Any thoughts why I can't get to FX Mode?
Noisy Chairs is offline   Reply With Quote
Old 03-27-2019, 01:41 PM   #9
1Man
Human being with feelings
 
1Man's Avatar
 
Join Date: Apr 2013
Location: Appleton, WI
Posts: 7
Default

Quote:
Originally Posted by Noisy Chairs View Post
Shucks, I just spent hella time getting the Reaper Preferences to recognize this driver. It does finally, but now I can't get this thing to go into FX Mode using this method. I checked my .ini file, and it is indeed written as described above. Nor will Shift+Stop+Play make it blink. Any thoughts why I can't get to FX Mode?
I have just reinstalled mine after upgrading computers, and I had to delete the "Non-XT" Control surface before the XT one would work properly. Having done that I hold shift + Bank and it indeed does start blinking. Then I open a plugin sand select a knob with my mouse and the Faderport jumps right to that parameter. When finished hit [Shift + Bank] another time.
1Man is offline   Reply With Quote
Old 08-25-2019, 06:02 PM   #10
Alleyoop
Human being with feelings
 
Join Date: Sep 2017
Posts: 44
Default Faderport loses contact with Reaper

If I don't use Reaper for a few weeks my Faderport Classic loses contact with Reaper. It's happened two or three times before, but this time I can't seemt to reconnect it despite updating my firmware and deleting any copies in the Control Surfaces Tab.
The clue is, similar to a poster above, that the MIDI in and MIDI out drop downs are blank.
What does that suggest that I've failed to do or have done incorrectly?
Thanks.
Attached Images
File Type: jpg Presonus Faderport.JPG (25.1 KB, 43 views)
Alleyoop is offline   Reply With Quote
Old 12-20-2015, 08:37 AM   #11
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Quote:
Originally Posted by The_Nimaj View Post
After working with the code for a while I've decided to release the faderport XT driver based on the work of yhertogh's and karbomusic's additions to the driver.
This is just fantastic work!
I was able to write paramter-envelopes with my Faderport.
That's just amazing good
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 12-20-2015, 08:40 AM   #12
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Had some fader hangup (conflicting messages I believe)
Tried EasyQ (vst), didn't work first. But that's because Reaper doesn't see parameters there.
Tried some other 3rd part vsts. Working so good

This is awesome!
__________________
Reaper x64, win 8.1
My music on Bandcamp

Last edited by G-Sun; 12-20-2015 at 08:46 AM.
G-Sun is offline   Reply With Quote
Old 01-19-2016, 01:20 AM   #13
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

I notice tooltip shows last touched parameter on shift vol left drag,
and in upper right corner.
Is that by intention?
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 01-20-2016, 05:22 PM   #14
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default

Quote:
Originally Posted by G-Sun View Post
I notice tooltip shows last touched parameter on shift vol left drag,
and in upper right corner.
Is that by intention?
It shows in the upper right because I couldn't figure out how to make it show up in a more useful location, so yes it's by intention.
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.
The_Nimaj is offline   Reply With Quote
Old 01-21-2016, 02:38 AM   #15
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

I'm experiencing errors when a parameter has envelope.

I have a delay, and are unabel to select feedback for the Faderport fader, as it holds onto another parameter that has envelope.
When I add an envelope for feedback, there sound like conflicting messages to the fader, like to motors going in different directions.
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 01-26-2016, 05:47 AM   #16
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Here is a visual of the flicker between two parameters



(I do no change on the gif above, and it's actually much faster changes)
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 01-26-2016, 05:49 AM   #17
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

The problem with tooltip is in fact quite important to me.
When I'm tweeking a fader, I often need to see the values,
but now it's gone, and replaced by last touch parameter.
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 01-26-2016, 09:51 PM   #18
Brado231
Human being with feelings
 
Join Date: Sep 2012
Location: Oz
Posts: 195
Default

Thanks karbomusic for the original mods (I've been using it and loving it for the last few years) and thanks to The_Nimaj for all of these new updates (fantastic additions!).

Two problems I have encountered so far that I was wondering if anyone has any ideas on....

1. The Intro lights don't work for me even although ENABLE_INTRO=1 is set in the ini file. When is this supposed to come up? When Reaper first initializes the device upon loading Reaper?

2. When I press Output it doesn't select the Master track anymore. ACTION_OUTPUT=1 is set in my ini file. Does anyone else have this issue?

FYI, I'm running Reaper 5.15 pre4 x64 atm I have 1.3.8 firmware on the faderport.

EDIT: Both problems happen on MAC and Windows version of Reaper for me (64-bit)

Thanks,
Brad

Last edited by Brado231; 01-26-2016 at 10:37 PM.
Brado231 is offline   Reply With Quote
Old 01-27-2016, 07:27 PM   #19
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default

I know about the intro light glitch (I haven't addressed it because I honestly didn't think anyone would use it ). I will look into the Output issue, I don't really use it myself so it's quite possible I've missed the bug. Thanks for the bug report, I'll post fixes soon.
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.
The_Nimaj is offline   Reply With Quote
Old 01-27-2016, 09:08 PM   #20
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default

Quote:
Originally Posted by Brado231 View Post
Thanks karbomusic for the original mods (I've been using it and loving it for the last few years) and thanks to The_Nimaj for all of these new updates (fantastic additions!).
Two problems I have encountered so far that I was wondering if anyone has any ideas on....
Fixed and updated along with an important bug fix.

Quote:
Originally Posted by G-Sun View Post
I'm experiencing errors when a parameter has envelope.

I have a delay, and are unabel to select feedback for the Faderport fader, as it holds onto another parameter that has envelope.
When I add an envelope for feedback, there sound like conflicting messages to the fader, like to motors going in different directions.
This is the important bug fix (hopefully). Also I missed your more recent post about the tooltip. I will try to fix ASAP (tomorrow if I get time), sorry about that.

EDIT: Actually the tooltip was related to the conflicting fader messages bug. So it may, in fact, be fixed.
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.

Last edited by The_Nimaj; 01-27-2016 at 09:25 PM.
The_Nimaj is offline   Reply With Quote
Old 01-27-2016, 11:48 PM   #21
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Quote:
Originally Posted by The_Nimaj View Post
Fixed and updated along with an important bug fix.



This is the important bug fix (hopefully). Also I missed your more recent post about the tooltip. I will try to fix ASAP (tomorrow if I get time), sorry about that.

EDIT: Actually the tooltip was related to the conflicting fader messages bug. So it may, in fact, be fixed.
Thank you very much!
I believe the driver don't release the parameters properly.
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 01-28-2016, 04:25 AM   #22
Brado231
Human being with feelings
 
Join Date: Sep 2012
Location: Oz
Posts: 195
Default

Quote:
Originally Posted by The_Nimaj View Post
Fixed and updated along with an important bug fix.
Thanks!! Both seem to be working perfectly for me now

I like the intro message. Very creative on your part!
Brado231 is offline   Reply With Quote
Old 01-28-2016, 09:30 AM   #23
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Tried 1.27.2016
and seemed like the bugs were sorted
Thanks!
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 01-28-2016, 11:14 PM   #24
Deewah
Human being with feelings
 
Deewah's Avatar
 
Join Date: Jan 2016
Location: Western Australia, Perth
Posts: 16
Default

Hi
Please help
My problem is: my effects on my sample aren't working.
Here's what's happening.
I use a synth machine (YAMAHA SU700) I have a sample with an effect, from the Machine I'm connected to an audio interface (DidgiDesign 003 rack) connected through six channels(synth connected with Audio interface).
From interface to CPU and into Reaper.
When I play sample the effect is not working.
Is it because through the channels effects are turned off. So is it because of the audio interface or do I have to adjust a setting in Reaper?

Thank you
Deewah is offline   Reply With Quote
Old 02-19-2016, 12:11 PM   #25
dro21
Human being with feelings
 
Join Date: Jun 2014
Posts: 3
Default reaper resource folder

is there actually a folder call "reaper resource" where do i copy the ini ?? i have no reaper resource folder
dro21 is offline   Reply With Quote
Old 02-19-2016, 04:53 PM   #26
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default

It's named "REAPER". If you just open up REAPER and go to Options -> Show REAPER resource path in explorer/finder, it will open it for you.
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.
The_Nimaj is offline   Reply With Quote
Old 03-02-2016, 05:18 PM   #27
Boogaloo
Human being with feelings
 
Join Date: Feb 2016
Posts: 2
Default Not quite there...

Originally posted in http://forum.cockos.com/showthread.php?t=91053 in error, but the driver I'm is from this thread, 13/2/2016....

My FP seems to be behaving fine in all respects, though I'm not sure what the default behaviour is for selecting its 'focus' regarding touching other controls and not selecting channels by pan/scrolling or by mouse.

For instance, if I pan/scroll to select (or mouse select) a channel so it's highlighted, the FP updates to the right fader levels. If I move off with the pan/scroll or mouse to another channel, all good.

However, if I touch (not even move) a pan control on another channel, that doesn't highlight that channel, but my FP behaves as if it had and will then control that channel. Is this normal?

Does this have any bearing on something I'm trying to do, which is use the Output (or Mix) button to launch the FX chain for the selected channel?

ACTION_OUTPUT=40291

This seems to work, so long as I mouse select, or scroll select *and then* touch the fader for the channel on my FP (or click on a panpot). If I just pan/scroll to a select a new channel, hitting Output only shows the last channels' FX chain.

It's piddling, but it gets confusing when I'm expecting my highlighted channel to be in focus and I'm off changing another fader, and the show FX chain for selected channel would be soooo helpful.

Win7/64, back to old firmware from the Presonus support link (the update broke me).

Fantastic work mate, much appreciated.
Boogaloo is offline   Reply With Quote
Old 03-04-2016, 07:03 PM   #28
The_Nimaj
Human being with feelings
 
Join Date: Dec 2015
Location: A city in GA
Posts: 103
Default

Quote:
Originally Posted by Boogaloo View Post
Originally posted in http://forum.cockos.com/showthread.php?t=91053 in error, but the driver I'm is from this thread, 13/2/2016....

For instance, if I pan/scroll to select (or mouse select) a channel so it's highlighted, the FP updates to the right fader levels. If I move off with the pan/scroll or mouse to another channel, all good.

However, if I touch (not even move) a pan control on another channel, that doesn't highlight that channel, but my FP behaves as if it had and will then control that channel. Is this normal?
Yes this was intended but may be something to make optional. As for your Output Action bringing up the wrong track FX, I can confirm this but it isn't immediately apparent as to why. I will look into it and see what the issue is.
__________________
Faderport XT for WIN/OSX
If it sounds good, it IS good...unless, of course, it doesn't sound good.
The_Nimaj is offline   Reply With Quote
Old 03-06-2016, 08:52 AM   #29
scotch
Human being with feelings
 
Join Date: Dec 2015
Posts: 5
Default

I am able to customize all of my Faderport buttons, except I cannot find an action code to make the "OUTPUT" button select the master track. Any ideas?

Last edited by scotch; 03-06-2016 at 02:18 PM.
scotch is offline   Reply With Quote
Old 03-07-2016, 06:54 AM   #30
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

My Faderport is working crappy now,
but are not sure it's this driver that causes it.
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 03-09-2016, 09:06 AM   #31
stevedcook
Human being with feelings
 
Join Date: Aug 2015
Posts: 31
Default Thanks for the work!

Just bought my Faderport and was having the usual fun with installing, then I found this thread and the magic happened! Thanks Karbo and Nimaj!
__________________
"We have no idea what we're doing...so we can do ANYthing!" Sir Paul McCartney
stevedcook is offline   Reply With Quote
Old 03-09-2016, 09:53 AM   #32
mlprod
Human being with feelings
 
Join Date: Jul 2015
Location: Stockholm, Sweden
Posts: 701
Default

Great job with this!

Im having trouble getting my FP to react to changes in the ini-file. It's supposed to also be in the UserPlugins folder right?

Also, probably related but I cant get the intro to work either=)

Any tips?
mlprod is offline   Reply With Quote
Old 03-09-2016, 01:31 PM   #33
Brado231
Human being with feelings
 
Join Date: Sep 2012
Location: Oz
Posts: 195
Default

Quote:
Originally Posted by mlprod View Post
Great job with this!

Im having trouble getting my FP to react to changes in the ini-file. It's supposed to also be in the UserPlugins folder right?

Also, probably related but I cant get the intro to work either=)

Any tips?
No, only the dll should be in the UserPlugins folder. The .ini file should be in the parent folder (Reaper resource path - e.g. C:\Users\<username>\AppData\Roaming\REAPER on Windows). See post #142 in this thread to see how you can find where the Reaper resource path exists on your system.
Brado231 is offline   Reply With Quote
Old 04-05-2016, 10:55 AM   #34
zakwax
Human being with feelings
 
zakwax's Avatar
 
Join Date: Apr 2016
Location: London, UK
Posts: 17
Default Faderport reborn after XT..

I am buzzin right now Faderport working great after getting its lovely little upgrade to XT...thanks again for everyone involved in this.
I only purchased this about a week ago and to be honest was so dissapointed till now...excellent stuff!
Just one thing.. that isnt really a biggy ... the undo function it seems is the only parameter that isnt working from the default Faderport
Any ideas?
zakwax is offline   Reply With Quote
Old 04-05-2016, 01:38 PM   #35
DistinctIsMe
Human being with feelings
 
DistinctIsMe's Avatar
 
Join Date: Apr 2016
Location: Columbus, OH
Posts: 22
Default

Quote:
Originally Posted by zakwax View Post
I am buzzin right now Faderport working great after getting its lovely little upgrade to XT...thanks again for everyone involved in this.
I only purchased this about a week ago and to be honest was so dissapointed till now...excellent stuff!
Just one thing.. that isnt really a biggy ... the undo function it seems is the only parameter that isnt working from the default Faderport
Any ideas?
I had to enter that path manually too: "ACTION_UNDO=40029"

Just so you know, you can find the path codes to customize each action by accessing the Action List in Reaper. The codes are listed under the Command ID tab.
DistinctIsMe is offline   Reply With Quote
Old 04-05-2016, 02:39 PM   #36
zakwax
Human being with feelings
 
zakwax's Avatar
 
Join Date: Apr 2016
Location: London, UK
Posts: 17
Default

Quote:
Originally Posted by DistinctIsMe View Post
I had to enter that path manually too: "ACTION_UNDO=40029"

Just so you know, you can find the path codes to customize each action by accessing the Action List in Reaper. The codes are listed under the Command ID tab.
Got it..thanks man
zakwax is offline   Reply With Quote
Old 04-05-2016, 11:59 PM   #37
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Quote:
Originally Posted by zakwax View Post
the undo function it seems is the only parameter that isnt working from the default Faderport
Working fine here.
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 04-06-2016, 12:22 PM   #38
Grappa
Human being with feelings
 
Join Date: May 2007
Posts: 11
Default Faderport Heaven

All,

After seeing this thread a while ago I got the wallet out and my new Faderport arrived today. 10 minutes later all was good and my Reaper world changed forever..

I can't begin to express what a game changer this is for me and I really like to make a contribution to the people that worked to bring this to life. How can I do this?

Regards,

Simon
Grappa is offline   Reply With Quote
Old 04-06-2016, 12:25 PM   #39
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 24,765
Default

Quote:
Originally Posted by Grappa View Post
All,

After seeing this thread a while ago I got the wallet out and my new Faderport arrived today. 10 minutes later all was good and my Reaper world changed forever..

I can't begin to express what a game changer this is for me and I really like to make a contribution to the people that worked to bring this to life. How can I do this?

Regards,

Simon
You just did.
__________________
If it requires a null test to find it, it is by definition minuscule.
karbomusic is online now   Reply With Quote
Old 04-06-2016, 12:37 PM   #40
DistinctIsMe
Human being with feelings
 
DistinctIsMe's Avatar
 
Join Date: Apr 2016
Location: Columbus, OH
Posts: 22
Default

Quote:
Originally Posted by karbomusic View Post
You just did.
Hey Karbo...just wanted to make sure you saw my requested feature (and offer to pay you for however much work it would take) before it gets buried in the thread. Thanks for your time!
DistinctIsMe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:04 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.