COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :

Go Back   Cockos Incorporated Forums > Other Software Discussion > WDL users forum

Reply
 
Thread Tools Display Modes
Old 09-06-2019, 01:17 PM   #1
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 248
Default Post-build "plists" don't always match resource.h - why?

I have made a habit now of compiling revised versions of my plugins TWICE in Xcode because sometimes the first compilation does not update the "plists" to match resource.h Any idea why that is happening? I am using the Xcode config files that came in WDL-OL. Updating the plists SHOULD be part of the process per the build settings - but it's not always working.

Anyone else come across this? Cause/solution?

Last edited by Nonlinear; 09-21-2019 at 08:59 AM.
Nonlinear is offline   Reply With Quote
Old 09-15-2019, 11:18 PM   #2
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 248
Default

Anyone?

For example, I can change and save the plugin version in resource.h to 1.2.0 from 1.1.0 but when compiled I get a plist that says version 1.1.0. If I build it a second time (changing nothing else) I get the correct 1.2.0 plist version.

Why is that happening?

Last edited by Nonlinear; 09-15-2019 at 11:28 PM.
Nonlinear is offline   Reply With Quote
Old 09-21-2019, 08:59 AM   #3
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 248
Default

Bump. Anyone?
Nonlinear is offline   Reply With Quote
Old 09-22-2019, 02:00 AM   #4
olilarkin
Human being with feelings
 
olilarkin's Avatar
 
Join Date: Apr 2009
Location: UK
Posts: 1,163
Default

It’s to do with the sequencing of when the script gets run in the Xcode build phases.We have a IPlug2 branch To fix it that I need to look at
__________________
VirtualCZ | pMix | Endless Series | iPlug2 | Linkedin | Facebook
Available for Audio Dev tuition via Skype (IPlug/JUCE/C++)
olilarkin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:04 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.