Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 10-24-2018, 10:49 AM   #601
tonfunk
Human being with feelings
 
Join Date: Oct 2018
Posts: 5
Default

Hi osxmidi,

Quote:
Originally Posted by osxmidi View Post
I don't know much about the Waves licenses and I have only used the demo licenses.

Did you manage to install a Waves license via usb using Wine?, because some have had trouble doing that.

A possible reason for the Waveshell to not load a plugin is that a dll override is possibly missing but it could be due to other reasons as well.
yes, no issues with the license conversion to my machine. As pointed out the location is indicated with the hostname of my linux machine, not the mostly mentioned 'drive_c' from wine.

regarding the issue w/ VComp - a missing dll overwrite could be the issue, but which one is not indicated by the error message, so I do not know how to debug this. Maybe you can check with a demo of VComp if this catches your attention.

Br,
Sven
tonfunk is offline   Reply With Quote
Old 10-24-2018, 10:04 PM   #602
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 536
Default

Quote:
Originally Posted by tonfunk View Post
Hi osxmidi,



yes, no issues with the license conversion to my machine. As pointed out the location is indicated with the hostname of my linux machine, not the mostly mentioned 'drive_c' from wine.

regarding the issue w/ VComp - a missing dll overwrite could be the issue, but which one is not indicated by the error message, so I do not know how to debug this. Maybe you can check with a demo of VComp if this catches your attention.

Br,
Sven
I tried v-comp and it seems like something Wine can't handle (yet?).

Wine is hit and miss and a hit rate of say 80% is maybe possible but some things are not going to work due to Wines current capabilities/limitations.
osxmidi is offline   Reply With Quote
Old 10-24-2018, 11:25 PM   #603
tonfunk
Human being with feelings
 
Join Date: Oct 2018
Posts: 5
Default

Quote:
Originally Posted by osxmidi View Post
I tried v-comp and it seems like something Wine can't handle (yet?).

Wine is hit and miss and a hit rate of say 80% is maybe possible but some things are not going to work due to Wines current capabilities/limitations.
ok, but thanks for checking!
tonfunk is offline   Reply With Quote
Old 10-25-2018, 03:18 AM   #604
TonE
Human being with feelings
 
Join Date: Feb 2009
Location: Reaper HAS send control via midi !!!
Posts: 1,833
Default

Quote:
Originally Posted by TonE View Post
Now let me check quickly if shortcircuit 1.1.2 behaves better with linvst, that would be too cool.
shortcircuit 1.1.2 behaves in same bad form, it can not find the samples after save, close, reopen of the project. Strange shortcircuit working correctly only in windows, but not in wine or linux.
TonE is offline   Reply With Quote
Old 11-01-2018, 08:15 AM   #605
halfshavedyaks
Human being with feelings
 
Join Date: May 2018
Posts: 35
Default

I'm no longer bothering with the NI plugins or Kontakt. It can be made to work but life is too short.

I have reinstalled my system with Mint 19 and I am using the latest wine stable and LinVST 2.32

I'm trying to run DMG audio plugins Limitless and Trackcontrol and Equick

also GSi V3B and V3B-2 organs

The DMG plugins run but they don't process any sound. I have previously had them working on Mint 18 but I'm really not sure what is different - could be lots of things.

V3B original demo runs fine.

V3B-2 demo works but crashes reaper when trying to use some functions.

Unfortunately the original V3B is no longer available for sale and the new one is both more expensive to buy and isn't working for me as a demo.

Does anyone have any experience with these plugins under Wine? or have any suggestions about what to try?

Last edited by halfshavedyaks; 11-01-2018 at 08:23 AM.
halfshavedyaks is offline   Reply With Quote
Old 11-01-2018, 03:03 PM   #606
halfshavedyaks
Human being with feelings
 
Join Date: May 2018
Posts: 35
Default

can anyone tell me anything about these errors I get when launching winecfg and could any of them be related to the lack of sound in the dmg plugins?

Code:
000f:err:service:process_send_command receiving command result timed out
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"WineBus" failed to start: 1053
0014:err:service:process_send_command receiving command result timed out
002a:err:plugplay:handle_bus_relations Failed to load driver L"WineHID"

Last edited by halfshavedyaks; 11-01-2018 at 03:09 PM.
halfshavedyaks is offline   Reply With Quote
Old 11-01-2018, 07:05 PM   #607
halfshavedyaks
Human being with feelings
 
Join Date: May 2018
Posts: 35
Default

oops the DMGaudio problem was simply that the licence hadn't taken in the reg editor, I have got it now.

Now it is just VB3 to sort out.
halfshavedyaks is offline   Reply With Quote
Old 11-04-2018, 03:40 PM   #608
Sblissk
Human being with feelings
 
Sblissk's Avatar
 
Join Date: Jun 2015
Posts: 17
Default Considering moving to Linux

Hi there i'm thinking about moving over to linux for a number of reasons i wont go into. well im tired of apple and windows haha.But my issue is ive purchased a lot of plugins that im certain wont work on linux for example toontrack ex drummer and waves plugins ect. is there away to get these plugins to work on linux? or should i Kust dual boot linux for day today use and use windows for when i record and edit music.

if anyone has any videos on how they use reaper in linux that would be aweseome thanks.
Sblissk is offline   Reply With Quote
Old 11-05-2018, 02:48 AM   #609
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 536
Default

Quote:
Originally Posted by Sblissk View Post
Hi there i'm thinking about moving over to linux for a number of reasons i wont go into. well im tired of apple and windows haha.But my issue is ive purchased a lot of plugins that im certain wont work on linux for example toontrack ex drummer and waves plugins ect. is there away to get these plugins to work on linux? or should i Kust dual boot linux for day today use and use windows for when i record and edit music.

if anyone has any videos on how they use reaper in linux that would be aweseome thanks.
Some Windows vst's can run using Wine, but Wine is not Windows and Wine has some limitations and so some things might be ok and some things might not be ok.

Wine can need some additional bits added to it in order to get a vst plugin to run, things like reg entries (regedit) and dll overrides (which are Windows dll files that get added to Wine).

Using LinVst and Wine/Wine Staging,

EZ Drummer should be ok from what I remember.

Waves and Waves Central should be ok (maybe a few plugins won't run) and the details on how to set it up are on the previous page.

Wine has different releases and Wine Staging needs to be used for Waves Central.

Last edited by osxmidi; 11-05-2018 at 03:01 AM.
osxmidi is offline   Reply With Quote
Old 11-05-2018, 03:58 PM   #610
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 408
Default

Quote:
Originally Posted by Sblissk View Post
should i just dual boot linux for day today use and use windows for when i record and edit music.

if anyone has any videos on how they use reaper in linux that would be aweseome thanks.
Put a linux on an external drive, and start the learning curve.
Products from these devs install and register OK with consistancy
for me:

IK Multimedia
discoDSP (linux ports exist)
U-he (linux ports exist)
PianoteQ (linux ports exist)
Overtone DSP (linux ports exist)
KV331
Dimitri Sches
Fathom
EZDrummer
SugarBytes
the old Cakewalk synths (Rapture, Dimension Pro, z3ta+ 1.5
Wusikstation V5 and addons
AirWindows

----------------------------
Some reading is required to get NI's Native Access going, with a few
wine over-rides put in place, and LinVst is used in general,
to wrap windows .dlls as linux-native .so vsts.

I have Razor and Prism registered from NI along with
their freebies, and the Form demo.(others have Kontakt running)
and oldies like Massive, FM8, Absynth, run OK and
might register OK, with Service Center. Sometimes
copying registry data and sneakernet of installed folders
to wine counterparts works.

This assumes using linux versions of Reaper or Bitwig,
a recent wineHQ, and also using windows Reaper in wine.
to cover a lot of bases. Harrison Mixbus is also good
to get when on sale. About 90% of synthedit plugins
will work.
Cheers
4duhwinnn is offline   Reply With Quote
Old 11-10-2018, 03:19 AM   #611
pdbq
Human being with feelings
 
Join Date: Nov 2018
Posts: 5
Default

Quote:
Originally Posted by Sblissk View Post
for example toontrack ex drummer and waves plugins ect. is there away to get these plugins to work on linux?
I have EZDrummer & EZMix working well right now. It was pretty straightforward:

1. Download the product manager & install via Wine
2. Use the product manager to download & install Toontrack software.
3. Create symbolic links to a WindowsVST folder (just so I don't have do keep hunting down $HOME/.wine/drive_c/etc/etc/etc)
4. Copy the linvst.so file.

My history looks like this:

Quote:
pdbq@ubuntureaper:~$ history | egrep "cp|ln"
105 ln -s /home/pdbq/.wine/drive_c/Program\ Files\ \(x86\)/VstPlugins/Toontrack/EZdrummer.dll EZDrummer.dll
106 ln -s /home/pdbq/.wine/drive_c/Program\ Files\ \(x86\)/VstPlugins/Toontrack/EZMix.dll EZMix.dll
107 cp linvst.so EZDrummer.so
108 cp linvst.so EZMix.so
I have a few others that don't work as well, so it is a bit hit and miss. But the Toontrack stuff was my biggest concern, so I'm pretty happy.
pdbq is offline   Reply With Quote
Old 11-14-2018, 10:43 PM   #612
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 408
Default

There's a bunch of Soundspot effects and mastering plugins for $1 each
at www.pluginboutique.com
in case someone has a sweet tooth.
Cheers

Last edited by 4duhwinnn; 11-14-2018 at 10:57 PM.
4duhwinnn is offline   Reply With Quote
Old 11-19-2018, 06:14 PM   #613
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 408
Default

The good news first, Reaktor from Native Instruments is part of
their holiday half-price sale, and I have it registered in linux
by means of Native access. As I type, I have one of the Reaktor's
wonderful auto-generating ensembles playing into z3ta+ multi-effects
plugin, using the Pluk Bells preset, as well reaper-out
sent into Rakarrack with the Backwards Tumble preset (bank 2),
and another rak using Summer At The Beach preset,
and it's all being recorded with the simple Timemachine
audio recorder, and I can switch among
hundreds of z3ta effects presets on the fly...

The lesser quality news is, some sneakernet was employed,
and I didn't document things as I went.

NI's Native Access didn't want to complete updating itself,
so I manually replaced it, and some other related NI folders
kept in a dark, dank covered parking garage,
(aka a win7 partition)

I found both Native Access and the new Reaktor installer archives in

.wine/drive_c/users/my_username/Downloads

I ran the Native Access app again, and it asked
for serial numbers, and when I gave the Reaktor serials,
they were accepted.

When I started Reaper in wine-staging 3.20,
the Reaktor FX plugin was scanned, but Reaper
crashed as the Reaktor plugin was scanned.
I restarted Reaper, but the Reaktor plugin was
missing, but found safely tucked away
in the developers portion of the list, rather than
front & center with most vsti's, a momentary panic,
as I gambled my $100 on getting it running in linux.
(worst case, the Reaktor demo runs for 30 minute sessions,
before needing to be reloaded, very generous of NI
in my opinion)

The user library is full of audio software, some unique,
some typical, some are glorious,
some are perplexing, and some defy description, the lab work
of mad scientists who love sounds and tunes.

I do believe this is one of my favorite five linux moments.
There's a good chance it will also work fine with LinVst.
Many thanks to osxmidi and Jack Winter, who have made
so many things possible. And to Justin, for making a place
where such possibilities can happily work and play.
And to the throngs of coders making instruments and effects
that have changed both music history, and the stories of
those who benefit from it all.
Cheers
4duhwinnn is offline   Reply With Quote
Old 11-23-2018, 03:32 PM   #614
Fourstepper
Human being with feelings
 
Join Date: Apr 2018
Posts: 24
Default

Hey guys, will ask in this part of the forum too...

Do you all know if Izotope products; Trash 2 and Iris 2, work preferably via LinVST and latest Wine staging on linux? There is a pretty huge deal on them right now and those 2 are like my long time want-tos that just costed too much before for me to justify the purchase.

At the same time, I also have Ozone 8 Standard purchased, anyone knows if that would work?

Thank you very much!
Fourstepper is offline   Reply With Quote
Old 11-23-2018, 03:47 PM   #615
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,416
Default

Can't you download them and try them in demo mode?
clepsydrae is offline   Reply With Quote
Old 11-23-2018, 04:50 PM   #616
Fourstepper
Human being with feelings
 
Join Date: Apr 2018
Posts: 24
Default

I currently dont have a linux machine and am actually right now not even using my own pc because I forgot my charger at my other place, thats why I am asking, not because I am lazy
Fourstepper is offline   Reply With Quote
Old 11-23-2018, 05:20 PM   #617
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,416
Default

Does LinVST only support VST2? I can't seem to google that info up...
clepsydrae is offline   Reply With Quote
Old 11-23-2018, 08:50 PM   #618
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 536
Default

Quote:
Originally Posted by clepsydrae View Post
Does LinVST only support VST2? I can't seem to google that info up...
Yes, only VST2.
osxmidi is offline   Reply With Quote
Old 11-23-2018, 08:55 PM   #619
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 536
Default

Quote:
Originally Posted by Fourstepper View Post
Hey guys, will ask in this part of the forum too...

Do you all know if Izotope products; Trash 2 and Iris 2, work preferably via LinVST and latest Wine staging on linux? There is a pretty huge deal on them right now and those 2 are like my long time want-tos that just costed too much before for me to justify the purchase.

At the same time, I also have Ozone 8 Standard purchased, anyone knows if that would work?

Thank you very much!
I was just testing Ozone 8 recently.

It seems to work ok from what I can make out.

It has multiple dlls and the Ozone 8.dll is the one to have an associated Ozone 8.so file and not the other dlls.

So, just rename the linvst.so file to Ozone 8.so and move it to where Ozone 8 was installed and it should be ok.

---------

Izotope Ozone has multiple dlls and only the main dll (which is a vst dll) needs to have a linvst .so file associated with it. For instance, the Ozone 8.dll would have an associated Ozone 8.so file and none of the other dlls would have associated .so files (otherwise the DAW will try and load the other dlls which are not vst dlls and then produce errors).

Last edited by osxmidi; 11-23-2018 at 09:03 PM.
osxmidi is offline   Reply With Quote
Old 11-23-2018, 11:59 PM   #620
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,416
Default

Quote:
Originally Posted by osxmidi View Post
Yes, only VST2.
Thanks.

If I get time I'll install the Trash 2 dll and see what it does (currently only have VST3 version installed.)
clepsydrae is offline   Reply With Quote
Old 11-24-2018, 03:00 AM   #621
Fourstepper
Human being with feelings
 
Join Date: Apr 2018
Posts: 24
Default

Thank you guys!
Fourstepper is offline   Reply With Quote
Old 11-24-2018, 02:21 PM   #622
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,416
Default

I couldn't authorize it -- it gave an error that the license was already in use by a different account. If I used a different email address (not one associated with the license) it just said "internal error". Apparently you can't use the plugin in more than one "place". Annoying. Not sure if there is a way around, or if iZotope would bump up your license by one user on request.

The plugin seemed to work OK in demo mode, except that it was very slow. Meaning, UI elements took noticeably longer to update. Maybe this is normal with plugins bridged in this way; this is my first adventure into this world. (I'm sure I'm not on latest wine, either.)

I started with a dedicated linvst_dlls directory, and as with osxmidi and ozone, I had to make an .so for the main plugin file (iZotope Trash 2.dll) but make sure NOT to make an .so for iZTrash2.dll, which I symlinked to the same location. Alternately I could just make a iZotope Trash 2.so in the same directory as the original iZotope Trash 2.dll and that worked without further meddling.

Last edited by clepsydrae; 12-05-2018 at 09:17 PM.
clepsydrae is offline   Reply With Quote
Old 11-24-2018, 03:17 PM   #623
Fourstepper
Human being with feelings
 
Join Date: Apr 2018
Posts: 24
Default

Thank you a lot for the information!!!
Fourstepper is offline   Reply With Quote
Old 12-15-2018, 01:21 PM   #624
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 408
Default

While sorting out an issue with this years
Native Instruments Christmas gift, I came across
one of their help pages:

https://support.native-instruments.c...ashes-Windows-

one of the helps is trying a special installer that places
all the sundry Visual C++ Redistributable packages in the correct
locations, in one go. It's provided by the

https://www.majorgeeks.com/

If you click the 'this page' link at the above NI
help page, you'll wind up here, to install the
multiple Visual C++ things:

https://www.majorgeeks.com/files/det...installer.html

I suspect/hope this might help
wine users setting up a new prefix for specific
plugins/standalones, I have a few I'll be trying
later.
Bon Voyage

Last edited by 4duhwinnn; 12-15-2018 at 01:23 PM. Reason: grummar/spellng
4duhwinnn is offline   Reply With Quote
Old 12-31-2018, 05:41 AM   #625
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default [not a reaper bug] zombie processes w/ VST plugins

if a Win VST plugin is opened via LIN-VST bridge everything is still ok ... until I click the "Remove" button in the FX window a Zombie process is generated,
same thing happens when clear & re-scan VST cache was clicked ... for each vst plugin a zombie process is displayed ... i had about 43 zombie processes ...
this does not happen if I open the same plugins in Audacity or via Wine with Soundforge only with Reaper the problem occurs.

### edit ###
not related to reaper see:
https://forum.cockos.com/showpost.ph...&postcount=210
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII

Last edited by monty; 01-02-2019 at 01:25 AM.
monty is offline   Reply With Quote
Old 12-31-2018, 06:32 AM   #626
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

I doubt that is a problem with reaper itself, most likely something to do with linvst/wine/your system.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 12-31-2018, 07:02 AM   #627
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default

Quote:
Originally Posted by Jack Winter View Post
I doubt that is a problem with reaper itself, most likely something to do with linvst/wine/your system.
Hi Jack,
is there a newer version of linvst available?
the strange is that I can use the same VSTs (same path) in audacity without zombies ... maybe the close (remove) process was not finished properly?
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 12-31-2018, 09:00 AM   #628
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default

hmm, now I have switched from staging to wine-rt, but it does not changed anything ... could be a lin-vst issue but I did not find any error logs or reason ...

Code:
ps ax -o s,pid,comm,ppid | grep '^Z'
Z  1959 lin-v <defunct>  1876
as long as reaper is running I can not kill this process, after I close reaper the zombies are gone ...

is there something I can try in reaper VST the settings?
I do not used Reaper firewalled/ bridged stuff it's turned off ...
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 01-01-2019, 05:06 AM   #629
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

Quote:
Originally Posted by monty View Post
if a Win VST plugin is opened via LIN-VST bridge everything is still ok ... until I click the "Remove" button in the FX window a Zombie process is generated
I can actually duplicate this. Don't think it was like that before, but I haven't used this for quite a few months. Let me update all the relevant software and see what happens.

A zombie process is actually a process that has already terminated and takes very little resources, but it's parent ought to have cleaned up after it. For all practical purposes more or less a cosmetic problem.

In my case the zombie process is called lin-vst-server.exe.so, which points at linvst being the culprit, as it's linvst that started the above process.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 01-01-2019, 05:09 AM   #630
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

You can't kill a zombie process as it's already dead.. It's also not a big problem as it uses close to no resources, mostly it's cosmetic, but still shouldn't happen. AFAIK there is nothing you can do about it except wait for an update to linvst or ignore it.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 01-01-2019, 05:14 AM   #631
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default

Quote:
Originally Posted by Jack Winter View Post
You can't kill a zombie process as it's already dead.. It's also not a big problem as it uses close to no resources, mostly it's cosmetic, but still shouldn't happen. AFAIK there is nothing you can do about it except wait for an update to linvst or ignore it.
many thanks!
could you re-produce this w/ arch linux too?
thinking about ... moving to manjaro soon
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 01-01-2019, 05:24 AM   #632
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

Yes I'm on Archlinux, don't think it has anything at all to do with the distro. AFAIK it's just because linvst didn't clean up properly when it shutdown. It's just a temporary state for the process and normal, it's a state that all processes pass through until the parent process has cleaned up after it.

I assume it's lin-vst-server.exe.so for you too?
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 01-01-2019, 05:32 AM   #633
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default

Quote:
Originally Posted by Jack Winter View Post
Yes I'm on Archlinux, don't think it has anything at all to do with the distro. AFAIK it's just because linvst didn't clean up properly when it shutdown. It's just a temporary state for the process and normal, it's a state that all processes pass through until the parent process has cleaned up after it.

I assume it's lin-vst-server.exe.so for you too?
could be a wine prefix issue w/ lin-vst-server.exe/so in /usr/bin ... maybe
but I thought that many packages & scripts have been fixed in the arch sources:
https://aur.archlinux.org/packages/linvst/

thats why I think about moving to manjaro KDE ...
My KDE neon is very fast but there are a few things broken from outdated packages.
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 01-01-2019, 07:10 AM   #634
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default

@Jack
just running a manjaro test installation in a VM ... it seems there is already a lowlatency kernel installed by default:
Code:
4.19.13-1-MANJARO #1 SMP PREEMPT
so I do not have to install a RT kernel from AUR ... right?
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII

Last edited by monty; 01-01-2019 at 07:44 AM.
monty is offline   Reply With Quote
Old 01-01-2019, 07:33 AM   #635
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

I've updated my software and it still does it.

AFAIK, linvst needs to use the wait() syscall with fork/exec otherwise the wine process terminates but still keeps a few resources, mainly a PID. This is the reason for the zombie status of the terminated process. This could potentially be a problem if you have a lot of them as you could run out of possible PIDs for the system to use.

But like I said it's mainly cosmetic and I'm sure that osxmidi can easily fix it.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)

Last edited by Jack Winter; 01-01-2019 at 09:37 AM.
Jack Winter is offline   Reply With Quote
Old 01-01-2019, 09:02 AM   #636
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

Started looking at this but I'm going to leave it for osxmidi to fix

I have no idea what is happening as he uses vfork() instead of fork(), and I don't wanna get stuck with a lot of googling and head scratching AFAIK it's an obsolete system call and shouldn't really be used anymore..
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 01-01-2019, 10:19 AM   #637
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default

Quote:
Originally Posted by Jack Winter View Post
Started looking at this but I'm going to leave it for osxmidi to fix

I have no idea what is happening as he uses vfork() instead of fork(), and I don't wanna get stuck with a lot of googling and head scratching AFAIK it's an obsolete system call and shouldn't really be used anymore..
ouh, it seems there is already an upgrade available ....
https://github.com/osxmidi/LinVst/releases
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 01-01-2019, 11:02 AM   #638
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default

but unfortunately the problem after the upgrade was not solved, at least not for the Kubuntu or Debian systen ...
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 01-01-2019, 11:15 AM   #639
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

Seems to still create the zombies..
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 01-01-2019, 11:31 AM   #640
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 171
Default

Quote:
Originally Posted by Jack Winter View Post
Seems to still create the zombies..

yep, for now it's not a big deal when closing a VST plugin w/ a zombie but the clear & scan action (and init. while startup) creates about 50 zombies ... as far as I know, a few weks or months ago I did not seen any zombie processes w/ linvst
__________________
KDENeon (5.0.0-31-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:36 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.