Old 12-27-2018, 03:19 PM   #1
aledosim
Human being with feelings
 
Join Date: Dec 2018
Location: São Paulo SP Brazil
Posts: 13
Default Can't install ReaPack on KXStudio

Hello everyone,

I've been trying to install ReaPack in my Reaper 5.965 but it won't go. I downloaded the Linux 64bits version and copied to the "Reaper resource path". I needed to create the UserPlugin folder (tried copying into Plugin folder either). I'm running under KXStudio 14.04.

Thanks a lot.
aledosim is offline   Reply With Quote
Old 12-27-2018, 04:09 PM   #2
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,787
Default

Normally it would go into ~/.config/REAPER/UserPlugins, unless you have made a portable install.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 12-30-2018, 10:35 AM   #3
aledosim
Human being with feelings
 
Join Date: Dec 2018
Location: São Paulo SP Brazil
Posts: 13
Default

Quote:
Originally Posted by Jack Winter View Post
Normally it would go into ~/.config/REAPER/UserPlugins, unless you have made a portable install.
I installed it at /opt/REAPER and created the UserPlugin folder there instead. Now that I got the file copied to the right place, Reaper should show me the Extension menu, right? I don't see it.

Thanks
aledosim is offline   Reply With Quote
Old 12-30-2018, 10:53 AM   #4
Tobbe
Human being with feelings
 
Tobbe's Avatar
 
Join Date: Sep 2009
Location: Backe, Jämtland, Sweden
Posts: 357
Question

Have you installed it here (see attachment)? And downloaded the so files from https://landoleet.org/ (reaper_sws_x86_64_fc28caa7.tar.xz)
Attached Images
File Type: png ReaPack.png (6.4 KB, 101 views)
__________________
OS: Linux Mint XFCE 19.01, Reaper For Linux (64Bit) and native linux-vst plugins (16GB RAM) LSP-Suite, Drumgizmo, TpL-Plugins, LinuxSampler/Fantasia, Behringer U-PHORIA UMC22.
Tobbe is online now   Reply With Quote
Old 12-30-2018, 02:06 PM   #5
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,787
Default

Yes you ought to see the menu..

Is there anything in the terminal output if you run reaper from a terminal?

Did you install the right architecture build, x86_64 vs i686?
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 12-30-2018, 10:32 PM   #6
aledosim
Human being with feelings
 
Join Date: Dec 2018
Location: São Paulo SP Brazil
Posts: 13
Default

Quote:
Have you installed it here (see attachment)? And downloaded the so files from https://landoleet.org/ (reaper_sws_x86_64_fc28caa7.tar.xz)
I've downloaded reaper_reapack64.so from ReaPack website (https://reapack.com/). Tried the one you indicated and didn't work either.

Quote:
Is there anything in the terminal output if you run reaper from a terminal?

Did you install the right architecture build, x86_64 vs i686?
Of course, the terminal. I think its the right build. I suspect it has something to do with library versions in an old versioned system, I'm testing AV Linux right now.

Code:
jack: created client
jack: setting TIME_CRITICAL = 79
swell: dlopen() failed: libcurl.so.4: cannot open shared object file: No such file or directory
Error loading /opt/REAPER/Plugins/reaper_reapack64.so: (null)
swell: dlopen() failed: libcurl.so.4: cannot open shared object file: No such file or directory
Error loading /home/jonh5ck/.config/REAPER/UserPlugins/reaper_reapack64.so: (null)
swell: dlopen() failed: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/jonh5ck/.config/REAPER/UserPlugins/reaper_sws64.so)
Error loading /home/jonh5ck/.config/REAPER/UserPlugins/reaper_sws64.so: (null)
jack: activated client
jack: deactivated client
jack: close client
Thanks for the advices
aledosim is offline   Reply With Quote
Old 12-31-2018, 06:29 AM   #7
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,787
Default

Yeah, that looks like the right verioned libs aren't found. If you know how to, try to build sws/reapack from source yourself.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 01-01-2019, 12:23 AM   #8
aledosim
Human being with feelings
 
Join Date: Dec 2018
Location: São Paulo SP Brazil
Posts: 13
Default

I have a feeling that I'm a step away from building packages, and I've been failing. There's at least one lib that doesn't rely on default repository, and since AV Linux is up at date in a functional way, I'll format my KXStudio's partition.
Thanks for your time.
aledosim is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:59 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.