Old 11-18-2010, 01:55 PM   #1
seth2958
Human being with feelings
 
Join Date: Nov 2010
Posts: 1
Default VST Preset resetting after playback

So I imported some midi files generated by the Wolfram Tone Generator to edit in Reaper (this can be done at http://tones.wolfram.com/generate/). When I select a preset sound in any VST and press play, it plays fine, but when I hit stop and then hit play again, the preset switches back to the default preset.

So for example if the preset is trumpet and I select piano, I press play and it renders the midi using the piano sound, but when I press stop and then press play again, the preset switches back to trumpet. I can't figure out why this is happening.

Any help is appreciated.
seth2958 is offline   Reply With Quote
Old 11-18-2010, 02:06 PM   #2
pac-man
Human being with feelings
 
Join Date: Nov 2009
Location: a basement nearby
Posts: 541
Default

Might be a "program change" message in the MIDI file?
pac-man is offline   Reply With Quote
Old 08-17-2019, 11:53 PM   #3
BipTunia
Human being with feelings
 
BipTunia's Avatar
 
Join Date: Sep 2018
Location: Does Wyoming exist?
Posts: 97
Default

Quote:
Originally Posted by seth2958 View Post
So I imported some midi files generated by the Wolfram Tone Generator to edit in Reaper (this can be done at http://tones.wolfram.com/generate/). When I select a preset sound in any VST and press play, it plays fine, but when I hit stop and then hit play again, the preset switches back to the default preset.

So for example if the preset is trumpet and I select piano, I press play and it renders the midi using the piano sound, but when I press stop and then press play again, the preset switches back to trumpet. I can't figure out why this is happening.

Any help is appreciated.


Fixed it:
https://forum.cockos.com/showpost.ph...1&postcount=17
__________________
BipTunia: Similar Artists on Google Play = HP Lovecraft
BipTunia is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:17 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.