Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-25-2024, 09:32 PM   #1
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 4,967
Default Missing refresh when running "Unselect (clear selection of) all tracks" from a script

On Windows, if a script 1) selects all tracks 2) TrackList_AdjustWindows 3) Main_OnCommand(40297), the tracks will visually appear as selected until TrackList_AdjustWindows happens again. The IDE must be closed to duplicate. (This was originally reported as a SWS bug.)

Code:
for i = 0, reaper.CountTracks(nil) - 1 do
  local track = reaper.GetTrack(nil, i)
  reaper.SetTrackSelected(track, true)
end

reaper.TrackList_AdjustWindows(false)
reaper.Main_OnCommand(40297, 0) -- Track: Unselect (clear selection of) all tracks
REAPER v7.09 on Windows 10:



(iReaScript shown in the gif does an implicit TrackList_AdjustWindows after executing CountSelectedTracks.)

Last edited by cfillion; 01-25-2024 at 09:37 PM.
cfillion is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:49 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.