Old 01-12-2018, 09:21 AM   #1
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 21,131
Default v5.71pre11 - January 12 2018

v5.71pre11 - January 12 2018
  • + Solo: improve behavior with routing and folders [t=199396]
  • + VST: avoid incorrect offline-processing notifications on plug-in load
  • # Grid: fix track divider lines in certain themes [p=1938081]
  • # MIDI: minor tweaks when drawing peaks edges [p=1938984]
  • # ReaControlMIDI: fix MIDI learn [p=1938515]
  • # Video: add undocumented refresh_ms= ini file tweak
Changelog - Pre-Releases

Generated by X-Raym's REAPER ChangeLog to BBCode
EvilDragon is online now   Reply With Quote
Old 01-12-2018, 09:31 AM   #2
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 21,131
Default

Something changed in how edges on MIDI events are drawn. Color changed compared to previous versions (in my theme it was all white, now it's gray).

pre10 and before:



pre11:




Which one is supposed to be more correct? (Also sorry, I shouldn't have included the audio items there, I have draw edges on peaks option disabled.)


It looks like in pre11, the "media item peaks" colors are completely disregarded if peak edges are enabled, whereas before that was not the case.

Last edited by EvilDragon; 01-12-2018 at 09:43 AM.
EvilDragon is online now   Reply With Quote
Old 01-12-2018, 12:11 PM   #3
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,625
Default

Quote:
Originally Posted by EvilDragon View Post
Something changed in how edges on MIDI events are drawn.
Could you post your .reapertheme file please?
schwa is offline   Reply With Quote
Old 01-12-2018, 12:12 PM   #4
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 21,131
Default

Here's the whole theme:

https://drive.google.com/open?id=1hG...AWN1CDSXaAoZye


Plus:

EvilDragon is online now   Reply With Quote
Old 01-12-2018, 12:27 PM   #5
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,625
Default

OK, the issue is what happens when the media item pixel height is small enough relative to the range of notes in the MIDI item that each note is only 1 or 2 pixels. high. Previously we used the peak body color for those pixels, and pre11 uses the peak edge color. Either choice will make notes potentially disappear, depending on the particular theme settings.
schwa is offline   Reply With Quote
Old 01-12-2018, 12:28 PM   #6
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 21,131
Default

OK. I guess I'll make the edge colors the same as body color, then.
EvilDragon is online now   Reply With Quote
Old 01-12-2018, 12:34 PM   #7
heda
Human being with feelings
 
heda's Avatar
 
Join Date: Jun 2012
Location: Spain
Posts: 4,738
Default

Quote:
Originally Posted by EvilDragon View Post
OK. I guess I'll make the edge colors the same as body color, then.
Why do you use edges then if it is the same color?
in your screenshot, I like pre10 more.

what about displaying the note colors as in the MIDI editor(by pitch, channel etc) in MIDI peaks? or maybe only if peaks display is set to spectral peaks.
__________________
HeDaScripts for REAPER | VIP Donations
heda is offline   Reply With Quote
Old 01-12-2018, 12:38 PM   #8
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 21,131
Default

Yeah, just disabled edges, actually. Tweaked the edge highlight colors so they're not TOO different, in case the option gets enabled at some point. It's fine now. Actually it's better without the edges.

Quote:
Originally Posted by heda View Post
what about displaying the note colors as in the MIDI editor(by pitch, channel etc) in MIDI peaks? or maybe only if peaks display is set to spectral peaks.

THIS IS A BRILLIANT IDEA!
EvilDragon is online now   Reply With Quote
Old 01-12-2018, 12:42 PM   #9
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,625
Default

I think what we'll do is ensure the both the peak body and edge colors are always drawn, meaning notes will be a minimum of 3 pixels high if edges are enabled.
schwa is offline   Reply With Quote
Old 01-12-2018, 12:46 PM   #10
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 21,131
Default

Otherwise (if option disabled), minimum height of note peaks would be 1 px?
EvilDragon is online now   Reply With Quote
Old 01-12-2018, 02:02 PM   #11
JHughes
Human being with feelings
 
JHughes's Avatar
 
Join Date: Aug 2007
Location: Too close to Charlotte, NC
Posts: 3,198
Default

Quote:
Originally Posted by EvilDragon View Post
# Video: add undocumented refresh_ms= ini file tweak
I'm guessing this affects "video" video and not refresh rate of meters and playhead etc.?
__________________
You can only Reverse, Switch, Invert or Flip POLARITY, not "PHASE".
JHughes is offline   Reply With Quote
Old 01-12-2018, 02:12 PM   #12
J Reverb
Human being with feelings
 
J Reverb's Avatar
 
Join Date: Jul 2009
Posts: 466
Default

# ReaControlMIDI: fix MIDI learn [p=1938515]

Thank you! works as expected now cheers

Any chance the refresh rate of the ReaControlMIDI GUI Faders can be increased graphically as it feels and looks a bit sluggish.
Again all other plugs are fine in this respect.

Many thanks.

J.

Oh and loop item source envelope obeys. sorry to keep on about that but it will be so cool

There's a bug when recording TakeFX Automation in that points seem to be randomly collected and clogged around
the start and end of a loop cycle.
I have experimented with settings and media buffering etc but seems to make no difference.
__________________
I've been imitated so well I've heard people copy my mistakes. - Jimi Hendrix

Last edited by J Reverb; 01-12-2018 at 02:33 PM.
J Reverb is offline   Reply With Quote
Old 01-12-2018, 02:40 PM   #13
jnif
Human being with feelings
 
jnif's Avatar
 
Join Date: Dec 2008
Posts: 2,018
Default

Quote:
Originally Posted by EvilDragon View Post
[*]# Grid: fix track divider lines in certain themes [p=1938081]
Somewhat related to this fix, would it be possible to make Z order and visibility of vertical grid lines, track divider lines, and envelope lane divider lines more consistent?
Some of those issues might have become more obvious now when using "Divide arrange view vertically".

jnif
jnif is offline   Reply With Quote
Old 01-12-2018, 02:57 PM   #14
tronic307
Human being with feelings
 
Join Date: Jul 2014
Posts: 3
Default

Take FX goes silent after the first playthrough for this 32-bit plugin in its internal offline mode:

https://www.kvraudio.com/product/tapestop_by_tbt

Worked well up until Reaper 5.70
tronic307 is offline   Reply With Quote
Old 01-12-2018, 03:18 PM   #15
PitchSlap
Human being with feelings
 
PitchSlap's Avatar
 
Join Date: Jan 2008
Location: Vancouver, BC
Posts: 3,175
Default

Quote:
Originally Posted by EvilDragon View Post
v5.71pre11 - January 12 2018

+ Solo: improve behavior with routing and folders
I'd really love the option for non-soloed tracks to be treated like muted tracks. "Do not process unsoloed tracks" or something similar.

I often solo tracks or folders to work on parts individually, but it's not any easier to work on 20 tracks, when 100 others are needlessly chomping resources.

-It's way easier to solo the tracks I want to hear than all the ones I don't. Also it's a hassle to remember which tracks were originally muted, and which were muted just to save CPU as a 'reverse-solo' technique.

Alt-clicking solo is a quick way to return playback to normal, but the same can't be done with Alt-clicking mute since it will unmute all tracks including those I want to remain muted.


I understand there are probably reasons for the current behavior, but for me, it seems to be all downsides.
__________________
FRs: v5 Media Explorer Requests, Global Quantization, Session View
Win10 64-bit, Reaper 5(x64), Core i7-5700HQ, 16GB RAM, GeForce GTX 960M, SSD

Last edited by PitchSlap; 01-12-2018 at 03:25 PM.
PitchSlap is offline   Reply With Quote
Old 01-12-2018, 09:53 PM   #16
mawi
Human being with feelings
 
mawi's Avatar
 
Join Date: Apr 2011
Posts: 554
Default

Quote:
Solo: improve behavior with routing and folders
Thanks, it seems the bug has been fixed!
mawi is offline   Reply With Quote
Old 01-13-2018, 05:39 AM   #17
heda
Human being with feelings
 
heda's Avatar
 
Join Date: Jun 2012
Location: Spain
Posts: 4,738
Default

Quote:
Originally Posted by EvilDragon View Post
[*]# Video: add undocumented refresh_ms= ini file tweak
I don't know how to test this or what it does.

In windows 7 I see videos ok.. but in a laptop with Windows 10... there is a lot of screen tearing in full screen. I have tried all options for Vsync in nvidia control panel.
In REAPER I have disabled EVR enhanced render in windows 10 and restarted REAPER and then it works ok without tearing. In win7 it works well with or without EVR
__________________
HeDaScripts for REAPER | VIP Donations
heda is offline   Reply With Quote
Old 01-13-2018, 11:18 AM   #18
Naquela
Human being with feelings
 
Join Date: Feb 2017
Location: Portugal
Posts: 25
Default

+ VST: avoid incorrect offline-processing notifications on plug-in load

the problem still happend , some vst dont load (64) , if the vst is on the project it loads fine another instance, if is not in the project and you try add , they go offline .
in a blank project all vst work fine.
so i load a vst (problematic/new vst) in one track in a blank project and save .
And i copy the track info (txt) and paste in my project and the vst works fine and open another instances fine.
Sorry my ingles
__________________
Sonic Core Scope / UAD 2
Naquela is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:49 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.