Old 10-24-2016, 04:05 PM   #401
Sju
Human being with feelings
 
Join Date: Jun 2015
Posts: 686
Default

Another: If I delete a track, Stripper loses active track focus. Can only restore it by creating a new track or selecting one from Strippers GUI.

PS. those sliders are still a bit glitchy on the right side:



PPS. the button type button works/feels good now with mwheel and rclick, thanks!

Oh but except the cycle button tab doesn't close when changing the type with the mwheel.

off to bed for now ->
Attached Images
File Type: gif stripper slider glitch 2.gif (24.3 KB, 378 views)

Last edited by Sju; 10-24-2016 at 04:15 PM.
Sju is offline   Reply With Quote
Old 10-24-2016, 04:15 PM   #402
RJHollins
Human being with feelings
 
Join Date: Dec 2011
Posts: 1,355
Default

Question.

TBPro has posted an update/mod to his A/B Level Match script.

The added Parameter is for a RESET switch that cause a recalculation of gain differences. I want to test this ... but

The question. What controller do I use within LBX-Stripper to use this parameter. From my understanding, we need a simple 'trigger' button. What would that be for LBX ?

thx
RJHollins is online now   Reply With Quote
Old 10-24-2016, 04:50 PM   #403
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by RJHollins View Post
Question.

TBPro has posted an update/mod to his A/B Level Match script.

The added Parameter is for a RESET switch that cause a recalculation of gain differences. I want to test this ... but

The question. What controller do I use within LBX-Stripper to use this parameter. From my understanding, we need a simple 'trigger' button. What would that be for LBX ?

thx
I would say just use BUTTON control type - with a single frame image (like the simplebox). See if that works.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-24-2016, 04:56 PM   #404
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by Sju View Post
Another: If I delete a track, Stripper loses active track focus. Can only restore it by creating a new track or selecting one from Strippers GUI.

PS. those sliders are still a bit glitchy on the right side:



PPS. the button type button works/feels good now with mwheel and rclick, thanks!

Oh but except the cycle button tab doesn't close when changing the type with the mwheel.

off to bed for now ->
Fixed now the closing of cycle options when changing ctl type with wheel

I know the slider graphics are a little glitchy - I had a good play around with them when I first made them - and had troubles getting rid of the problem (it's a rounding issue). Will fix eventually - but can't be bothered right now - more important stuff to fix !! but thanks for the heads up as usual!

Will look into the delete track focus issue.

EDIT: Have made it so that when a track is deleted - it auto focusses on master track (within stripper) - which ensures the follow selected track continues to work ok.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 10-24-2016 at 05:04 PM.
lb0 is offline   Reply With Quote
Old 10-24-2016, 05:04 PM   #405
PitchSlap
Human being with feelings
 
PitchSlap's Avatar
 
Join Date: Jan 2008
Location: Vancouver, BC
Posts: 3,192
Default

This is sick!

Sorry, I haven't read all 11 pages, but one thing that would make this super useful for me is if the effect chain could be automatically bypassed when the input is silent (or drops below a threshold).

NYRV Agent has this. And it would be great for setting up chains for CPU hogs and be like a working version of the experimental "reduce CPU use of silent tracks" setting in Reaper.
__________________
FRs: v5 Media Explorer Requests, Global Quantization, Session View
Win10 64-bit, Reaper 5(x64), Core i7-5700HQ, 16GB RAM, GeForce GTX 960M, SSD
PitchSlap is offline   Reply With Quote
Old 10-24-2016, 05:07 PM   #406
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by timbralzoom View Post
absolutely no problem
one more Q "Get or auto select-show last touched parameter" is it possible?
would be a great time saver, when you have something like :

http://imgur.com/ERv7wwr

even maybe optionally move knob make it selected move another to add in to selection
similar to Chaos Engine?
I've now updated so it should cope with a two (or more) state button on a single state cycle control to indicate selected value. You must have pos to frame option checked. For my buttons which are stupidly inverted (0=on, 1=off) I have had to invert the values to make it look right - therefore at the moment - you will need a similar frame 0 = on, frame 1 = off button for it to look right (ie. you can use my buttons). Let me know if this works ok for you.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-24-2016, 05:12 PM   #407
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by PitchSlap View Post
This is sick!

Sorry, I haven't read all 11 pages, but one thing that would make this super useful for me is if the effect chain could be automatically bypassed when the input is silent (or drops below a threshold).

NYRV Agent has this. And it would be great for setting up chains for CPU hogs and be like a working version of the experimental "reduce CPU use of silent tracks" setting in Reaper.
Thanks! I will need to ponder this - as my script obviously works across all tracks - that could be a lot of tracks to keep track of and monitor. Depends on the overhead I guess. I am assuming I can get access to the levels of each track of course (not investigated yet). I guess it could be an option - my main worry would be any latency involved in reinstating the bypass settings when audio comes back in - could I ensure it be quick enough? Can I get a lookahead value for the track audio?? dunno.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-24-2016, 05:16 PM   #408
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by timbralzoom View Post
absolutely no problem
one more Q "Get or auto select-show last touched parameter" is it possible?
would be a great time saver, when you have something like :

http://imgur.com/ERv7wwr

even maybe optionally move knob make it selected move another to add in to selection
similar to Chaos Engine?
haha - i feel your pain with that gif - that's quite a few parameters to look through. Yes- I'm sure I can work something out here - I can't take the credit for how Chaos engine does it - got this from mpl's Randomize Track FX Parameters script - but yeah I could just do something like that.

Basically a learn function I guess.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-24-2016, 05:56 PM   #409
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,658
Default

first Thank you as always that was fast add!

this is what i get
in all, pos to frame checked, it works only for the first one
i mean only first one stays at on state others just flashing then goes to off...

https://drive.google.com/file/d/0B9h...g4NG5vZGc/view

yes some plugins hurts, would great thank you again!
timbralzoom is offline   Reply With Quote
Old 10-24-2016, 06:07 PM   #410
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by timbralzoom View Post
first Thank you as always that was fast add!

this is what i get
in all, pos to frame checked, it works only for the first one
i mean only first one stays at on state others just flashing then goes to off...

https://drive.google.com/file/d/0B9h...g4NG5vZGc/view

yes some plugins hurts, would great thank you again!
Can I just ask - did you rebuild the setting of the values - ie. go into cycle options and change the stored value? I should have said that the original stored values need to be captured again - because there was a discrepancy between what I did before and now. If you are using the same values captured as before - they won't work with the matching algo.

If you completely rebuild the cycle buttons from scratch and it still does it - then I'll be sure it's not quite working yet - but I had that same issue until I removed what I had and started again.

Sorry - should have mentioned this before...

EDIT - actually not so sure now - but if you set up just a few new ones - and see if they work?

EDIT2 - gotta go to bed now - but will look into tomorrow if there's still a definite issue.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-24-2016, 06:17 PM   #411
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,658
Default

Have a nice sleep!
probably ill go to sleep too...(if i can stop messing with it )
ill test what you suggest tomorrow.

here is the latest fun

https://www.youtube.com/watch?v=GclE3uajyjw
timbralzoom is offline   Reply With Quote
Old 10-24-2016, 09:29 PM   #412
TBProAudio
Human being with feelings
 
TBProAudio's Avatar
 
Join Date: May 2014
Location: Germany
Posts: 473
Default

Quote:
Originally Posted by lb0 View Post
Thanks for everything you're doing getting this working - I think the VU meters so far look amazing and react really nicely! I take it all this calibration stuff will be between the png stacks and your JSFX code. If there's anything in the script I need to look into - let me know.

Thanks again - this is a great collaboration!!
Your welcome. No issues from my side so far!
__________________
www.tb-software.com/TBProAudio
TBProAudio is online now   Reply With Quote
Old 10-25-2016, 07:26 AM   #413
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,658
Default

while waiting for The Boss
edit...just microtonic & in the Kick&Snare channel megababy nm mod and 3x reasamplomatic
https://www.youtube.com/watch?v=W5lrt2UwJaU

edit2..
is it possible to have an option to place Name and Value also Left/Right of the controllers?

Last edited by timbralzoom; 10-25-2016 at 07:48 AM.
timbralzoom is offline   Reply With Quote
Old 10-25-2016, 07:51 AM   #414
Sju
Human being with feelings
 
Join Date: Jun 2015
Posts: 686
Default

Quote:
Originally Posted by timbralzoom View Post
is it possible to have an option to place Name and Value also Left/Right of the controllers?
+1 for optional horizontal layout of the text elements.
Sju is offline   Reply With Quote
Old 10-25-2016, 09:32 AM   #415
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 14,632
Default LED buttons

On the stash now

https://stash.reaper.fm/v/28707/LED%2...20STRIPPER.zip

red, green, blue, yellow, orange LED buttons ready to use

.knb files included so just unzip and copy into your controls folder

I'm using these mostly for the 'on\off' of the Bypass but they could be anything... just remember they are not a slider, they are a 'BUTTON' or most likely a 'BUTTON INV'
__________________
...should be fixed for the next build... http://tinyurl.com/cr7o7yl
https://soundcloud.com/hopikiva/angel-rain

Last edited by hopi; 10-25-2016 at 09:45 AM.
hopi is offline   Reply With Quote
Old 10-25-2016, 09:49 AM   #416
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 14,632
Default bugglet?

using the current version that is 261 kb in size

seems to be a problem with a normal knob when it's moved to -inf [lowest setting of the VST parameter]

IF that happens one can no longer move the knob with the mousewheel

easy to test this with the Cockos EQ and the gain for band #2

I 'think' this has been mentioned before? ...yes? no?

I hope it is not just me doing something wrong %^)
__________________
...should be fixed for the next build... http://tinyurl.com/cr7o7yl
https://soundcloud.com/hopikiva/angel-rain
hopi is offline   Reply With Quote
Old 10-25-2016, 09:49 AM   #417
Sju
Human being with feelings
 
Join Date: Jun 2015
Posts: 686
Default Bug when using renamed plugins (maybe, see edit)

I was wondering why some of the effects in my chains just refused to load along with the strip... then I noticed that I had renamed them in the FX Browser.

Some of the plugins have really long default names, like for example "VST: TDR VOS SlickEQ GE (Tokyo Dawn Labs)". I had renamed it to just "SlickEQ", but that breaks compatibility with Stripper apparently. Is there a way around this, any way to reference to the plugin without the exact name? Not a biggie though, I'll just use the default names for now.

--- EDIT ---

Hmm I somehow managed to get it to work with SlickEQ by removing the custom name in the FX Browser. BUT, the plugin instance in the channel still has the custom name... but it works now... and was unable to get EQuilibrium to load even without the custom names. Well, I'll investigate further.

--- EDIT 2 ---

Now I got it working with EQuilibrium too, but I'm not sure what I did opened a fresh project though and created a new strip with unnamed instance of the plugin.

Well anyway, seems like the custom naming can cause some problems, so maybe something worth looking into.

Last edited by Sju; 10-25-2016 at 10:38 AM.
Sju is offline   Reply With Quote
Old 10-25-2016, 10:31 AM   #418
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,658
Default

i just saw this jumpy movement
reaEQ strange thing is only with the Gain parameter

http://imgur.com/FqL4dSn

sorry if its known already.
timbralzoom is offline   Reply With Quote
Old 10-25-2016, 10:43 AM   #419
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by timbralzoom View Post
i just saw this jumpy movement
reaEQ strange thing is only with the Gain parameter

http://imgur.com/FqL4dSn

sorry if its known already.
It's since I have changed the normalizing. If I switch back to using GetParamNormalized (hence use reapers normalization) - it works smoothly.

I needed to not use reapers normalization - as it didn't work properly with the meters.

I will investigate - but the reaEQ does do some odd things sometimes...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 10:54 AM   #420
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 14,632
Default

Quote:
but the reaEQ does do some odd things sometimes...
just to say, it was working OK about 2 or 3 versions back...

I mean the behavior of the knob was working OK

I'm sure you'll get it to be as it should before too long %^)
__________________
...should be fixed for the next build... http://tinyurl.com/cr7o7yl
https://soundcloud.com/hopikiva/angel-rain
hopi is offline   Reply With Quote
Old 10-25-2016, 11:01 AM   #421
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by hopi View Post
just to say, it was working OK about 2 or 3 versions back...

I mean the behavior of the knob was working OK

I'm sure you'll get it to be as it should before too long %^)
Yeah - that's about when I swapped to the unnormalized parameter reads.

It's ok though - think I've sussed it. I've now swapped to write out the unnormalized values too - at the expense of a small amount of CPU.

So we should be able to have meters and ReaEQ working ok...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 11:04 AM   #422
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by Sju View Post
I was wondering why some of the effects in my chains just refused to load along with the strip... then I noticed that I had renamed them in the FX Browser.

Some of the plugins have really long default names, like for example "VST: TDR VOS SlickEQ GE (Tokyo Dawn Labs)". I had renamed it to just "SlickEQ", but that breaks compatibility with Stripper apparently. Is there a way around this, any way to reference to the plugin without the exact name? Not a biggie though, I'll just use the default names for now.

--- EDIT ---

Hmm I somehow managed to get it to work with SlickEQ by removing the custom name in the FX Browser. BUT, the plugin instance in the channel still has the custom name... but it works now... and was unable to get EQuilibrium to load even without the custom names. Well, I'll investigate further.

--- EDIT 2 ---

Now I got it working with EQuilibrium too, but I'm not sure what I did opened a fresh project though and created a new strip with unnamed instance of the plugin.

Well anyway, seems like the custom naming can cause some problems, so maybe something worth looking into.
Aaaargh!! I've been working on the custom names a lot recently - thought I almost had it sorted but clearly not quite... will take another look. Incidentally - was it just SlickEQ (no spaces) that you renamed to? The lack of space will point me at which bit to look at as a space means I have to parse quotes.

I have to say - I've had custom names working ok here - so would be good if you could double check with a fresh project.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 11:06 AM   #423
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by hopi View Post
using the current version that is 261 kb in size

seems to be a problem with a normal knob when it's moved to -inf [lowest setting of the VST parameter]

IF that happens one can no longer move the knob with the mousewheel

easy to test this with the Cockos EQ and the gain for band #2

I 'think' this has been mentioned before? ...yes? no?

I hope it is not just me doing something wrong %^)
Not seeing this problem here - but maybe my work on the normalize - denormalize stuff has sorted this...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 11:07 AM   #424
Sju
Human being with feelings
 
Join Date: Jun 2015
Posts: 686
Default

Piling on the bug reports here...

Not quite getting POS TO FRAME to work; I think I've ran into the same problem that was reported a while back

I'm trying to make a two-state button from a parameter which has three states 0-1-2. The button will need to toggle between 1 and 2, and change to the second frame in the 2 position.

The button will display the second frame when I save the cycle button settings in EDIT mode, but once I switch to LIVE and click it once, all states will use just the first frame.

--- EDIT ---

Nevermind, looks like I need a png with 3 frames :P

Last edited by Sju; 10-25-2016 at 01:51 PM.
Sju is offline   Reply With Quote
Old 10-25-2016, 11:18 AM   #425
Sju
Human being with feelings
 
Join Date: Jun 2015
Posts: 686
Default

Quote:
Originally Posted by lb0 View Post
Aaaargh!! I've been working on the custom names a lot recently - thought I almost had it sorted but clearly not quite... will take another look. Incidentally - was it just SlickEQ (no spaces) that you renamed to? The lack of space will point me at which bit to look at as a space means I have to parse quotes.

I have to say - I've had custom names working ok here - so would be good if you could double check with a fresh project.
Yep just SlickEQ. I tried again in a fresh project, and renaming the plugin to "SlickEQ" in the FX Browser caused it not to be detected, when trying to load the strip to another track (I get the NOT AVAILABLE message on the knob).

Another thing that I noticed is that, after creating the test chain with renamed plugin, if I then clear the naming in the FX Browser, insert the plugin again on the same track and save the chain, when I try to drop it on the grid it doesn't create a knob at all. Maybe it corrupts the strip file somehow?

Anyways, everything works fine when I use the default plugin names.
Sju is offline   Reply With Quote
Old 10-25-2016, 11:20 AM   #426
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Ok - I'm going out on a limb with this one. As in I've no idea how well it will perform. You can probably break it quite well by moving tracks about - so be warned.

I have added something which has been a bit of a headache - and as such it's largely untested - but seems to workish for me. This might put a smile on TimbralZooms face i hope...

It's a learn option - so it will learn the last touched fx parameter and allow you to drag to the grid.

But - it will allow you to drag parameters from other tracks into the current grid.

Now currently there is a caveat (if it works ok for you)
If you save the strip - the fx from other tracks will not load back in and they will appear as missing plugin fx (the red text).

But obviously they should save with the project ok

The other problem I've experience - is if I have TBProAudio's VUMeter plug running - it takes over the last touched fx param value. So all instances need disabling before you can use the learn feature - I don't know if this can be sorted TBProAudio - or is it the way the plug works??

Might break everything mind you

also contains the reaeq normalisation fix...

L.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 11:21 AM   #427
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by Sju View Post
Yep just SlickEQ. I tried again in a fresh project, and renaming the plugin to "SlickEQ" in the FX Browser caused it not to be detected, when trying to load the strip to another track (I get the NOT AVAILABLE message on the knob).

Another thing that I noticed is that, after creating the test chain with renamed plugin, if I then clear the naming in the FX Browser, insert the plugin again on the same track and save the chain, when I try to drop it on the grid it doesn't create a knob at all. Maybe it corrupts the strip file somehow?

Anyways, everything works fine when I use the default plugin names.
will look into it
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 11:25 AM   #428
Sju
Human being with feelings
 
Join Date: Jun 2015
Posts: 686
Default reaper.TrackFX_GetFXName return value parsed as empty?

Check this out:



four instances of SlickEQ named differently. The last one is custom named in the FX Browser, but also in the MCP FX list right-click context menu.

That name field displayed "VST: SlickEQ" at first, but then I renamed the plugin to just "SlickEQ" in the MCP FX list right-click context, and it now displays as empty in the field that apparently uses reaper.TrackFX_GetFXName function.

Code:
local _, fx_name = reaper.TrackFX_GetFXName(track, fx, ""); fx_name = fx_name:match(" %P+")
(the code is from DarkStars fx pin matrix script.)

Ok I see, it matches the first string after a space. Without a space it returns empty.

EDIT: Meant MCP not TCP...
Attached Images
File Type: png getfxname returns empty.png (11.6 KB, 256 views)

Last edited by Sju; 10-25-2016 at 11:53 AM.
Sju is offline   Reply With Quote
Old 10-25-2016, 11:33 AM   #429
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by Sju View Post
Check this out:



four instances of SlickEQ named differently. The last one is custom named in the FX Browser, but also in the TCP FX list right-click context menu.

That name field displayed "VST: SlickEQ" at first, but then I renamed the plugin to just "SlickEQ" in the TCP FX list right-click context, and it now displays as empty in the field that apparently uses reaper.TrackFX_GetFXName function.

Code:
local _, fx_name = reaper.TrackFX_GetFXName(track, fx, ""); fx_name = fx_name:match(" %P+")
(the code is from DarkStars fx pin matrix script. Could it be the same issue here?)
All I will say is that parsing the fxchunk to pull out the required name to reload a plugin is a PITA!!

Especially with renamed plugins - but it will be possible. Think I might resort to old school parsing techniques instead of pattern matching...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 11:51 AM   #430
Sju
Human being with feelings
 
Join Date: Jun 2015
Posts: 686
Default

Quote:
Originally Posted by lb0 View Post
All I will say is that parsing the fxchunk to pull out the required name to reload a plugin is a PITA!!
Heh yeah. There's no UUID system for plugins?

Anyway condensing the chaotic mess of information in my above post here:

If you rename a plugin in the FX Browser, the name will be: "VST: renamed" (or whatever the plugin format)
If you rename a plugin in the MCP fx list right-click menu, the name will be just: "renamed"
The MCP fx list automatically crops away any plugin format prefixes from the name that's displayed in the mixer.

although you probably figured this out already.
Sju is offline   Reply With Quote
Old 10-25-2016, 11:56 AM   #431
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,658
Default

Quote:
Originally Posted by lb0 View Post
Ok - I'm going out on a limb with this one. As in I've no idea how well it will perform. You can probably break it quite well by moving tracks about - so be warned.

I have added something which has been a bit of a headache - and as such it's largely untested - but seems to workish for me. This might put a smile on TimbralZooms face i hope...

It's a learn option - so it will learn the last touched fx parameter and allow you to drag to the grid.

But - it will allow you to drag parameters from other tracks into the current grid.

Now currently there is a caveat (if it works ok for you)
If you save the strip - the fx from other tracks will not load back in and they will appear as missing plugin fx (the red text).

But obviously they should save with the project ok

The other problem I've experience - is if I have TBProAudio's VUMeter plug running - it takes over the last touched fx param value. So all instances need disabling before you can use the learn feature - I don't know if this can be sorted TBProAudio - or is it the way the plug works??

Might break everything mind you

also contains the reaeq normalisation fix...

L.
yay!!
sounds miracle!
downloaded but i can't find where is the learn last touched function?
did i jump too early?
(btw.. github notification was saying "updated 17 mins ago" )
timbralzoom is offline   Reply With Quote
Old 10-25-2016, 12:04 PM   #432
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by timbralzoom View Post
yay!!
sounds miracle!
downloaded but i can't find where is the learn last touched function?
did i jump too early?
(btw.. github notification was saying "updated 17 mins ago" )
haha - i could be cruel and say look for it...

or I could say look for the L next to FX PARAMS button in FX PARAM edit mode
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 12:15 PM   #433
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,658
Default

Quote:
Originally Posted by lb0 View Post
haha - i could be cruel and say look for it...

or I could say look for the L next to FX PARAMS button in FX PARAM edit mode
i am going to cry
i can't find the secret L
but i just realized we were able to resize browser part


https://snag.gy/jD0lpT.jpg
timbralzoom is offline   Reply With Quote
Old 10-25-2016, 12:46 PM   #434
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by timbralzoom View Post
i am going to cry
i can't find the secret L
but i just realized we were able to resize browser part


https://snag.gy/jD0lpT.jpg
Really odd - try redownloading - have uploaded again...
Attached Images
File Type: png FX PARAM L.png (5.3 KB, 65 views)
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 12:48 PM   #435
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by Sju View Post
Heh yeah. There's no UUID system for plugins?

Anyway condensing the chaotic mess of information in my above post here:

If you rename a plugin in the FX Browser, the name will be: "VST: renamed" (or whatever the plugin format)
If you rename a plugin in the MCP fx list right-click menu, the name will be just: "renamed"
The MCP fx list automatically crops away any plugin format prefixes from the name that's displayed in the mixer.

although you probably figured this out already.
Nope - I guess I only use the MCP for renaming as I was unaware of the other method... will look into it when I can face it!!
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 12:57 PM   #436
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,658
Default

downloaded again...ta daaa!
time to test hard!

did i say Thank you so much?!
timbralzoom is offline   Reply With Quote
Old 10-25-2016, 12:58 PM   #437
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Quote:
Originally Posted by timbralzoom View Post
downloaded again...ta daaa!
time to test hard!

did i say Thank you so much?!
Lets just see if it works ok first

I think it should now cope ok with track and fx reordering. No idea if it works with the Master bus though... haven't checked that.

EDIT - seems to work ok with master bus
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 01:04 PM   #438
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,061
Default

Hmmm... my normalize, denormalize method working with threshold on ReaGate only gives you up to +6 on the slider - whereas the slider goes up to +12

I can only think this is a problem with the reported max value from the plugin - as i'm using the plugin's own min and max values to normalize!!

I think there might be a few issues with some of the ReaPlugs (good as they are). Probably can not do anything about these if the bugs are external...

Of course - I could be doing something wrong in my denormalize function - but it works perfectly for other parameters.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 10-25-2016, 01:18 PM   #439
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,658
Default

^^ i can confirm this..it was since the first day i start to test it...
for example rea delay has +24 but only +6 db can controllable via script.
( to me not a problem btw.)
timbralzoom is offline   Reply With Quote
Old 10-25-2016, 01:23 PM   #440
zappsunzorn
Human being with feelings
 
zappsunzorn's Avatar
 
Join Date: Feb 2008
Location: Virginia Beach VA
Posts: 2,269
Default

Forgive me for the OT but am I the only one that sees "LBX Stripper" and thinks they are on the wrong forum for about half a second, or gets self conscious when others might have a passing glance at the thread title.
zappsunzorn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:55 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.