Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for macOS X

Reply
 
Thread Tools Display Modes
Old 11-27-2013, 08:18 AM   #1
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default Reaper 4.57/64 + MOTU PCIe-424 + OSX Mavericks

First of all i want to say that reaper works pretty stable with mavericks for me and i have only a few problems with some 32bit plugins which won't work or totally slow down reaper. if i don't use those plugs, reaper works pretty stable.

well, apart of one thing which really starts to bug me:

i've downloaded the newest driver for the motu pcie-424 card (MUAI_Mac_59200) since i've heard of and also experienced some problems with the motu card under mavericks. so, the new driver works better now, but i'm still having some issues.

the problem is, that the playback just suddenly stops (although the play button is active and the timeline is moving) and there is no audio coming from reaper anymore. unless i stop the playback, go to audio preferences, choose another audio device, select the motu device again and press apply. then everything works fine again... until the next mute... so the motu card seems to kind of unsync from reaper somehow and stops playback (until i reset it again). i never had that kind of problem before mavericks though.

is anyone else experiencing this kind of issues (with motu cards and reaper)? the problem occurs quite often (like 5-6 times during a day, sometimes even more) and it's not reproduceable for me (or in other words unpredictable). it seems that i'm not having this issues with other daw's or apps like cubase or wavelab.

any ideas?
TimS is offline   Reply With Quote
Old 11-29-2013, 06:20 AM   #2
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

no one? so i am the only one experiencing those issues?
TimS is offline   Reply With Quote
Old 12-20-2013, 05:49 AM   #3
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

still having the same issue, also after updating to reaper 4.581/64.

well, even if it seems that nobody else is having that problem, no one has a suggestion what to try?

what is your recommended settings in preferences -> audio -> device? anything i should know about settings there regarding motu pcie-424?

any help/idea is welcome, guys! ;-)
TimS is offline   Reply With Quote
Old 08-07-2014, 07:15 AM   #4
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,705
Default

We'll better take it here since communication with tech-support doesn't seem to be reliable and your emails are very hard to read (maybe some formatting issue with your email client). Also it could help when there's more eyes and brains on the issue.

Some questions, please answer each of them thoroughly (even though you already have answered some of them in your emails, just to fill in any potential readers):

- Did you successfully run the same setup before installing Mavericks on the same computer?

- Is that also happening in a project without plug-ins (I think the answer was "no") and what plug-ins exactly are you running in all projects that show this problem? Tech-Support suggested removing a group of plug-ins at a time, saving the project with a new name and restarting REAPER with that new project until the problem stops happening, then you know the offending plug-in is in the last set of plug-ins you removed and you could examine them the same way to find the culprit.

In case the problem can't be boiled down to a plug-in, please also answer those:

- Does your Mac have a Fusion Drive?

- Please post screenshots of your

Preferences->Audio
Preferences->Audio->Device
Preferences->Audio->Buffering
Preferences->Audio->Recording

pages. Maybe there's something amiss.
Ollie is offline   Reply With Quote
Old 08-07-2014, 03:12 PM   #5
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

hi ollie,

thanks for your reply! regarding your questions:

- Did you successfully run the same setup before installing Mavericks on the same computer?

yes, indeed it worked without any problem until i switched to mavericks. as i told you before i only experience those problems with reaper. in cubase, wavelab or other programs i don't experience this issue at all. that's why motu support thinks that it has to be a reaper related issue. by the way: in reaper i only record or playback most of the time just a stereo track at once. in cubase for instance, i record up to 16 channels drums at the same time without a single dropout...

- Is that also happening in a project without plug-ins (I think the answer was "no")?

i will check again and let you know!

- And what plug-ins exactly are you running in all projects that show this problem?

well, i have a selected set of plugins in reaper which stays mostly the same all the time. some uad plugins, plugin-alliance, fabfilter, sonnox, slate digital or cockos reainsert, so nothing really too "exotic". by the way, except from the reainsert, i used most of those plugins in cubase during a multitrack mixing session (also with much more instances of plugins running at the same time) and i never experienced anything like these dropouts or playback stops i have in reaper.

- Tech-Support suggested removing a group of plug-ins at a time, saving the project with a new name and restarting REAPER with that new project until the problem stops happening, then you know the offending plug-in is in the last set of plug-ins you removed and you could examine them the same way to find the culprit.

yes, will try that again and see what's happening! so you keep thinking it might be related to a single plugin? well, when i look at it the way reaper behaves to me it somehow doesn't "feel" plugin related... but let's see... ;-)

- Does your Mac have a Fusion Drive?

no, it doesn't.

- Please post screenshots of your

Preferences->Audio
Preferences->Audio->Device
Preferences->Audio->Buffering
Preferences->Audio->Recording

attached!
Attached Images
File Type: jpg Pic1.jpg (59.4 KB, 118 views)
File Type: png Pic2.png (62.6 KB, 104 views)
File Type: jpg Pic3.jpg (63.0 KB, 108 views)
File Type: jpg Pic4.jpg (59.1 KB, 111 views)
TimS is offline   Reply With Quote
Old 09-18-2014, 09:27 AM   #6
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

Well, although it seems that I can't expect too much help here (when I look at the number of replies), I'll give you a little news update. Even when I updated OS X to 10.9.5 and reaper to 4.73/64 the issue remains, still couldn't find a way to get rid of that clicks and crackling. Motu driver is v1.6.60625. I'm not sure if it might be related to the reainsert plugin (also found some reainsert topics describing some similar issues), but I'm also not sure if there is an alternative plugin I could use instead (to check for different behaviour)... Any ideas?

Last edited by TimS; 09-18-2014 at 09:35 AM.
TimS is offline   Reply With Quote
Old 09-18-2014, 02:12 PM   #7
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 4,689
Default

Hi !

I use the very same setup as you:

- OSX 10.9.4.
- latest driver Motu pci-e. (i use a Motu 2408 MKiii audio interface)
- Latest version of Reaper (64bit)
- Samplerate: 44.1 khz
- Bitdepth: 24bit
- AudioBuffer: 512


I experience NO audio playback problems at all with this setup and settings in Reaper.
But then again, i don't use Rea insert at all.

Sorry to not be able to help you any further.
vanhaze is offline   Reply With Quote
Old 09-18-2014, 04:31 PM   #8
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

hi vanhaze,

thanks a lot for your feedback!

so, you never used the reainsert plugin? would you be up for a try and insert it for a quick test?
i have set it like spdif port of my motu is sending out the audio (to an external converter) and receiving it back from there on the spdif in. maybe you have another setup to run something through in kinda comparable way?

would be more than interesting to see if you have the same issues.

and i'd appreciate it a lot... ;-)
TimS is offline   Reply With Quote
Old 09-18-2014, 05:05 PM   #9
cyrano
Human being with feelings
 
cyrano's Avatar
 
Join Date: Jun 2011
Location: Belgium
Posts: 3,239
Default

There's one thing:

In audio settings pic, you seem to have a sample rate setting of 41000. The tick box is not checked, but it seems weird.

Also, did you try opening audio/midi setup and checking all settings there?
cyrano is offline   Reply With Quote
Old 09-19-2014, 05:37 AM   #10
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

yes, cyrano, you're right. i also noticed that after posting the photos and changed it to 44100, but nothing changed. i've checked the tick box now for a test (with 44100) and it seems a bit more stable so far... but not 100% sure yet, let's check this a bit longer... do you have the tick box checked as well, by the way?
TimS is offline   Reply With Quote
Old 09-19-2014, 05:56 AM   #11
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 4,689
Default

I have always the "request samplerate" and "request blocksize" options ticked.

I do that because i use my Motu interface also in other audiosoftware, but then with other samplerate and buffer settings.
vanhaze is offline   Reply With Quote
Old 09-19-2014, 06:16 AM   #12
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

you have them always checked because otherwise you also had/get problems?
TimS is offline   Reply With Quote
Old 09-19-2014, 06:19 AM   #13
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 4,689
Default

That's very right.
vanhaze is offline   Reply With Quote
Old 09-19-2014, 06:21 AM   #14
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

sorry to ask again, but could you be a bit more specific which kind of problems you experienced when those boxes were unchecked?
TimS is offline   Reply With Quote
Old 09-19-2014, 06:39 AM   #15
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 4,689
Default

No Problem:

crackling, hickups in playback.

Have you tested how it goes when you do NOT use Rea Insert ?
vanhaze is offline   Reply With Quote
Old 09-19-2014, 06:46 AM   #16
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

i see... so could be the same issues i've experienced...

well, the reainsert is kind of mandatory for me, since i always use my analog hardware chain, which is fed through the reainsert plug... anyway, since i've checked the sample rate box it seems MUCH more stable... i think i didn't experience any click at all in the session i have for the last 2 hours. usually i've had a plenty of clicks during that time. i mean i never thought that it's necessary to check that box since the motu pci audio setup is set to 44100 and i thought that the daw is always following the settings of the motu pci audio setup...

anyway, let's keep the fingers crossed... i'll keep you updated about the progress!
TimS is offline   Reply With Quote
Old 09-24-2014, 04:42 AM   #17
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

so, after a couple of days testing i can confirm that reaper is running MUCH more stable for me regarding clicks/dropouts after i selected "request sample rate". only once or twice the playback was totally muted after an online rendering was finished. i had to reset the audio card, then it worked again... but compared to the behaviour before this is definitely much better now!

by the way, could someone explain what "request sample rate" means exactly in this matter. i mean from "where" does it request it? this needs to be selected when receiving the sample rate from an external source (and not internally) or does it have other opportunities where it's better to select it?
couldn't find much in the manual though...

another question: anyone knows a proper alternative to the reainsert plugin maybe?
TimS is offline   Reply With Quote
Old 09-25-2014, 10:19 AM   #18
cyrano
Human being with feelings
 
cyrano's Avatar
 
Join Date: Jun 2011
Location: Belgium
Posts: 3,239
Default

I think "request sample rate" from the hardware. At least I see lights blinking on some interfaces that correspond to sample rate.
cyrano is offline   Reply With Quote
Old 09-25-2014, 10:52 AM   #19
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,494
Default

Quote:
Originally Posted by TimS View Post
so, after a couple of days testing i can confirm that reaper is running MUCH more stable for me regarding clicks/dropouts after i selected "request sample rate". only once or twice the playback was totally muted after an online rendering was finished. i had to reset the audio card, then it worked again... but compared to the behaviour before this is definitely much better now!

by the way, could someone explain what "request sample rate" means exactly in this matter. i mean from "where" does it request it? this needs to be selected when receiving the sample rate from an external source (and not internally) or does it have other opportunities where it's better to select it?
couldn't find much in the manual though...

another question: anyone knows a proper alternative to the reainsert plugin maybe?
Your system should most certainly run more efficiently with the project, audio, and your hardware all running at the same sample rate!

Reaper gives you the ability to run your hardware at a different sample rate than the project and you would do that by setting "request sample rate" different than the project. Reaper will then sample rate convert on the fly (which can use a healthy amount of processing). An example would be working on an 88.2k project on the road on a laptop away from the studio interface where the laptops built-in audio does not support 88.2k sample rate.
serr is online now   Reply With Quote
Old 09-25-2014, 11:14 AM   #20
Kundalinguist
Human being with feelings
 
Kundalinguist's Avatar
 
Join Date: Nov 2008
Location: Toronto, Canada
Posts: 4,576
Default

This reveals one of the paradoxes of Reaper, wherein the untold mass of "options" allows you to customize until you're old and grey, yet they can also create hazards if you do not click the right box, or even know to look for them.

In your case, it seems that nothing was actually "broken." Only your understanding of how to configure Reaper seems to have been at the core of the problem. For this reason (and not having to wait months for a reply on this forum) it sometimes proves that less is more and that simplicity is not necessarily a sign of missing features but perhaps efficiency in design.

That attracted me to Studio One, although I still make good use of and admire Reaper.
__________________
Success is just one more plugin away! And happiness is as close as your next upgrade.
Kundalinguist is offline   Reply With Quote
Old 09-30-2014, 03:58 AM   #21
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

yes, indeed i think "request sample rate" should be labeled a bit more "clear" or at least the manual should give some more detailed info about it... or did i miss that in the manual?

anyway, it is still running much more stable but actually not solid as a rock. sometimes (as described earlier) after an online render the playback is totally muted and i have to reset the soundcard again. i mean at least no dropouts or clicks/crackle anymore during online render, but i'm not sure why it is still muting the sound card from time to time...

@vanhaze or other motu users: do you experience the same regarding the mutes?
TimS is offline   Reply With Quote
Old 09-30-2014, 08:02 AM   #22
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,494
Default

Quote:
Originally Posted by TimS View Post
yes, indeed i think "request sample rate" should be labeled a bit more "clear" or at least the manual should give some more detailed info about it... or did i miss that in the manual?

anyway, it is still running much more stable but actually not solid as a rock. sometimes (as described earlier) after an online render the playback is totally muted and i have to reset the soundcard again. i mean at least no dropouts or clicks/crackle anymore during online render, but i'm not sure why it is still muting the sound card from time to time...

@vanhaze or other motu users: do you experience the same regarding the mutes?
I absolutely agree that both of those controls (request sample rate & request block size) are labeled and presented quite poorly! And have poor documentation as well. You're just expected to know that you need to set your sample rate and disc buffer size for your interface (or aggregate of interfaces) before you do anything else and go digging through preference settings to find the controls.

That IS step one for any DAW to be sure but the manual could use some help considering the scope of the controls they give you here.

And also, these controls should be in the main window, not buried in preferences. This is an all the time thing if you work with different sample rates, different interfaces or combinations of them, or different setups for studio post work vs. live sound.

Setting your sample rate is a two step process:

1. Project sample rate is set in Project Settings under the File menu (also a button in the main arrangement window by default).

2. Your interface's sample rate is set in Preferences/Audio/Device with 'request sample rate'. Normally you would set this identically to the project. This gives you the ability to run your interface at a different sample rate to the project. Reaper will convert on the fly (which uses processing power). I gave a real world example above.

Setting your disc buffer size is then the 'request block size' control. This is just labeled in a slightly unconventional way.

Reaper gives you further options to let you control your interface with it's control panel outside of Reaper. You can disable the 'request' controls by unchecking their boxes. This is intended for a situation where the interface is being used/controlled by a different app or system to avoid a conflict. You would need to follow the lead of the other system for setting the project sample rate.

Basically Reaper has every odd situation that could come up covered.


As for the muting thing (which would be the interface going off line)...

There are all kinds of ways to grab the interface away from Reaper depending on what you do. Take over with it's own control panel or a different media player app, etc etc. You'll find that if you follow setup instructions that things work consistently. Things like: Maybe 9 times out of 10 you can simply open a 96k Reaper project after running a media player at 44.1k and it just switches and works. But it works 100% of the time when you 'follow directions' and make the preference selections in Reaper right after you open it.
serr is online now   Reply With Quote
Old 09-30-2014, 06:01 PM   #23
Jacos
Human being with feelings
 
Join Date: Jun 2014
Location: New Zealand
Posts: 227
Default

Also on MacOS10.9.5, with a Zoom H4 interface. I had crackles after installing a new version of Reaper a few weeks back. It was eventually solved after I checked the buffer size box in Prefs. The number was probably ok but the box wasn't checked.
Jacos is offline   Reply With Quote
Old 10-01-2014, 07:30 AM   #24
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

well, i can totally understand now that it is mandatory to check that "request sample rate" box when you sync to external gear (makes perfect sense as soon as you know what "request sample rate" exactly means here), but the thing which is really annoying me, that the recording/playback is still not solid as a rock. i mean i have to sit right next to reaper while rendering to listen to the entire track/recording to make sure there are no dropouts (because there still are little dropouts from time to time)... it's less than before when "request sample rate" wasn't selected, but it is still an issue!

this should be one of the things you never should worry about in my opinion! your daw should be totally reliable regarding playback and recording at all times... by the way: reaper was like that to me before, never had problems concerning this matter though, but i still claim it all started after i updated to mavericks...

anyway, could any of the cockos/reaper related guys here in this forum (ollie?) give some kind of a statement concerning this issue or further support to get that problem solved? anything else i could try to have a reliable daw/system again?

sorry for "moaning", but i have to admit that i slowly loose my patience...

Last edited by TimS; 10-01-2014 at 07:38 AM.
TimS is offline   Reply With Quote
Old 10-01-2014, 08:26 AM   #25
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,705
Default

Are you rendering in "1x Offline" or "Online"? Try the latter, not all plug-ins like offline rendering and ReaInsert forbids at least rendering faster than realtime.

If you mean "Apply FX/Glue/render stems" by "render", make sure Options->Preferences->Rendering->"Limit apply FX/render stems..." is checked.

If all fails, File->"Save live output to disk (bounce)" should give you the same result as the realtime playback. If that's still coming with clicks, the problem should be something else, sometimes operating system updates break things etc..
Ollie is offline   Reply With Quote
Old 10-01-2014, 08:44 AM   #26
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,494
Default

Quote:
Originally Posted by TimS View Post
well, i can totally understand now that it is mandatory to check that "request sample rate" box when you sync to external gear (makes perfect sense as soon as you know what "request sample rate" exactly means here), but the thing which is really annoying me, that the recording/playback is still not solid as a rock. i mean i have to sit right next to reaper while rendering to listen to the entire track/recording to make sure there are no dropouts (because there still are little dropouts from time to time)... it's less than before when "request sample rate" wasn't selected, but it is still an issue!

this should be one of the things you never should worry about in my opinion! your daw should be totally reliable regarding playback and recording at all times... by the way: reaper was like that to me before, never had problems concerning this matter though, but i still claim it all started after i updated to mavericks...

anyway, could any of the cockos/reaper related guys here in this forum (ollie?) give some kind of a statement concerning this issue or further support to get that problem solved? anything else i could try to have a reliable daw/system again?

sorry for "moaning", but i have to admit that i slowly loose my patience...
Have you done any system optimization with Reaper?

I know you said it was working in the past. Reaper can be tricky to troubleshoot though. It will work flawlessly with very wrong preference settings until you cross the line of processing needs. This can make it difficult to test different settings and makes it easy to go in circles.

It usually comes down to the root cause being a 3rd party plugin. Reaper seems to have a weakness when it comes to 3rd party VST & AU plugins. But they give you a number of controls in preferences to work around it.

This worked for me and made Reaper limitless again for large projects (anything HD and well over 100 tracks and 100 plugins):

Audio thread setting of auto (8 cores in this case for the i7) in Preferences/Audio/Buffering

Anticipative fx processing on globally Preferences/Audio/Buffering and then disabled on any track with a 3rd party (non native Reaper) plugin. Right-click (ctrl-click) the track and select Track performance options > Prevent anticipative fx

* If you turn anticipative fx processing from off to on while a project is open, you need to close the project and reopen it.

* You need anticipative fx processing on in order to set audio threads higher than 1 for that performance boost.

* You need to make sure to disable anticipative fx processing on any track with a misbehaving 3rd party vst or au plugin (which may or may not include all 3rd party... but it's all of mine).


Perhaps you've done all that and this is really a problem with 10.9?
If that's the case, are you able to load up your your old system and see the problems go away? Then put 10.9 back and the issues are back and this is repeatable?
serr is online now   Reply With Quote
Old 10-01-2014, 08:47 AM   #27
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

always doing online render since i thought when i use reainsert/external hardware i MUST render in realtime, right?

"Limit apply FX/render stems..." wasn't checked, i did now and will see if it changes anything.

ok, i will check the ""Save live output to disk (bounce)" as well later on and let you know the results.

thanks!
TimS is offline   Reply With Quote
Old 10-01-2014, 08:49 AM   #28
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

thanks @serr

will check the things you've mentioned as well and let you know the results when finished!
TimS is offline   Reply With Quote
Old 10-02-2014, 05:50 AM   #29
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

Quote:
Originally Posted by Ollie View Post
If you mean "Apply FX/Glue/render stems" by "render", make sure Options->Preferences->Rendering->"Limit apply FX/render stems..." is checked.
well, i think i didn't totally understand your statement in the first place. i mean with "render" the "render to file" option when you select alt+cmd+r.

i've tried the "save live output to disk" option quickly, but to be honest, i didn't get the difference between that and the "render to file" option (apart from having less parameters to select in "save live output..."). what is the difference anyway?

i've tried the "render to file" option now again to see if there are any changes or if it works more stable. so far it works pretty cool, no dropouts came across, but i guess it needs a bit more time to make a proper judgement...

so to summarize the current preferences settings:

device:
- request sample rate is selected (44100)
- request block size is selected (1024)

buffering:
- auto detect the number of needed audio processing threads is selected
- anticipative FX processing - superior multiprocessing... is selected (200ms)

rendering:
- allow anticipative FX processing when rendering is selected
- limit apply FX/render stems to realtime is selected

further on i've selected in each individual channel/track the track performance options ->
"prevent anticipative FX"

by the way, could someone explain what does "Limit apply FX/render stems..." exactly mean?
same with "Anticipative fx processing"? would be cool to get some more information (especially for a non native english speaker)... ;-)

alright, let's see how it is developing... i'll keep you updated!
TimS is offline   Reply With Quote
Old 10-02-2014, 08:39 AM   #30
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

there are still dropouts while online rendering... :-(

sometimes, when rendering is finished (and it worked without dropouts) i start playback again and i have heavy distortion and crackling, almost sounding like there is a wrong sample rate and the signal is also shifted down in tuning (but it definitely has the right sample rate in the preferences)... only resetting the audio device helps in this case...

so, apparently, still no cure for the issue... :-/

any ideas are welcome...
TimS is offline   Reply With Quote
Old 10-02-2014, 08:59 AM   #31
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,494
Default

Quote:
Originally Posted by TimS View Post
there are still dropouts while online rendering... :-(

sometimes, when rendering is finished (and it worked without dropouts) i start playback again and i have heavy distortion and crackling, almost sounding like there is a wrong sample rate and the signal is also shifted down in tuning (but it definitely has the right sample rate in the preferences)... only resetting the audio device helps in this case...

so, apparently, still no cure for the issue... :-/

any ideas are welcome...
Try offline rendering.

I tried online rendering once quite a while ago and I seem to remember it glitching out. I just thought at the time that it must be asking too much of the system somehow. Playback and offline rendering worked as expected.

That was before I had optimized the preference settings for post work with large projects (100+ tracks and 100+ plugins and HD audio). I haven't tried it since.

I actually prefer offline rendering because otherwise I'll hear something to make me stop the mix and start fiddling again!


I'm going to speculate that whatever crashed during your online render caused the disconnect from the audio interface (where you then had to select it again to "reset" the connection).


I'm still interested if you are able to confirm your suspicion that you are only having these problems in 10.9. Are you able to clone your 10.6 system back quick to test the theory?

I'm still running 10.6.8. I got about half way building a 10.9 system but put it aside. I was annoyed with the mission control/spaces changes and a couple other things. I intend to revisit this at some point soon so I'm very interested if you have found a potential bug in 10.9!
serr is online now   Reply With Quote
Old 10-02-2014, 09:32 AM   #32
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

alright, will try offline rendering. although with online rendering i could at least hear on the fly, if there is a dropout or not... with offline rendering, i have to wait for the rendering to finish and then listen again through the entire track to check if there are dropouts...

apparently i can't check that osx rollback option because i don't have an image for that state of the system and apart from that it would be actually too much time consuming to do so... i'm using this computer professionally on a daily basis, that's why i can't "experiment" too much regarding os rollbacks etc..

by the way, i'm using reaper more for mastering applications rather than mixing. i don't have too much single channels going on at the same time neither hundreds of plugins. the plugin chain is only enabled for the active track i'm working on, so i'd say there should be plenty of resources for my computer (mac pro, 3.33ghz 6-core intel xeon with 16gb ram) to deal with my projects... so
from that point of view it should be covered big time to be able to render/record without dropouts...

will let you know about the offline rendering!
TimS is offline   Reply With Quote
Old 10-02-2014, 09:37 AM   #33
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

well, it seems offline render doesn't work at all since it doesn't send the audio through my external hardware chain...
TimS is offline   Reply With Quote
Old 10-02-2014, 10:20 AM   #34
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,494
Default

Quote:
Originally Posted by TimS View Post
well, it seems offline render doesn't work at all since it doesn't send the audio through my external hardware chain...
Oh! Sorry, bad advise. I missed that you were doing that.

How about just doing a 'layback' then? Arm a new track, route your final output tracks/buses to it, and record your mix to it.


I'll try to do some experiments with 10.9 as soon as I can and see if I can duplicate what you see. I do keep disc images for everything (it's how I make backups too) and have a couple SSD's available for system disks.

PS. Look at Carbon Copy Cloner if you haven't. It lets you make 1:1 clones of your disk volumes, schedule backups, etc. You could have your system drive fail completely, install a new one, clone your system back from the backup volume and be back up and running with no manual installs or system configuration. Really valuable tool!

Last edited by serr; 10-02-2014 at 10:27 AM.
serr is online now   Reply With Quote
Old 10-02-2014, 10:53 AM   #35
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,494
Default

Did you say you were using ReaInsert to send/receive from your hardware?

I haven't used this one myself but I have seen many forum posts reporting problems with it!

Maybe do a test where you route manually to/from your hardware. If you are doing parallel processing that includes the hardware path, you would need to accommodate for the latency manually for this test.


My layback vs. render and manual routing vs. ReaInsert suggestions are workarounds but you could easily make templates for the workflow once you set it up if this turns out to work for you.
serr is online now   Reply With Quote
Old 10-02-2014, 04:31 PM   #36
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

yes, i'm using reainsert just because i haven't found a decent alternative. actually i already asked earlier in this conversation if somebody knows a better working plugin to include external hardware. afaik most of the daw's have their built in options and i'm not sure if there are 3rd party solutions?!

well, before i started using reainsert i actually did what you suggested, recording through a manually routing, but i switched to the rendering method (including reainsert) because when i did the recording, it was even worse...

i mean, now i have changed the preferences settings, so i could give it another try to check the manually routing method, but i have to admit that i'm pretty sceptical it will work...

thanks for the carbon copy cloner hint, i'll give it a try! ;-)
TimS is offline   Reply With Quote
Old 10-04-2014, 06:32 AM   #37
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

ok, so i've tried the manually output recording method again (while using the same preferences settings like before when rendering), still having dropouts... :-(

no plugins involved, simply routing the output of a stereo channel to my converter (via spdif from my motu), through the analog chain, back in the converter (and back via spdif to my motu). i mean it can't be more basic, right? so it seems it's not only reainsert related... also here sometimes the playback is totally muted after i stop playback, i have to reset the sound card in the preferences so it works again...

i've set buffer size to 1024, i think i can't give more to the sound card, 1024 is highest. so why the hell are there still dropouts although the VERY same in/out setup with cubase for example is rock solid and NO dropouts at all... so it seems too that it is nothing motu related i'd say...

this is really weird... well, although i definitely like some of the reaper features i'm really thinking about switching back to cubase...
TimS is offline   Reply With Quote
Old 10-04-2014, 07:36 AM   #38
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,494
Default

Quote:
Originally Posted by TimS View Post
ok, so i've tried the manually output recording method again (while using the same preferences settings like before when rendering), still having dropouts... :-(

no plugins involved, simply routing the output of a stereo channel to my converter (via spdif from my motu), through the analog chain, back in the converter (and back via spdif to my motu). i mean it can't be more basic, right?
This sounds for all the world like you are having hardware trouble with the interface. For Reaper not to even be able to pass basic audio like it's just some flaky crashy Windows app...

You mentioned you didn't think there was a problem with the MOTU. I imagine you've tried other media players or DAW's and it seems to work correctly?

I have used MOTU interfaces for many years now with no issues and Reaper has been flawless. I haven't used their PCI interfaces though. So... maybe there's truly a bug in Reaper that comes out with PCI MOTU hardware and OS 10.9?

You said your troubles came up with 10.9.

I think the next move is to retest with 10.6 (or .8 if that was your old system). I know you said you were not keeping backups in the past so this will take more than 10 minutes. First, start making backup clones! CCC is $40 and has a free trial. Especially considering you do paid production work with this system, this will pay for itself.

Once you have a clone of your current 10.9 system parked somewhere, get the old system installed and running enough to install Reaper.

Maybe you'll discover you need to keep an older OS for Reaper and it's just the excuse you needed to pick up another 240GB SSD for $90 for another system volume.


PS. 1024 samples is the max allowed disc buffer size for the firewire MOTU's too.

Last edited by serr; 10-04-2014 at 07:45 AM.
serr is online now   Reply With Quote
Old 10-04-2014, 04:55 PM   #39
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

well, that's exactly the thing:

ALL my other daw's (cubase/wavelab) or audio players are working just fine without any problem on the very same setup/os. i even can record like 16 (or more) channels of drums in cubase simultaneously if required and there are no glitches, dropouts or distortions. nothing!

in other words: i only experience those problems in reaper! honestly, i really haven't got a clue why that is (and it drives me nuts). even when i created a comparable project setup (which i used in reaper) in cubase today, it just worked fine... from that point of view i'm really getting more than sceptical that it is an issue of my motu cards... wouldn't you?

what to say, i'm even not so sure anymore if it's 10.9 related (based on the things i've just mentioned), so i must say that i don't know if i'm going to try the os rollback, just because it seems to be too much time & effort for me... especially when here are plenty of motu/10.9/reaper users who don't have any issues. i know i asked for any ideas... i really appreciate it a lot that you're holding on to that topic so closely and you're trying to help! but i hope you can understand my point too...

by the way, i've had a quick check with wavelab and the asio external gear plugin (like wavelab's reainsert) seems to work very solid (although i need a bit more time for testing). i also want to try the external gear plugin in cubase in combination with bounce/rendering to check the behaviour there to have another comparison (today i only tested recording), will let you know how that works...

Last edited by TimS; 10-04-2014 at 05:19 PM.
TimS is offline   Reply With Quote
Old 10-07-2014, 04:55 AM   #40
TimS
Human being with feelings
 
Join Date: Dec 2012
Posts: 50
Default

while i'm writing this text here i'm listening to the realtime export of cubase which hosts a similar mastering setup i used in reaper (including the external gear plugin of cubase) and what should i say...

in cubase it works like it should, just great, very stable and without any artifacts or anything else unwanted!!! recording AND rendering both always work just fine, no dropouts, no distortions, no nothing...

so again, if this is working in cubase on the very same sound card setup, with the very same osx and everything else exactly the same, it seems pretty clear, that it is a reaper related issue... don't you think?

i still would like to return to reaper as it has some features which are better or at least better for my workflow, but as long as i'm experiencing those issues cubase seems to be the solution for me...

Last edited by TimS; 10-07-2014 at 05:25 AM.
TimS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:27 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.