Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Q&A, Tips, Tricks and Howto

Reply
 
Thread Tools Display Modes
Old 11-28-2018, 02:22 AM   #201
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by melkerpetterson View Post
Yes the first track reads NIKB00 and the second reads NIKB01. I have my VST bridging/firewalling set to "Automatic bridging (when required)"

I tested the other three options now to but still not working.

Do I need to redo the JAVA install?
Hmm, strange. I guess you do not see any errors in the window? Is this Mac or Windows?
moss is offline   Reply With Quote
Old 11-28-2018, 09:34 AM   #202
melkerpetterson
Human being with feelings
 
Join Date: Oct 2018
Posts: 6
Default

Quote:
Originally Posted by moss View Post
Hmm, strange. I guess you do not see any errors in the window? Is this Mac or Windows?
No errors that I can se, but on the other hand I don't know what I should be looking for. But nothing obvious. I'm on a mac running Sierra 10.12.6.

Can it have something to do with the JAVA install? When pressing the mixer button on the controller it shows me the Track names and levels so something seems to be working.

Can I do a complete reinstall in some way and see if that helps?
melkerpetterson is offline   Reply With Quote
Old 12-02-2018, 03:27 AM   #203
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by melkerpetterson View Post
No errors that I can se, but on the other hand I don't know what I should be looking for. But nothing obvious. I'm on a mac running Sierra 10.12.6.

Can it have something to do with the JAVA install? When pressing the mixer button on the controller it shows me the Track names and levels so something seems to be working.

Can I do a complete reinstall in some way and see if that helps?
I just tested it on Mac and it works fine for me. So, the only reason I can think of is that you have old libraries. Please check again that you really replaced the old ones and did not copy the new ones (then you have duplicated JAR files with different version numbers).
moss is offline   Reply With Quote
Old 12-05-2018, 10:41 AM   #204
flipotto
Human being with feelings
 
flipotto's Avatar
 
Join Date: Feb 2007
Posts: 518
Default

Hey - I have a push 2 and an apc40
I want to use them both at the same time.
Is there a way to have the push 2 trigger synth on track 1 and apc40 trigger a synth on track 2, at the same time?

Is there any documentation for what does what on the apc40?

Thanks
__________________
KeyMce/GenMce - pc keyboard/midi to Mackie control emulation (built with ahk). Also - an ahk script to build your own midi programs.
flipotto is offline   Reply With Quote
Old 12-07-2018, 09:33 AM   #205
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by flipotto View Post
Hey - I have a push 2 and an apc40
I want to use them both at the same time.
Is there a way to have the push 2 trigger synth on track 1 and apc40 trigger a synth on track 2, at the same time?
Pinning is not supported. What you can do currently is use one device for clip triggering, one for mixing and one for devices.

Quote:
Originally Posted by flipotto View Post
Is there any documentation for what does what on the apc40?
Yes, the link is on the download page: https://github.com/git-moss/DrivenBy...40-&-APC40mkII
moss is offline   Reply With Quote
Old 12-07-2018, 10:47 AM   #206
flipotto
Human being with feelings
 
flipotto's Avatar
 
Join Date: Feb 2007
Posts: 518
Default

Thanks much!
__________________
KeyMce/GenMce - pc keyboard/midi to Mackie control emulation (built with ahk). Also - an ahk script to build your own midi programs.
flipotto is offline   Reply With Quote
Old 12-07-2018, 08:56 PM   #207
themixtape
Human being with feelings
 
themixtape's Avatar
 
Join Date: Aug 2009
Posts: 486
Default

Just got an NI A61 keyboard controller. Trying to get Reaper to understand the Transport and track functions.

Can't get this working at all. I have 5.962 Reaper (portable install), on Windows 7, 64-bit. I followed the directions on how to get the Java installed but I don't know if I set the environment variables properly.

Does this work on a portable install or is it hopeless? Thank you!
themixtape is offline   Reply With Quote
Old 12-08-2018, 05:27 AM   #208
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by themixtape View Post
Just got an NI A61 keyboard controller. Trying to get Reaper to understand the Transport and track functions.
The A-series is not supported (but might be in the near future) but you can use the Generic Flexi to map the buttons.

Quote:
Originally Posted by themixtape View Post
Can't get this working at all. I have 5.962 Reaper (portable install), on Windows 7, 64-bit. I followed the directions on how to get the Java installed but I don't know if I set the environment variables properly.
Does this work on a portable install or is it hopeless? Thank you!
I don't know why it should not work but you need to give me some hints what is the problem. Do you get any errors?
moss is offline   Reply With Quote
Old 12-10-2018, 05:54 AM   #209
melkerpetterson
Human being with feelings
 
Join Date: Oct 2018
Posts: 6
Default

Quote:
Originally Posted by moss View Post
I just tested it on Mac and it works fine for me. So, the only reason I can think of is that you have old libraries. Please check again that you really replaced the old ones and did not copy the new ones (then you have duplicated JAR files with different version numbers).
Weird. Now I've tried to delete all the DrivenByMoss files in the UserPlugins folder, re-installed the latest version av reaper, downloaded and installed Java again. I've have checked and there are no double jar files.

The latest JAVA version i now jdk-11.0.1.jdk, should that work to?
melkerpetterson is offline   Reply With Quote
Old 12-10-2018, 07:27 AM   #210
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by melkerpetterson View Post
Weird. Now I've tried to delete all the DrivenByMoss files in the UserPlugins folder, re-installed the latest version av reaper, downloaded and installed Java again. I've have checked and there are no double jar files.

The latest JAVA version i now jdk-11.0.1.jdk, should that work to?
Better stick with 8 or 10 for the time being since 11 needs some adjustments.
moss is offline   Reply With Quote
Old 12-14-2018, 07:08 AM   #211
x7i7l
Human being with feelings
 
Join Date: Sep 2018
Posts: 8
Default

Hi Moss,

On Ubuntu 18.04

when I am in Control Surface Settings

I get the following:

drivenbymoss: Java dynamic library not found at usr/lib/jvm/java-11-openjdk-amd64/lib/jli/libjli.so
drivenbymoss: Could not find Java dynamic library.

I can confirm that the file libjli.so is at the given location, so I am not sure what it is the extension cannot find.

Any ideas about solutions would be great.

Thank you!

Adrienne
x7i7l is offline   Reply With Quote
Old 12-16-2018, 02:23 AM   #212
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by x7i7l View Post
Hi Moss,

On Ubuntu 18.04

when I am in Control Surface Settings

I get the following:

drivenbymoss: Java dynamic library not found at usr/lib/jvm/java-11-openjdk-amd64/lib/jli/libjli.so
drivenbymoss: Could not find Java dynamic library.

I can confirm that the file libjli.so is at the given location, so I am not sure what it is the extension cannot find.

Any ideas about solutions would be great.

Thank you!

Adrienne
Please stick with Jdk 8 or 10 for the time being. 11 needs some adjustments.
moss is offline   Reply With Quote
Old 12-26-2018, 04:19 AM   #213
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Just released version 4.03!

- Integrated DrivenByMoss 4.03

* Ableton Push / Push 2 - 11.03
- Fixed: Fixed resetting of Push 2 display colors.

* Novation Launchpad Pro & MkII - 3.45
- Fixed: Transposing the piano view was broken

- Fixed: New tracks with no name did sometimes not turn up until given a name

Enjoy!
moss is offline   Reply With Quote
Old 01-02-2019, 11:46 AM   #214
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

Latest version 4.03 loses LED connection in Push 2 on 09 Max Pro with OS 10.2.5
Everything else works. all buttons light up etc. Ableton Live works with the LED. I have not updated in a while so went back to 3.31 and it works. I'll try some of the other updates and see if they work.
machinesworking is offline   Reply With Quote
Old 01-02-2019, 12:00 PM   #215
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

Adding to my last post, just went through and tested all the 4. versions, none of them show the LED screen on my machine. 3.31 is working just fine. Let me know if there's anything I can do to help solve this issue?
machinesworking is offline   Reply With Quote
Old 01-03-2019, 02:09 AM   #216
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by machinesworking View Post
Adding to my last post, just went through and tested all the 4. versions, none of them show the LED screen on my machine. 3.31 is working just fine. Let me know if there's anything I can do to help solve this issue?
Are you talking about the display or the button LEDs? If it is the display: Does it show nothing at all or is it turning off after a while?
moss is offline   Reply With Quote
Old 01-03-2019, 11:35 AM   #217
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

Quote:
Originally Posted by moss View Post
Are you talking about the display or the button LEDs? If it is the display: Does it show nothing at all or is it turning off after a while?
The display, it never reacts to the software at all. The button LEDs all react. Selecting them selects different tracks in Reaper..

All versions of 4 do not display the display.

Ableton Live 10 does.
machinesworking is offline   Reply With Quote
Old 01-04-2019, 02:17 AM   #218
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by machinesworking View Post
The display, it never reacts to the software at all. The button LEDs all react. Selecting them selects different tracks in Reaper..

All versions of 4 do not display the display.

Ableton Live 10 does.
Hmm, I guess it could be a conflict with your Ableton installation. I do not have Ableton installed, so I do not know how they implemented the display communication, I guess there is a background service running?! Have you tried after a clean reboot? Do you get any errors in the DrivenByMoss configuration window?
moss is offline   Reply With Quote
Old 01-04-2019, 02:06 PM   #219
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

Quote:
Originally Posted by moss View Post
Hmm, I guess it could be a conflict with your Ableton installation. I do not have Ableton installed, so I do not know how they implemented the display communication, I guess there is a background service running?! Have you tried after a clean reboot? Do you get any errors in the DrivenByMoss configuration window?
OK that makes some sense. It's just funny that it works with 3.31 but not any version of 4.

I'm out and about but I will test it and send the errors on the configuration window when I get home.

From what I know you can run the Live 10 demo and all it cripples is saving songs etc.
machinesworking is offline   Reply With Quote
Old 01-04-2019, 08:54 PM   #220
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

Here's the log in the configuration window

Quote:
Loading device INI files from /Users/machines/Library/Application Support/REAPER ...
Starting controller 'Ableton Push 2 - 11.03'
Unable to claim interface.
org.usb4java.LibUsbException: USB error 99: Other error
at de.mossgrabers.reaper.framework.usb.UsbDeviceImpl. getEndpoint(UsbDeviceImpl.java:173)
at de.mossgrabers.controller.push.controller.PushUsbD isplay.<init>(PushUsbDisplay.java:67)
at de.mossgrabers.controller.push.controller.PushDisp lay.<init>(PushDisplay.java:107)
at de.mossgrabers.controller.push.PushControllerSetup .createDisplay(PushControllerSetup.java:236)
at de.mossgrabers.controller.push.PushControllerSetup .createSurface(PushControllerSetup.java:229)
at de.mossgrabers.framework.controller.AbstractContro llerSetup.init(AbstractControllerSetup.java:108)
at de.mossgrabers.reaper.controller.AbstractControlle rInstance.lambda$start$1(AbstractControllerInstanc e.java:123)
at de.mossgrabers.reaper.ui.utils.SafeRunLater.lambda $execute$0(SafeRunLater.java:37)
at java.desktop/java.awt.event.InvocationEvent.dispatch(Invocation Event.java:313)
at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.j ava:770)
at java.desktop/java.awt.EventQueue.access$600(EventQueue.java:97)
at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at java.base/java.security.ProtectionDomain$JavaSecurityAccessI mpl.doIntersectionPrivilege(ProtectionDomain.java: 87)
at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java: 740)
at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilter s(EventDispatchThread.java:203)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(E ventDispatchThread.java:124)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarch y(EventDispatchThread.java:113)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispa tchThread.java:109)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispa tchThread.java:101)
at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThre ad.java:90)

Initialized.
machinesworking is offline   Reply With Quote
Old 01-05-2019, 12:57 AM   #221
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by machinesworking View Post
Here's the log in the configuration window
Could you please try to start Reaper as root/admin?
moss is offline   Reply With Quote
Old 01-05-2019, 02:44 PM   #222
HammyHavoc
Human being with feelings
 
HammyHavoc's Avatar
 
Join Date: Jun 2018
Location: Liverpool, United Kingdom
Posts: 22
Default

Hey Moss, hope 2019 is treating you well!
Just a quick one whilst I'm away from my machine: is DrivenByMoss4Reaper available via ReaPack? If not, are there plans to make it available? Would make updating much easier.
__________________
Hammy Havoc | Split An Atom
HammyHavoc is offline   Reply With Quote
Old 01-06-2019, 02:51 AM   #223
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by HammyHavoc View Post
Hey Moss, hope 2019 is treating you well!
Just a quick one whilst I'm away from my machine: is DrivenByMoss4Reaper available via ReaPack? If not, are there plans to make it available? Would make updating much easier.
It is not available. Might be something to look into for the future but I am not sure how much it would actually help.
moss is offline   Reply With Quote
Old 01-06-2019, 04:57 AM   #224
HammyHavoc
Human being with feelings
 
HammyHavoc's Avatar
 
Join Date: Jun 2018
Location: Liverpool, United Kingdom
Posts: 22
Default

Quote:
Originally Posted by moss View Post
It is not available. Might be something to look into for the future but I am not sure how much it would actually help.
Hi Moss! Thank you for the swift response. :-)

You support the plugin very well (10 new versions since September!), and the updates add some great functionality and fix some sizeable issues. DrivenByMoss4Reaper is the only add-on I use that isn't automatically updated through ReaPack. Would be nice to make use of those new versions as soon as they're available, might cut down on the number of people seeking support or having issues.

A simple way of implementing support for ReaPack would be adding the plugin to an existing repository, or, probably more ideally, adding your own repository to the third-party list, then it's as simple as pushing to GitHub and you maintain complete control.
__________________
Hammy Havoc | Split An Atom
HammyHavoc is offline   Reply With Quote
Old 01-07-2019, 02:07 AM   #225
KuulArt
Human being with feelings
 
Join Date: Apr 2015
Posts: 13
Default

Hi moss,

I would like to start with a thank you for the amazing work you have done. This thing is outstanding and I can really use my Push with Reaper now for mixing duties. Even the nice small touches as "Start Reaper to play" being displayed on Push is very cool.

With this being said - I do have one request that would make Push an even better controller for mixing:
* is it possible to add a way for Push to follow selected fx in Reaper? For an example I want to quickly adjust/insert an EQ for a track. I drop an eq on a track an would like to have it selected on push, so I can grab the knobs to start adjusting. Or the active fx window is selected on Push as a device.

Also - has anyone had success on doing touch automation with either rotary controls on Push 1 or ribbon strip? I get an erratic behaviour which writes touch automation only when I am changing value, not keeping it at the last position while I have my fingers on the control.
KuulArt is offline   Reply With Quote
Old 01-07-2019, 06:02 AM   #226
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by KuulArt View Post
* is it possible to add a way for Push to follow selected fx in Reaper? For an example I want to quickly adjust/insert an EQ for a track. I drop an eq on a track an would like to have it selected on push, so I can grab the knobs to start adjusting. Or the active fx window is selected on Push as a device.
Until I am missing something there is no selection state for FX in Reaper. Furthermore, you can have many open FX windows.
moss is offline   Reply With Quote
Old 01-07-2019, 12:46 PM   #227
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

Quote:
Originally Posted by moss View Post
Could you please try to start Reaper as root/admin?
I spent some time setting this up. I'm able to run Reaper in demo mode in root.
Do you want that I install DBYM4R into root?
machinesworking is offline   Reply With Quote
Old 01-07-2019, 02:39 PM   #228
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by machinesworking View Post
I spent some time setting this up. I'm able to run Reaper in demo mode in root.
Do you want that I install DBYM4R into root?
Sorry, I did not mean that you should "install" it as root, only "run" it as root. E.g. see here:
http://osxdaily.com/2013/02/06/how-t...t-in-mac-os-x/
moss is offline   Reply With Quote
Old 01-07-2019, 05:23 PM   #229
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

Quote:
Originally Posted by moss View Post
Sorry, I did not mean that you should "install" it as root, only "run" it as root. E.g. see here:
http://osxdaily.com/2013/02/06/how-t...t-in-mac-os-x/

I briefly ran Reaper as root, which killed the license, left Reaper throwing init files next to the application etc. Anyway I can try running it as root.

Even with the 3.31 DBM4R which works, this appears in the configuration log
Quote:
Loading device INI files from /Users/machines/Library/Application Support/REAPER ...
/Users/machines/Library/Application Support/REAPER/reaper-fxfolders.ini not present, skipped loading.
/Users/machines/Library/Application Support/REAPER/reaper-jsfx.ini not present, skipped loading.
Starting controller 'Ableton Push 2 - 11.00'
Initialized.
machinesworking is offline   Reply With Quote
Old 01-08-2019, 01:15 AM   #230
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by machinesworking View Post
Even with the 3.31 DBM4R which works, this appears in the configuration log
That's totally fine. These files will be created by Reaper the first time that you open the respective section in the plugin browser.
moss is offline   Reply With Quote
Old 01-08-2019, 01:16 PM   #231
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

Quote:
Originally Posted by moss View Post
That's totally fine. These files will be created by Reaper the first time that you open the respective section in the plugin browser.
So use to clarify, running Reaper as root you're thinking that if it is some code from Ableton causing the blank screen, then the DBM4R software will work just fine?

I'm about to try again, opening up Reaper while restarted in Root as Admin etc. caused it to lose it's license and other weird behavior. Let you know if I get the LED screen back.
machinesworking is offline   Reply With Quote
Old 01-08-2019, 04:36 PM   #232
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 100
Default

So, running Reaper as root as per that web link, the Terminal command for "showing" JAVA to the DBM4R software Reaper etc. does not seem to work. After my third attempt Reaper seems to have dumped it's VST scan and is rescanning all of my VSTs. It seems there's no way to start Reaper without loading VSTs so now I have to move all plug ins to "disabled" folders. After doing so it's dumped a bunch of .ini files next to the Application, it also hosed the license again, and does not see the DBM4R controller in the MIDI controller preferences at all.

I actually wish you were paid to write this software, I really find it supremely useful, but being on OSX and owning Live 10 Suite I'm presenting you and me with real problems that are killing me here. I'm going to have to figure out how to get my Actions and preferences back since I foolishly thought that they were destroyed the first time because I opened Reaper in Root, that doesn't seem to be the case.

Here's the last terminal open of Reaper, not the one that hosed my preferences and authorization, but just one where it's not seeing the DBM4R controller in preferences.
Quote:
Last login: Tue Jan 8 14:28:32 on ttys000
michaels-Mac-Pro:~ machines$ sudo /Applications/REAPER64.app/Contents/MacOS/REAPER
Password:
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
michaels-Mac-Pro:~ machines$
machinesworking is offline   Reply With Quote
Old 01-11-2019, 05:10 AM   #233
rothchild
Human being with feelings
 
Join Date: Oct 2007
Posts: 550
Default

Quote:
Originally Posted by rothchild View Post
Sorry for the probably dumb question, but would this be better to use with my MCU than the Klinke plugin? Can I record send automation from MCU with this? (one of the big drawbacks of Klinke that I've found).
Hi Moss,

I finally got around to installing DrivenBy today and it seems that the 2 main issues I have with the Klinke plug also exist in your driver.

1. Although I can control sends with my MCU I can't record automation for sends.

2. When recording volume automation the level on the MCU screen is fixed at whatever it was when it was put into write mode, I'd like the MCU to continue to reflect the fader level even when in write mode.

Hopefully these are just issues with the way I have things configured but it would be great to know if there was anything that can be done about it (especially recording send automation).


Many thanks for all your work on this though, seems pretty great.


EDIT: Redface! Helps if you disable the klinke plugin first, all appears to work correctly now! Many thanks

Last edited by rothchild; 01-11-2019 at 06:04 AM.
rothchild is offline   Reply With Quote
Old 01-11-2019, 05:03 PM   #234
barbaroja
Human being with feelings
 
barbaroja's Avatar
 
Join Date: Jul 2009
Posts: 224
Default

Quote:
Originally Posted by moss View Post
It is not available. Might be something to look into for the future but I am not sure how much it would actually help.
It would definitly be super easy and fast to install and update, Moss.
barbaroja is offline   Reply With Quote
Old 01-13-2019, 06:46 AM   #235
Kejnel
Human being with feelings
 
Join Date: Nov 2012
Posts: 31
Default A question about sequencing and note editing with Push

(I have already posted this in "Tip: Tool to use Ableton Push with Reaper is here" thread but I wasn't sure how active that thread was so I repost it here in order to get more feedback about this. Hopefully you won't mind! :-) )

Hi Jürgen,

first of all very impressed with what you have accomplished! Great job!

I have a question about sequencing and note editing.

Is it possible to edit notes in midi clips with your script (add notes, select notes, freely move notes in time, transpose them, change their length)?

The best implementation of note editing with a hardware controller I have seen so far is Maschine but I don't own one so I am looking for scripts for Push 2 that would allow me to do this. Ableton's vanilla sequencing and editing capabilities for Push 2 in Live completely sucks so I am trying my luck with custom scripts and Reaper.

Thank you and wish you all the best!

Last edited by Kejnel; 01-13-2019 at 06:46 AM. Reason: More descriptive title
Kejnel is offline   Reply With Quote
Old 01-13-2019, 07:50 AM   #236
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

Quote:
Originally Posted by Kejnel View Post
Is it possible to edit notes in midi clips with your script (add notes, select notes, freely move notes in time, transpose them, change their length)?
Most of what you want is there. Freely moving notes does not work. Watch my Bitwig videos about the Push, which are nearly 99% identical to the Reaper implementation.
moss is offline   Reply With Quote
Old 01-13-2019, 07:54 AM   #237
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 209
Default

DrivenByMoss 4 Reaper 5.0 is online!

And don't be afraid anymore, the installation is now dead simple!

https://youtu.be/8_xvQ1qV-ZM

Changes:

- Integrated DrivenByMoss 5.0
* Open Sound Control (OSC) protocol - 6.12
- Fixed: Potential synchronisation issue when sending OSC messages.
* Generic Flexi - 2.0
- New: Completely new settings user interface
- New: Support for modes: Track, Volume, Panorama, Send 1-8, Parameters
- New: Support for using Pitchbend as a controller
- New: Added command: "Master: Crossfader"
- Fixed: Blocking notes which are mapped to a command did only work after restart.
- Fixed: "Send value to device" did always send on midi channel 1.

- Bundled Java Virtual Machine for easier installation
- Does not require SWS anymore
moss is offline   Reply With Quote
Old 01-13-2019, 09:45 AM   #238
Kejnel
Human being with feelings
 
Join Date: Nov 2012
Posts: 31
Default

Quote:
Originally Posted by moss View Post
Most of what you want is there. Freely moving notes does not work. Watch my Bitwig videos about the Push, which are nearly 99% identical to the Reaper implementation.
Thank you for the answer!

Just to clarify: Moving notes is not possible because of programming limitations or because you haven't implemented it yet?
Kejnel is offline   Reply With Quote
Old 01-13-2019, 10:15 AM   #239
Kejnel
Human being with feelings
 
Join Date: Nov 2012
Posts: 31
Default Portable installation

Does DrivenByMoss 4 Reaper work with portable installation of Reaper? There is no AppData folder for portable Reaper.

I tried to copy the files into <Disk letter>:\<A folder>\REAPER_portable\UserPlugins\ but it does not show up in Control Surfaces options.

I use 32bit portable Reaper.
Kejnel is offline   Reply With Quote
Old 01-13-2019, 04:12 PM   #240
HammyHavoc
Human being with feelings
 
HammyHavoc's Avatar
 
Join Date: Jun 2018
Location: Liverpool, United Kingdom
Posts: 22
Default

Quote:
Originally Posted by moss View Post
DrivenByMoss 4 Reaper 5.0 is online!

And don't be afraid anymore, the installation is now dead simple!

https://youtu.be/8_xvQ1qV-ZM

Changes:

- Integrated DrivenByMoss 5.0
* Open Sound Control (OSC) protocol - 6.12
- Fixed: Potential synchronisation issue when sending OSC messages.
* Generic Flexi - 2.0
- New: Completely new settings user interface
- New: Support for modes: Track, Volume, Panorama, Send 1-8, Parameters
- New: Support for using Pitchbend as a controller
- New: Added command: "Master: Crossfader"
- Fixed: Blocking notes which are mapped to a command did only work after restart.
- Fixed: "Send value to device" did always send on midi channel 1.

- Bundled Java Virtual Machine for easier installation
- Does not require SWS anymore
Love you, Moss. Great work!
__________________
Hammy Havoc | Split An Atom
HammyHavoc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:25 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.