Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Compatibility

Reply
 
Thread Tools Display Modes
Old 07-17-2017, 02:59 AM   #1
bloke1
Human being with feelings
 
Join Date: Jul 2017
Posts: 2
Default Novation Ultranova synth timing issues with Reaper

Good evening,

Issues similar to mine have been discussed throughout the forum and I apologize in advance but if anyone could offer any advice it would be greatly appreciated.

My ultranova is connected to Reaper via usb and the ultranova also acts as my audio interface which I have conservatively set at 10ms of latency. There is an editor that accompanies the ultranova's hardware synth, which can be utilized as a VST, but it does not generate sound but allows the user to alter the hardware synth's parameters on screen in the DAW.

In order to play the synth, via Reaper, the editor must be opened as an FX and record enabled but then a subsequent audio track must also be created, and also record enabled, so that the midi is sent to the hardware device and audio brought back into Reaper to be recorded, and heard, in Reaper.

I have the ultranova's audio interface settings so that it is 100% from host, (as in the hardware synth being played back is, "sounding thru" Reaper and not, "live.")

When tempo based effects are engaged with the ultranova synth, (LFO / arp / delay etc) the synth does not play back in time with the content material in reaper, (drums, samples , vst synths etc.) When the material is recorded it can be shifted so it is perfectly in line but this is annoying when auditioning sounds. Eventually Reaper and the synth do sync but it is arbitrary when and how this occurs.

I have tried the following to no avail:

1. Disabling the, "Use audio driver reported latency feature" in recording settings and manually inputting offsets, (this has the effect of offsetting both the midi and audio return track when record enabled and generates timing conflicts.)
2. Attempting to, "Offset output to this device" in Midi output configurations seems to have little effect.
3. Using Reainsert to avoid the latency issued presented has delivered minimal results.
4. Preserve PDC monitoring again, to my mind, produces inconsistent results.
5. Adjusting the manner in which the ultranova receives its clock source, (internal or from host) delivers minimal results.

The obvious thing would be to just record the audio live into Reaper but then automation or other effects cannot be applied.

As a preference I would prefer to, "hear" the ultranova in time and then have to adjust the recorded material accordingly but I just can't figure out how to do this. In a perfect world I would hear the synth in time and it would also be recorded in time but this may be a pipe dream.

If anyone could take a moment to respond I would be very grateful.
bloke1 is offline   Reply With Quote
Old 07-17-2017, 05:58 AM   #2
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,621
Default

Right-click the MIDI output port to the Novation in Preferences->MIDI Devices, there is a "Offset output to this device by..." function to fine-tune sync. You need to determine how much the audio from the synth is "late" or "early" first, then enter a corresponding correction value there, whereas the max. amount of negative delay (which is needed if MIDI is early) is limited by your block size (more buffer=more wiggle room).

IOW if you set your audio buffers too low you may not be able to correct the device sufficiently in the negative range (for example, my MOX synth needs -24ms, which requires buffers <1024 samples). The resulting high latency is a problem of course if you want to track more stuff with live monitoring, so you'd need to increase buffers (so the output is in sync), record the synth's output to an audio track, then put the buffers back to the old value.

This may or may not work for you tho, the problem is pretty complex. See this thread:

https://forum.cockos.com/showthread.php?t=137555
Ollie is offline   Reply With Quote
Old Today, 02:42 AM   #3
bloke1
Human being with feelings
 
Join Date: Jul 2017
Posts: 2
Default

Hi Ollie,

Thanks for the response - I think I may have stumbled on that post you sent already, and its associated links. The battle continues.
bloke1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:41 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.