Old 08-10-2018, 08:01 AM   #1
JeffM
Human being with feelings
 
Join Date: Oct 2009
Posts: 77
Default Reaper won't recognise keypad

I just bought an Elgato Stream Deck and Reaper won't recognise it!!!

To test it at the most simple level, I programmed one of the keys to type the letter P (I was then goung to assign P to play in actions but I've not even got that far yet).

If I open just about any program on my PC (notepad for example or any program that has a text input dialog, such as the "save as" function) and press the relevant button, it types the letter P on screen.

However, in Reaper if I do "save as" or try to rename a track and then press the same button, nothing happens.

As far as I can see, Reaper doesn't recognise that the keypad even exists.

Any suggestions gratefully recieved.
JeffM is offline   Reply With Quote
Old 08-10-2018, 08:55 AM   #2
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,100
Default

Hi Jeff

For reaper you should use the Hotkey function, not the Text function in streamdeck.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 08-10-2018, 09:05 AM   #3
JeffM
Human being with feelings
 
Join Date: Oct 2009
Posts: 77
Default

Thanks for your reply.

I tried that and it doesn't work.

The reason I had the key programmed to enter text was to try to test the keypad at the absolute most simple level - to enter the letter P into a text input box.

I figure if I can't even do that then there's not much point in trying to get something more complicated to work.

This key prints a letter P into any text input box on any program I try (except Reaper).

Even in this message...

PPPPPPPPPPPPPP

Last edited by JeffM; 08-10-2018 at 09:21 AM.
JeffM is offline   Reply With Quote
Old 08-10-2018, 09:46 AM   #4
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,100
Default

so in this window the streamdeck is not recognized?

__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 08-10-2018, 09:57 AM   #5
JeffM
Human being with feelings
 
Join Date: Oct 2009
Posts: 77
Default

Quote:
Originally Posted by EpicSounds View Post
so in this window the streamdeck is not recognized?

Correct.
JeffM is offline   Reply With Quote
Old 08-10-2018, 11:02 AM   #6
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,100
Default

I can't think of anything in reaper or streamdeck that would stop this. The only trouble I ever had with it is sending actions while a plugin window is focused, which doesn't always pass through to arrange.

I'm assuming you've done all the usual troubleshooting stuff - check for updates, restart, different usb port
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 08-11-2018, 06:56 AM   #7
JeffM
Human being with feelings
 
Join Date: Oct 2009
Posts: 77
Default

Quote:
Originally Posted by EpicSounds View Post
I can't think of anything in reaper or streamdeck that would stop this. The only trouble I ever had with it is sending actions while a plugin window is focused, which doesn't always pass through to arrange.

I'm assuming you've done all the usual troubleshooting stuff - check for updates, restart, different usb port
It's really crazy because I literally can't find any other bit of software on my PC that doesn't recognise the Stream Deck.

Last edited by JeffM; 08-11-2018 at 07:12 AM.
JeffM is offline   Reply With Quote
Old 08-11-2018, 10:12 AM   #8
JeffM
Human being with feelings
 
Join Date: Oct 2009
Posts: 77
Default

OK - problem solved.
I've no idea why it worked, but I just installed Reaper into a new directory and it's all working perfectly.

I had already re-installed it into the original directory to no avail.
JeffM is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:40 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.