Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER General Discussion Forum

Reply
 
Thread Tools Display Modes
Old 10-09-2019, 09:42 PM   #1
changeng
Human being with feelings
 
Join Date: Sep 2010
Posts: 72
Default key switches in Kontakt are lower than possible in Reaper piano roll

I'm lost. I am trying to put on the big boy pants and finally dig into deeper midi editing than just drawing velocities in a cc lane. I have been using an old Korg M1 for a keyboard and have a Nektar T6 coming early next week. In the mean time, I'm trying to understand how to get Reaper to detect Kontakt Player's keyswitches.

I can PLAY the keyswitches and they work in real time, but they are not detected if I write them in the piano roll of Reaper. Is there something I have to turn on in Reaper? Or is something not turned on in Kontakt? The samples play fine - I just can't get anything other than the volume and the notes themselves to record.

Also, I'm working with "Emotional Cello" in Kontakt Player. Some of the keyswitches occur at B-1 down to G#-1. My 88 key keyboard doesn't go that low. WTF?!? I can't find how to transpose the notes in Reaper down that far - they stop at C-1 and won't go lower. The notes I have recorded seem to correspond to the proper places on the keyboard, so I don't need to transpose them down or up. I don't know what to do.


Can anyone help with these problems?!?!
changeng is offline   Reply With Quote
Old 10-09-2019, 11:37 PM   #2
changeng
Human being with feelings
 
Join Date: Sep 2010
Posts: 72
Default

OKAY! So I got the piano roll to work - Kontakt put the keyswitches an octave below where they show on Reaper - so yay!

For anyone with a similar problem, once you have that figured out, you may want to label the piano roll notes - open the piano roll, double right click each key that you have identified through Kontakt. Once you have labeled each key, go to File, click on Note/CC Names, click on Save Note/CC Names to File, title it and hit save. Now you can call this configuration out whenever you need it once the piano roll is open.
changeng is offline   Reply With Quote
Old 10-10-2019, 12:04 AM   #3
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,317
Default

Set the MIDI octave name offset to -1 in Reaper's Preferences->Media->MIDI. Reaper uses C4 by default for middle C, but Kontakt uses C3.

No need to use named notes for this.
EvilDragon is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:14 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.