Old 03-02-2021, 08:33 AM   #1
FEF
Human being with feelings
 
Join Date: Mar 2019
Posts: 10
Default Alt+Mousewheel does not reset (Solved, but not)

I have Alt+Mousewheel set to scroll horizontally in the main and MIDI windows, I'm not sure if I made the action or it's stock and I'm not sure if this has anything to do with this behavior. All the odd behavior appears to boil down to these actions.

Odd thing #1
- Click anywhere in the main window. The mouse wheel will zoom the tracks in and out.
- Press and release the Alt key. The mouse wheel does not zoom in and out.
- Press and release the Alt key. The mouse wheel functions as designed.

Odd thing #2
- Click anywhere in the main window. The mouse wheel will zoom the tracks in and out.
- Press and release the Alt key. The mouse wheel does not zoom in and out.
- Alt-Tab to a different window then Alt-Tab back to Reaper. The mouse wheel functions as designed.

I've always had Alt key reset problems, but it's more frustrating now since I'm doing more audio editing. I do not have this issue editing MIDI.

Win 10 is up to date and I'm running the latest rev of Reaper.

I hope this is a quick fix. It's absolutely frustrating.

Last edited by FEF; 03-10-2021 at 07:26 AM.
FEF is offline   Reply With Quote
Old 03-10-2021, 08:06 AM   #2
FEF
Human being with feelings
 
Join Date: Mar 2019
Posts: 10
Default

This is a MS Windows behavior thing that I can't find a resolution for. Unknown to me (I feel kinda stupid), when you hit the Alt key once it activates the menu function. It appears that the mouse wheel is not seen like a keystroke. As a result, MS Windows thinks you have not pressed a key and latches the menu function until the Alt key is pressed again.

The only fix that I can find is to use AutoHotKey script that I found when searching for 'disable alone alt key'.

Sorry for wasting your time.
FEF is offline   Reply With Quote
Old 03-10-2021, 10:50 AM   #3
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 2,322
Default

If ALT key causes problem maybe try to disable it in Preferences?,..

Edgemeal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.