Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for macOS X

Reply
 
Thread Tools Display Modes
Old 09-20-2018, 08:45 AM   #1
Vathek
Human being with feelings
 
Vathek's Avatar
 
Join Date: Jul 2009
Posts: 9
Default Reaper64 crashes after about 5 seconds (empty project)

I haven't used Reaper much the last couple of years, but at this point need to do some multichannel stuff, so I installed it again and I can't get it running. It always quits/crashes after about 5 seconds without anything loaded.

The computer is a otherwise stable High Sierra hackintosh, running Bitwig, Studio One and various video stuff without issues.

Reaper doesn't crash with macOS offering me to view a crash report, it just goes poof. What's the proper way to look into this? Where do I find (crash) logs? Or is there a way to start Reaper without any plugins for example? Thanks!
Vathek is offline   Reply With Quote
Old 09-20-2018, 09:11 AM   #2
cyrano
Human being with feelings
 
cyrano's Avatar
 
Join Date: Jun 2011
Location: Belgium
Posts: 3,174
Default

There's a program for all things logged. It's in Appliactions/Utilities and it's called Console.

Have a look. In the left pane, you can select the kind of logs you want to see.
__________________
“Political correctness is fascism pretending to be manners.” George Carlin
cyrano is offline   Reply With Quote
Old 09-20-2018, 09:21 AM   #3
Vathek
Human being with feelings
 
Vathek's Avatar
 
Join Date: Jul 2009
Posts: 9
Default

Ah, learn something new everyday, thanks!

This is what it says in Console:

Sep 20 16:44:19 Vatheks-iMac REAPER[833]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Sep 20 16:44:35 Vatheks-iMac com.apple.xpc.launchd[1] (com.cockos.reaper.3200[833]): Service exited due to SIGPIPE | sent by REAPER[833]

and various times for different content in the Plugins folder:

Non-fatal error enumerating at <private>, continuing: Error Domain=NSCocoaErrorDomain Code=260 "The file “PlugIns” couldn’t be opened because there is no such file." UserInfo={NSURL=PlugIns/ -- file:///Applications/REAPER64.app/Contents/Plugins/reaper_host_x86_64.app/Contents/, NSFilePath=/Applications/REAPER64.app/Contents/Plugins/reaper_host_x86_64.app/Contents/PlugIns, NSUnderlyingError=0x7f8b93d161a0 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}

Last edited by Vathek; 09-20-2018 at 09:36 AM.
Vathek is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:14 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.