Old 09-25-2021, 07:22 AM   #241
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

EuCon Exp.zip

Possible fix for Windows Track colours.
I'm not sure if I'm noticing any change. Orange in Reaper is blue on Avid Control (iOS), Blue in Reaper is orange on Avid Control. Dark blue is dark orange. Purple is kind of pink (maybe close enough).

Quote:
Originally Posted by Geoff Waddington View Post
First cut at Auto-manage Track Count.

[Edit] -- removed the 64 Channel minimum, no longer needed :
Over here, performance took a hit in small projects compared to even the last build.

Example: if I Ctr+T to insert a bunch of tracks at once (like if I were creating 10 audio channels to get ready to mic up some drums), Reaper hangs for a second or two, and the surface takes a few seconds to rebuild. In the prior build with the minimum, projects under 64 tracks were instantly built. No hanging in Reaper or on the surface.

Hopefully the performance can be improved upon, but at the moment, the builds with .ini were much better from a performance perspective. They were instantaneous. This build feels like a faster version of the old Eucon plugin in that there's a bit of lag that occurs with each change to the channel count. I'd say 2 seconds for the surface to rebuild for a single track, a little more if you do the Ctrl+T shortcut to input a bunch at once. So it's not as bad as the old plugin, but still noticeable. Whereas the .ini version was instantaneous up until the max channel count in the .ini.
Funkybot is offline   Reply With Quote
Old 09-25-2021, 07:25 AM   #242
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Also, closing the project and going to a blank project didn't reset the surface at all. It's still showing the faders and channels from the prior project. Both on the Artist Mix and the Avid Control app.
Funkybot is offline   Reply With Quote
Old 09-25-2021, 08:40 AM   #243
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Funkybot View Post
Also, closing the project and going to a blank project didn't reset the surface at all. It's still showing the faders and channels from the prior project. Both on the Artist Mix and the Avid Control app.
Thanks, yeah, haven't done that bit yet, obviously
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 08:48 AM   #244
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Funkybot View Post
Over here, performance took a hit in small projects compared to even the last build.

Example: if I Ctr+T to insert a bunch of tracks at once (like if I were creating 10 audio channels to get ready to mic up some drums), Reaper hangs for a second or two, and the surface takes a few seconds to rebuild. In the prior build with the minimum, projects under 64 tracks were instantly built. No hanging in Reaper or on the surface.

Hopefully the performance can be improved upon, but at the moment, the builds with .ini were much better from a performance perspective. They were instantaneous. This build feels like a faster version of the old EuCon plugin in that there's a bit of lag that occurs with each change to the channel count. I'd say 2 seconds for the surface to rebuild for a single track, a little more if you do the Ctrl+T shortcut to input a bunch at once. So it's not as bad as the old plugin, but still noticeable. Whereas the .ini version was instantaneous up until the max channel count in the .ini.
Well, performance didn't really take a hit, you just didn't notice the lag building the initial 64 Channels at Reaper load

The new way, if you add a Track or Tracks, it takes time proportional to the number of Tracks you add.

The 64 track minimum seems about right for the default size for you, but I don't know about other folks, some might wish for a different default size...

Maybe there's a better way...

It's really about how slow EuCon is at adding Channels, we're just trying to work around this constraint as much as possible
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 09:01 AM   #245
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Funkybot View Post
I'm not sure if I'm noticing any change. Orange in Reaper is blue on Avid Control (iOS), Blue in Reaper is orange on Avid Control. Dark blue is dark orange. Purple is kind of pink (maybe close enough).
Just checked, everything is working fine here in iOS.

Right click on TCP ->Track color->Set track to custom color.
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 09:23 AM   #246
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Same approach on how to select the colors. Here's the side by side on the colors. I believe Reaper relies on the OS color picker tool so maybe that's somehow the difference?



Funkybot is offline   Reply With Quote
Old 09-25-2021, 09:24 AM   #247
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
Thanks, yeah, haven't done that bit yet, obviously
It's also not adding tracks when I open a blank project. Only if I open an existing project. Probably also not implemented but figured I'd call it out.
Funkybot is offline   Reply With Quote
Old 09-25-2021, 09:34 AM   #248
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Funkybot View Post
Same approach on how to select the colors. Here's the side by side on the colors. I believe Reaper relies on the OS color picker tool so maybe that's somehow the difference?
Ah, got it now.

So, if you are on Windows and set a Track colour, it displays incorrectly on Artist and iOS devices -- finally clicked

OK, so a Windows platform difference I must take into account
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 09:35 AM   #249
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Funkybot View Post
It's also not adding tracks when I open a blank project. Only if I open an existing project. Probably also not implemented but figured I'd call it out.
Cool, thanks.
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 09:35 AM   #250
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
Well, performance didn't really take a hit, you just didn't notice the lag building the initial 64 Channels at Reaper load

The new way, if you add a Track or Tracks, it takes time proportional to the number of Tracks you add.

The 64 track minimum seems about right for the default size for you, but I don't know about other folks, some might wish for a different default size...

Maybe there's a better way...

It's really about how slow EuCon is at adding Channels, we're just trying to work around this constraint as much as possible
Did anyone complain about the 64? Are you thinking it was too high or too low. My normal projects might get into the low 40s, but I'm not doing film scores or video games or huge pop productions. So I'm sure folks use more, but I'd venture to guess the majority of folks use fewer.

I liked your original idea of taking 10% of current channel count and pre-creating those when combined with the 64 channel minimum.

As I understood it, that would've worked as such:

1. If you open a project with 200 tracks, because this exceeds the 64 minimum, the Eucon channel count would be set to 220 (200+10%) behind the scenes. So you can add 20 tracks before any rebuilds. No input needed from user, no .ini file. Might be a bit slow, but it's all happening on project load while your plugins, sample libraries, etc. are all loading too so users may not even notice.

2A. Instead, if you open an empty project or a project with say 48 tracks, Eucon would load a minimum of 64. Eucon won't do any rebuilding until you create the 65th track. When it creates the 65th track, it's actually also creating 6 or 7 additional channels behind the scenes (depending on whether you round down or up). Let's say you're rounding up, that means adding track 65 would build channels behind the scenes for tracks 65-71.

2B. That means could add another 6 on top of that before another rebuild occurs.
Funkybot is offline   Reply With Quote
Old 09-25-2021, 09:36 AM   #251
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
Ah, got it now.

So, if you are on Windows and set a Track colour, it displays incorrectly on Artist and iOS devices -- finally clicked

OK, so a Windows platform difference I must take into account
You got it! I should've just posted screen prints weeks ago!
Funkybot is offline   Reply With Quote
Old 09-25-2021, 10:42 AM   #252
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

New build is up.

EuCon Exp.zip

Possible fix for Track color issue.

Default is back to 64 Channels.

Adding 10% is tricker than it looks -- for now let's let the user decide whether they want to add by blocks of one, 8, 50... whatever suits them.
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 11:06 AM   #253
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post

Possible fix for Track color issue.
Confirming the fix. That was quick!

Quote:
Originally Posted by Geoff Waddington View Post
Default is back to 64 Channels.

Adding 10% is tricker than it looks -- for now let's let the user decide whether they want to add by blocks of one, 8, 50... whatever suits them.
The first 64 channels are back to working great. I like the idea of letting the users decide how many to build but does that mean the return of the .ini? Note: I didn't have a problem with the .ini so I'd be good with that.
Funkybot is offline   Reply With Quote
Old 09-25-2021, 11:26 AM   #254
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Funkybot View Post
Confirming the fix. That was quick!
After I finally understood the problem

Quote:
Originally Posted by Funkybot View Post
The first 64 channels are back to working great. I like the idea of letting the users decide how many to build but does that mean the return of the .ini? Note: I didn't have a problem with the .ini so I'd be good with that.
No, I'm saying the default is again 64, unless the project is larger.

Once you are in a project, it's up to you how you do Track management.

So, for some workflows, you might choose to add 10 Tracks, when you only need one.

Others might add in blocks of 4, whatever you fancy.

This way, once you pass the default 64, the Track counts in EuCon and Reaper agree -- no blank EuCon Channels hanging off the end of the project due to auto allocation
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 11:39 AM   #255
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 998
Default

Just announcing my presence here. I downloaded the control app and got it up and running. Really slick so far, Geoff!

The control app is great. I'm trying to borrow (read: steal) as much as I can from it to put into my OSC layout.
cjewellstudios is offline   Reply With Quote
Old 09-25-2021, 11:52 AM   #256
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
After I finally understood the problem



No, I'm saying the default is again 64, unless the project is larger.

Once you are in a project, it's up to you how you do Track management.

So, for some workflows, you might choose to add 10 Tracks, when you only need one.

Others might add in blocks of 4, whatever you fancy.

This way, once you pass the default 64, the Track counts in EuCon and Reaper agree -- no blank EuCon Channels hanging off the end of the project due to auto allocation
Makes sense. And works for me!

Thanks!
Funkybot is offline   Reply With Quote
Old 09-25-2021, 12:34 PM   #257
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

OK, probably going to head back over to CSI land for a bit, is there anything else urgent here besides FX (which requires more thought/work on my end) ?
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 01:32 PM   #258
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
OK, probably going to head back over to CSI land for a bit, is there anything else urgent here besides FX (which requires more thought/work on my end) ?
Prior to switching back to CSI would it be possible to fix the issues around: 1) blank project and adding tracks doesn't work, 2) closing a project with tracks doesn't reset the channels?

Otherwise, I can always rollback a few versions for now.
Funkybot is offline   Reply With Quote
Old 09-25-2021, 02:07 PM   #259
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

New build is up.

EuCon Exp.zip

Fix for adding Tracks to blank project.
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 02:08 PM   #260
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Funkybot View Post
Prior to switching back to CSI would it be possible to fix the issues around: 1) blank project and adding tracks doesn't work, 2) closing a project with tracks doesn't reset the channels?

Otherwise, I can always rollback a few versions for now.
Closing projects seems to work fine here, could you please recheck with the latest build.
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 02:20 PM   #261
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
Closing projects seems to work fine here, could you please recheck with the latest build.
Adding to a blank project works in the latest build. Closing a project still does not.

Try this:

1. Open Reaper
2. Load a saved project with a lot of tracks
3. Click play to begin playback (not necessary but has an interesting effect later on)
4. Click File -> Close Project (this should drop you off in an empty project)

Result: all the channel faders and names from the prior project are still mapped on the surface. If you were in the middle of playback (as in step 3) when the project was closed, the meters stay frozen too! Happens on the hardware and Avid Control app.

Expected Result: surface should be in an initialized state.
Funkybot is offline   Reply With Quote
Old 09-25-2021, 02:50 PM   #262
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

New build is up.

EuCon Exp.zip

Possible fix for surface not clearing if you close the project but do not exit Reaper.
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-25-2021, 07:11 PM   #263
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

EuCon Exp.zip

Possible fix for surface not clearing if you close the project but do not exit Reaper.
Thanks for all the builds today! Was out earlier but just gave this a go. Progress, but not quite 100%.

Here's what happens.

1. Start Reaper with an empty project
2. Add tracks, everything's ok so far
3. Open a saved project with tracks, track colors, etc., play around, things work
4. Now, go to File -> Close Project

Result: project closes, Artist Mix hardware completely clears (progress)! Avid Control (iOS) Mixer page still shows the track colors from the previous project, and the little horizontal thumbnail overview at the top still shows the tracks from the prior project. So the Avid Control app has not fully cleared.

5. Next, in your new empty project, hit Ctrl+T to insert a new track

Result: Reaper crashes. Happens every time here following the above procedure.
Funkybot is offline   Reply With Quote
Old 09-27-2021, 09:03 AM   #264
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Funkybot View Post
Thanks for all the builds today! Was out earlier but just gave this a go. Progress, but not quite 100%.

Here's what happens.

1. Start Reaper with an empty project
2. Add tracks, everything's ok so far
3. Open a saved project with tracks, track colors, etc., play around, things work
4. Now, go to File -> Close Project

Result: project closes, Artist Mix hardware completely clears (progress)! Avid Control (iOS) Mixer page still shows the track colors from the previous project, and the little horizontal thumbnail overview at the top still shows the tracks from the prior project. So the Avid Control app has not fully cleared.

5. Next, in your new empty project, hit Ctrl+T to insert a new track

Result: Reaper crashes. Happens every time here following the above procedure.
Uggh, yeah, the problem is I can't find a reliable way to determine when the project is closed

Kinda' like the Focused FX thing, but more lethal

There is a cheesy workaround (I know, I know, lame) until we can sort this.

After you close a project, make sure you load another or select "New" from the menu before you add tracks, then things work as they should.

If anyone knows of a way to determine when a project closes. I'm all ears
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-27-2021, 03:32 PM   #265
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

New build is up.

EuCon Exp.zip

Fix for nasty crash.

Anything else before I head back over to the OSC/Midi side for a while ?

PS: I know the FX work is still outstanding.
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 09-27-2021, 05:36 PM   #266
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

EuCon Exp.zip

Fix for nasty crash.

Anything else before I head back over to the OSC/Midi side for a while ?

PS: I know the FX work is still outstanding.
Crash resolved. Thank you sir!

One small thing that can wait until the next time you're back in Eucon-ville: if you close a project and go to a new project, the channel colors on the Avid Control app (iOS) don't clear and the channel thumbnails remain on the top navigator. Very minor thing. Thanks again!
Funkybot is offline   Reply With Quote
Old 09-27-2021, 05:51 PM   #267
Old School Audio Guy
Human being with feelings
 
Join Date: Aug 2013
Location: Mesa, AZ
Posts: 288
Default new eucon project

Hi Geoff
Just loaded in the new Eucon build
All is working fine so far
I will let you know if there are other issues
Faders zero out when Project is closed
I still have not tried the Masterfader workaround
But I will this last week was crazy where I live
tons of construction I wound up sleeping most of the weekend
Being woke up at 5 am from construction noise took its toll
I was really tired
Thanks for the update Yeah so far I don't have to restart Eucon apps when I open reaper Kudos!!!
I will let you know about the master fader workaround I have to set it up
in the current project.
Again Kudos
Cheers
Perry
Old School Audio Guy is offline   Reply With Quote
Old 09-27-2021, 06:37 PM   #268
Old School Audio Guy
Human being with feelings
 
Join Date: Aug 2013
Location: Mesa, AZ
Posts: 288
Default new eucon project

Hi Geoff
That worked just fine to control the master fader
I have 2 mixers so I used Track 9 to control Master
One thing I have noticed is that both track 9 and the Master have to be selected
for it to work this is the only way I can get it to work.
Is there a way to have this control without having to select both track?
Thanks
Perry
Old School Audio Guy is offline   Reply With Quote
Old 09-27-2021, 07:15 PM   #269
Old School Audio Guy
Human being with feelings
 
Join Date: Aug 2013
Location: Mesa, AZ
Posts: 288
Default new eucon project

HI Geoff
I have it working fine with both tracks selected and track grouping turned off
I guess this is track ganging
Track grouping gets a bit weird channels I have not selected are being controlled
that I did not select. And How do you remove tracks from a group?
This doesn't seem to be remembered when you shut down Reaper the open reaper again
I'll go thru the procedure again and see what happens Ganging seems to work fine but I have to set this every time I boot reaper. I guess I have missed something
This will work for now. Just wish it would be remembered when I save and quit
Cheers
Perry
Old School Audio Guy is offline   Reply With Quote
Old 09-27-2021, 07:31 PM   #270
Old School Audio Guy
Human being with feelings
 
Join Date: Aug 2013
Location: Mesa, AZ
Posts: 288
Default

Quote:
Originally Posted by Geoff Waddington View Post
Think there is a reasonable workaround here:

You can use Reaper Groups to create an alias for the Master.

Check this video, right at the beginning: https://www.youtube.com/watch?v=3tmI88BKnb8

Let's say you have an 8 Channel surface and you want the Master to be rightmost.

Insert a blank Track in Reaper on Track 8.

Using Groups, tie Track 8 directly to the Master, they will now move in unison.

Now, using the EuControl app, Assign Channel 8 to Track 8 -- now the Master will not move, it will always be Channel 8.

It's actually a lot easier to do than explain
I am still having some issues with grouping I need to read more about it
When I turn on Track grouping other tracks I did not assign as you suggested I can get it to do what I want by selecting both tracks in the mixer
I chose fader 16 to group to the Master but when I assign track 16 to Track grouping some weird stuff happens on other tracks so I will use the track selection for now till there is a better way
Thanks
Perry

Last edited by Old School Audio Guy; 09-27-2021 at 07:32 PM. Reason: Needed to add a line
Old School Audio Guy is offline   Reply With Quote
Old 09-28-2021, 12:17 PM   #271
Old School Audio Guy
Human being with feelings
 
Join Date: Aug 2013
Location: Mesa, AZ
Posts: 288
Default new eucon project

Quote:
Originally Posted by Geoff Waddington View Post
Sorry I missed this !

Glad to hear things are generally running well.

Haven't started development on the Jog Wheel yet.

Don't have any touchscreen files, maybe someone else out there?
Hi Geoff
Great work on the new Eucon files
I turned on my workstation just now and booted up reaper and
low and behold the Artist series changed over to Reaper without
me having to restart Eucon applications.!!
A major step forward!
Kudos Geoff!! can't wait for the jog wheel to get implemented
I haven't found anyone that is willing to share their Eucon Touchscreen files
Yet I will probably have to do them all myself but no problem I am very up on writing Them Just working on the File Hierarchy so I can get the most menus out of the process.
Thanks again
Cheers
Perry
Old School Audio Guy is offline   Reply With Quote
Old 09-28-2021, 01:16 PM   #272
Funkybot
Human being with feelings
 
Funkybot's Avatar
 
Join Date: Jul 2007
Location: New Joisey
Posts: 6,068
Default

Quote:
Originally Posted by Old School Audio Guy View Post
Hi Geoff
Great work on the new Eucon files
I turned on my workstation just now and booted up reaper and
low and behold the Artist series changed over to Reaper without
me having to restart Eucon applications.!!
A major step forward!
Kudos Geoff!! can't wait for the jog wheel to get implemented
I haven't found anyone that is willing to share their Eucon Touchscreen files
Yet I will probably have to do them all myself but no problem I am very up on writing Them Just working on the File Hierarchy so I can get the most menus out of the process.
Thanks again
Cheers
Perry
Don't be discouraged. I suspect no one's put together a set of files yet with everything being so new! I started doing one just to test it out, but the only buttons I assigned were grid divisions and screensets, and only on the Soft Keys screen of the Avid Control app.

I've just got a lowly Artist Mix, and I only use the Avid Control app for testing. When I'm actually working, my tablet is dedicated to FX control via CSI+OSC, not Eucon.
Funkybot is offline   Reply With Quote
Old 09-29-2021, 12:29 AM   #273
Old School Audio Guy
Human being with feelings
 
Join Date: Aug 2013
Location: Mesa, AZ
Posts: 288
Default

Quote:
Originally Posted by Funkybot View Post
Don't be discouraged. I suspect no one's put together a set of files yet with everything being so new! I started doing one just to test it out, but the only buttons I assigned were grid divisions and screensets, and only on the Soft Keys screen of the Avid Control app.

I've just got a lowly Artist Mix, and I only use the Avid Control app for testing. When I'm actually working, my tablet is dedicated to FX control via CSI+OSC, not Eucon.
HI Funky
I'm not discouraged I'm glad it works now. I have 3 mixers and 1 control
2 of the mixers I have to send to LA for repair so I am just working out the menus
on paper before I start writing Softkeys for the control touchscreen.
I have been battling problems with my left eye all day. Feels like someone poured a 90 lb bag of cement in it and I've gone thru 3 bottles of eye drops ARRRG!
Hope tomorrow is better. When I finish writing the softkeys I will post it so everyone can use them and modify to their workflow. I know it's new and not everyone uses these control surfaces. So I'm not surprised I have not gotten any replys to my request for them. Thanks again for all your help with getting Eucon up and running with me. Things would go faster if I could see better. Tomorrow is another day. I want to pack up the two mixers so I can send them out when I get my Social Security payment.
I had been using my Android tablet when I was using Studio one V5 but I like faders and knobs, Just how I learned from back in the 70's till 2005 at my last paying job at The Plant Studios in Sausalito. It will all come together soon I hope I just want to start working again on music, I've spent so much time with software and fixing hardware, it's time to get back to work.
Cheers
Perry
Old School Audio Guy is offline   Reply With Quote
Old 09-29-2021, 11:21 PM   #274
oval
Human being with feelings
 
Join Date: Aug 2018
Posts: 17
Default Most functions working well

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

EuCon Exp.zip

Fix for nasty crash.

Anything else before I head back over to the OSC/Midi side for a while ?

PS: I know the FX work is still outstanding.
Hi!
I have been following the CSI and EuCon thread for a few weeks. I have some midi controllers, Mackie MC pro and Behringer X-touch-one which I have used most for a while with Reaper's built-in Mackie drivers. Now I'm building a new studio, so I found two old controllers that I have not used in many years, Radical SAC 2K and Euphonix MC controller. Put them at the kitchen table and found them really useful with CSI (some zone editing) for the Radical controller, and "New Eucon libs" for MC control. Hope my new studio is up and running before December, and then I will use the CSI end EuCon so I can customize my controllers. I will test and maybe give some feedback on the EuCon development when I do not use the kitchen for cooking.
Great job Geoff

Olav
oval is offline   Reply With Quote
Old 10-01-2021, 10:28 AM   #275
Berg
Human being with feelings
 
Join Date: Jul 2014
Location: Rennes, FR
Posts: 201
Default colors Avid Control Mac Catalina with eucon vers 27th of sept

Hi there,
I can see something weired when using different tracks visibility settings between edit and mix windows in track manager. Avid control gives us the correct tracks on the mixer but not the correct colors, it seems to give us the colors of the edit window visible tracks but we would like it to show us mixer visible tracks colors if I am correct...I hope I am clear...Any idea about that ? Or maybe there is an option in Avid Control?
Berg is offline   Reply With Quote
Old 10-01-2021, 03:26 PM   #276
RobinGShore
Human being with feelings
 
Join Date: May 2013
Location: New York
Posts: 788
Default

Just tried the latest build after being away for a few weeks. The dynamic track count handling is nice, but I'm seeing some problems with it when you start adding tracks past the 64 track default. It all works fine if I add new tracks after the last track, but if I add new tracks somewhere in the middle of the tracklist things get a little screwy.

Say I have a project with 64 tracks named 1A,2A,3A... up through 64A. If I add a new track between 1A and 2A and name it 1B, the new track gets added on my S1 conrrectly, but not in the app, instead of the new track 1B being inserted between 1A and 2A in the app, it replaces 2A, and a duplicate of the final track is added to the very end of the list, so the app now no longer show a track with the name 2A and shows two tracks named 64A. Hopefully that's not too confusing, let me know if it would help to make a video demonstrating the issue.
RobinGShore is offline   Reply With Quote
Old 10-01-2021, 03:27 PM   #277
RobinGShore
Human being with feelings
 
Join Date: May 2013
Location: New York
Posts: 788
Default

Quote:
Originally Posted by Berg View Post
Hi there,
I can see something weired when using different tracks visibility settings between edit and mix windows in track manager. Avid control gives us the correct tracks on the mixer but not the correct colors, it seems to give us the colors of the edit window visible tracks but we would like it to show us mixer visible tracks colors if I am correct...I hope I am clear...Any idea about that ? Or maybe there is an option in Avid Control?
I'm seeing the same thing as well, colors are not updating when tracks get hidden from eucon
RobinGShore is offline   Reply With Quote
Old 10-01-2021, 03:54 PM   #278
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by Berg View Post
Hi there,
I can see something weired when using different tracks visibility settings between edit and mix windows in track manager. Avid control gives us the correct tracks on the mixer but not the correct colors, it seems to give us the colors of the edit window visible tracks but we would like it to show us mixer visible tracks colors if I am correct...I hope I am clear...Any idea about that ? Or maybe there is an option in Avid Control?
Thanks for testing, will investigate.
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 10-01-2021, 04:00 PM   #279
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 11,444
Default

Quote:
Originally Posted by RobinGShore View Post
Just tried the latest build after being away for a few weeks. The dynamic track count handling is nice, but I'm seeing some problems with it when you start adding tracks past the 64 track default. It all works fine if I add new tracks after the last track, but if I add new tracks somewhere in the middle of the tracklist things get a little screwy.

Say I have a project with 64 tracks named 1A,2A,3A... up through 64A. If I add a new track between 1A and 2A and name it 1B, the new track gets added on my S1 conrrectly, but not in the app, instead of the new track 1B being inserted between 1A and 2A in the app, it replaces 2A, and a duplicate of the final track is added to the very end of the list, so the app now no longer show a track with the name 2A and shows two tracks named 64A. Hopefully that's not too confusing, let me know if it would help to make a video demonstrating the issue.
Well, if the S1 does one thing and the app does another, that is a EuCon bug.

Reaper/EuCon just sends the info -- it appears there is a discrepancy in how it is handled by the 2 devices in EuCon land.


However, we will have to work around it.

The simplest way is going back to a one entry EuCon.ini file -- number of EuCon Channels.

Anyone got anything better ?
__________________
To install you need the CSI Software and Support Files
For installation instructions and documentation see the Wiki
Donate -- via PayPal to waddingtongeoff@gmail.com
Geoff Waddington is offline   Reply With Quote
Old 10-01-2021, 05:17 PM   #280
RobinGShore
Human being with feelings
 
Join Date: May 2013
Location: New York
Posts: 788
Default

Quote:
Originally Posted by Geoff Waddington View Post
Well, if the S1 does one thing and the app does another, that is a EuCon bug.

Reaper/EuCon just sends the info -- it appears there is a discrepancy in how it is handled by the 2 devices in EuCon land.


However, we will have to work around it.

The simplest way is going back to a one entry EuCon.ini file -- number of EuCon Channels.

Anyone got anything better ?
That all makes sense, I don't think having to set the number of channels is much of a hassle if that's what it takes to make it work well.

Something I'm noticing now though is that if, after adding the new track, I switch project tabs and then switch back to the initial project, the app corrects itself. If there's a way to force eucon to reload the project when adding new tracks the same way it does when switching tabs maybe that could also fix things?

Last edited by RobinGShore; 10-01-2021 at 06:40 PM.
RobinGShore is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:42 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.