Old 10-22-2018, 04:05 AM   #1
gimbo_fede
Human being with feelings
 
Join Date: Sep 2018
Posts: 4
Default ASIO4ALL Latenza

Buongiorno a tutti,

sto provando a registrare dei video con OBS di alcune sessioni di mixing in Reaper, magari per poter lavorare a distanza con amici e colleghi. Ovviamente, per fare ciò ho dovuto installare gli ASIO4ALL, così da poter impostare più output nella sessione. Quindi come uscite nella sessione ho:

1. La mia scheda audio (Focusrite Scarlett 18i8) come uscita principale per le mie cuffie.
2. Il mixer virtuale VoiceMeeter che manda lo stesso segnale di output a Virtual Audio Cable per poi entrare dentro OBS.

Sono riuscito a far funzionare tutto finché mando in playback il lavoro. Però, nel momento in cui vado a registrare si avverte una latenza impressionante, da non poter suonare proprio. Nonostante abbia reinstallato i driver, nonostante sia stato molto attento al Buffer Size, la latenza non accenna a diminuire. In qualsiasi sessione io lavori con i driver asio4all e la mia scheda Focusrite c'è questo problema. Mentre se uso i driver focusrite funziona tutto correttamente.
Sapete dirmi cos'è? Quasi totale incompatibilità tra asio4all e focusrite o un problema di impostazioni asio?

Grazie.
gimbo_fede is offline   Reply With Quote
Old 10-22-2018, 05:16 AM   #2
DaveKeehl
Human being with feelings
 
DaveKeehl's Avatar
 
Join Date: Nov 2015
Location: Switzerland
Posts: 1,652
Default

Io questa cosa l'ho fatta semplicemente usando voicemeeter come punto centrale per tutto l'audio del mio computer, senza usare ne asio4all o altri driver
__________________
My band: Spotify | iTunes | YouTube | Bandcamp | Amazon | Google Play
YouTube Channel: https://www.youtube.com/channel/UClI...NKp8d-lsUKRu2Q
REAPER Contest: Website | Donations | YouTube
DaveKeehl is offline   Reply With Quote
Old 10-22-2018, 09:36 AM   #3
gimbo_fede
Human being with feelings
 
Join Date: Sep 2018
Posts: 4
Default

Ti ringrazio. Riesci a spiegarmi il routing del segnale? Sto addirittura provando ad utilizzare Rearoute per entrare in Voicemeeter ma nonostante lo abbiamo installato correttamente (64bit) non mi trova i driver ASIO.
gimbo_fede is offline   Reply With Quote
Old 10-22-2018, 10:45 AM   #4
DaveKeehl
Human being with feelings
 
DaveKeehl's Avatar
 
Join Date: Nov 2015
Location: Switzerland
Posts: 1,652
Default

Premettendo che sono su Windows 10, nel pannello di controllo della riproduzione audio di Windows ho impostato "VoiceMeeter Aux Input" dispositivo predefinito.
Dentro Reaper ho messo ASIO > Voicemeeter Virtual ASIO.
Poi ovviamente devi scegliere le schede audio di ascolto in voicemeeter, se no non senti una mazza.

Se segui questi due passi dovresti essere in grado di usare voicemeeter banana come mixer per tutto l'audio del tuo pc.

Poi per OBS devi mettere "VoiceMeeter Output" come Mic/Auxiliary Audio Device (spero funzionino perché è abbastanza che non uso OBS).

Fammi sapere se va!
__________________
My band: Spotify | iTunes | YouTube | Bandcamp | Amazon | Google Play
YouTube Channel: https://www.youtube.com/channel/UClI...NKp8d-lsUKRu2Q
REAPER Contest: Website | Donations | YouTube
DaveKeehl is offline   Reply With Quote
Old 10-22-2018, 10:46 AM   #5
DaveKeehl
Human being with feelings
 
DaveKeehl's Avatar
 
Join Date: Nov 2015
Location: Switzerland
Posts: 1,652
Default

Ovviamente se vuoi usare un microfono collegato alla tua scheda audio devi sceglierlo come input in voicemeeter
__________________
My band: Spotify | iTunes | YouTube | Bandcamp | Amazon | Google Play
YouTube Channel: https://www.youtube.com/channel/UClI...NKp8d-lsUKRu2Q
REAPER Contest: Website | Donations | YouTube
DaveKeehl is offline   Reply With Quote
Old 10-22-2018, 03:35 PM   #6
gimbo_fede
Human being with feelings
 
Join Date: Sep 2018
Posts: 4
Default

Grazie mille sono riuscito a risolvere nel modo che mi hai spiegato. La latenza è rimasta ma è comunque diminuita. Ad ogni modo questo sistema è molto più stabile degli ASIO4ALL che con focusrite funzionano malissimo.

Buona musica DaveKeehl
gimbo_fede is offline   Reply With Quote
Old 10-22-2018, 05:21 PM   #7
DaveKeehl
Human being with feelings
 
DaveKeehl's Avatar
 
Join Date: Nov 2015
Location: Switzerland
Posts: 1,652
Default

Per la latenza quando voglio ascoltarmi uso semplicemente il direct monitoring della scheda audio invece di quello di voicemeeter
__________________
My band: Spotify | iTunes | YouTube | Bandcamp | Amazon | Google Play
YouTube Channel: https://www.youtube.com/channel/UClI...NKp8d-lsUKRu2Q
REAPER Contest: Website | Donations | YouTube
DaveKeehl is offline   Reply With Quote
Old 10-22-2018, 05:54 PM   #8
gimbo_fede
Human being with feelings
 
Join Date: Sep 2018
Posts: 4
Default

Sí, anche io, il problema sta quando faccio le chitarre con i plug in di simulazione Amp e cabinet. Ma alla fine registro al volo la traccia in direct e poi ci metto il plug in.
Grazie ancora
gimbo_fede is offline   Reply With Quote
Old 10-27-2018, 05:58 AM   #9
maver
Human being with feelings
 
Join Date: Feb 2018
Posts: 17
Default

fate attenzione che i driver focursite vanno istallati PRIMA degli asio4all
altrimenti il sistema ha qualche inghippo.
questo problema e' stato inoltrato e verificato dalla focursite che ha ammesso il problema che ho lamentato.
risolto con questo semplice accorgimento.
maver is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.