Old 04-18-2023, 07:01 AM   #1
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,712
Default MIDI file: last tick ommited

Hello,

I have a MIDI file type 1 which has no error in the code (see pic 1): the last note lasts 120 ticks (a 1/16th note, because PPQ = 480).

But when imported in REAPER, when I zoom at the maximum, I can see that it misses one tick to the note. It does end at the next bar, but exactly a tick before (see pic 2).

Can you confirm the bug?

EDIT: MIDI file included
Attached Images
File Type: png pic 1.png (91.6 KB, 131 views)
File Type: png pic 2.png (8.5 KB, 141 views)
Attached Files
File Type: mid groove_01 (last tick).mid (260 Bytes, 116 views)

Last edited by creal; 04-18-2023 at 07:28 AM.
creal is offline   Reply With Quote
Old 04-18-2023, 07:15 AM   #2
dangguidan
Human being with feelings
 
Join Date: Jan 2019
Location: China
Posts: 688
Default

The starting position of the MIDI item has slightly shifted.
dangguidan is offline   Reply With Quote
Old 04-18-2023, 07:27 AM   #3
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,712
Default

Quote:
Originally Posted by dangguidan View Post
The starting position of the MIDI item has slightly shifted.
nope, the MIDI item starts exactly at bar 1, and all other notes of the file start and end at their right points (indicated in the hexa code) ; only the last note is problematic
creal is offline   Reply With Quote
Old 04-18-2023, 07:52 AM   #4
gibi25
Human being with feelings
 
Join Date: Jan 2010
Location: France
Posts: 2,907
Default

I can see the missing tick here as well.
__________________
I'm a simple man,
so I sing a simple song.
gibi25 is online now   Reply With Quote
Old 04-18-2023, 08:57 AM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 15,866
Default

Fixing, thanks!
Justin is online now   Reply With Quote
Old 04-19-2023, 12:00 AM   #6
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,712
Default

Quote:
Originally Posted by Justin View Post
Fixing, thanks!
Thanks, Justin.
creal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:33 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.