Old 05-07-2024, 11:20 PM   #1
Amely_Suncroll
Human being with feelings
 
Amely_Suncroll's Avatar
 
Join Date: Mar 2021
Posts: 49
Default [SCRIPT] Auto Aim Midi | Item 3.0

Auto Aim Midi - glue edit cursor to start, mouse position or end of selected note or notes. Best script for working with foleys.

It has the main script and the switch scriipt.

1. Turn on main script and select midi note.
2. Switch cursor mode by calling "toggle script".
3. When you finish your work just turn off main script.

You can select more then one midi note - then edit cursor will glue to start or end of selection.

I recommend you set "toggle" script to double mouse click on midi note: Preferences - Mouse Modifiers - Context: MIDI note / double click - Default action - Action list... - and choose "Auto Aim Midi 2.0 (toggle).lua".








Auto Aim Item - an exact copy of the Auto Aim Midi script, but applied to items and also consists of two scripts - the main one and the switch. Enjoy.

When you work with version 3.0 "Two-in-one": call this script when your mouse is near the first (or last) 5% of selected item to glue edit cursor to item start (or end). Otherways edit cursor will glue to mouse position.

To change gluing type always deselect an item and then select it again.

If you have some troubles with desync video after move item, please, check your video settings head on Preferences - Video - Video window follows edits (uncheck it).









Donations are welcomed: PayPal.

This script is included to "Academic Scripts" line. You can see it here.

Thank you.



Add my repo to ReaPack:
Code:
https://raw.githubusercontent.com/AmelySuncroll/Academic-Scripts/master/index.xml
__________________
Professional music composer | Teacher | Academic Scripts | Reaper UA (telegram)

Last edited by Amely_Suncroll; 06-18-2024 at 02:23 AM. Reason: update
Amely_Suncroll is offline   Reply With Quote
Old 05-15-2024, 11:43 PM   #2
Amely_Suncroll
Human being with feelings
 
Amely_Suncroll's Avatar
 
Join Date: Mar 2021
Posts: 49
Default UPDATE UPDATE UPDATE

Update to 3.0!

Version TWO IN ONE (without startup screen):



If you work with version 3.0 "Two-in-one": call this script when your mouse is near the first (or last) 5% of selected item to glue edit cursor to item start (or end). Otherways edit cursor will glue to mouse position.
To change gluing type always deselect an item and then select it again.




Version MAIN AND TOGGLE (2.0-like version):

__________________
Professional music composer | Teacher | Academic Scripts | Reaper UA (telegram)

Last edited by Amely_Suncroll; 06-11-2024 at 01:18 PM.
Amely_Suncroll is offline   Reply With Quote
Old 06-08-2024, 10:56 AM   #3
Amely_Suncroll
Human being with feelings
 
Amely_Suncroll's Avatar
 
Join Date: Mar 2021
Posts: 49
Default

Now it is inside my repo. Enjoy!
__________________
Professional music composer | Teacher | Academic Scripts | Reaper UA (telegram)
Amely_Suncroll is offline   Reply With Quote
Old 06-11-2024, 01:08 AM   #4
lachinhan
Human being with feelings
 
lachinhan's Avatar
 
Join Date: Nov 2014
Location: Can Tho - Viet Nam
Posts: 312
Default

Oh! So many thanks
__________________
NK Recording Studio
Email: lachinhan@gmail.com or admin@thuamninhkieu.com
Website:nkpro.top and ntmusicpro.com
lachinhan is offline   Reply With Quote
Old 06-11-2024, 06:48 AM   #5
ceanganb
Human being with feelings
 
Join Date: May 2009
Location: Brazil
Posts: 345
Default

Neat! Thanks you.
__________________
Ceanganb
ceanganb is offline   Reply With Quote
Old 06-11-2024, 11:11 AM   #6
zakb
Human being with feelings
 
Join Date: Jul 2009
Posts: 10
Default

Script is very cool- though when using the script, when dragging the item to match the video track, I am getting strange offset errors where as soon as I stop dragging the item, the video playback head snaps to a different location. It's hard to put my finger on what's happening, other to say that the sync is out by at least 5 frames every time I select, drag, and release a media item. Maybe it's the video decoder causing issues? Here's the format of the video where it's happening:

Length: 0:20.283
Video: 2560x1440@59.95fps, Aspect=1.00, Decoding format=I420/YV12
Audio: 48000Hz 2ch 16bps

Using Windows Media Foundation v2 decoder for video and audio

Encoded video format: H264
Encoded audio format: AAC
zakb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:32 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.