Old 06-09-2024, 10:27 AM   #1
AudioBabble
Human being with feelings
 
AudioBabble's Avatar
 
Join Date: Dec 2021
Location: Jupiter Island
Posts: 1,104
Default Arturia V Collection?

Just wondering if anyone's had any luck getting this to work under wine?

I have installers for 8, 9 and X versions, but each time i get:



I've tried installing the MS VCREDIST package under wine, which seems to go OK and shows as installed, yet still no joy.
__________________
{Read This} | {FR - FX inserts on sends} | {latest drivel}
AudioBabble is online now   Reply With Quote
Old 06-09-2024, 10:37 AM   #2
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 9,229
Default

While it's not the V collection, I've got Arturia's MiniMoog V installed and working fine in Manjaro.

I installed it way back in 2018 when I first switched to Linux. It also worked fine in Xubuntu, which is what I was running back then.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 06-09-2024, 04:17 PM   #3
AudioBabble
Human being with feelings
 
AudioBabble's Avatar
 
Join Date: Dec 2021
Location: Jupiter Island
Posts: 1,104
Default

Thanks for that, kind of makes me wonder if the individual installers would probably be fine.

Will have to do a bit more digging into what the error actually means.
__________________
{Read This} | {FR - FX inserts on sends} | {latest drivel}
AudioBabble is online now   Reply With Quote
Old 06-10-2024, 02:43 PM   #4
unholyeyebrows
Human being with feelings
 
Join Date: Nov 2023
Posts: 16
Default

I can confirm Arturia V Collection 9 works perfectly on Ubuntu and Yabridge.
unholyeyebrows is offline   Reply With Quote
Old 06-10-2024, 04:25 PM   #5
AudioBabble
Human being with feelings
 
AudioBabble's Avatar
 
Join Date: Dec 2021
Location: Jupiter Island
Posts: 1,104
Default

Quote:
Originally Posted by unholyeyebrows View Post
I can confirm Arturia V Collection 9 works perfectly on Ubuntu and Yabridge.
It looks like you're right, thanks for that -- i tried Collection X first... no luck... Tried Collection 8... no luck, so kind of 'assumed' 9 wouldn't work.

But it seems it does!

So... no Acid V, but I guess you can't have it all.
__________________
{Read This} | {FR - FX inserts on sends} | {latest drivel}
AudioBabble is online now   Reply With Quote
Old 06-10-2024, 05:48 PM   #6
AudioBabble
Human being with feelings
 
AudioBabble's Avatar
 
Join Date: Dec 2021
Location: Jupiter Island
Posts: 1,104
Default

Good news!

After a bit of mooching around the net, I found 'winetricks' (I imagine it's probably familiar to many here).

So... looks like this is the thing to use for missing VCredist packages and the like...

anyway, here's what worked to overcome the error reported in my first post about missing 'ISSKINU.DLL'

Code:
cd ~/Downloads

wget  https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks

chmod +x winetricks

sudo apt install cabextract

sh winetricks vcrun6sp6
[you could also just run 'sh winetricks' and follow the GUI to install the relevant package, but you will need cabextract installed

now the installer works fine... and I guess I know what to do if I encounter such a problem again
__________________
{Read This} | {FR - FX inserts on sends} | {latest drivel}
AudioBabble is online now   Reply With Quote
Old 06-10-2024, 06:31 PM   #7
AudioBabble
Human being with feelings
 
AudioBabble's Avatar
 
Join Date: Dec 2021
Location: Jupiter Island
Posts: 1,104
Default

...oh yes, and...

in the interests of 'full disclosure' I did previously install 'vcredist_x64.exe' from microsoft https://learn.microsoft.com/en-us/cp...?view=msvc-170

^^with wine obviously

this didn't help at all, but thought I should mention it.
__________________
{Read This} | {FR - FX inserts on sends} | {latest drivel}
AudioBabble is online now   Reply With Quote
Old 06-11-2024, 04:19 AM   #8
AudioBabble
Human being with feelings
 
AudioBabble's Avatar
 
Join Date: Dec 2021
Location: Jupiter Island
Posts: 1,104
Default

ahh shucks!

after all that, the V Collection X installer runs fine, does everything it's supposed to... but the installed VSTs fail on scanning in Reaper. I mean, it scans them without reporting any errors, but they don't show up in the fx list and end up listed under 'plugins that failed to scan'.

Weird, but sadly true... so it's back to Collection 9 then.
__________________
{Read This} | {FR - FX inserts on sends} | {latest drivel}
AudioBabble is online now   Reply With Quote
Old 06-11-2024, 06:07 AM   #9
AudioBabble
Human being with feelings
 
AudioBabble's Avatar
 
Join Date: Dec 2021
Location: Jupiter Island
Posts: 1,104
Default

arrgh! this is getting silly...

I now realize something has gone horribly wrong somewhere along the way. Having uninstalled the non-working Collection X and tried to install Collection 9 again, i find that reaper now crashes while trying to scan those plugins!

Time to restore my OS and start from scratch... why do I do this to myself? I had Collection 9 working fine!

[UPDATE, OS backup restored, did winetricks > cvrun6sp6 as described above, installed Collection X.

now it WORKS.]
__________________
{Read This} | {FR - FX inserts on sends} | {latest drivel}

Last edited by AudioBabble; 06-11-2024 at 08:22 AM.
AudioBabble is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:02 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.