Old 01-03-2005, 11:26 PM   #1
alex_n
Human being with feelings
 
Join Date: Jan 2005
Location: b'klyn NY
Posts: 12
Default Refuses to start on linux

I have a gentoo system with a vanila 2.6.10, I have ALSA compiled in. I run udev in pure mode. Here's the error message:
Code:
alex_n@styx[~/jesusonic-0.96-preview] $ ./jesusonic -mode ALSA
JesuSonic v0.96 - Copyright (C) 2004 Cockos Incorporated
Using output mode: 'ALSA'
Opening ALSA 'hw:0,0' for read
Error setting periods.
jesusonic: pcm.c:984: snd_pcm_drop: Assertion `pcm->setup' failed.
zsh: abort      ./jesusonic -mode ALSA
I've tried several other options for -in/-out, same error. Recording works fine with other applications, so I know the sound card works.
__________________
alex_n
http://onehalf.net
alex_n is offline   Reply With Quote
Old 01-04-2005, 12:32 AM   #2
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 11,860
Default

Quote:
Originally Posted by alex_n
I have a gentoo system with a vanila 2.6.10, I have ALSA compiled in. I run udev in pure mode. Here's the error message:
Code:
alex_n@styx[~/jesusonic-0.96-preview] $ ./jesusonic -mode ALSA
JesuSonic v0.96 - Copyright (C) 2004 Cockos Incorporated
Using output mode: 'ALSA'
Opening ALSA 'hw:0,0' for read
Error setting periods.
jesusonic: pcm.c:984: snd_pcm_drop: Assertion `pcm->setup' failed.
zsh: abort      ./jesusonic -mode ALSA
I've tried several other options for -in/-out, same error. Recording works fine with other applications, so I know the sound card works.
You may need to experiment with different -bufsize options.. the defaults work on most cards I've tested, but maybe your driver is picky. Let me know if/how you get it to work, and what soundcard you are using.

-Justin
Justin is online now   Reply With Quote
Old 01-04-2005, 01:53 AM   #3
alex_n
Human being with feelings
 
Join Date: Jan 2005
Location: b'klyn NY
Posts: 12
Default

Got it to work with OSS:
Code:
alex_n@styx[~/jesusonic-0.96-preview] $ ./jesusonic -mode OSS -in /dev/sound/dsp1 -bufsize 1024 
JesuSonic v0.96 - Copyright (C) 2004 Cockos Incorporated
Using output mode: 'OSS'
Opening OSS '/dev/sound/dsp1' for read
Opening OSS '/dev/sound/dsp1' for write
Opened OSS audio devices at 48000hz 2ch 16bps
Using buffer size of 1024x-1 bytes
ALSA refuses to work with any setting.

(Also, can't change bps with OSS for some reason...)
__________________
alex_n
http://onehalf.net
alex_n is offline   Reply With Quote
Old 01-04-2005, 12:07 PM   #4
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 11,860
Default

Quote:
Originally Posted by alex_n
Got it to work with OSS:
Code:
alex_n@styx[~/jesusonic-0.96-preview] $ ./jesusonic -mode OSS -in /dev/sound/dsp1 -bufsize 1024 
JesuSonic v0.96 - Copyright (C) 2004 Cockos Incorporated
Using output mode: 'OSS'
Opening OSS '/dev/sound/dsp1' for read
Opening OSS '/dev/sound/dsp1' for write
Opened OSS audio devices at 48000hz 2ch 16bps
Using buffer size of 1024x-1 bytes
ALSA refuses to work with any setting.

(Also, can't change bps with OSS for some reason...)
Hmm, try adding -nbufs 4 to see if that gets OSS to work. Can try that on ALSA as well.

-Justin
Justin is online now   Reply With Quote
Old 01-04-2005, 04:58 PM   #5
alex_n
Human being with feelings
 
Join Date: Jan 2005
Location: b'klyn NY
Posts: 12
Default

OSS works when you specify -in and -bufsize, adding -nbufs only increases the number of buffers (which is helpful).
ALSA still does not work. I messed around with strace a bit, dunno if it's relevant or not, I attached the output for both cards. Oh yea, the cards are:
hw:0,0 - SB Live
0000:00:0c.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 05)
hw:1,0 - Delta 66
0000:00:0a.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)

Some explanation of the attached files (in the zip):
1.txt- ./jesusonic -mode ALSA, which gives Error Setting periods
2.txt- ./jesusonic -mode ALSA -in hw:1,0 , which give Error Setting format
3.txt- ./jesusonic -mode ALSA -nbufs 4, same as 1.txt
4.txt- ./jesusonic -mode ALSA -in hw:1,0 -nbufs 4, which give Error Setting format

I tried using several variations of -nbufs, -bufsize, -srate, etc., no good.
Attached Files
File Type: zip 1234.zip (8.3 KB, 750 views)
__________________
alex_n
http://onehalf.net
alex_n is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:38 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.