Go Back   Cockos Incorporated Forums > REAPER Forums > MIDI Hardware, Control Surfaces, and OSC

Reply
 
Thread Tools Display Modes
Old 09-17-2019, 12:17 PM   #4761
pepe44
Human being with feelings
 
pepe44's Avatar
 
Join Date: Jul 2013
Location: Portugal
Posts: 566
Default

Ok i had one uppercase letter in the widget, damn, BUT, if i have 24 tracks i can only go to track 16 on the Xtouch...ai ai ai! eheheh
__________________
Intel core i7 6700K - socket 1151 LGA - Chipset z170 - 16G DDR4 - Nvidia GTX 1060
pepe44 is offline   Reply With Quote
Old 09-17-2019, 12:21 PM   #4762
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by pepe44 View Post
Thanks @MixMonkey, that worked. I had stuff there but there was a | sign blocking things from going to subMenus i think.

Now another thing is my Faderbank and channel bank dont do anything, I have them set in the widgets page, *.mst file

Widget BankLeft
Press 90 2E 7f
WidgetEnd

Widget BankRight
Press 90 2F 7f
WidgetEnd

Widget ChannelLeft
Press 90 30 7f
WidgetEnd

Widget ChannelRight
Press 90 31 7f
WidgetEnd


and in the Zone Buttons set this way:

BankRight TrackBank 8
BankLeft TrackBank -8
ChannelLeft TrackBank -1
ChannelRight TrackBank 1

anything else missing ?
You can use Learn Mode to troubleshoot this, it's a very capable diagnostic tool.

You can open the Learn Mode Window by running Reaper Action "No-op (No action)" -- 65535

Just go into actions menu and start typing No-op, you'll see it.

Ok, with the Window open Check the "Show Input from Surfaces" checkbox in the Monitor section -- bottom right.

Now press the BankRight button.

You should see ReaConsole open and show the Midi message -- does this agree with your .mst entry ?

Assuming they agree, you should see BankRight selected in the left panel.

If there is an action mapped you will also see selections in the middle panel and the right panel.


If you don't see anything in ReaConsole, but do for controls that work, there is an issue with the hardware config., or the way the ports are set up, something like that.

Let me know how you make out.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old 09-17-2019, 12:26 PM   #4763
pepe44
Human being with feelings
 
pepe44's Avatar
 
Join Date: Jul 2013
Location: Portugal
Posts: 566
Default

Yes , it shows the right MIDI code that is already made in the mst file.
I normally check using the MIDI-ox but nice tip for the learn mode.
What about just going to track 16 when i have 24 track ?

EDIT: We cant use the learn to save yet , right ?
__________________
Intel core i7 6700K - socket 1151 LGA - Chipset z170 - 16G DDR4 - Nvidia GTX 1060

Last edited by pepe44; 09-17-2019 at 12:40 PM.
pepe44 is offline   Reply With Quote
Old 09-17-2019, 12:39 PM   #4764
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by pepe44 View Post
What about just going to track 16 when i have 24 track ?
Not sure what you mean by this, please explain further.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old 09-17-2019, 01:02 PM   #4765
pepe44
Human being with feelings
 
pepe44's Avatar
 
Join Date: Jul 2013
Location: Portugal
Posts: 566
Default

i have 24 tracks in my reaper session, when i press faderBank right i can go to the next bank page, till track 16, when i press again faderBank right nothing happens.

Even if i write this:
ChannelLeft TrackBank -1
ChannelRight TrackBank 1
BankLeft TrackBank -16
BankRight TrackBank 16

i only get to track 16.
Maybe something wrong on another place i cant find where.
__________________
Intel core i7 6700K - socket 1151 LGA - Chipset z170 - 16G DDR4 - Nvidia GTX 1060
pepe44 is offline   Reply With Quote
Old 09-17-2019, 01:44 PM   #4766
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 730
Default

Quote:
Originally Posted by pepe44 View Post
Maybe something wrong on another place i cant find where.
Make sure you don't have any 'extra' surfaces defined in the CSI prefs- just the ones you're using.
MixMonkey is offline   Reply With Quote
Old 09-17-2019, 01:45 PM   #4767
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 730
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

More CR LF stuff.

IncludedZones and ParentZone should now work in Learn Mode.

Thanks to @Freex, there is now a Touch OSC layout for the C4, that means we have a C4 emulator -- YAY !

Also included are the .ost and a starter .zon or 2 in the C4 folder.

@Freex, I tuned those files a bit, should work better now.
CR+LF now looking OK in both Win and Mac.
MixMonkey is offline   Reply With Quote
Old 09-17-2019, 01:55 PM   #4768
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 492
Default

Quote:
Originally Posted by MixMonkey View Post
CR+LF now looking OK in both Win and Mac.
I'm glad you commented on Geoff's post MixMonkey it went by me completely unnoticed.

I'LL HAVE TO GET ON HERE AND HAVE A TRY.
Freex is offline   Reply With Quote
Old 09-17-2019, 03:47 PM   #4769
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by MixMonkey View Post
CR+LF now looking OK in both Win and Mac.
Nice, thanks !
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old 09-17-2019, 03:49 PM   #4770
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by Freex View Post
I'm glad you commented on Geoff's post MixMonkey it went by me completely unnoticed.

I'LL HAVE TO GET ON HERE AND HAVE A TRY.
Make sure you get the .touchosc, .ost, and .zon files from the new build.

Please also have a play with Learn Mode, you can now add/delete, etc., anxious to know how it "feels" to do normal operations.

The only things that don't work are:
Save
Realtime

Everything else is a bug.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old 09-17-2019, 04:04 PM   #4771
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 730
Default

Quote:
Originally Posted by Geoff Waddington View Post
Please also have a play with Learn Mode, you can now add/delete, etc., anxious to know how it "feels" to do normal operations.

The only things that don't work are:
Save
Realtime

Everything else is a bug.
So, even though Save is disabled, we can still modify the 'loaded' configuration- it just doesn't survive restarting Reaper?
MixMonkey is offline   Reply With Quote
Old 09-17-2019, 04:35 PM   #4772
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by MixMonkey View Post
So, even though Save is disabled, we can still modify the 'loaded' configuration- it just doesn't survive restarting Reaper?
It doesn't even survive a restart of the Window

It's really just cosmetic right now, since it doesn't do realtime either.

I'm more looking for -- does it feel like a natural way to edit .zon files, that's all.

Also looking to see if you can crash it (again)

On the optimistic side, I've got realtime delete working here -- realtime add and save left to go...
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old 09-17-2019, 04:56 PM   #4773
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 896
Default

Hi Geoff, I have tried to test the Learn mode a few times for a few builds, but honestly it's a little overwhelming, and the fact that it doesn't actually "do" anything yet (as in, create/save zon files) makes it hard to feel like I'm actually testing it.

I do have some plugs I need to map and don't really have the time to go back and forth between builds to get the raw file for the C4 config. BUT, whenever Learn is operational I will certainly test it fully.

Thanks again for all the great work!
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-17-2019, 05:21 PM   #4774
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 68
Default Generating Zone file from VST via Learn Window

Just grabbed the latest build, as I'm about to tackle the FX zone files (haven't converted my old fxt's yet).

Following the steps in an earlier post, I focused the FX window (ReaEQ), brought up the LearnMode window, moved a control on the surface and clicked the New button.

The window pops up to let me edit the default name and filename, except I can't give it focus. The LearnMode window has precedence.

I can switch from the LearnMode window to the FX and to other parts of Reaper, so it's not modal, but just that one window can't be focused.

If I close the LearnMode window, I can click save and it does generate the RawFX file like this:

Code:
VST: ReaEQ (Cockos)
Freq-Low Shelf
Gain-Low Shelf
Q-Low Shelf
Freq-Band 2
Gain-Band 2
Q-Band 2
Freq-Band 3
Gain-Band 3
Q-Band 3
Freq-High Shelf
Gain-High Shelf
Q-High Shelf
Bypass
Wet
I'm on Windows 10 64bit, and the latest CSI build.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-17-2019, 05:49 PM   #4775
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 730
Default

Quote:
Originally Posted by Geoff Waddington View Post
I'm more looking for -- does it feel like a natural way to edit .zon files, that's all.

Also looking to see if you can crash it (again)

On the optimistic side, I've got realtime delete working here -- realtime add and save left to go...
Feels pretty good here Recognises the Shift Zones now. I tend to agree with @PoetnProphet, until it can actually be used to create/edit Zones you're not really going to get much conclusive feedback. After you enable it, I'm sure you'll get a deluge I see you've got the 'Are you sure?' box ready to go
MixMonkey is offline   Reply With Quote
Old 09-17-2019, 05:52 PM   #4776
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by MalcolmG View Post
Just grabbed the latest build, as I'm about to tackle the FX zone files (haven't converted my old fxt's yet).

Following the steps in an earlier post, I focused the FX window (ReaEQ), brought up the LearnMode window, moved a control on the surface and clicked the New button.

The window pops up to let me edit the default name and filename, except I can't give it focus. The LearnMode window has precedence.

I can switch from the LearnMode window to the FX and to other parts of Reaper, so it's not modal, but just that one window can't be focused.

If I close the LearnMode window, I can click save and it does generate the RawFX file like this:

Code:
VST: ReaEQ (Cockos)
Freq-Low Shelf
Gain-Low Shelf
Q-Low Shelf
Freq-Band 2
Gain-Band 2
Q-Band 2
Freq-Band 3
Gain-Band 3
Q-Band 3
Freq-High Shelf
Gain-High Shelf
Q-High Shelf
Bypass
Wet
I'm on Windows 10 64bit, and the latest CSI build.
Yeah, on Windows it's not modal, but it's not not modal either

Save doesn't work at all yet, that's not how the Raw FX file gets generated.

When you have a focused FX, open the Learn Window and Press New, you will see the defaults for filename and Zone name -- keep them, and Press OK -- see the FX parameter numbers and names listed first in the right hand list (Action List) -- that means the Raw FX file has been generated, nothing further needed if all you are interested in is a Raw FX file.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old 09-17-2019, 05:54 PM   #4777
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by MixMonkey View Post
Feels pretty good here Recognises the Shift Zones now. I tend to agree with @PoetnProphet, until it can actually be used to create/edit Zones you're not really going to get much conclusive feedback. After you enable it, I'm sure you'll get a deluge I see you've got the 'Are you sure?' box ready to go
Agree, pretty soon now...
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old 09-17-2019, 06:11 PM   #4778
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 68
Default

Quote:
Originally Posted by Geoff Waddington View Post
Yeah, on Windows it's not modal, but it's not not modal either

Save doesn't work at all yet, that's not how the Raw FX file gets generated.

When you have a focused FX, open the Learn Window and Press New, you will see the defaults for filename and Zone name -- keep them, and Press OK -- see the FX parameter numbers and names listed first in the right hand list (Action List) -- that means the Raw FX file has been generated, nothing further needed if all you are interested in is a Raw FX file.
AH, ok. Got it.

Once I had the RAW FX file I had enough to go on. My ReaEQ zone is working nicely mapped onto one of my BCF2000s (except I could do with a few more buttons)
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-17-2019, 06:15 PM   #4779
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 68
Default

Quote:
Originally Posted by MalcolmG View Post
Once I had the RAW FX file I had enough to go on. My ReaEQ zone is working nicely mapped onto one of my BCF2000s (except I could do with a few more buttons)
Out of interest I just tried generating one for Reaktor. Holy crap! I'd need more than a few more buttons!

Instead I just closed the file and pretended I'd never done that.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-17-2019, 06:51 PM   #4780
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 730
Default

Quote:
Originally Posted by MalcolmG View Post
Out of interest I just tried generating one for Reaktor. Holy crap! I'd need more than a few more buttons!

Instead I just closed the file and pretended I'd never done that.
If you load something like Monark into it before generating the RawFX file, you do get the parameter names (...and then the balance of the 1000 unused parameters)
MixMonkey is offline   Reply With Quote
Old 09-17-2019, 10:25 PM   #4781
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Krefeld, Germany
Posts: 7,686
Default

Quote:
Originally Posted by MixMonkey View Post
. After you enable it, I'm sure you'll get a deluge I see you've got the 'Are you sure?' box ready to go
Maybe a backlog is necessary to undo unwanted changes to the config files.....
-Michael
mschnell is offline   Reply With Quote
Old Yesterday, 12:20 AM   #4782
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 68
Default Map Focused FX to Widgets

I have the workflow working where I had a button that would select my track and then map that track's FX to widgets on my surface. That worked fine.

I've just started to look at how to enable the alternative, where I only map the focused FX to widgets.

To do this, I changed a few things:

- in my FX zone, I changed the SelectedTrackNavigator to FocusedFXTrackNavigator
- in my surface zone, I changed my call from MapSelectedTrackFXToWidgets to MapFocusedTrackFXToWidgets

Is there anything else I need to do? This alone didn't seem to work, so I also tried:

- changing the surface in CSI.INI to have AutoMapFocusedFX enabled
- I also tried having OnFXFocus MapFocusedFXToWidgets in my Home zone on the same surface

Neither of these seemed to help. I feel like there's a step I'm missing. Basically I'd like to try having no FX mapped until it is focused.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki

Last edited by MalcolmG; Yesterday at 12:25 AM.
MalcolmG is offline   Reply With Quote
Old Yesterday, 02:49 AM   #4783
pepe44
Human being with feelings
 
pepe44's Avatar
 
Join Date: Jul 2013
Location: Portugal
Posts: 566
Default

Thanks MixMonkey, i deleted the ones that come by default in the new version and did the job.
On thing i┤ve noticed is i don┤t have the channel VU meter working, on the Xtouch with other MCU┤s they are there.
I was trying to find the place on the zone file where that is set but dont know which one it is.I see a Fader| TrackVolume , is that it ? if so its there, has you can see bellow.


Zone Channel|1-8
TrackNavigator
DisplayUpper| TrackNameDisplay
DisplayLower| TrackPanDisplay
TrackTouch+DisplayLower| TrackVolumeDisplay
RotaryPush| GoZone PanWidth|
Rotary| TrackPan 0
RecordArm| TrackRecordArm
Solo| TrackSolo
Mute| TrackMute
Select| TrackUniqueSelect
Shift+Select| TrackRangeSelect
Control+Select| TrackSelect
Shift+Control+Select| TogglePin
Option+Select| TrackFolderDive
Fader| TrackVolume
TrackTouch+Fader| TrackVolume
FaderTouch| TrackTouch
ZoneEnd
__________________
Intel core i7 6700K - socket 1151 LGA - Chipset z170 - 16G DDR4 - Nvidia GTX 1060

Last edited by pepe44; Yesterday at 03:59 AM.
pepe44 is offline   Reply With Quote
Old Yesterday, 03:04 AM   #4784
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 492
Default

Quote:
Originally Posted by Geoff Waddington View Post
Make sure you get the .touchosc, .ost, and .zon files from the new build.

Please also have a play with Learn Mode, you can now add/delete, etc., anxious to know how it "feels" to do normal operations.

The only things that don't work are:
Save
Realtime

Everything else is a bug.
Weirdly i'm getting not communication between tablet and PC, learn mode with params enabled is showing nothing.

Now i'm very confused.

UPDATE
A few restarts and I have transport but the Fabfilter Q3 is not showing.
I'm seeing the homezone when i open learn fron EQ button on tablet, but nothing when I


More confused.

UPDATE 2
Thought i'd found the problem, something worked somewhere and I was able to see the FXzone in learn and there was no navigator assigned, went in and noticed it was FocusedFXTrackNavigator when I think by the learn dialog and a vague memory it shuld be FocusedFXNavigator

But still no joy, and can't seem to get the FXZone to display in learn mode again.

None the wiser...

Last edited by Freex; Yesterday at 03:37 AM.
Freex is offline   Reply With Quote
Old Yesterday, 04:37 AM   #4785
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 730
Default

Quote:
Originally Posted by MalcolmG View Post
I have the workflow working where I had a button that would select my track and then map that track's FX to widgets on my surface. That worked fine.

I've just started to look at how to enable the alternative, where I only map the focused FX to widgets.

To do this, I changed a few things:

- in my FX zone, I changed the SelectedTrackNavigator to FocusedFXTrackNavigator
- in my surface zone, I changed my call from MapSelectedTrackFXToWidgets to MapFocusedTrackFXToWidgets

Is there anything else I need to do? This alone didn't seem to work, so I also tried:

- changing the surface in CSI.INI to have AutoMapFocusedFX enabled
- I also tried having OnFXFocus MapFocusedFXToWidgets in my Home zone on the same surface

Neither of these seemed to help. I feel like there's a step I'm missing. Basically I'd like to try having no FX mapped until it is focused.
Some of the nomenclature has been changed:
Code:
FocusedFXNavigator			old: FocusedFXTrackNavigator
ToggleMapSelectedTrackSends		old: ToggleMapSends
ToggleMapSelectedTrackFX 		old: ToggleMapFX
ToggleMapSelectedTrackFXMenu		old: ToggleMapFXMenu
ToggleMapFocusedFX

MapSelectedTrackSendsToWidgets 		No Change
MapSelectedTrackFXToWidgets		No Change 
MapSelectedTrackFXToMenu 		No Change
MapFocusedFXToWidgets			old: MapFocusedTrackFXToWidgets
MixMonkey is offline   Reply With Quote
Old Yesterday, 10:54 AM   #4786
Colox
Human being with feelings
 
Join Date: Feb 2012
Location: The land of meatballs and blondes
Posts: 964
Default

After making a ****** of myself yesterday, I thought I'd give Console1 a new shot. But um ... it looks like I might be making a ****** out myself tonight too.

When I try using Console1 as hardware, I get no response from Reaper. I removed the Console 1 onscreen display and drivers (as recommended by Waddington in #4747), but then my Console1 just goes dead. No LEDs shining and no response, at all. Yet Console1 is listed as present, in the Reaper preferences for MIDI devices. That's odd.

I've re-installed and uninstalled and rebooted the computer and Reaper several times, but it feels like Console1 just lies there like a dead trout. No response in Reacomp either, as expected. I'm on a not much customized Win10 x64.

Seems like I must be doing something wrong. But I'm not sure what (?)
__________________
There are only two kinds of people in the world: those who entertain, and those who are absurd.
- Britney Spears
Colox is offline   Reply With Quote
Old Yesterday, 12:05 PM   #4787
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 730
Default

Quote:
Originally Posted by Colox View Post
Seems like I must be doing something wrong. But I'm not sure what (?)
Is the Console 1 disabled in the Reaper MIDI preferences? (It should be)

Does the Console 1 need to be switched into a different mode to be used without its own software?
MixMonkey is offline   Reply With Quote
Old Yesterday, 12:52 PM   #4788
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by Colox View Post
I removed the Console 1 onscreen display and drivers (as recommended by Waddington in #4747), but then my Console1 just goes dead.
Nope, never said to remove any software -- just said don't RUN the software.

I have no idea what will happen if you remove the software and drivers... well.. now I do
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old Yesterday, 12:53 PM   #4789
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by MixMonkey View Post
Does the Console 1 need to be switched into a different mode to be used without its own software?
Nope, no action necessary, at least on mine.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old Yesterday, 02:55 PM   #4790
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 68
Default

Quote:
Originally Posted by MixMonkey View Post
Some of the nomenclature has been changed:
Code:
FocusedFXNavigator			old: FocusedFXTrackNavigator
ToggleMapSelectedTrackSends		old: ToggleMapSends
ToggleMapSelectedTrackFX 		old: ToggleMapFX
ToggleMapSelectedTrackFXMenu		old: ToggleMapFXMenu
ToggleMapFocusedFX

MapSelectedTrackSendsToWidgets 		No Change
MapSelectedTrackFXToWidgets		No Change 
MapSelectedTrackFXToMenu 		No Change
MapFocusedFXToWidgets			old: MapFocusedTrackFXToWidgets
Ah, cool. Thanks. I'll try these out when I get home tonight. I'll also update my wiki.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old Yesterday, 04:43 PM   #4791
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 730
Default

Quote:
Originally Posted by pepe44 View Post
Thanks MixMonkey, i deleted the ones that come by default in the new version and did the job.
On thing i┤ve noticed is i don┤t have the channel VU meter working, on the Xtouch with other MCU┤s they are there.
I was trying to find the place on the zone file where that is set but dont know which one it is.I see a Fader| TrackVolume , is that it ? if so its there, has you can see bellow.


Zone Channel|1-8
TrackNavigator
DisplayUpper| TrackNameDisplay
DisplayLower| TrackPanDisplay
TrackTouch+DisplayLower| TrackVolumeDisplay
RotaryPush| GoZone PanWidth|
Rotary| TrackPan 0
RecordArm| TrackRecordArm
Solo| TrackSolo
Mute| TrackMute
Select| TrackUniqueSelect
Shift+Select| TrackRangeSelect
Control+Select| TrackSelect
Shift+Control+Select| TogglePin
Option+Select| TrackFolderDive
Fader| TrackVolume
TrackTouch+Fader| TrackVolume
FaderTouch| TrackTouch
ZoneEnd
No, it's not TrackVolume I don't use the meters myself (I find them kinda annoying) but I think the syntax would be:
Code:
 DisplayLower| VUMeter
As this obviously clashes with the Pan display, I'm hoping it's only active when Reaper is playing.

If this doesn't work, hopefully someone who does use the meters can chime in. Sorry I can't be more help.
MixMonkey is offline   Reply With Quote
Old Yesterday, 06:43 PM   #4792
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 68
Default

Quote:
Originally Posted by MixMonkey View Post
Some of the nomenclature has been changed:
Code:
FocusedFXNavigator			old: FocusedFXTrackNavigator
ToggleMapSelectedTrackSends		old: ToggleMapSends
ToggleMapSelectedTrackFX 		old: ToggleMapFX
ToggleMapSelectedTrackFXMenu		old: ToggleMapFXMenu
ToggleMapFocusedFX

MapSelectedTrackSendsToWidgets 		No Change
MapSelectedTrackFXToWidgets		No Change 
MapSelectedTrackFXToMenu 		No Change
MapFocusedFXToWidgets			old: MapFocusedTrackFXToWidgets
Thanks MixMonkey, it was the FocusedFXTrackNavigator in my VST Zone. Changing that to FocusedFXNavigator made it work.

However, when I close or unfocus the FX window, I expected my Home zone to reapply. It doesn't seem to though. Probably related to the earlier thing about zones not being in a stack, and needing to explicitly GoZone back to Home.

So I did that:
Code:
OnFXFocus MapFocusedFXToWidgets
OnTrackSelection GoZone Home
and it works, except it's a little clumsy as it doesn't happen until I click on a track (not surprising, given I used OnTrackSelection).

Is there some way to make it happen once I close/unfocus the FX window?
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old Yesterday, 06:53 PM   #4793
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,541
Default

Quote:
Originally Posted by MalcolmG View Post
However, when I close or unfocus the FX window, I expected my Home zone to reapply. It doesn't seem to though.
Is there some way to make it happen once I close/unfocus the FX window?
If you find one let us know

Seriously, you are lucky you missed the gyrations we went through on this a while back.

As I remember it, the last FX never loses focus, not by clicking something else (except another FX), not by closing it, nuttin'.

Still working on that one...
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is online now   Reply With Quote
Old Yesterday, 07:09 PM   #4794
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 68
Default

Quote:
Originally Posted by Geoff Waddington View Post
If you find one let us know

Seriously, you are lucky you missed the gyrations we went through on this a while back.

As I remember it, the last FX never loses focus, not by clicking something else (except another FX), not by closing it, nuttin'.

Still working on that one...
OK, no worries. Just wanted to make sure I wasn't missing something obvious. Meantime I guess I can designate a Home button somewhere and get it to GoZone Home.

Cheers
Malcolm
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:37 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.