Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 05-31-2021, 11:14 AM   #1
olaservo
Human being with feelings
 
olaservo's Avatar
 
Join Date: May 2021
Posts: 11
Default [v6.29] "Allow trim of MIDI items when splitting" setting not respected when new MIDI

Edit: sorry the title of this thread got cut off, it was supposed to be: "Allow trim of MIDI items when splitting" setting not respected when new MIDI takes are created

Steps to reproduce:

1.) Set Options > New recording that overlaps existing media items > Split existing items and create new takes
2.) Uncheck Preferences > Media > MIDI: "Allow trim of MIDI items when splitting"
3.) Record MIDI repeatedly over a looped area of the timeline so that new takes are created, and record a partial loop before stopping recording

Expected:
If I drag out the right edge of the second-to-last take, the additional MIDI information should show up at the end of the MIDI take. This is what happens when recording audio items.

Actual:
The additional MIDI information is trimmed out after the split on the second-to-last take.

For more context on why this is a problem:
I would like to use the option to discard partial takes but still be able to extend the last complete take to include any of the recorded MIDI from the last partial take.
I am able to do this with audio and not MIDI.
When looking up the problem, it looks like "Allow trim of MIDI items when splitting" is supposed to prevent splitting from trimming MIDI, making it behave the same as audio items. But that is not being respected in this scenario.

OS/Reaper version:
Windows 10 Pro 64bit
Reaper v6.29/x64

Last edited by olaservo; 05-31-2021 at 11:33 AM.
olaservo is offline   Reply With Quote
Old 06-20-2021, 10:55 AM   #2
olaservo
Human being with feelings
 
olaservo's Avatar
 
Join Date: May 2021
Posts: 11
Default

Can anybody reproduce this issue? It's still a problem when recording MIDI takes. Thanks!
olaservo is offline   Reply With Quote
Old 06-20-2021, 11:44 AM   #3
Daodan
Human being with feelings
 
Join Date: Jan 2011
Posts: 274
Default

Quote:
Originally Posted by olaservo View Post
Expected:
If I drag out the right edge of the second-to-last take, the additional MIDI information should show up at the end of the MIDI take. This is what happens when recording audio items.

Actual:
The additional MIDI information is trimmed out after the split on the second-to-last take.
+1. Same experience. Maybe not a bug really but a bit annoying.
Daodan is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:06 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.