Old 08-17-2019, 01:00 PM   #1
Mr.Oizo
Human being with feelings
 
Mr.Oizo's Avatar
 
Join Date: Aug 2019
Posts: 1
Angry MIDI Keyboard control knobs issue

Hello. The problem is that one day MIDI Keyboard's (Oxygen49) control knobs started working only when whatever track has record armed. Control knobs doesn't work not only on selected track. Throughout Reaper. Even when I wanted to add some MIDI CC on some action in action list Reaper doesn't react on knob moving unless "record arm" is on.
I've tried to reset Midi devices, delete Midi keyboard from device manager in Windows and reinstal it, reset reaper to default settings, reset midi keyboard to default settings. All of it doesn't help. It's a very strange bug and I don't understand when and why this happened.
Mr.Oizo is offline   Reply With Quote
Old 08-17-2019, 01:28 PM   #2
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Krefeld, Germany
Posts: 7,877
Default

I suppose the "control knobs" send Midi CC messages.

Reaper sends all Midi messages to the appropriate tracks whem Record is armed. You can ro9ute them with the Reaper Midi Routing mechanism

Reaper additionally creates "Control Path" messages from CCs when in the Midi Device setting the "Control" box is checked.

The Control Path messages are not available as Midi in tracks but via the dedicated "Learn (from Control Path)" functionality in Reaper (e.g. to trigger Reaper actions or to tweak plugin parameters).

-Michael
mschnell is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:25 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.