Old 08-14-2019, 05:12 PM   #1
madbrain
Human being with feelings
 
Join Date: Aug 2019
Posts: 3
Default Save as "trim" function not working (FIXED)

Long-time Reaper user and licensee here.

I have a problem with Reaper 5.981/x64 on Win10 with a WAV file recorded from my Tascam DA-3000 in stereo 24 bits/192 kHz. This is a file containing practice takes. I want to trim it to only keep the last take in it. I created a project and used the "save project as" function, then checked "copy all media into project directory", also "convert media", and finally "trim media, tail size 500ms".

I then select a new location for to save it, and click "save".
The problem is that the entire WAV file is still duplicated in full, and not actually trimmed.

This is only happening with this particular WAV file. The trim function has worked so far with all other WAV files from my DA-3000. Not sure why it doesn't work with this one.

The project and WAV file in question are in a ZIP at https://drive.google.com/open?id=1aS...ib17NoXw2W2V-- .
madbrain is offline   Reply With Quote
Old 08-18-2019, 03:55 PM   #2
madbrain
Human being with feelings
 
Join Date: Aug 2019
Posts: 3
Default

FYI, tried with version 5.982 . I now get a pop-up that says "There were errors copying media for this project: 1 files could no be copied/moved.". I tried recreating the project and PEAKS file, but the issue remained.

I would really appreciate if developers would look at this test case.

In the meantime, I worked around this trim bug by doing a render of the project in the same format as the original WAV, ie. 192 kHz stereo 24 bits.
madbrain is offline   Reply With Quote
Old 08-19-2019, 11:12 AM   #3
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,439
Default

Thanks! It looks like there's a rounding bug where the 'save-trim' logic thinks that the item loops, so it renders out the whole source. We can fix this for the next version.

As a temporary work around either:

A) disable "loop source" for this item, or

B) make the item slightly shorter (10ms would be enough for example)
Justin is offline   Reply With Quote
Old 08-19-2019, 10:42 PM   #4
madbrain
Human being with feelings
 
Join Date: Aug 2019
Posts: 3
Default

Justin,

Quote:
Originally Posted by Justin View Post
Thanks! It looks like there's a rounding bug where the 'save-trim' logic thinks that the item loops, so it renders out the whole source. We can fix this for the next version.

As a temporary work around either:

A) disable "loop source" for this item, or
Thanks for your reply. I am not familiar with this feature. I never turned it on.

Quote:
B) make the item slightly shorter (10ms would be enough for example)
Not an option in this case as I was trying to extract the last 52s of audio out of a much longer WAV file.

I'll wait for the fix !

Thanks,
Julien
madbrain is offline   Reply With Quote
Old 08-20-2019, 07:31 AM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,439
Default

Quote:
Originally Posted by madbrain View Post
Justin,



Thanks for your reply. I am not familiar with this feature. I never turned it on.



Not an option in this case as I was trying to extract the last 52s of audio out of a much longer WAV file.

I'll wait for the fix !

Thanks,
Julien
Either of these fixes would definitely help you now! All you need to do for the first one is right click the item, go to "Item settings", and uncheck the "Loop item source" menu item.
Justin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:01 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.