Old 05-11-2019, 09:31 AM   #1
Frans
Human being with feelings
 
Join Date: Jul 2018
Posts: 5
Default Open projects created on Windows

Hello,

Coming from Windows, I am trying to migrate to Linux.

I have installed the native Linux version of Reaper.

This works : Insert a file from /Home , playing it back, apply effects etc.

But when I try to open a project formerly created in my Windows install, it can't find the media files.

In the dialog that shows up, the file locations of the missing files start with the Windows drive letter.

I tried coping the project directory to /Home and open the projet from there.

The same thing happens, the file location is still on the Windows drive letter.

I tried Browse for file, I can browse to- and select the file but when I clic "open", nothing happens.

The dialog seems frozen. Search button and "Auto Search after succesfull search" do not work either.

The only way to close the dialog is to clic the close button in the upper right corner.

The project than loads, with just the peak files I presume, because I can see the audio peaks but there is not the usual empty lane with File Offline mention...)

I'm totally new to Linux, so I do not know if I'm missing something on the generic Linux side or if this is a "bug" in the Linux version of reaper.


I hope somebody could help me, and I apologize in advance for my lack of knowledge of Linux in general...

Kind Regards,

Frans
Frans is offline   Reply With Quote
Old 05-12-2019, 07:22 AM   #2
Frans
Human being with feelings
 
Join Date: Jul 2018
Posts: 5
Default Replace missing Files when Open New Project is not working properly

OK, I have narrowed down the problem.

In fact, I can load projects created in windows. If all needed files are in the project folder, there is no problem.

If a file was in a different location when the project was saved, the path is stored in absolute way, so Linux will not be able to "follow" that path and the file will be missing.

If a file is missing and if it CAN BE FOUND by clicking "browse for file" or "search", it is OK, all is well.

BUT :

If you choose "leave file offline", the menu freezes, and won't continue to prompt for the next missing file.

The same if the search did not find the file.

The same if you try to load a m4a file (it says "invalid file")

If you close the menu (cross upper right corner), it will however show the next missing file, but you can't do anything anymore, no button will work.

Is there a way to tell reaper to always safe relative paths when you save a project ? This would make migrating files to a different hardware setup easier.

I hope this can help people who experience the same issues, and :

Should I create a Bug report for this ?
Frans is offline   Reply With Quote
Old 05-12-2019, 07:32 AM   #3
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 3,909
Default

I wouldn't classify that as a bug. There is no way REAPER could convert a Windows path to a Linux one unless it were relative to the project file, and even then there are problems in that Linux uses a slash rather than a backslash to designate folder elements, Plus Linux differentiates between upper and lower case.

All my Windows projects are self contained in their own project folders so the only issues I see are the two or three Windows plugins I didn't migrate to Linux. That and the location of track icons, which is different in Linux.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 05-12-2019, 09:18 AM   #4
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

Does it help to do save-as with copy in windows before trying to open the project? You can also try to Consolidate the project before opening it.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:09 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.