Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 02-23-2019, 09:52 AM   #1
RainyDaze
Human being with feelings
 
RainyDaze's Avatar
 
Join Date: May 2015
Location: Ireland
Posts: 24
Default Need some help with Linux/Reaper/M-Audio Oxygen25

Nearly have my set up complete I think - just one main problem at the moment and that is getting my M-Audio Oxygen25 to work with Reaper/Linux/Jack/blah...blah

Using Native Reaper, Linux Mint 19, Focusrite 2i4 (1stGen), i7-7700K @4.20GHz x 4, 16GB RAM, Samsung SSD etc, etc.

But I don't seem to understand MIDI connectivity
Should the MIDI Devices tab in Preferences actually list the Oxygen25?

No problems with plugins/virtualKeyboard/Midi editor - can get sounds, just not with the Oxygen25.

It's probably something 'obvious' I'm not doing right but I can't see it and at this stage I'm a bit like a moth flying into a lamp.
TIA for any help
Pete





RainyDaze is online now   Reply With Quote
Old 02-23-2019, 10:50 AM   #2
Drumfix
Human being with feelings
 
Join Date: Oct 2007
Posts: 41
Default

You need to enable the alsa midi driver for jack.
Since you apparently use qjackctl, go to preferences and select raw as the midi driver.
Drumfix is offline   Reply With Quote
Old 02-23-2019, 04:14 PM   #3
RainyDaze
Human being with feelings
 
RainyDaze's Avatar
 
Join Date: May 2015
Location: Ireland
Posts: 24
Default

Thanks for that.
I enabled that driver but still no Oxygen25 keyboard activity in Reaper.
Am i supposed to select Oxygen25 as Input/Output device in Jack Advanced tab as well? Because that doesn't seem to make any difference either.
Complete MIDI imbecile here Although in my defence it works okay in Win7 which I have on the same pc (different disk).
Do I need a MIDI device with MIDI 'out' that I can connect to the Focusrite 2i4? This device is just usb.
I'm off to bed, I'll look at it again in the morning.
RainyDaze is online now   Reply With Quote
Old 02-23-2019, 05:32 PM   #4
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,784
Default

Something to note, is that when using JACK there are 2 midi subsystems, the standard ALSA, and a JACK specific one. Your midi hardware will only be available as ALSA.

I guess you are running jack2. Try running "a2jmidid -e", this will create a bridge.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 02-24-2019, 05:12 AM   #5
RainyDaze
Human being with feelings
 
RainyDaze's Avatar
 
Join Date: May 2015
Location: Ireland
Posts: 24
Default

Thanks Jack. Will try that later today.

I'm delighted to be at the stage I'm at with Linux for recording, have been wanting to ditch windows for a long long time.
I have Kuassa amp sims working well enough, ZynAddSubFX and MTDrums running as well. Sforzando and couple of orchestral samples SSO/VPO available.
Just this last little detail will keep me happy for a long time to come.
RainyDaze is online now   Reply With Quote
Old 02-24-2019, 08:30 AM   #6
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 3,910
Default

Quote:
Originally Posted by Jack Winter View Post
Something to note, is that when using JACK there are 2 midi subsystems, the standard ALSA, and a JACK specific one. Your midi hardware will only be available as ALSA.

I guess you are running jack2. Try running "a2jmidid -e", this will create a bridge.
On my Raspberry Pi I put "a2jmidid -e" right in qjackctl in the "Execute script after startup" box on the options tab.

On my Linux DAW I link to a script there that does that then launches REAPER.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 02-25-2019, 03:28 PM   #7
RainyDaze
Human being with feelings
 
RainyDaze's Avatar
 
Join Date: May 2015
Location: Ireland
Posts: 24
Default

Go Linux Reaper!!

Thanks guys for the help getting my M-Audio Oxygen25 up and running.

RainyDaze is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:51 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.