Old 07-12-2019, 02:37 PM   #1
strachupl
Human being with feelings
 
strachupl's Avatar
 
Join Date: Jan 2013
Posts: 394
Default Is mixer fader laggy for you also?

I noticed when I adjust more than 7 tracks volume, faders are laggy so I installed FL trial to check if its common in other DAWs but no...






Lenovo laptop win 7 x64

Intel Core i7 4710mq 2,5ghz
16gb ram, geforce840m
__________________
The truth is not in the middle but exactly where it is.
strachupl is offline   Reply With Quote
Old 07-12-2019, 05:59 PM   #2
foxAsteria
Human being with feelings
 
foxAsteria's Avatar
 
Join Date: Dec 2009
Location: Oblivion
Posts: 7,110
Default

UI refresh is dependent on preferences that I can't find rn. Yea after a hundred tracks or so, it gets a bit slow for me.

But honestly you shouldn't drag faders for many tracks at once. If you need to do that a lot, make a VCA. Much simpler, no lag, and it preserves relative differences between tracks.
__________________
Myy Wyyrd Muzyyk
foxAsteria is online now   Reply With Quote
Old 07-12-2019, 07:22 PM   #3
strachupl
Human being with feelings
 
strachupl's Avatar
 
Join Date: Jan 2013
Posts: 394
Default

It happen with 7+ tracks for me and in Fl this is not happening with 40 tracks as in example gif so what is this preference you talk about.

I did more tests, almost every theme is laggin but I found theme that almost not lag called Event Horizon X



__________________
The truth is not in the middle but exactly where it is.

Last edited by strachupl; 07-12-2019 at 07:54 PM.
strachupl is offline   Reply With Quote
Old 07-12-2019, 08:18 PM   #4
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,669
Default

I don't get this behavior with stock themes including the V6 alpha theme. (I didn't test with other themes because I use the V6 alpha theme now.)

I'm currently using the latest dev prerelease version of Reaper, and there have been some changes to the UI handling. It might be worth trying that.
__________________
http://petersamplification.com
Using REAPER for Linux
JamesPeters is offline   Reply With Quote
Old 07-12-2019, 09:00 PM   #5
strachupl
Human being with feelings
 
strachupl's Avatar
 
Join Date: Jan 2013
Posts: 394
Default

I have tried both x32 and x64 latest prerelease and still exacly same thing...

I tried everything, turning off win7 oreo, even mouse settings. Why it happen only to me in Reaper and not in FL?
__________________
The truth is not in the middle but exactly where it is.
strachupl is offline   Reply With Quote
Old 07-12-2019, 09:03 PM   #6
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,669
Default

Quote:
Originally Posted by strachupl View Post
I have tried both x32 and x64 latest prerelease and still exacly same thing...

I tried everything, turning off win7 oreo, even mouse settings.
Oreo. lol.

I'm using the Linux version so maybe it's more of a Windows thing.
__________________
http://petersamplification.com
Using REAPER for Linux
JamesPeters is offline   Reply With Quote
Old 07-13-2019, 05:29 AM   #7
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 15,078
Default

if you just want to get it done, do yourself a favor and go here:

https://reaper.hector-corcin.com/

make a very small donation 5 bucks, and get the VIP versions of HeDa's stuff

Included will be the VIP Mixer... which will let you do things like you won't believe

Multiple mixers in tabs, change the size of panels, colors, on and on ...all without switching to
some other layout...
__________________
...should be fixed for the next build... http://tinyurl.com/cr7o7yl
https://soundcloud.com/hopikiva/angel-rain
hopi is offline   Reply With Quote
Old 07-13-2019, 06:04 AM   #8
strachupl
Human being with feelings
 
strachupl's Avatar
 
Join Date: Jan 2013
Posts: 394
Default

lol...
__________________
The truth is not in the middle but exactly where it is.
strachupl is offline   Reply With Quote
Old 07-13-2019, 05:10 PM   #9
Greg Savage
Human being with feelings
 
Join Date: Apr 2016
Posts: 471
Default

Quote:
Originally Posted by strachupl View Post
Why it happen only to me in Reaper and not in FL?
Hard to say without the system in front of us. Maybe its an issue on the windows side, who knows. I'd contact the dev about see if they know but I've never had this issue
Greg Savage is offline   Reply With Quote
Old 07-13-2019, 06:05 PM   #10
foxAsteria
Human being with feelings
 
foxAsteria's Avatar
 
Join Date: Dec 2009
Location: Oblivion
Posts: 7,110
Default

Personally, I commend Reaper for allocating the resources to what really matters. FL has always been more about bling bling than anything else, imo.

But it could have to do with the way WALTER is implemented. Maybe because Reaper is themeable, the UI has to check through the whole rtconfig each refresh or something. Idk, just a guess.

The preference I was referring to before has since been removed. From what I gather, it was pretty negligible in most cases.
__________________
Myy Wyyrd Muzyyk
foxAsteria is online now   Reply With Quote
Old 07-14-2019, 07:52 AM   #11
1111Eugene
Human being with feelings
 
Join Date: Mar 2019
Posts: 76
Default

https://forum.cockos.com/showpost.ph...0&postcount=54

soon it should be fixed ( I really hope it wiil, because it is impossible to be in a right mood with such lags forever)
1111Eugene is online now   Reply With Quote
Old 07-19-2019, 03:51 PM   #12
strachupl
Human being with feelings
 
strachupl's Avatar
 
Join Date: Jan 2013
Posts: 394
Default

https://s3.gifyu.com/images/asfafs.gif

22 tracks and CPU jumping, faders lagging

FL studio - 100 tracks, nothing strange (I can make gif proof if needed)
__________________
The truth is not in the middle but exactly where it is.

Last edited by strachupl; 07-19-2019 at 04:02 PM.
strachupl is offline   Reply With Quote
Old 07-20-2019, 07:25 AM   #13
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,268
Default

1600 tracks. Reaper is still instantly responsive and all the track volume faders move together as one when scrolling the volume up/down with one of them with all tracks selected. On the laptop (2011 MBP 4x 2.5GHz (3.6GHz) i7 16GB).

Just duplicated to 6400 tracks. Still perfectly responsive.

Duplicated again to 12800 tracks. It took about 5 seconds for the new tracks to appear this time. Ever so slight choppy scroll if you look close. Still responsive and the faders still move together as one.
serr is offline   Reply With Quote
Old 07-20-2019, 08:12 AM   #14
puddi
Human being with feelings
 
puddi's Avatar
 
Join Date: Jun 2018
Posts: 247
Default

Quote:
Originally Posted by serr View Post
1600 tracks. Reaper is still instantly responsive and all the track volume faders move together as one when scrolling the volume up/down with one of them with all tracks selected. On the laptop (2011 MBP 4x 2.5GHz (3.6GHz) i7 16GB).

Just duplicated to 6400 tracks. Still perfectly responsive.

Duplicated again to 12800 tracks. It took about 5 seconds for the new tracks to appear this time. Ever so slight choppy scroll if you look close. Still responsive and the faders still move together as one.


You should Licecap that.
puddi is offline   Reply With Quote
Old 07-20-2019, 09:27 AM   #15
strachupl
Human being with feelings
 
strachupl's Avatar
 
Join Date: Jan 2013
Posts: 394
Default

Quote:
Originally Posted by puddi View Post


You should Licecap that.
This. It would be very helpful if you show me how it works for you.
__________________
The truth is not in the middle but exactly where it is.
strachupl is offline   Reply With Quote
Old 07-21-2019, 11:29 AM   #16
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,669
Default

I'm using the latest dev version from July 17.

The CPU spikes quite high when I use >6000 tracks (RT CPU is high too), but with a bit higher of an audio buffer (which takes strain off the RT CPU) I can do this with 3000 tracks without it becoming sluggish. Beyond that even with a higher buffer size I notice the faders are a bit laggy in their response, but they all do move simultaneously. Considering I'm using an i3 6300 that's not bad (I'd never run a project with that many tracks especially with a CPU like this).

I also tried it in my laptop with a lowly i5 2520m (your CPU is considerably better than this one) Windows 7 64-bit. It worked just as smoothly with 1000 tracks. At around 2000 tracks it was behaving sluggishly at my default driver settings (low-ish latency but not super low).

Reaper uses CPU to draw everything, not GPU. So this will require more CPU than any program which uses GPU. My CPU does spike during this and it scales with how many tracks I have added, but on my desktop (i3 6300) it only hits around 12% when I'm doing this with 1600 tracks (and my usual audio device buffer setting). It makes my laptop (i5 2520m) hit around 35% when doing this with the same number of tracks.

If your CPU is being bogged down in any way, the UI can get sluggish. This can be due to any number of things including any background processes that you're running, your audio driver settings in Reaper, if your CPU is being used up by a lot of plugins, your screen resolution, and so on. I'd say try these things:

-Enable Windows Aero again but disable the individual things you don't want active. I've found that sometimes helps the video driver work properly (disabling Aero entirely isn't necessarily a good thing).

-Switch anything in the Windows Power profile you need to, to keep the processor/USB/etc. from throttling or going to sleep (select "high performance" plan and/or go through it changing things).

-Try a stock Reaper theme just in case. (You didn't mention doing that yet.)

-Try higher buffer size settings for your audio driver. Running a very low blocksize (and number of periods) can demand more CPU. If you're trying to get the lowest latency possible, especially if the audio driver (or hardware) isn't the best, you might be hitting a limit. Compare driver settings with what you have in FL and replicate those in Reaper, for a start.

And the usual things to think about when it comes to running a DAW: disable anti-virus, close anything running in the background that you don't absolutely need, etc. But I guess this isn't much of a factor if FL works well for you (it's still worth investigating).

And try Latencymon or something like that, to see if there's anything messing with your system latency.
__________________
http://petersamplification.com
Using REAPER for Linux
JamesPeters is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:26 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.