Old 11-12-2019, 10:30 AM   #1
tulamide
Human being with feelings
 
Join Date: Jul 2011
Posts: 8
Default Specific channel grouping

When I have a drum plugin with several outs, Reaper automatically offers to create the tracks for me. That's awesome.

However, when it comes to grouping then, I always fail. I can get a group track and then have all tracks in this group, and it works fine. But that's counter-intuitive for me personally.

So, what I'm looking for is to have the track with the plugin and the midi data as the grouping track, with all audio tracks grouped under it. I've set this up automatically and manually, but each time I make the plugin track the (I think it is called "folder track", right?) group track, audio vanishes. Only if I have a seperate group track and place all audio tracks and the plugin track is it, that audio is present.

Any tips to make it works as I want?

More visual example:

+ My Awesome Drum Plugin (as audio sum of all below, but also playing the midi data)
----+ Kick track
----+ Snare track
----+ Hihats track (marked as group end)
+ Next non-dependend track
etc.
tulamide is offline   Reply With Quote
Old 11-12-2019, 10:46 AM   #2
nait
Human being with feelings
 
nait's Avatar
 
Join Date: Jun 2018
Location: Edmonton, AB, Canada
Posts: 546
Default

The reason audio vanishes is because the routing gets a little buggered when you have it in the way you're hoping to have it. It creates a feedback loop. Reaper responds, by default, by disabling the audio so you don't potentially blow your ears off I might be exaggerating.. I'm not sure! Anyways, the gist of whats happening when you do it how you want to is that your drum track routes MIDI/audio to the individual parts, and those parts route audio back to the MIDI track, creating a loop of the audio being sent from the midi track, to the parts, back to the MIDI track, and back to the parts, etc... I don't know if you can just disable the AUDIO in the routing from MIDI track to the individual parts and have it work, but I think others have said that still causes Reaper to shut down the audio. This is where turning off the setting for disabling audio feedback loop may work in combination with that - I'm not sure, but beware of opening the door for accidental feedback loops elsewhere.

Anywho, I do it the way it sounds like you consider counterintuitive, but it works, and you can still tuck things away as necessary, imo.

--> Drums Folder
-----> Drums MIDI
-----> Kick Track
-----> Snare Track
-----> Hats Track


You put all your MIDI on that one labeled Drums MIDI Folder. When you create a new track from some VSTi that sets up the routing for you, it will put everything all on the same level. Just create a new folder, and drag everything into that folder and it should work. What I presume you're doing is dragging all those individual parts under the MIDI folder, and that's where you get into trouble with the audio disabling. You can turn off the option to disable audio on a feedback loop, but I don't think you really want to do that.

It does sound like you don't like doing it that way, but that's the best way I've found to do it without fighting with routing and stuff.
__________________
My Rig (also serves as my gaming PC): Asus Z270A Prime Mobo, i7-6700k, 32GB RAM, Samsung 960 Evo 500gb NVMe, Crucial 1TB NVMe, NVidia GTX 1070, Scarlett Focusrite 2i2, Nektar Impact LX25+ MIDI Controller Keyboard.
nait is online now   Reply With Quote
Old 11-14-2019, 12:24 AM   #3
tulamide
Human being with feelings
 
Join Date: Jul 2011
Posts: 8
Default

Thank you!

The explanation makes sense, and honestly I didn't think of feedback issues. That might be counted as a compliment though (as in "with Reaper I can do whatever I want")

Your proposed (and probably typical) structure works just fine, so I will stick to it.

Thanks again!
tulamide is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:45 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.