Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 06-15-2021, 05:01 AM   #1
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 24,464
Default MIDI event list properties destroys events (FIXED)

Steps to reproduce:

1. Open MIDI editor, add a note (say middle C)
2. Add some CC #1 points in the CC lane
3. Open Event List and open MIDI filter
4. Filter by Control Change
5. Select all CC events
6. Right-click, open Event Properties
7. Change all these CC events to poly aftertouch events belonging to middle C
8. Apply the changes

Result: these events disappear, conversion to poly aftertouch events fails hard. This doesn't happen if MIDI filter is disabled, apparently (but then this makes filtering MIDI CCs and converting them to poly AT events extremely difficult - and we have no other sane way of editing poly AT events in Reaper... See the first link in my signature for the best possible solution! )


What gives?


EDIT: Seems that doing any event properties changes when the filter is active has destructive tendencies and it just removes those events when applying the property changes! Pretty, pretty bad.

Last edited by EvilDragon; 06-15-2021 at 05:09 AM.
EvilDragon is online now   Reply With Quote
Old 06-15-2021, 07:47 AM   #2
vitalker
Human being with feelings
 
vitalker's Avatar
 
Join Date: Dec 2012
Posts: 7,769
Default

Quote:
Originally Posted by EvilDragon View Post
EDIT: Seems that doing any event properties changes when the filter is active has destructive tendencies and it just removes those events when applying the property changes! Pretty, pretty bad.
I've got the same behaviour with a project from this thread: https://forum.cockos.com/showthread.php?t=253840
vitalker is online now   Reply With Quote
Old 06-15-2021, 09:40 AM   #3
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 24,464
Default

Yeah, it happens from a completely fresh empty project. There's something borked about MIDI filter being enabled when changing event properties.

A real nasty bug.
EvilDragon is online now   Reply With Quote
Old 06-17-2021, 12:48 AM   #4
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 24,464
Default

Bump!


This is a workflow hazard.
EvilDragon is online now   Reply With Quote
Old 06-20-2021, 03:55 AM   #5
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 24,464
Default

And another bump! schwa, Justin, hopefully easy fix, right?
EvilDragon is online now   Reply With Quote
Old 06-20-2021, 09:19 AM   #6
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 13,641
Default

Edit: Fixing!

Last edited by Justin; 06-20-2021 at 09:34 AM.
Justin is offline   Reply With Quote
Old 06-20-2021, 10:44 PM   #7
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 24,464
Default

Thank you!
EvilDragon is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:27 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.