Old 11-02-2017, 12:13 PM   #4241
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by Arthur McArthur View Post
The FX routing is beautiful, Leon. Will save me many hours when making multi-channel FX strips. Cheers!
Glad you like it - plan to add receives in there at some point too. Anything else you can think of - let me know.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-02-2017, 12:17 PM   #4242
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by RJHollins View Post
ahh yes.

Something else that has changed. We used to be able to select 2 [or more] elements, and then use the ALIGN option. I've changed the SETUP option, but this ability does not seem to work anymore.

thx
arghhh! - will look into when I get a mo.

Not about too much tomorrow - running sound for a music event in the hall (in attached picture). Not looking too forward to it - the acoustics are a nightmare!! Not got high hopes for the rock band playing - but the choir and acoustic stuff should be ok...

But that is (the legendary) King Arthur's round table on the wall...
Attached Images
File Type: jpg Great-Hall-Winchester.jpg (28.0 KB, 34 views)
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-02-2017, 12:25 PM   #4243
Arthur McArthur
Human being with feelings
 
Join Date: Sep 2016
Location: Toronto
Posts: 389
Default

Great! A few thoughts from my first run through with it:

-lock the window in place to the upper left
-shift-mouseweheel scrolls horizontally
-a quick way or button to remove all connections for a plugin instance
-shift or control-click on input or output nodes writes changes for both input and output

The workflow I'm imagining is:

Make track, increase channel count, add plugin, press button to remove all connections for plugin, control click on 1&2 to add inputs and outputs, then on to adding the next plugin etc
Arthur McArthur is offline   Reply With Quote
Old 11-02-2017, 01:21 PM   #4244
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by RJHollins View Post
ahh yes.

Something else that has changed. We used to be able to select 2 [or more] elements, and then use the ALIGN option. I've changed the SETUP option, but this ability does not seem to work anymore.

thx
hmmm... just tested the align commands under fx edit mode - seems to work ok here... How is it not working for you..? And what setup option?

EDIT: If you mean the Simple select group option. You can still use alignment with or without this option on. If it's activated - you can just use Ctrl+click to add individual controls to selection - then use the align options. When deactivated - it should work as it always has. I'm not having any difficulty here - testing with your strip.

EDIT2:

Update fixes ctrl-click to default value bug
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 11-02-2017 at 01:49 PM.
lb0 is online now   Reply With Quote
Old 11-02-2017, 03:55 PM   #4245
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by Arthur McArthur View Post
Great! A few thoughts from my first run through with it:

-lock the window in place to the upper left
-shift-mouseweheel scrolls horizontally
-a quick way or button to remove all connections for a plugin instance
-shift or control-click on input or output nodes writes changes for both input and output

The workflow I'm imagining is:

Make track, increase channel count, add plugin, press button to remove all connections for plugin, control click on 1&2 to add inputs and outputs, then on to adding the next plugin etc
All sounds doable Will be onto it in the next few days.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-02-2017, 05:13 PM   #4246
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Another feature I forgot about I added a week or so back was the default plugin strip.

Say like me - you have old projects or even new ones but added plugins via the mixer that don't appear in Stripper. Well - for single plugin strips - you can set a default strip for that plugin (only works for strips containing a single plugin thus far).

So now you can right-click on the plugin name in the list in FX EDIT mode - and it will allow you to drag in the strip that's been set as default for that plugin - but it just connects to the already existing plugin instead of loading a new one.

To set a strip as default for a particular plugin - just right-click the strip name (in the strips list in STRIP EDIT mode) and choose the new option at the bottom. It will tell you if the strip isn't suitable (if it contains more than one plugin).

So this makes it easier if the plugin is already loaded in the track to add it to Stripper. The best way before to do it was to drag the strip in and then reassign the controls and deleting the newly loaded plugin - but this way is quicker and easier.

Of course I've thought about doing similar for multi plugin strips - but this is somewhat more complex so maybe a project for the future... So for now - if you find yourself in this situation - you will still have to do the manual reassignment of the plugins as before.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-02-2017, 09:56 PM   #4247
RJHollins
Human being with feelings
 
Join Date: Dec 2011
Posts: 1,221
Default

Quote:
Originally Posted by lb0 View Post
hmmm... just tested the align commands under fx edit mode - seems to work ok here... How is it not working for you..? And what setup option?

EDIT: If you mean the Simple select group option. You can still use alignment with or without this option on. If it's activated - you can just use Ctrl+click to add individual controls to selection - then use the align options. When deactivated - it should work as it always has. I'm not having any difficulty here - testing with your strip.

EDIT2:

Update fixes ctrl-click to default value bug
hmmm ... the simple select group ... you are correct, sir. It IS now working. I have no explanation for what was going on before ... but, importantly, it is working correct.

Also confirming that the DEFAULT RESETS are now working again. Thanks for the fixes.

2. Interesting photo you posted. It would seem 'nice' for an acoustic or vocal group. A 'Rock Band' ... oh my. I feel the trepidation. :|
RJHollins is offline   Reply With Quote
Old 11-03-2017, 01:53 AM   #4248
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by RJHollins View Post
hmmm ... the simple select group ... you are correct, sir. It IS now working. I have no explanation for what was going on before ... but, importantly, it is working correct.

Also confirming that the DEFAULT RESETS are now working again. Thanks for the fixes.

2. Interesting photo you posted. It would seem 'nice' for an acoustic or vocal group. A 'Rock Band' ... oh my. I feel the trepidation. :|
Well - as always - let me know if it happens again - maybe something triggered it into not working temporarily for some reason.

Glad everything else seems fixed

2. Yes - My normal technique for this hall is to place 4 speakers around the hall (at low volume) so people sat at the back get decentish sound - but the venue have now told me it's not possible to plug everything into the same end (under the round table as planned), so I have to run 2 separate PA's (one at either end) - so the Jazz and Rock bands will be one end, and the show choir and acoustic set at the other. So unfortunately for those sitting farthest away it's going to be an echoey mess. But I've voiced my concerns and that's all I can do.

Fortunately - I have 4 Bose L1 II systems to use for the main PAs - which have quite a wide arc for direct sound distribution and work reasonably well in this hall...

But yeah - the Rock band aren't going to sound great as soon as you move farther than 10 metres away!

BTW - the picture doesn't really represent the actual scale of the space - those doors in the picture are about 4+ metres tall!!
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-03-2017, 12:01 PM   #4249
Arthur McArthur
Human being with feelings
 
Join Date: Sep 2016
Location: Toronto
Posts: 389
Default

Quote:
Originally Posted by lb0 View Post
Another feature I forgot about I added a week or so back was the default plugin strip.
Very useful! Thanks for this feature. A cool extension of it would be an automatic mode that automatically adds all missing strips for all plugins on the track.
Arthur McArthur is offline   Reply With Quote
Old 11-03-2017, 04:27 PM   #4250
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by Arthur McArthur View Post
Very useful! Thanks for this feature. A cool extension of it would be an automatic mode that automatically adds all missing strips for all plugins on the track.
Something I've thought about doing...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-03-2017, 10:10 PM   #4251
RJHollins
Human being with feelings
 
Join Date: Dec 2011
Posts: 1,221
Default

Hi lb0,

I've found an issue with the 'default rest' function.

1. The knobs in question 'seem' to be the FREQ knobs [why I don't know].

2. Doing a Cntrl-Clk DOES reset the KNOB .... but ...

The NUMERIC display I have positioned ON the knob does not always reset to the default value. If I Cntrl-Clk again, it finally does.

It seems a 're-draw' is missing.

EDIT

In fact, it appears that just clicking on the knob afterward redraws the correct value.

hope this is clear to understand.

thx
RJHollins is offline   Reply With Quote
Old 11-04-2017, 03:29 AM   #4252
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by RJHollins View Post
Hi lb0,

I've found an issue with the 'default rest' function.

1. The knobs in question 'seem' to be the FREQ knobs [why I don't know].

2. Doing a Cntrl-Clk DOES reset the KNOB .... but ...

The NUMERIC display I have positioned ON the knob does not always reset to the default value. If I Cntrl-Clk again, it finally does.

It seems a 're-draw' is missing.

EDIT

In fact, it appears that just clicking on the knob afterward redraws the correct value.

hope this is clear to understand.

thx
Only happens for me when Nebula instance is bypassed.

Can you confirm?

Problem here - is that when Nebula is bypassed - it is much slower internally to update it's internal values (hence why clicking again works to display the correct value). EDIT: This is likely an internal Nebula optimisation to make it more efficient when the plugin is bypassed.

If this is happening when the plugin is enabled - I can only think it's a similar problem - the values are internally not updated (in Nebula) before Stripper requests the value. This may be library dependent - or it may depend on the overall CPU load going on at the time maybe (maybe Nebula is not running optimally if your project contains loads of instances)

What library is causing the issue - or is it all libraries. I could add some sort of delay before requesting the updated value - but it would likely make the control updates sluggish. I'll have a think.

EDIT2: BUG FOUND! Fixed
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 11-04-2017 at 05:37 AM.
lb0 is online now   Reply With Quote
Old 11-04-2017, 10:15 AM   #4253
RJHollins
Human being with feelings
 
Join Date: Dec 2011
Posts: 1,221
Default

"If this is happening when the plugin is enabled - I can only think it's a similar problem"

THIS !

The library is the SURGE-eQ. and yes, it is a dense library, with spectacular sound
RJHollins is offline   Reply With Quote
Old 11-04-2017, 10:23 AM   #4254
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by RJHollins View Post
"If this is happening when the plugin is enabled - I can only think it's a similar problem"

THIS !

The library is the SURGE-eQ. and yes, it is a dense library, with spectacular sound
Well - hopefully it should always display the correct value now - enabled or bypassed.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-04-2017, 11:06 AM   #4255
RJHollins
Human being with feelings
 
Join Date: Dec 2011
Posts: 1,221
Default

Quote:
Originally Posted by lb0 View Post
Well - hopefully it should always display the correct value now - enabled or bypassed.
Yeah ... just tested with SURGE. She be workin' again !

Thx lb0
RJHollins is offline   Reply With Quote
Old 11-04-2017, 01:29 PM   #4256
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by RJHollins View Post
Yeah ... just tested with SURGE. She be workin' again !

Thx lb0
Just need Timbral to check his midi matrix again - as it was the fix I did for him which added a small bug - so need to ensure it still works ok for plugins that don't have a formatted string...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-04-2017, 01:53 PM   #4257
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,549
Default

is this is what you waiting for?


EDIT:
also made a quick test with NSA Granite .. works fine!
timbralzoom is offline   Reply With Quote
Old 11-04-2017, 02:13 PM   #4258
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by timbralzoom View Post
is this is what you waiting for?


EDIT:
also made a quick test with NSA Granite .. works fine!
Thanks for confirming. Was just a small logic error I made. Something which would work fine in VB, but needs to be parenthesized or written using different syntax in Lua.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-04-2017, 02:20 PM   #4259
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,549
Default

that's why we are here
& Thank you!

and
here is the v3 Final Sharestrip & VST(x86)
https://drive.google.com/open?id=1sv...QrY0CSSvl1riBo
i hope you found it useful!

Last edited by timbralzoom; 11-04-2017 at 03:01 PM.
timbralzoom is offline   Reply With Quote
Old 11-04-2017, 04:22 PM   #4260
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by timbralzoom View Post
that's why we are here
& Thank you!

and
here is the v3 Final Sharestrip & VST(x86)
https://drive.google.com/open?id=1sv...QrY0CSSvl1riBo
i hope you found it useful!
and thank you for the strip. Will give it a whirl when I next get some leisure time!
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-05-2017, 06:07 PM   #4261
ThrashJazzAssassin
Human being with feelings
 
ThrashJazzAssassin's Avatar
 
Join Date: Oct 2010
Location: Scotland
Posts: 285
Default

When 6% through loading strip data... on a big old project with loads of tracks/strips:

Code:
LBX Stripper.lua:42518: attempt to perform arithmetic on a nil value (field 'w')
Line 42518 is: strip.controls[c].xsc = math.floor(strip.controls[c].x + strip.controls[c].w/2 - (strip.controls[c].w*strip.controls[c].scale)/2)

[EDIT] .lbxstripper file: https://drive.google.com/file/d/0B_-...ew?usp=sharing
__________________
REAPER-OSC-panels
erthoide

Last edited by ThrashJazzAssassin; 11-05-2017 at 06:33 PM.
ThrashJazzAssassin is online now   Reply With Quote
Old 11-06-2017, 02:36 AM   #4262
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by ThrashJazzAssassin View Post
When 6% through loading strip data... on a big old project with loads of tracks/strips:

Code:
LBX Stripper.lua:42518: attempt to perform arithmetic on a nil value (field 'w')
Line 42518 is: strip.controls[c].xsc = math.floor(strip.controls[c].x + strip.controls[c].w/2 - (strip.controls[c].w*strip.controls[c].scale)/2)

[EDIT] .lbxstripper file: https://drive.google.com/file/d/0B_-...ew?usp=sharing
I cannot see anything wrong with the lbxstripper file. Remember - though that projects may use a lbxstripper__ file too (depending on how the project was saved (with stripper open or closed).

I'm guessing the problem file is the __ one.

So a few things to try.

1. Make sure you back up both the lbxstripper and lbxstripper__ files.

2. Rename or delete the lbxstripper__ file for the project. Either stripper will prompt for a new file, or instantiate an empty stripper.

3. In Stripper - Go to ... menu -> Script Data -> Load Data File.

4. Find the lbxstripper file that you sent me - and load it. Does this load ok?

If this doesn't work - and the project is so old you don't have a lbxbak file - then could you send me the rpp file? I don't need any of the items or anything - just the rpp file to try and load the data.

Also could you send me the lbxstripper__ file associated with the project.

If you DO have a lbxbak file - try loading this from the Script Data part of the menu.

The only problem I see with reloading the lbxstripper file instead of the lbxstripper__ file - is that any tweaks to the layout that you made between a save within Stripper and a save with stripper closed (or closing down reaper) - may be lost... Hopefully that's not much - and if it's just plugin parameter tweaks - then this won't affect anything as they will refresh as soon as stripper runs.

BUT PLEASE ENSURE TO BACKUP ALL Stripper DATA FILES BEFORE DOING ANY OF THIS!

EDIT: If you still get errors - even with the lbxstripper data file - then email me the rpp like I said earlier as I need to identify exactly what data is missing from the file (but like I said - looks ok from scanning through the file - but obviously it's a large amount of data and hard to propery check without being able to load it into Stripper (ie. without the rpp file)).
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-06-2017, 07:42 AM   #4263
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Update: Fixed error in control value updating.

If anyone is running a version of Stripper from the last week or so - I'd recommend an update to the latest version which fixes an error which will make controls referencing parameters from a plugin on a different track behave weirdly.

Oops - sorry. Anyway - is fixed.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-06-2017, 07:54 AM   #4264
ThrashJazzAssassin
Human being with feelings
 
ThrashJazzAssassin's Avatar
 
Join Date: Oct 2010
Location: Scotland
Posts: 285
Default

Thanks a lot Leon. Deleting the lbxstripper__ done the trick

This was its contents:
Code:
[version]0.95
[stripcount]1
[strip_s1_page]1
[strip_s1_track_name]
[strip_s1_track_guid]{118F5CD0-6BFC-4609-8A15-976F4BCEBD2D}
[strip_s1_track_num]13
[strip_s1_track_strip]1
[strip_s1_p1_surface_x]0.0
[strip_s1_p1_surface_y]0.0
[strip_s1_p1_controls_count]342
[strip_s1_p1_graphics_count]2
__________________
REAPER-OSC-panels
erthoide
ThrashJazzAssassin is online now   Reply With Quote
Old 11-06-2017, 08:06 AM   #4265
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by ThrashJazzAssassin View Post
Thanks a lot Leon. Deleting the lbxstripper__ done the trick

This was its contents:
Code:
[version]0.95
[stripcount]1
[strip_s1_page]1
[strip_s1_track_name]
[strip_s1_track_guid]{118F5CD0-6BFC-4609-8A15-976F4BCEBD2D}
[strip_s1_track_num]13
[strip_s1_track_strip]1
[strip_s1_p1_surface_x]0.0
[strip_s1_p1_surface_y]0.0
[strip_s1_p1_controls_count]342
[strip_s1_p1_graphics_count]2
Ah yes - looks like it's missing some data!!

A very good reason to always ensure the backups are working and being made.

I plan to revisit the saving of data - making a temporary backup before saving the current data - because if anything goes wrong whilst saving - (ie a crash happens) - then the save data file ends up corrupted. Then only deleting the temporary backup if saving completes ok.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-07-2017, 01:28 AM   #4266
Hamulus
Human being with feelings
 
Join Date: Oct 2009
Posts: 24
Default

Hi!
I follow this instruction to create XY morph
https://www.youtube.com/watch?v=713elb70KT0

But when I drag asterix (dot on video) I get this control instead of XY
So snapshots can be switched but not morphed


Attached Images
File Type: jpg LBX.jpg (3.5 KB, 254 views)

Last edited by Hamulus; 11-07-2017 at 01:39 AM.
Hamulus is offline   Reply With Quote
Old 11-07-2017, 01:41 AM   #4267
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by Hamulus View Post
Hi!
I follow this instruction to create XY morph
https://www.youtube.com/watch?v=713elb70KT0

But when I drag asterix (dot on video) I get this control instead of XY
So snapshots can be switched but not morphed


Hi,

XY Control only works on a subset - so first create a subset and add the controls you want to the subset (using Learn Ctls).

Judging from your screenshot - you've already done above bit -

So just Shift+Drag the * button.

EDIT: Also - you have the MetaLite XY controller - to allow for even more versatile morphing of snapshots
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-07-2017, 01:44 AM   #4268
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,549
Default

EDIT:
Hi & do what The Boss says

Last edited by timbralzoom; 11-07-2017 at 02:16 AM.
timbralzoom is offline   Reply With Quote
Old 11-07-2017, 03:16 AM   #4269
Hamulus
Human being with feelings
 
Join Date: Oct 2009
Posts: 24
Default

Shift+Drag helped me, thanks!

By the way, as I understood, I can automate morphing only using MetaLite, but standard XY controller cannot be automated, right?
But it requires missed plugin
Faderbox JSFX

https://forum.cockos.com/showpost.ph...postcount=2043
https://forum.cockos.com/showpost.ph...06&postcount=2

File not found

could you plase tell me where I can find it

Last edited by Hamulus; 11-07-2017 at 03:33 AM.
Hamulus is offline   Reply With Quote
Old 11-07-2017, 03:58 AM   #4270
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by Hamulus View Post
Shift+Drag helped me, thanks!

By the way, as I understood, I can automate morphing only using MetaLite, but standard XY controller cannot be automated, right?
But it requires missed plugin
Faderbox JSFX

https://forum.cockos.com/showpost.ph...postcount=2043
https://forum.cockos.com/showpost.ph...06&postcount=2

File not found

could you plase tell me where I can find it
It's on LBX Stripper github:

LBX-FaderBox(32x)
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-07-2017, 08:23 AM   #4271
Hamulus
Human being with feelings
 
Join Date: Oct 2009
Posts: 24
Default

thanks, it works perfectly!
really great script
Hamulus is offline   Reply With Quote
Old 11-07-2017, 10:17 AM   #4272
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by Hamulus View Post
thanks, it works perfectly!
really great script
Thanks. Just remember - for the automation to work - Stripper must be running. And you either need to render in realtime - or write the parameter morphing to envelopes before rendering.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-10-2017, 07:16 PM   #4273
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,549
Default

Hi there

i am trying a little weird replacement of "Chord Track"
with Midi Force To Key (insertpizhere) plugins and Linker JS for linking plugin parameters
in different tracks


first.. a question
-is it possible to make plugins of the strip put always top of the fx chain (optionally)
as like Take Switcher does for LBX_Track Utility JS ?

basic video:
https://drive.google.com/open?id=1Ya...mcMkgF95XY_CwC

idea:
two strip
one Master .. this will rule all the Slaves
second Slave .. you can multiple it in many tracks as you need
in the Master strip channel Plugin parameters rules the JS Linker parameters
in the Slave channels Linker parameters rules the plugin parameters
all linked via Reaper Parameter modulation.
and all works in the Strip prepare project

now the problematic part
saving and loading FX Chain has no problem
but the Strips somehow drops the parameter modulation/links
only first 22 parameter links working in the Master strip (it has 23 )
and the Slave Strip drops all links..

i have of course no idea is it bug or something that belongs to area that we have no total control in it (API ? )
anyway ..still no wacky idea yet but i think this would count too

final..
i updated two days ago ..should start to hunt for eggs or it was just internal things?

Last edited by timbralzoom; 11-10-2017 at 07:23 PM.
timbralzoom is offline   Reply With Quote
Old 11-11-2017, 12:56 AM   #4274
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by timbralzoom View Post
Hi there

i am trying a little weird replacement of "Chord Track"
with Midi Force To Key (insertpizhere) plugins and Linker JS for linking plugin parameters
in different tracks


first.. a question
-is it possible to make plugins of the strip put always top of the fx chain (optionally)
as like Take Switcher does for LBX_Track Utility JS ?

basic video:
https://drive.google.com/open?id=1Ya...mcMkgF95XY_CwC

idea:
two strip
one Master .. this will rule all the Slaves
second Slave .. you can multiple it in many tracks as you need
in the Master strip channel Plugin parameters rules the JS Linker parameters
in the Slave channels Linker parameters rules the plugin parameters
all linked via Reaper Parameter modulation.
and all works in the Strip prepare project

now the problematic part
saving and loading FX Chain has no problem
but the Strips somehow drops the parameter modulation/links
only first 22 parameter links working in the Master strip (it has 23 )
and the Slave Strip drops all links..

i have of course no idea is it bug or something that belongs to area that we have no total control in it (API ? )
anyway ..still no wacky idea yet but i think this would count too

final..
i updated two days ago ..should start to hunt for eggs or it was just internal things?
last update was bug fix only.

It would be possible to add a strips fx to beginning of the strip as an option - will think about it.

Regarding losing param links - not really looked into that in strips. Think it could get pretty complex but will look into when i get some time. Can I have copies of the strips to test with?
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-11-2017, 05:35 AM   #4275
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,549
Default

done & nothing urgent

EDIT:
i found the fix

just changing slots of Linker JS plugins did the job done..
-in the Master track: i put Linker JS after the plugins
-in the Slave track: before the plugins
and saved strips..both strips and all parameters loads fine now!

please just ignore the report!

EDIT2:
&
https://drive.google.com/open?id=1Vb...URpkixxBx43EPP

Last edited by timbralzoom; 11-11-2017 at 08:14 AM.
timbralzoom is offline   Reply With Quote
Old 11-11-2017, 10:56 AM   #4276
eugen2777
Human being with feelings
 
eugen2777's Avatar
 
Join Date: Aug 2012
Posts: 270
Default

lb0, Look at this point.
https://forum.cockos.com/showpost.ph...3&postcount=21
For fix - You can set the chunk twice.
The first time - without PARENV, the second time - with PARENV.
This has almost no effect on performance (~ 10%).
__________________
ReaScripts
eugen2777 is offline   Reply With Quote
Old 11-11-2017, 01:35 PM   #4277
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by eugen2777 View Post
lb0, Look at this point.
https://forum.cockos.com/showpost.ph...3&postcount=21
For fix - You can set the chunk twice.
The first time - without PARENV, the second time - with PARENV.
This has almost no effect on performance (~ 10%).
Thanks for looking into Eugen. Do I understand correctly - if I want to set the chunk with data that includes a PARENV section - I should first remove the PARENV section - add to chunk - then set the chunk a second time with the chunk data that includes the PARENV section??

Sounds odd - but I guess an initialization thing when adding new plugins via the chunk, the plugin needs to already exist before the Parameter Modulation can exist?

EDIT: Just to confirm - your fix works brilliantly. Got a few places to insert it in the code - so will update Stripper script accordingly soon.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 11-11-2017 at 04:57 PM.
lb0 is online now   Reply With Quote
Old 11-11-2017, 03:06 PM   #4278
deeb
Human being with feelings
 
deeb's Avatar
 
Join Date: Feb 2017
Posts: 1,818
Default

i am sorry i can't get this working i keep getting this message:

Code:
Please ensure you have the: 

__default
SimpleFlat_48
SimpleFlat_96
SimpleFlat2_96
__Snapshot
__XY
__XYTarget
SimpleBox_9632
Switcher

files in your LBXCS_resources/controls/ folder.
You can get these files from the LBX Stripper project on github - in the LBXCS_resources zip file
I am on OSX 10.9.5
Resources files are in
Reaper/Scripts/LBX/LBXCS_resources

Reaper/Scripts/LBX/LBXCS_resources/controls has all the requested files but not without the extension. Example there is: __default.knb and __default.png

anyone? What am i missing ?
deeb is offline   Reply With Quote
Old 11-11-2017, 03:35 PM   #4279
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 2,681
Default

Quote:
Originally Posted by deeb View Post
i am sorry i can't get this working i keep getting this message:

Code:
Please ensure you have the: 

__default
SimpleFlat_48
SimpleFlat_96
SimpleFlat2_96
__Snapshot
__XY
__XYTarget
SimpleBox_9632
Switcher

files in your LBXCS_resources/controls/ folder.
You can get these files from the LBX Stripper project on github - in the LBXCS_resources zip file
I am on OSX 10.9.5
Resources files are in
Reaper/Scripts/LBX/LBXCS_resources

Reaper/Scripts/LBX/LBXCS_resources/controls has all the requested files but not without the extension. Example there is: __default.knb and __default.png

anyone? What am i missing ?
Hmmm.

Sounds like they're in the right place.

That message should only show if any are missing or in the wrong place. You need knb and png files for all the listed controls. Can you double check there isn't one missing or named incorrectly? (Although I assume you've just copied the zip folder)

I'm not on Mac - but as far as I know - a number of people are who are successfully using the script.

Are you any good at following the code? You'll find that error message and the calls to LoadControl right at the end of the code. Just before the error message code check - and after the LoadControl function calls you could add the lines:

DBG(paths.controls_path)
DBG(def_knob)
DBG(def_knobsm)
DBG(def_snapshot)
DBG(def_xy)
DBG(def_xytarget)
DBG(def_eqcknobf)
DBG(def_eqcknobg)
DBG(def_box)
DBG(def_switch)

Run again and post the results here (you can copy and paste from the console window).

If any of the items are returning -1 - then that control cannot be found. If they all are -1 = then likely they are not in the correct place - or something in the OS is preventing them being read.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 11-11-2017, 04:25 PM   #4280
deeb
Human being with feelings
 
deeb's Avatar
 
Join Date: Feb 2017
Posts: 1,818
Default

Sorry sorry sorry it is my problem i was using Reaper/Script/Stable/LBX so not Reaper/Script/LBX

Last edited by deeb; 11-11-2017 at 04:33 PM.
deeb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:59 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.