Old 06-22-2019, 04:11 PM   #1
EMK
Human being with feelings
 
Join Date: Feb 2019
Posts: 36
Default Is FL Studio faster than Reaper on Mac?

When I click and drag an object fast with the mouse in Reaper, the cursor looses the initial position it grabbed the object. For me, this makes Reaper feel much slower than FL Studio. Is there a solution to this problem?



I posted this in the General Discussion, and apparently this is not a problem for the people that replied so far (Linux and Windows). It was suggested that this might be a Mac specific problem.
https://forum.cockos.com/showthread.php?t=222261


MacBook Pro mid 2016
Mojave 10.14.5
EMK is offline   Reply With Quote
Old 06-22-2019, 04:40 PM   #2
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,667
Default

I wonder if your theme's font choice has something to do with this.

See this post. You might want to choose different fonts for the theme or try a default theme to see if the problem goes away.
__________________
http://petersamplification.com
Using REAPER for Linux
JamesPeters is offline   Reply With Quote
Old 06-22-2019, 04:51 PM   #3
EMK
Human being with feelings
 
Join Date: Feb 2019
Posts: 36
Default

Quote:
Originally Posted by JamesPeters View Post
I wonder if your theme's font choice has something to do with this.

See this post. You might want to choose different fonts for the theme or try a default theme to see if the problem goes away.
I tried changing to the Default theme and Commala 5, but the problem was still there. I don't know how to change the font. But I will search.
EMK is offline   Reply With Quote
Old 06-22-2019, 06:01 PM   #4
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,667
Default

Quote:
Originally Posted by EMK View Post
I tried changing to the Default theme and Commala 5, but the problem was still there. I don't know how to change the font. But I will search.
From the Actions list, run Theme tweak/configuration window (use the filter at the top of the action list and use the word "tweak", it'll show up).

At the top of the Theme tweak/configuration window, filter for the word "font". You can change all of the fonts for the current theme that way. Your settings will not be saved with the theme unless you chose to save the theme (and you can save it to a new file if you want). If you don't save the settings, all you have to do is switch themes and those settings you changed will be gone.

As for how to change the font of the menu in MacOS, I don't know that since I don't use a Mac. However I can guess that it'd be in the font settings for the OS (since Reaper's menu seems to use fonts from the OS by default, except in Linux). So you'd be changing the fonts for your windows in the OS itself.
__________________
http://petersamplification.com
Using REAPER for Linux
JamesPeters is offline   Reply With Quote
Old 06-23-2019, 07:10 PM   #5
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,537
Default

I think this might be related to the tooltip.

In preferences>Appearance you can set a tooltip delay, or disable them completely.

on mac it used to be that having 'tooltips for UI elements' would cause serious lag moving the mixer faders. today it's making no difference on my system.
Anyway I hope that info helps
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 06-26-2019, 06:30 PM   #6
EMK
Human being with feelings
 
Join Date: Feb 2019
Posts: 36
Default

Quote:
Originally Posted by JamesPeters View Post
At the top of the Theme tweak/configuration window, filter for the word "font". You can change all of the fonts for the current theme that way. Your settings will not be saved with the theme unless you chose to save the theme (and you can save it to a new file if you want). If you don't save the settings, all you have to do is switch themes and those settings you changed will be gone.

As for how to change the font of the menu in MacOS, I don't know that since I don't use a Mac. However I can guess that it'd be in the font settings for the OS (since Reaper's menu seems to use fonts from the OS by default, except in Linux). So you'd be changing the fonts for your windows in the OS itself.
Thanks for the description. I tried to change every font to Arial, but the problem is still there.

Quote:
Originally Posted by EpicSounds View Post
I think this might be related to the tooltip.

In preferences>Appearance you can set a tooltip delay, or disable them completely.

on mac it used to be that having 'tooltips for UI elements' would cause serious lag moving the mixer faders. today it's making no difference on my system.
Anyway I hope that info helps
I disabled the tooltip delay, and I also disabled "Mouse click/edit in track view changes track selection". They don't seem to affect the result on my computer.

EMK is offline   Reply With Quote
Old 06-26-2019, 06:42 PM   #7
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,667
Default

Do you have an unusual pointer device (mouse etc.) or any unusual/custom settings for it? It's a stab in the dark...
__________________
http://petersamplification.com
Using REAPER for Linux
JamesPeters is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:37 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.