Old 07-11-2019, 05:11 AM   #1
barrettisgold
Human being with feelings
 
Join Date: Jul 2012
Location: UK
Posts: 12
Default Video Render - 1 frame out

If I lay back a stereo master wav to a video film the export is 1 frame out, delayed from the master.

Does this happen for anyone else?

Please see the screen shot:

Track 1 - Video from the editor which I will use to export (audio is a wip mix supplied by me)
Track 2 - Master stereo wav I have created
Track 3 - MOV render of the above two tracks (audio from video muted) from Reaper. 1 frame out.
Track 4 - Render of the Master stereo wav as a wav, fine.

I hope that makes sense! I have tried this on other projects with different videos and get the same result.

I have searched the forum and not found any posts regarding this. Forgive me if I have missed this, please point me in the right direction if you are aware of it.

Thanks for any help!

Tom

barrettisgold is offline   Reply With Quote
Old 07-14-2019, 07:18 AM   #2
Eliseat
Human being with feelings
 
Eliseat's Avatar
 
Join Date: Mar 2018
Location: Cologne
Posts: 1,167
Default

Seems strange. But I don't get why you would render the video to .mov without audio in the first place. Or do you mean if you export it with audio, the video then is one frame behind? If that's the case, it looks like a bug.
__________________
☆.。.:*・°☆.。.:*・°☆.。.:*・°☆REAPER//✿◔‿◔)°☆.。.:*・°☆.。.:*・°☆
Eliseat is offline   Reply With Quote
Old 07-16-2019, 09:37 AM   #3
barrettisgold
Human being with feelings
 
Join Date: Jul 2012
Location: UK
Posts: 12
Default

Quote:
Originally Posted by Eliseat View Post
Seems strange. But I don't get why you would render the video to .mov without audio in the first place. Or do you mean if you export it with audio, the video then is one frame behind? If that's the case, it looks like a bug.
The audio is in place and synced when playing in Reaper. On export the audio is delayed by 1 frame. The screenshot shows this when the exported mov is then brought into a Reaper project.

I've tried this on two computers and get the same results.


Eliseat - Have you tried it?
barrettisgold is offline   Reply With Quote
Old 07-16-2019, 12:32 PM   #4
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 5,405
Default

I just tried it with a video that I'm working on. I rendered the video (MOV, H.264, 30fps, 24 bit PCM) and then brought the render into the same project. Doing a null test, the audio nulls perfectly, so the one frame delay you experience does not happen here (Reaper v5.980/x64, W/x64).

Could it be problem with PDC, somehow?
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is offline   Reply With Quote
Old 07-17-2019, 04:54 AM   #5
barrettisgold
Human being with feelings
 
Join Date: Jul 2012
Location: UK
Posts: 12
Default

Quote:
Originally Posted by Fabian View Post
I just tried it with a video that I'm working on. I rendered the video (MOV, H.264, 30fps, 24 bit PCM) and then brought the render into the same project. Doing a null test, the audio nulls perfectly, so the one frame delay you experience does not happen here (Reaper v5.980/x64, W/x64).

Could it be problem with PDC, somehow?
Good shout Fabian! Appreciate your help.

I was running out a MOV with AAC audio. I just did a test again, both with AAC and PCM. PCM was spot on, AAC was a frame out. So it looks like it is to do with the codec. Could you try with AAC please? You may not have that option as you are Windows. I'm using the AVfoundation option when exporting.

(Reaper v5.979/64, Mac OS Mojave)
barrettisgold is offline   Reply With Quote
Old 07-17-2019, 10:13 AM   #6
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 5,405
Default

OK, I rendered with the following settings

and it is still fully in sync with the original. It doesn't null, of course, but the transients are at exactly the same places for the original and the rendered.
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is offline   Reply With Quote
Old 07-17-2019, 10:29 AM   #7
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 24,572
Default

Quote:
Originally Posted by Fabian View Post
It doesn't null, of course, but the transients are at exactly the same places for the original and the rendered.
If you change the audio output to PCM instead of AAC/128 it should null (random aside).
__________________
If it requires a null test to find it, it is by definition minuscule.
karbomusic is offline   Reply With Quote
Old 07-17-2019, 10:36 AM   #8
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 5,405
Default

Quote:
Originally Posted by karbomusic View Post
If you change the audio output to PCM instead of AAC/128 it should null (random aside).
As already mentioned in my post #4 (https://forum.cockos.com/showpost.ph...66&postcount=4) above
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is offline   Reply With Quote
Old 07-17-2019, 10:37 AM   #9
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 24,572
Default

Now I have to actually read and pay attention.
__________________
If it requires a null test to find it, it is by definition minuscule.
karbomusic is offline   Reply With Quote
Old 07-23-2019, 05:48 AM   #10
barrettisgold
Human being with feelings
 
Join Date: Jul 2012
Location: UK
Posts: 12
Thumbs up

Quote:
Originally Posted by Fabian View Post
OK, I rendered with the following settings

and it is still fully in sync with the original. It doesn't null, of course, but the transients are at exactly the same places for the original and the rendered.
I think I've found the issue Fabian, with your help! Thanks for taking the time.

I was exporting using Apple's AVFoundation. Many years ago I found this to be better than using FFMPEG. Well it much faster to run out exports so opted ti use it as the main codec.

I updated to the latest FFMPEG 4.1.4 build today and used this as the export option, trying AAC 128, 320 and WAV. All exports were perfect, no frame delay with the audio.

I also tested AVFoundation again with the same results; WAV was fine, AAC was a frame late.

FFMPEG is still slower when exporting compared to AVFoundation but the time is negligible when runnin out short MOVS...and more importantly they are in sync!

I'd be interested to know if anyone else on a Mac has this issues with AVFoundation with AAC settings. Anyone care to test? If it is an issue hopefully Apple will fix it in the future.
barrettisgold is offline   Reply With Quote
Old 07-23-2019, 09:25 AM   #11
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,526
Default

do my videos look 1 frame off? I use avfoundation on mac for all renders.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 07-25-2019, 05:03 AM   #12
barrettisgold
Human being with feelings
 
Join Date: Jul 2012
Location: UK
Posts: 12
Default

Quote:
Originally Posted by EpicSounds View Post
do my videos look 1 frame off? I use avfoundation on mac for all renders.
Not that I've noticed. The nature of your videos don't often have tight edits to sync audio so it may not be so obvious. I must say, I've been using AVFoundation for years and hadn;t noticed the frame slip until a colleague pointed it out and we started testing.

Do you render out AAC or WAV?
barrettisgold is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.