COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 05-27-2007, 04:58 PM   #1
stringyd
Human being with feelings
 
stringyd's Avatar
 
Join Date: May 2007
Posts: 18
Default Server Setup

Can someone please explain to me how to set up a server so that I can use ninjam for private jam sessions for my band and personal friends? Is it possible to use my own computer or my web site server as an ninjam server? I've seen a few examples in the forums where people have done this so I know it's possible but do you have to be a rocket scientist to do this?

It sounds like a great concept but is it a current reality or in my head?
stringyd is offline   Reply With Quote
Old 05-27-2007, 07:34 PM   #2
dirmass
Human being with feelings
 
dirmass's Avatar
 
Join Date: Nov 2005
Location: AU, WA
Posts: 141
Default

OK, so I'm assuming you're running Windows, here is a guide for starting up your own server.

If you are behind a router/firewall:
Forward port 2049 to your computer from your router configuration page.
Example: Forward both TCP/UDP 2049 to 192.168.0.3
AND/OR make sure your firewall allows you to use port 2049.

1. Download this :http://www.ninjam.com/downloads/ninj...win32_v006.zip

2. Unzip it to a nice simple folder, C:\ninjamserver

This is where you setup your server
---------------------------------------------
3. Go to the above directory and open example.cfg in Notepad.

If you want people to be able to connect without a password make sure this line has a "yes" in it like this:

AnonymousUsers yes

To setup your admin account scroll down to:

#user/password/permissions sets
Change the default administrator password and add users to your liking.
To enable voting scroll down to:
# voting system:
Make sure the last two lines are uncommented (don't have a hash sign in front of them).

(you will find a more detailed explanation for every line in here: http://www.ninjam.com/server-guide.php)

Save this file in the same directory as config.cfg and close Notepad.
-------------------------------------------
4. Start > Run > type: cmd

5. In the command prompt window that comes out type: cd \ninjamserver

6. now type: ninjamserver.exe config.cfg
The server should now be started displaying this:


That's it!

You should now be able to connect to it using ReaNINJAM with REAPER (www.reaper.fm) or the standalone NINJAM (www.ninjam.com)
.
For others to connect to it they need to know your IP.

go to http://www.whatsmyip.org/ to show your IP address:

For examplpe: to connect to a server people will use 66.249.73.154:2049 for the address.

As an admin you can change the BPI, BPM and topic easily:

Example:
For BPI: !bpi 16
for BPM: !bpm 160
for the topic: !topic Welcome to my new server!

People can vote with the following commands:

!vote bpm xxx
!vote bpi xxx


Hopefully this helps you a bit.

As for running the server at your web hosting provider you would need SSH access. I'm not the linux expert ; ) but you also need to compile the server and do the same as above for the config.

Cheers.

PS. Can admins make this a sticky?
dirmass is offline   Reply With Quote
Old 05-28-2007, 05:52 PM   #3
franklin
Human being with feelings
 
Join Date: May 2007
Posts: 1
Default

I figured out what stringyD and I had to do to get it working. We had already done everything, pretty much, in the above post. Your description was reaffirmation that at least we were on the right track. Basically I had to log into my Netgear router and set up port forwarding at port triggering and assign Ninjam to it. I do not know if either of the two or a combination of both made it work. We then jammed for hours and got pretty used to the Ninjam concept rather quickly. I can't wait to try session mode. If we would have known to set up this "port" thing, we would been able to start many long hours of frustration earlier. Thanks so Dirmass! Also, Reaper is a great program. Especially for how inexspensive it is. StringyD has already bought a copy, and I'm soon to follow.
franklin is offline   Reply With Quote
Old 05-29-2007, 04:12 AM   #4
stringyd
Human being with feelings
 
stringyd's Avatar
 
Join Date: May 2007
Posts: 18
Default Got It Working

Thanks Dirmass, we got the server working on my brothers computer by port triggering and forwarding through the router setup. It works great.

Once getting used to Ninjam, it proves to be an exciting and useful tool, and addictive.
stringyd is offline   Reply With Quote
Old 08-02-2007, 04:28 PM   #5
Arg0
Human being with feelings
 
Join Date: Aug 2007
Posts: 2
Default Completely noob question

It is possible to run the NINJAM server on the same computer we're running NINJAM as an application?
Arg0 is offline   Reply With Quote
Old 08-02-2007, 05:00 PM   #6
stringyd
Human being with feelings
 
stringyd's Avatar
 
Join Date: May 2007
Posts: 18
Default

Yes, just connect to you ip address
stringyd is offline   Reply With Quote
Old 08-03-2007, 12:16 AM   #7
spuddle
Human being with feelings
 
Join Date: Jun 2006
Posts: 90
Default

sticky sticky
spuddle is offline   Reply With Quote
Old 12-15-2007, 12:46 PM   #8
Dieter
Human being with feelings
 
Join Date: Dec 2007
Posts: 2
Default

Has anyone been successful at running a server behind two routers?

basically my setup is this: DSL > router1 > router2 > my PC.

I have port forwarding set up on both routers. router1 fwds port 2049 to router2's IP. router2 fwds port 2049 to my PC's IP.

A friend was trying to connect last night but was getting "can't connect to host" errors. I expected to see him trigger my firewall but that also never happened.
Dieter is offline   Reply With Quote
Old 12-18-2007, 06:54 AM   #9
the all new rob
Human being with feelings
 
the all new rob's Avatar
 
Join Date: Dec 2007
Location: east coast of Kansas
Posts: 681
Default

Great writeup. One minor clarification:

As an admin you can change the BPI, BPM and topic easily while logged in to the client:

Example:
For BPI: /bpi 16
for BPM: /bpm 160
for the topic: /topic Welcome to my new server!

This info (admin commands in the client) is not in the wiki, someone with access should add it.
the all new rob is offline   Reply With Quote
Old 03-08-2008, 10:41 AM   #10
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 597
Default

bump - set sticky? And maccool - can you comment what's different on MacOS, please?
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 03-08-2008, 02:37 PM   #11
maccool
Human being with feelings
 
Join Date: Mar 2008
Posts: 12
Default

Quote:
Originally Posted by pljones View Post
...maccool - can you comment what's different on MacOS, please?
Sure.

I was having trouble for two reasons. First, I took all the components from the downloaded .dmg and put them in a folder which I called NinjamServer. I put that folder in the Applications folder of my startup volume. Wrong! Second, instead of changing directory from ~user to /Applications in Terminal, I typed in what I thought was the path to the ninjamsrv. That folder I made and put the Ninjamserver components in is not a valid directory as far as Terminal is concerned. Had I changed directory to get to the ninjamsrv I would have been alerted to that fact.

So, copy the ninjamsrv and the example.cfg.txt files from the mounted NinJamOSXServer disk image to the Applications folder of your boot volume.

Edit the example.cfg.txt file in TextEdit and save it as configfilename.cfg, and again, it should be saved in the Applications folder. The only changes I made to that file, aside from the name, was to delete line 13 because I was getting an error which referred to line 13, and to insert users and their passwords. It might be obvious, although it wasn't to me, but the lines are numbered simply from the top of the file and refer to the lines of the basic document, not the lines of text as they appear.

The reference to SetPID in the Server setup guide page is only there to confuse idiots like me. Ignore it.

With all that said, then just like in the guide, ./ninjamsrv configfilename.cfg should launch the server. You can call ninjamsrv and configfilename whatever you like, just as long as you your chosen names in the command line.

Something I noticed about quitting the server; if you simply close the Terminal window, it does not kill the process! Next time you launch it you'll then have two instances of the server running. I wound up with 3 at one point, and while I could connect locally, login from the internet was inhibited, I guess because the first instance was still using port 2049.

It also seems that the command killall -HUP ninjamsrv, or whatever you've called your server, leaves the process running. I either use Activity Monitor to kill it, or if I'm using Terminal, then use top to identify the process number and kill it that way.

Hope this helps.

Last edited by maccool; 03-08-2008 at 03:13 PM.
maccool is offline   Reply With Quote
Old 04-13-2008, 06:18 AM   #12
MarkFrancombe
Human being with feelings
 
Join Date: Oct 2006
Posts: 31
Default getting errors

Altho I have had no trouble getting the pc version to work, I have now switched over to mac. I am also trying to run the server from home, wheras before I was using a pc at work and connecting from home.

Firstly, have I got my server running?

I get an error thats says
error listening on port 2049
but then goes on to say
Using defaults 110p bpm 8bpi

which suggests its working...?? But its not is it?

I cant seem to connect to it from my client, but maybe Im making a mistake there too?? As Im trying to connect from the same machine as the server, whatdo I put in the ninjam connection window?
My IP address? My IP + port number (as per usual) or something else???

I really hope someone can help, My singer lives in Paris, and we have been collaboration this way for a while, till my company suddenly changed me over to a mac (I wanted that - Im a film-maker and mac is better for that kinda thang) but I forgot NinJam!!!!

Surely I dont need to buy a cheap PC JUST to do this??? (incidentaly how crap can the server computer be, I have som REALLY old and rubbish PC´s lying around)

Looking forward to wonderous advice!!

Mark
MarkFrancombe is offline   Reply With Quote
Old 04-19-2008, 03:44 AM   #13
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 597
Default

Bump and link
http://www.cockos.com/forum/showthread.php?t=18730
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 04-21-2008, 02:19 AM   #14
massobservation
Human being with feelings
 
massobservation's Avatar
 
Join Date: Nov 2007
Posts: 6
Default Thanks Dirmass

Without any prior knowledge of this kind of interface, I managed to set up the server, and get my friend on the other side of Europe logged on and playing & listening within about 20 minutes. Precise and concise as it needs to be for newbies, although I think even with the link to the page of explanations, there is a presumption that everyone understands the last half of the .cfg file. A clearer explanation is still needed at some points in the last sections, but that's not up to you, of course. We have still got our server running, and we'll sort out the details with a little time. Cheers again for bringing me into the 21st Century.
]M[
massobservation is offline   Reply With Quote
Old 04-21-2008, 03:55 PM   #15
williamle8300
Human being with feelings
 
Join Date: Apr 2008
Posts: 2
Default "Error Listening on Port 2049"

Hi, I've checked a lot of the links in this forum to get some insight into my problem. I'm trying to set up the ninjam server in mac osx. I've edited, renamed, and ran the bash command for my config.cfg file, but I get the message: "Error Listening on Port 2049".

My best deduction from reading other posts here (though none sufficiently solving my problem), that it's a firewall issue, or maybe even an I.P. issue. I do have a few domains with godaddy.com, but if possible, I'd like to opt for the no-i.p. alternative.

Thanks much.
williamle8300 is offline   Reply With Quote
Old 04-22-2008, 01:55 AM   #16
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 597
Default

Can you attach your config file to your next post, williamle8300, just in case it's something in there.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 04-22-2008, 04:45 AM   #17
maccool
Human being with feelings
 
Join Date: Mar 2008
Posts: 12
Default

Quote:
Originally Posted by williamle8300 View Post
Hi, I've checked a lot of the links in this forum to get some insight into my problem. I'm trying to set up the ninjam server in mac osx. I've edited, renamed, and ran the bash command for my config.cfg file, but I get the message: "Error Listening on Port 2049".

My best deduction from reading other posts here (though none sufficiently solving my problem), that it's a firewall issue, or maybe even an I.P. issue. I do have a few domains with godaddy.com, but if possible, I'd like to opt for the no-i.p. alternative.

Thanks much.
Perhaps it's because you still have an instance of ninjamsrv running? Use Activity Monitor to look see. Use Activity Monitor to Quit all instances of the ninjamsrv and try again?

From my earlier post: "Something I noticed about quitting the server; if you simply close the Terminal window, it does not kill the process! Next time you launch it you'll then have two instances of the server running. I wound up with 3 at one point, and while I could connect locally, login from the internet was inhibited, I guess because the first instance was still using port 2049.

It also seems that the command killall -HUP ninjamsrv, or whatever you've called your server, leaves the process running. I either use Activity Monitor to kill it, or if I'm using Terminal, then use top to identify the process number and kill it that way."
maccool is offline   Reply With Quote
Old 04-22-2008, 01:19 PM   #18
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 597
Default

Quote:
Originally Posted by maccool View Post
"It also seems that the command killall -HUP ninjamsrv, or whatever you've called your server, leaves the process running. I either use Activity Monitor to kill it, or if I'm using Terminal, then use top to identify the process number and kill it that way."
-HUP is very polite. In fact, it sends the same signal that closing the terminal window does: a "hang up" (from hanging up the line on a modem connection). If you really want to terminate a process, use -TERM (for "TERMinate" ). That's a fairly polite, but firm, way of telling a process you want it to exit now. If it still refuses to die, kill it (with -KILL, of course!). If a process becomes a zombie when you kill it... reboot.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 04-22-2008, 01:34 PM   #19
williamle8300
Human being with feelings
 
Join Date: Apr 2008
Posts: 2
Default

Here's my config.cfg file:

# only one port line allowed (last one will be used)
# these are comments
Port 2049



# limit connections of normal users to 10
MaxUsers 10

# limit normal users to 32 channels each, anonymous users to 2
MaxChannels 32 2

ServerLicense cclicense.txt

#anonymoususers yes or no, or multi (to allow multiple users of the same name from the same IP)
AnonymousUsers no
AnonymousUsersCanChat yes
AnonymousMaskIP yes # shows just the nn.nn.nn.x instead of full IP.


AllowHiddenUsers no # set to yes to allow people without channels to not appear in the user list


#ACL list lets you specify in order a list, first match is used
ACL 10.0.0.0/8 deny
ACL 192.168.0.0/16 reserve # reserve slots for local
ACL 0.0.0.0/0 allow # allow all


#user/password/permissions sets
User administrator myadminpass * # allow all functions
User booga anotherpass CBTKRM # allow chat, bpm/bpi, topic changing, and kicking, a reserved slot, and multiple logins
User myuser mypass # allow default functions (chat, no topic)


DefaultTopic "Welcome to NINJAM. Please play nicely."
DefaultBPM 120
DefaultBPI 8

# two parameters: path to log to, and session length (in minutes). 0 for length means 30 seconds.
# if the first parameter (path) is empty, no logging is done
# SessionArchive . 1


# these two require a full restart to update:

# write PID file (non-windows version only)
# PIDFile ninjamserver.pid

# LogFile ninjamserver.log


# set keep-alive interval in seconds. should probably not bother
# specifying this, the default is 3, which is adequate.
# SetKeepAlive 3

__________________________________________________ ______

I didn't change anything, other than the file name... Just in case, what's the play-by-play to set up a ninjam channel in mac osx?

Thanks for the tip maccool, but unfortunately, it didn't work..
williamle8300 is offline   Reply With Quote
Old 01-23-2010, 05:37 PM   #20
flipotto
Human being with feelings
 
flipotto's Avatar
 
Join Date: Feb 2007
Posts: 539
Default HELP ninjam server! Solved!

Hey,
Trying to get this nut going....
I have a zyxel 660 in bridge mode.
I have a netgear 614.
I have two machines running... IP's are assigned by netgear.
Ninjam machine ip is 192.168.1.2.
Andy's ninjam setup on default port 2049.

I can connect to server with other machine by using local address above, no problem.
I cannot connect to it using ip of my network.
Shouldn't I be able to do that?
I can't get others to connect either.
In my Netgear I have setup port forwarding tcp/udp to 2049-2050
to ip 192.168.1.2. I have also setup ah...ha.
I had port triggering set to tcp 2049 but it needs to be udp 2049.
For those trying, that was my problem.
__________________
KeyMce/GenMce - pc keyboard/midi to Mackie control emulation (built with ahk). Also - an ahk script to build your own midi programs.
flipotto is offline   Reply With Quote
Old 01-23-2010, 06:54 PM   #21
AndyMc
Human being with feelings
 
AndyMc's Avatar
 
Join Date: Dec 2006
Posts: 441
Default

Routers are funny little things, some need or wont work with out the port trigger some will work with just the port forward and some call it Virtual Servers.
Far as I know its TCP but I looked in my forward and I had both set, so maybe I had similar prob as you.
On an older software router box I did only use TCP and it worked fine.

If you want it added to the list just let me know and I'll put it on, if its private I can put that in there, with a website link if you have one or ya Ninjamers Page or group if ya got one.

Even if the Server is Passworded it shows your friends when you in it and shows people there is more activity than is seen in the NINJAM world.
Also if you have used Brennan's NINJAM bot to stream the Audio then that can be added too so people can click and hear your NINJAM Stream.
__________________
Latest Shit (looking for singers): http://www.soundcloud.com/AndyMcProducer
Twitter (@AndyMcProducer): http://www.twitter.com/AndyMcProducer
Facebook Page: http://www.facebook.com/AndyMcProducer
AndyMc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:45 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.