COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 05-13-2012, 10:24 AM   #1
Acall
Human being with feelings
 
Join Date: Dec 2009
Posts: 62
Default Can't connect to my own server...

Hello, my fellow musicians!
My problem is the following: I've opened (not forwarded) port 2049 in my router, I've enabled REAPER and Ninjamserver in the Windows Firewall - and yet when I try to connect to my IP:Port - Address, I get the message "invalid authentication information!" and disconnected. However, I can connect to my server and am able to see the licence agreement before I disconnect. I've tried to log in anonymously as well as with the login information I specified in my cfg file, yet I always get this message. What am I doing wrong?

PS: In the console, I get the message that my IP is connecting. Then, when I get disconnected, it says: xxx.xxx.xx.x: disconnected (username: '' , code=1)


Here's my configuration:


# only one port line allowed (last one will be used)
# these are comments
Port 2049



# limit connections of normal users to x
MaxUsers 5

# limit normal users to 32 channels each, anonymous users to 2
MaxChannels 16 2

ServerLicense Mylicense.txt

#anonymoususers yes or no, or multi (to allow multiple users of the same name from the same IP)
AnonymousUsers no
AnonymousUsersCanChat yes
AnonymousMaskIP yes # shows just the nn.nn.nn.x instead of full IP.


AllowHiddenUsers no # set to yes to allow people without channels to not appear in the user list


#ACL list lets you specify in order a list, first match is used
ACL 0.0.0.0/0 allow # allow all
ACL 217.239.13.173/0 allow
ACL 10.0.0.0/8 allow # deny
ACL 192.168.0.0/16 reserve # reserve slots for local

#user/password/permissions sets
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX (Censored)

# optional user/pass with simple status retrieving permissions (this also has the advantage of having the server do less work)
# StatusUserPass username password


DefaultTopic "Welcome to Ninjam!"
DefaultBPM 120
DefaultBPI 2

# two parameters: path to log to, and session length (in minutes). 0 for length means 30 seconds.
# if the first parameter (path) is empty, no logging is done
# SessionArchive . 15


# these two require a full restart to update:

# write PID file (non-windows version only)
# PIDFile ninjamserver.pid

# LogFile ninjamserver.log


# set keep-alive interval in seconds. should probably not bother
# specifying this, the default is 3, which is adequate.
# SetKeepAlive 3


# voting system:
# SetVotingThreshold 50 # sets threshold to 50%. can be 1-100%, or >100 to disable
# SetVotingVoteTimeout 60 # sets timeout before votes are reset, in seconds

Last edited by Acall; 05-13-2012 at 11:48 AM.
Acall is offline   Reply With Quote
Old 05-13-2012, 10:39 AM   #2
AndyMc
Human being with feelings
 
AndyMc's Avatar
 
Join Date: Dec 2006
Posts: 441
Default

When ya connect to ya server on the same machine use localhost or 127.0.0.1, also you will need to forward port 2049 for outsiders to connect.

If ya connecting to a server on another machine on your LAN (Local Area Network, computers all your side of the router and internet) Then you will want to put in the local ip for the machine the server is on.
For example: 192.168.1.x, 192.168.0.x, 10.10.10.x

If #anonymoususers yes or no, or multi (to allow multiple users of the same name from the same IP)
AnonymousUsers no

Then only users you setup with a password in the config, where you put (censored) will be able to connect.
To test it's probably best at first to set it too:

AnonymousUsers yes
__________________
Latest Shit (looking for singers): http://www.soundcloud.com/AndyMcProducer
Twitter (@AndyMcProducer): http://www.twitter.com/AndyMcProducer
Facebook Page: http://www.facebook.com/AndyMcProducer
AndyMc is offline   Reply With Quote
Old 05-13-2012, 11:28 AM   #3
Acall
Human being with feelings
 
Join Date: Dec 2009
Posts: 62
Default

Hey Andy!

Thanks a bunch! It's all working now. (for me!)

I can't actually forward port 2049 in my router however, it's saying that I already have used port 2049 in another instance (opening it, that is)... Or should I just forward it instead without opening the port?

I actually set it to accept anonymous users, but I changed it for this post. Of course you're right that it's better to leave it on for testing purposes. I enabled it again.

Last edited by Acall; 05-13-2012 at 11:48 AM.
Acall is offline   Reply With Quote
Old 05-20-2012, 01:54 PM   #4
AndyMc
Human being with feelings
 
AndyMc's Avatar
 
Join Date: Dec 2006
Posts: 441
Default

Try deleting all the rules then re-entering them but settings that have any, unless you know it needs to be changed then leave them at there default.
If you still have problems let us know the name and model of your router.
__________________
Latest Shit (looking for singers): http://www.soundcloud.com/AndyMcProducer
Twitter (@AndyMcProducer): http://www.twitter.com/AndyMcProducer
Facebook Page: http://www.facebook.com/AndyMcProducer
AndyMc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:43 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.