Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 10-26-2020, 05:23 PM   #1
hans
Human being with feelings
 
Join Date: Aug 2020
Posts: 32
Default Reaper not enabling and arming envelopes of an FX when created.

Hi there all!



My settings are that Reaper should create and arm new envelopes that are being touched/created, but that isn't the reality for me, unfortunately. I often have to manually open up the fx parameters list to enable and arm some of the parameters that wont activate on touch. In latch and write mode, some knobs and sliders in an fx, are snapping back to the original position just like if i were in Read.



Update 12/11 - 2020:


I finally know what causes the problem!

When I move an Item with automation written over it to another track (with envelope points move with media items) It un-arms the envelopes that was written to it on the new track it lands on. So touching the same FX parameters on the new track with identical FX chain, makes those parameters impossible to re-arm on touch.

short video showing what happens:

https://youtu.be/WhnVml9X8io

Last edited by hans; 11-13-2020 at 02:54 AM.
hans is offline   Reply With Quote
Old 10-26-2020, 06:35 PM   #2
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 6,044
Default

preferences: Editing Behavior: Automation

"Automatically add envelopes when tweaking parameters in automation write modes" Enable

automation write modes are:
Write
Latch
Latch Preview
Touch

I would also enable
Hidden Envelopes: Display read automation feedback
Hidden envelopes: Allow writing automation
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 10-27-2020, 01:00 AM   #3
hans
Human being with feelings
 
Join Date: Aug 2020
Posts: 32
Default

Thanks for your reply. I use those settings as well.

This also happens on both my setups and re-installing is not helping.

Trying to change a preset for a reverb in, lets say ,preview latch, will start to create a long envelope list, which looks good to me at first. But there will always be a numberous of FX parameters that doesn't show up and get activated, even if i see that every knob / slider moves when i browse through presets.

Last edited by hans; 10-27-2020 at 01:07 AM.
hans is offline   Reply With Quote
Old 10-27-2020, 10:31 AM   #4
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 6,044
Default

I don't think preset changes trigger 'moves' of parameters, even in write mode.


trying this here in Latch Preview mode, I had to tap on every parameter with the mouse to get the lanes to come up, and preset changes showed values in the envelope panels changing but the envelopes would update when I used "Automation: Write current values for actively-writing envelopes to time selection" action.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 10-27-2020, 03:25 PM   #5
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 6,044
Default

X-Raym let me know about this today
https://forum.cockos.com/showthread.php?t=178354

not perfect but could be useful.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 10-29-2020, 08:55 AM   #6
hans
Human being with feelings
 
Join Date: Aug 2020
Posts: 32
Default

Thanks for the tip! Gonna check it out. There are sometimes a few hundered extra envelopes (midi channels)in some plugins that perhaps will make the computer slow upon activation of so many envelopes. But this might be very helpful in many cases. Thanks to you, xray-m and spk77!

Last edited by hans; 10-29-2020 at 10:29 AM.
hans is offline   Reply With Quote
Old 11-11-2020, 05:50 AM   #7
hans
Human being with feelings
 
Join Date: Aug 2020
Posts: 32
Default

I can't figure it out.

It seems that some envelopes are being de-activated in the background. I have to run "Arm last touched envelope" so many times. Really killing my workflow.
hans is offline   Reply With Quote
Old 11-11-2020, 09:17 AM   #8
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 6,044
Default

try to find the steps to reproduce the problem in a simplified project
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 11-12-2020, 01:15 AM   #9
hans
Human being with feelings
 
Join Date: Aug 2020
Posts: 32
Default

Thanks EpicSounds. I did a simple test.


I finally know what causes the problem!

When I move an Item with automation written over it to another track (with envelope points move with media items) It un-arms the envelopes that was written to it on the new track it lands on. So touching the same FX parameters on the new track with identical FX chain, makes those parameters impossible to re-arm on touch.


Video showing the problem:

https://youtu.be/WhnVml9X8io

Last edited by hans; 11-13-2020 at 02:44 AM.
hans is offline   Reply With Quote
Old 11-13-2020, 09:47 AM   #10
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 6,044
Default

confirmed. It was hard to tell from your video but I could replicate it.

1 - create 2 tracks
2 - on first track add an item
3 - in a write automation mode move any parameter (you can also draw in some automation
4 - move item from first track to second.

At this point the new envelope on second track will pop up with the envelope points BUT will be disarmed.

tested with v6.16RC1 on Windows.

__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:48 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.