Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 09-03-2022, 12:24 AM   #1
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Kalispell
Posts: 14,759
Default Single CCs (now with video) (SOLVED)

I have found that this is a Kontakt bug, not a Reaper bug, and wanted to post this in case anyone else runs across it.

EvilDragon gave me this link.
https://www.native-instruments.com/f...events.345041/

I've complained about this before, and it's so irritating I need to bring it up again. Please fix.

These midi editor pictures are midi for my Pedal Steel Guitar in Kontakt

This only works part of the time.


This works all of the time.



This only works part of the time.


This works all of the time.

Last edited by Tod; 11-03-2022 at 03:51 PM.
Tod is offline   Reply With Quote
Old 09-03-2022, 06:23 AM   #2
MonkeyBars
Human being with feelings
 
MonkeyBars's Avatar
 
Join Date: Feb 2016
Location: Hollyweird
Posts: 2,638
Default

what is the bug? what do you mean by works
MonkeyBars is offline   Reply With Quote
Old 09-03-2022, 07:21 AM   #3
sockmonkey72
Human being with feelings
 
sockmonkey72's Avatar
 
Join Date: Sep 2021
Location: Berlin
Posts: 1,969
Default

If you put a ReaControlMIDI before the PSG and examine the log, are the single CC messages being sent? Does the problem occur with other plugins (best, not from NI)? Does the problem occur with the same plugin in other DAWs?
__________________
ReaPack Repository: right-click and copy index URL
sockmonkey72 is online now   Reply With Quote
Old 09-03-2022, 12:57 PM   #4
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Kalispell
Posts: 14,759
Default

Quote:
Originally Posted by sockmonkey72 View Post
If you put a ReaControlMIDI before the PSG and examine the log, are the single CC messages being sent? Does the problem occur with other plugins (best, not from NI)? Does the problem occur with the same plugin in other DAWs?
Thanks for your reply sockmonkey, yes ReaControlMIDI shows the events are working.

Simple CC event tests with the Steel Guitar also work okay.

It's when the midi is more complex, like the midi track used to create that Steel Guitar in the demo I posted above, that's when things become ify.
Tod is offline   Reply With Quote
Old 09-04-2022, 07:40 PM   #5
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Kalispell
Posts: 14,759
Default

Here's a video showing the problem and you can clearly see the bug in this video.

https://youtu.be/t0dfH2_0Fig

Now I have to be absolutely honest. It wasn't until I was putting this video together that I found another factor. This is a midi program with key-switches and as I was putting this video together I accidentally put a CC4 event in front of the key-switch, and it played properly.

This is good, but does not mean this is not a bug, it is still a bug with important reasons to try and fix.
Tod is offline   Reply With Quote
Old 09-04-2022, 11:23 PM   #6
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 3,653
Default

Quote:
Originally Posted by Tod View Post
It's when the midi is more complex, like the midi track used to create that Steel Guitar in the demo I posted above, that's when things become ify.
But does ReaControlMIDI then still shows events are working? Because that would suggest that it might not be a REAPER bug, but rather a Pedal Steel Guitar (or Kontakt) issue.
Tale is offline   Reply With Quote
Old 09-05-2022, 12:05 AM   #7
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Kalispell
Posts: 14,759
Default

Quote:
Originally Posted by Tale View Post
But does ReaControlMIDI then still shows events are working? Because that would suggest that it might not be a REAPER bug, but rather a Pedal Steel Guitar (or Kontakt) issue.
Hi Tale, I didn't put ReaControlMIDI on this time because as I mentioned above it showed all the midi data before.

I'm the one who wrote the script and created this Steel Guitar, all the key-switch does is tell witch group in Kontakt is to be used and the velocity of the KS tells what the pitch amount will be..

I can't see how selecting the group before the CC-event would cause this you'd think it would be the other way around. I mean if the group to be played is selected and then CC-event is played.

I guess it's not that big of deal if in deed it will work with the cc events played before the key switches, we'll just have to wait and see.
Tod is offline   Reply With Quote
Old 09-03-2022, 12:12 PM   #8
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Kalispell
Posts: 14,759
Default

Quote:
Originally Posted by MonkeyBars View Post
what is the bug? what do you mean by works
These are CC events that control the pitch of my steel guitar.

The ones that work part of the time have 1 CC event before the note is played.

The only way to get it to work all the time, every time is to draw several events under the notes.

One CC event before the note should work which is why I call it a bug.

I have this Steel Guitar on the market, here is one of the demos.
https://youtu.be/j_Ypn79rt_s
Tod is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:25 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.