Old 11-22-2018, 02:33 PM   #1
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default "Split" bug in Takes mode

In the past I've requested that auto-crossfades be added as a feature, but upon looking at the description of Takes Mode, this feature being absent may actually be closer to a bug.

Takes Modes is defined in the menu as follows:

"Splits existing items and creates new takes"

Auto-crossfade is defined in Defaults for media items as:

"overlap and crossfade items when splitting, length: "x:xx:xxx"

So it would appear as though in takes mode it is not correctly creating the split in the items, specifically not referencing the auto-crossfade rule for splitting. Either that or it's doing something else that isn't actually the action of "splitting".

Last edited by explodingPSYCH; 11-22-2018 at 02:51 PM.
explodingPSYCH is offline   Reply With Quote
Old 11-25-2018, 02:12 PM   #2
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Any work arounds or hope of a fix?
explodingPSYCH is offline   Reply With Quote
Old 11-28-2018, 03:11 PM   #3
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,389
Default

I don’t follow, hmm can you try again on the explanation?
Justin is offline   Reply With Quote
Old 11-30-2018, 10:57 AM   #4
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Quote:
Originally Posted by Justin View Post
I don’t follow, hmm can you try again on the explanation?
Here's a picture of the two settings which imply that they reference each other, but do not:

https://drive.google.com/open?id=1JM...o-S-I0bVpCQWLD

As you can see, in the default (Takes) mode, it is describing the action as "splitting" but auto-crossfades are not available in that mode. You either get no crossfade, or if you activate fade in/out, you get fade in outs. I know I'm not the only one who would really like auto-crossfades to be available while working with Takes.

If Takes worked as described (by splitting) and if that splitting action is respecting the "Overlap and crossfade..." setting, then it should work. But it doesn't.
explodingPSYCH is offline   Reply With Quote
Old 12-09-2018, 01:20 PM   #5
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Bump! Would love to have auto-crossfades when working with takes!

Fade in/outs are great for items that are not overlapping, but I find that fade in/out on overlapping items sounds unnatural, for example on a sustaining tone it "dips" the audio to zero very quickly. Thus I currently have fade in/out deactivated and have to manually create every crossfade I want while working with takes.

If "splitting" referenced the "overlap and crossfade" option correctly in Takes mode, this would be solved!
explodingPSYCH is offline   Reply With Quote
Old 12-11-2018, 09:54 AM   #6
effitall
Human being with feelings
 
Join Date: Jan 2010
Posts: 254
Default

I think I follow what you're suggesting and think it makes sense. Perhaps a description:

Let's say you have auto-punch time-selection as your recording method. You punch in on the downbeat of bar 24 for a duration of 8 bars (24-32). You expect there to be a crossfade at the beginning and end of the punch. This means that your actual recording has to be longer than the 8 bars by the duration of your crossfade time split between the beginning/ending of your punch. (Recording actually starts at say 23.4.95, and ends at say 32.1.05 for a 0.0.10 duration crossfade.)

That's all fine and dandy and should be doable. Reaper just has to remember to start recording BEFORE, and record LONGER than, you told it to, and then overlap the previous take past the punch start point, and overlap before the punch stop point. The amount of the overlap/recording start/stop points is half of the crossfade value.

I can see some potential issues to be aware of when setup like this, but it's nothing major and could be a nice time saver. I usually just manually slip my tracks and get the crossfades just right after the recording.
effitall is offline   Reply With Quote
Old 12-11-2018, 10:56 AM   #7
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Quote:
Originally Posted by effitall View Post
I think I follow what you're suggesting and think it makes sense. Perhaps a description:

Let's say you have auto-punch time-selection as your recording method. You punch in on the downbeat of bar 24 for a duration of 8 bars (24-32). You expect there to be a crossfade at the beginning and end of the punch. This means that your actual recording has to be longer than the 8 bars by the duration of your crossfade time split between the beginning/ending of your punch. (Recording actually starts at say 23.4.95, and ends at say 32.1.05 for a 0.0.10 duration crossfade.)

That's all fine and dandy and should be doable. Reaper just has to remember to start recording BEFORE, and record LONGER than, you told it to, and then overlap the previous take past the punch start point, and overlap before the punch stop point. The amount of the overlap/recording start/stop points is half of the crossfade value.

I can see some potential issues to be aware of when setup like this, but it's nothing major and could be a nice time saver. I usually just manually slip my tracks and get the crossfades just right after the recording.
That's interesting, but not what I'm suggesting. My suggestion just entails having the described action reference the setting for said action.

If you are in Takes mode, and you record over an item no crossfade is made between the new and old item, even though Takes mode is defined as "splitting" and creating a new take. The "splitting" does not take into account if you have "overlap and crossfade when splitting" activated.

To recreate this, do the following:
1.) Check "overlap and crossfade items when splitting, length" (Media Item Defaults)
2.) Record a blank audio item
3.) Record another blank audio item over a section of the first audio item
4.) Inspect the point at which they meet. There will be no crossfade. There will either be a fade in/out or an abrupt change.
5.) Manually split an audio item. You will notice a crossfade is created.
6.) Go into Tape mode and repeat steps 2-4. Now there will be a crossfade. This mode correctly references the Media Item Default setting.

This means you can never have a crossfade created automatically when overlapping recordings in Takes mode. However, it works perfectly (and even over-rides creating fade in/outs at the point where the two items meet) in TAPE mode.

The action is not correctly referencing the Default Media Item settings in the same way it does in other situations (eg: manually splitting and Tape mode)
explodingPSYCH is offline   Reply With Quote
Old 12-11-2018, 11:06 AM   #8
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Quote:
Originally Posted by Justin View Post
I don’t follow, hmm can you try again on the explanation?
Do my following explanations clarify? Here's a brief youtube video illustrating the lack of crossfades where they should exist (And how they work in tape mode):

https://youtu.be/o4_XNsfznZk
explodingPSYCH is offline   Reply With Quote
Old 12-29-2018, 01:20 PM   #9
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Bump!

Checking in on properly "splitting" items in Takes mode to allow for proper Auto-Crossfades.
explodingPSYCH is offline   Reply With Quote
Old 02-28-2019, 11:05 AM   #10
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Quote:
Originally Posted by Justin View Post
I don’t follow, hmm can you try again on the explanation?
Bump!

Auto-crossfade does not work in Takes Mode.

Takes Mode ("splits existing items and creates new take")
is not working in conjunction with:
Auto-Crossfade ("overlap and crossfade items when splitting")

"split" =/= "split" in these two contexts.
explodingPSYCH is offline   Reply With Quote
Old 03-20-2019, 09:52 AM   #11
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Monthly Bump for Auto-crossfades in Takes mode!
explodingPSYCH is offline   Reply With Quote
Old 03-20-2019, 11:06 AM   #12
Coachz
Human being with feelings
 
Coachz's Avatar
 
Join Date: Oct 2010
Location: Charleston, SC USA
Posts: 7,163
Default

I get crossfades on take splits. Am I not in the same "mode" as you ?

Coachz is offline   Reply With Quote
Old 08-10-2019, 10:58 AM   #13
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Quote:
Originally Posted by Coachz View Post
I get crossfades on take splits. Am I not in the same "mode" as you ?

Correct, clicking "split" does create the crossfade, but recording one item over another item does not create the crossfade. It instead defaults to the fade in/fade out.

If you look at the recording modes, it describes takes mode it describes the action it is suppose to take WHEN OVERLAPPING audio with a newly recorded media item. This does not happen. It does happen in Tape recording mode.

Based on the language of the menu's (as listed above) it SHOULD create an crossfade when you record one item over another (At the dictated auto-crossfade length, as it is technically suppose to be treated as "SPLITTING and creating" a new take.
explodingPSYCH is offline   Reply With Quote
Old 08-10-2019, 11:02 AM   #14
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 180
Default

Quote:
Originally Posted by Justin View Post
I don’t follow, hmm can you try again on the explanation?
Perhaps my most recent response clarifies my post? "Splitting" does work in takes mode, but when recording one item over another, it is not treating it as "splitting and creating a new take" as it should (based on the language in the drop down menu).

It is only respecting the behavior of a newly created item (fade in/outs). It does create the new take as described, but it's not created the "split" (Which would create the crossfade!) as described.
explodingPSYCH is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:28 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.