Old 09-13-2018, 06:50 AM   #1
sts
Human being with feelings
 
Join Date: Oct 2008
Posts: 49
Default VSTs (32 bit) inactive and silent

I'm not sure if this is the right subforum for this, but I'll try anyway because the problem I report seems to be getting worse...

I'm running 64 bit REAPER with a number of 32 bit plugins that I regularly use (along with 64 bit plugins, of course). Until a couple of weeks (or months? - can't remember exactly) ago, everything worked fine using the built-in bridge to run old (or newer) 32 bit plugins in REAPER's 64 bit version. I have set up all 32 bit plugins (everything that is marked by "(x86)" in the FX browser) using the "Embed bridged UI" option under the "Run as" command. No problems so far.

But then something strange happened: Everytime I re-open a project, all or at least some 32 bit plug-ins I used in this project have lost their GUI and settings and won't let any sound pass through, so the entire track with these plugins is muted and the plugin(s) needs to be reloaded and set up again with all its previous settings (which I can't remember of course). All that is left of the plugin in the FX window is an empty window (see attached image). Switching over to the generic plugin interface (using the "UI" switch in the FX window) doesn't help - it is either empty or has a couple of sliders without names and functions.

64 bit plugins are not affected, as far as I can tell.

I doubt that this is related to particular buggy plugins, since it happens with old (and perhaps completely outdated) freeware plugins as well as commercial plugins such as the Fabfilter ProL.

Currently, I'm running the latest REAPER 5.95. It is possible (but I'm absolutely not sure about this) that this problem occurred for the first time after an update to one of the more recent REAPER versions, maybe from 5.80 to 5.90. I could downgrade to check this, but maybe there is a simple reason that can be fixed easily.

Any advice? How should I proceed to locate and solve this problem?
Attached Images
File Type: jpg empty_fx_window.jpg (8.2 KB, 25 views)
sts is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:23 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.