Old 12-08-2019, 02:25 PM   #1
headwind
Human being with feelings
 
Join Date: Dec 2017
Posts: 9
Default non-synchronous rendering with a video track

I mainly use reaper to record live performances of my band for (a) review/looking for areas of improvement and (b) if there is a particularly good performance, to throw it up on the band facebook page.

Often I mix in video as well captured from a GoPro camera. I add those files to a video track and sync them up looking at the drummer or other key point that I can synchronize. This has worked well. I usually bleed in a little of poor quality gopro audio in with the feeds from the mixer just to get some room sound.

Previously I had loaded the raw gigabyte+ video files into reaper which worked but slowed things down some. Most recently, I notice that for whatever reason, the raw video files were a few tens of milliseconds off between the video and the audio. So I then first processed them through ffmpeg using the method described here: https://superuser.com/questions/9823...verting-the-au This worked and as an added benefit (so I thought) was a smaller file size so Reaper didn't slow down as much handling the files (my computer is an older i3 but with plenty of RAM).

However, when I rendered the video files in Reaper, the video slowly gets out of sync with the rest of the tracks (i.e. the audio only tracks).

For example, here is what the end of one song sounds like when I rendered it with the video. This is a audio clipping only of the video file:

http://trailmap.us/cary-on-end-video-rendered.wav

You can clearly hear how the vocals are out of sync there. However, the initial part of the file is completely in sync. Sync is lost gradually throughout the render.

But if I go to the exact same spot in reaper and render only as an audio file, it is definitely in sync:

http://trailmap.us/end-of-carry-on-no-video.wav

Anybody ever seen this and have a solution? Is the overhead of dealing with compressed video files just causing reaper to just not keep up on that particular track? I could see it making the render time take longer, but not get out of sync.

Now the simple solution is just to put the original large file in there, but before I go and do that, I wanted to see if there were any suggestions for me to work with the video files I already have.
headwind is offline   Reply With Quote
Old 12-08-2019, 06:29 PM   #2
Philbo King
Human being with feelings
 
Philbo King's Avatar
 
Join Date: May 2017
Posts: 1,776
Default

Are the Project Settings at 48K sample rate? And the frame rate set to match the imported video? That would be a starting point.
__________________
Tangent Studio - Philbo King
www.soundclick.com/philboking - stream music
www.facebook.com/philboking - gigs and news
Philbo King is offline   Reply With Quote
Old 12-10-2019, 07:30 PM   #3
headwind
Human being with feelings
 
Join Date: Dec 2017
Posts: 9
Default

Quote:
Originally Posted by Philbo King View Post
Are the Project Settings at 48K sample rate? And the frame rate set to match the imported video? That would be a starting point.
Was out of town on a business trip, so sorry for the delay (no pun intended!) in trying out your suggestion.

It half worked, in that sound is now synced, but the video is still somewhat delayed. I had been doing 44,100 sample rate and 30 fps but saw the video was in 25 fps. I switched both parameters. I can live with the slight out-of-sync of the video for the purposes of this project. At least the sound is in sync which is the most important.
headwind is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.